Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Эпилог.

Библиотека разработчика
Главная Форум Гостевая Ссылки E-mail

Немножко поздравлений

Вы закончили читать учебный курс лекций "Маркетинг для малышей". На протяжении курса я подробно рассказывал вам обо всем, что связано с продвижением сайта, как коммерческого, так и не очень, в Интернете. Я старался изложить курс таким образом, чтобы он был достаточно всеобъемлющим - вы, наверное, заметили, что большое количество материалов дается для самостоятельного изучения. Я с удовольствием выслушаю (вернее, прочту) все ваши комментарии, если вы отправите их мне почтой. Если вы что-либо не поняли, или не можете найти, или просто не получается, то к вашим услугам всегда есть раздел "Толковище", где можно обсудить успехи и неудачи, понятное и непознаваемое, а также консультарий, где вы всегда можете получить бесплатную консультацию.

Если вы считаете, что мои курсы были вам полезны, то вы можете, при желании, разместить у себя на сайте нашу кнопку. Разместив у себя соответствующую кнопку, отправьте мне письмо, и ссылка на ваш сайт появится в разделе "Выпускники".

До следующих встреч.
Федор Вирин

предыдущая лекция
©STS


Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Лекция 1.

Лекция 1

Основы основ
или Изначальное

Итак, у вас есть прекрасный сайт с интересным содержанием, хорошей подачей материала и оформлением, вы готовы к его постоянной поддержке, обновлению и работе с ним. Теперь вы, естественно, хотите, чтобы ваш ресурс стал известным и популярным, то есть "раскрутить" его. Хорошо, вы к работе готовы, но готов ли к этому ваш свежий, только что законченный сайт? Давайте вместе проверим это. Первым делом необходимо проанализировать сам сайт.

1. Правильность написания кода. Даже простые, "не страшные", на первый взгляд, ошибки могут вылезти впоследствии в самый неподходящий момент. Многие веб-мастера, особенно начинающие, создают свои страницы в WYSYWIG редакторах, таких как Front Page или Dream Weaver, получающийся при этом код страницы совсем не идеален: он пестрит как мелкими шероховатостями, так и просто серьезными недоделками. Тем не менее, нет ничего страшного в использовании этих редакторов, т.к. их огрехи проявляются только при пиковых нагрузках, которые встречаются не так уж и часто. В большинстве же случаев, сайты сверстанные во Front Page работают ничуть не хуже, чем сделанные в кодовом редакторе, и в Сети немало прекрасных сайтов сделанных как тем, так и другим способом. Единственное серьезное преимущество профессиональных редакторов - это абсолютный контроль над HTML кодом вашей страницы, что означает обычно более качественное написание его и меньшее количество ошибок, недочетов и несовместимости тегов с разными браузерами

Проверить код страницы и исправить хотя бы грубые ошибки нужно в любом случае, вне зависимости от того каким инструментом вы пользовались.

2. Работоспособность всех ссылок на страницах. Это очень важный момент, так как сайт, ссылки на котором ведут в никуда (error 404 ), сразу теряет свою респектабельность и видимую надежность. Даже в том случае, если вы уверены в качественности всех ссылок, проверьте их еще раз, особенно это касается внешних (то есть ведущих на другие сайты ссылок), хотя бы для того, чтобы убедиться, что страницы, на которые вы ссылаетесь, существуют.

3. Размер страниц и скорость их загрузки. Одной из самых серьезных проблем интернета является низкое качество связи между узлами Сети и конечными пользователями. Естественно, что наибольшие ограничения это налагает на издателей, так как решающее значение для пользователя приобретает скорость загрузки требуемых страниц из Интернета. С учетом имеющихся на данный момент данных, я рекомендую удерживать размеры страниц в пределах 30-50 kb на все данные. То есть, в эту цифру входит не только размер самой страницы, но и все картинки, и чужие баннеры, и счетчики, в общем, все то, что есть у вас на странице. Теоретически, в указанный объем страница помещается без особого труда - 30-50 kb - это объем нормальной страницы без графических излишеств и не перегруженной рекламой.

4. Соответствие стандартам. Несмотря на "войну браузеров" и постоянно меняющийся с каждой новой версией MSIE или NN язык HTML, существуют стандарты, регулярно утверждаемые консорциумом WWW (www.3w.org). на данный момент актуальны два стандарта: HTML 3.2 и HTML 4.0, и именно им должен соответствовать сайт (HTML 4.0 полностью включает в себя предыдущий стандарт). Например, в соответствии со стандартом HTML 4.0 выключка абзаца оформляется следующим образом: <p align=right></p>,
а не <right></right>, как это было в предыдущих версиях языка. Соответствие стандарту не только делает ваш сайт более аккуратным и понятным для других разработчиков (что незаменимо при работе в команде), но и гарантирует вам наилучший баланс совместимости со всеми существующими браузерами.

Код, ссылки и время загрузки не обязательно проверять вручную. Существует немало сервисов в Сети, где это могут сделать за вас автоматически и бесплатно (с некоторыми ограничениями), например Site Inspector поддерживаемый компанией Link Exchange или Web Site Garage, причем в последнем есть возможность автоматической ежемесячной проверки вашего сайта (указанных страниц) с высылкой результатов по e-mail. И, между прочим, еще на стадии создания страницы вы можете проверить связи, внешние ссылки, качество кода и пр., так как многие специализированные редакторы HTML страниц поддерживают эту возможность, как встроенную функцию.

Все вышеперечисленные процедуры должны быть выполнены для каждой страницы сайта. Несмотря на то, что придется потратить значительное количество времени, вы окупите потом эти потери устойчивой работой сайта. Возможно, для некоторых операций имеет смысл нанять профессионалов (например, для вычитки текстов), особенно, если вы не обладаете достаточным опытом, чтобы выполнить их самостоятельно.

В отличие от всего остального сайта, титульную страницу никогда не вредно дополнительно проверить вручную, поскольку, она является ключевой для вашего сайта и вы не можете позволить себе терять посетителей из-за элементарных ошибок.

Следует повторять и повторять проверки до тех пор, пока вы не добьетесь удовлетворительных результатов по всем пунктам. Однако это лишь один из аспектов подготовки страниц к проведению маркетинговой кампании. Перейдем опять к вашей титульной странице.

Взгляните очень внимательно на вашу входную страницу. Подумайте, поймет ли человек, впервые очутившийся на этой странице, о чем идет речь, какие цели вы ставили перед созданным вами сайтом, и чем конкретно вы можете помочь вновь пришедшему посетителю. Сразу ли вам самому понятно какого рода информация представлена на сайте и в каком объеме? Сразу ли можно обнаружить систему навигации и удобно ли ею пользоваться? Главное - захотите ли вы вернуться сюда еще раз, основываясь только на тех ощущениях, которые вы получили, впервые увидев сайт.

Хорошо, если на эти вопросы вы будете отвечать не только сами, но попросите о том же и своих друзей или коллег по работе. Добейтесь того, чтобы ваши знакомые, по меньшей мере, не вздрагивали при виде вашего сайта - это гарантирует вам достижение того минимума, при котором работу уже можно показывать неподготовленному человеку. Реакция ваших знакомых будет прекрасным индикатором состояния вашего ресурса.

Внимательно исследуйте технические параметры сервера, на котором расположен ваш сайт. Один из важнейших параметров - это uptime, то есть время, которое сервер работает (а не просто включено питание) и доступен из Сети. Этот параметр фактически определяет вероятность "падения" сервера в самый неподходящий момент и обычно находится в районе 98-99,99%. В том случае, если ваш сервер висит несколько часов в день, стоит подумать о его переносе на другой сервер, так как раскручивать периодически недоступный ресурс невозможно. Узнайте, на каком канале (имеется ввиду пропускная способность) находится ваш сайт, и кто кроме вас этот канал использует. Например, сервер lgg.ru находится на канале 2 Mb, но, поскольку этот сервер предоставляет бесплатное дисковое пространство всем желающим, то на всех этого канала не хватает и, в результате, он часто бывает недоступен, поэтому работать с ним тяжело. С другой стороны, я знаю сервера, которые приемлемо работают на выделенной линии 64 kb, правда, только до тех пор, пока объем посетителей не начнет превышать 400-500 посетителей в сутки, после чего страница становится практически недоступной.

На сегодня - все. До следующих встреч.

Ссылки по теме:

  • Редколлегия - вычитка ваших текстов.
  • Проверка каскадных таблиц стилей
  • Web Site Garage - Один из лучших онлайновых проверяльщиков HTML кода страниц
  • Проверяльщик неработающих ссылок
  • Тоже проверка неработающих ссылок
  • Проверка сайта на доступность людей с нарушениями некоторых функций.
    в начало следующая лекция
    • ©STS


Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Лекция 2.

Лекция 2

Подготовка

Следуя наставлениям прошлой лекции, вы подготовили свой сайт к публикации так, чтобы посетителям было на него приятно смотреть. Теперь ваша задача подготовить сайт таким образом, чтобы его было удобно рекламировать. Именно об этом и пойдет речь в настоящей лекции.

Перовым делом определим, что же нужно рекламировать. Чаще всего - это титульная (или головная - кому как нравиться) страница. Именно она является входной для сайта, именно она может сразу дать общее представление обо всем сайте и его тематике. Поэтому рекламные кампании призывают обычно именно на титульную страницу, но всегда ли можно и нужно делать именно так? Попробуем разобраться.

Пример 1
Мой сайт "Библиотека Мастера" состоит из нескольких сотен HTML документов, нескольких CGI-скриптов и исполняемых модулей - вот было бы здорово сделать каждую страницу популярной! Однако это бессмысленно, так как человек, очутившись на одной из внутренних страниц сайта, просто не поймет, где он находится и что ему здесь надо. Сделав подобное умозаключение, человек покидает сайт, чтобы больше на него никогда не вернуться. Следовательно, рекламировать нужно только первую - титульную страницу.

Пример 2
С другой стороны, "Библиотека Мастера" состоит из четырех крупных разделов, каждый из которых тесно взаимосвязан со всеми остальными, но при этом является законченным модулем со своей тематикой, материалами и целями. Также на сайте присутствует несколько досок объявлений и несколько форумов на разные темы. В этом случае, если я буду рекламировать только титульную страницу сайта, объединяющую все разделы, то я автоматически теряю всех посетителей, которым не интересна тематика сайта целиком, но может быть интересен какой-либо конкретный раздел.

Из вышеприведенных примеров явственно следует, что выбор рекламируемого объекта не такая уж тривиальная задача, как может показаться, и этот выбор может серьезно повлиять на популярность вашего ресурса впоследствии. Таким образом, основной задачей на этом этапе является отбор всех тех страниц, которые необходимо рекламировать. Это, безусловно, титульная или входная страница (специально подготовленный материал, чтобы ввести человека, пришедшего от рекламного ресурса, в курс дела), титульные страницы самостоятельных разделов, а также отдельные модули, например такие как: лента новостей, доска объявлений и пр. В любом случае, я не рекомендую выбирать на первый раз более трех-четырех страниц, так как продвижение каждой из них требует времени, которого вам может просто не хватить - вы это почувствуете уже на первой стадии, так как каждую из рекламируемых страниц необходимо отдельно подготовить.

Внимательно изучите дизайн и макет страницы, которую вы в данный момент собираетесь готовить к маркетинговой кампании, оцените организацию свободного пространства на ней. Многие каталожные системы просят (а иногда - требуют) включения их кнопки в индексируемый ресурс, есть ли у вас место для этого? У вас также возникнет необходимость поставить счетчик для рейтинга и, возможно, не один, - есть ли у вас мысли, где их разместить? То же самое необходимо решить относительно баннеров, которые вы захотите поставить на странице, чтобы участвовать в баннерном обмене. Я настоятельно рекомендую подумать обо всех этих аспектах заранее, чтобы потом не стоять в качестве буриданова осла между раскруткой и дизайном. Оптимальным (и, как мне кажется, единственно верным) решением является с самого начала строить сетку с учетом размещения на странице баннеров и кнопок, тогда у вас не возникнет проблем с размещением рекламы, поскольку она изначально заложена в сетку макета.

Проанализируйте текст на вашей титульной странице. Какое слово или выражение встречается на ней чаще всего? Характерно ли это слово для тематики сайта, или это разговорный оборот? Как часто встречается это выражение? Все это необходимо для грамотной и выгодной индексации поисковыми роботами (о работе с ними я подробно расскажу в одной из следующих лекций), и, соответственно, удачного попадания в результаты поиска на поисковых машинах.

Большинство людей находят нужную информацию в Интернете с помощью поисковых машин. Таким образом, поисковая машина является одним из главнейших поставщиком новых посетителей, а следовательно, отнестись к ним нужно очень и очень ответственно. Короче говоря, поисковый робот располагает документы на странице результатов поиска в порядке убывания их соответствия запросу (релевантности). Одним из важнейших параметров релевантности документа является частота употребления ключевого слова в тексте.

Когда вы проанализируете текст на странице способом, указанным выше, то у вас образуется список из нескольких ключевых слов, которые достаточно точно и ярко характеризуют ваш ресурс. Перепишите эти слова в отдельный текстовый файл и сохраните, она вам еще пригодится. После этого переработайте текст на странице (речь идет только о той странице, которую вы собираетесь рекламировать), так, чтобы выбранные вами ключевые слова там не только встречались, но встречались регулярно (в среднем не менее 5-10 раз). В этом ключе надо переработать не только сам текст, но и название страницы, которое отображается в заголовке браузера, подписи к рисункам и пр.

Очевидно, что оптимизировать страницу под несколько ключевых слов крайне сложно, поэтому постарайтесь обойтись двумя-тремя словами, для этого выберите несколько "самых красивых" слов и подстраивайте страницу именно под них. Вследствие особенностей поисковых машин имеет смысл обратить особое внимание на первый килобайт текста страницы и работать целенаправленно с ним. Подробнее этот вопрос будет разбираться в пятой лекции, которая целиком посвященна поисковым машинам.

Наконец, завершающим штрихом нужно установить на странице счетчик посещений. Причем, это должен быть не просто элемент украшения страницы, а полноценный рабочий инструмент. Счетчик должен выдавать подробную статистику по целому ряду параметров посещаемости вашего сайта, знание которых будет необходимым вам в дальнейшем при проведении маркетинговой кампании. Я рекомендую установить один из следующих счетчиков: HitBox, Extreme, SuperStat или российский SpyLog, причем, последний - особенно. Все эти счетчики предоставляют массу полезной информации, более или менее достаточной для проведения полноценной маркетинговой акции и разбора ее результатов. С другой стороны, оптимальным инструментом все равно являются лог-файлы (файлы регистрации событий) вашего сервера, поэтому, если у вас есть к ним доступ, то пренебрегать такой возможностью не следует.

Это все, о чем я хотел рассказать сегодня,

До следующих встреч.

предыдущая лекция следующая лекция


Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Лекция 3.

Лекция 3

Каталоги

В прошлой лекции я рассказал о том, что нужно сделать для подготовки вашего сайта к проведению рекламной кампании. Вы определили, что именно будете продвигать, а также выделили место на страницах для разного рода баннеров и кнопок. Наконец, настала пора использовать это место и привлечь к себе первых посетителей. В этой лекции я расскажу о каталогах, о том, как правильно регистрироваться в них, в каких именно нужно регистрироваться, и что вам это принесет. Также мы поговорим немного о языковых особенностях рекламных кампаний.

Службы каталогов (или просто каталоги) - это огромные структурированные коллекции ссылок. Люди приходят на сайты каталогов, чтобы найти необходимую информацию, изучить новую для себя область, просто поискать что-нибудь интересное. Таких собраний в Сети множество, среди них есть супергиганты, такие как Yahoo, и простенькие, порой, совершенно карманные каталожки, созданные исключительно ради забавы. Каталоги, как вы понимаете, бывают и всеобъемлющие, как, например, @Rus (такие ресурсы называются горизонтальными порталами), и узкотематическими при специализированных сайтах, например, Ситимаркет(такие ресурсы называются вертикальными порталами).

Вам, как веб-издателю, безусловно, выгодно, чтобы такие каталоги размещали на вас ссылку, - тогда заинтересованные люди смогут найти вас в дебрях Интернета. На первый взгляд, очевидно, что чем больше каталогов поставили на вас ссылку, тем больше посетителей к вам придет; и, отчасти, это, конечно, верно, но только отчасти. Дело в том, что многие каталоги сами обладают очень низкой популярностью, иногда - это сотня посетителей в день, а иногда и того меньше. В таком случае, вы, скорее всего, не получите никакого отклика от каталога, а на регистрацию в нем уже потрачено ваше драгоценное время.

С другой стороны, каталогам выгодно, чтобы в них регистрировалось как можно больше сайтов, поэтому помимо поиска в Сети новых ресурсов редакторами каталогов они предоставляют владельцам сайтов предлагать ссылки для публикации самостоятельно. Для этого во всех каталогах существуют специальные формы, которые скрываются за надписями "добавить ссылку" или "добавить URL", или просто "добавить". Заполнив такую форму, где надо указать ряд данных о своем сайте, веб-мастер имеет шанс попасть в соответствующий каталог и получить от него свою долю посетителей. В некоторых каталогах ссылки публикуются сразу, в других - предварительно проверяются администратором, в зависимости от скорости этой процедуры регистрация ресурса может занять 1-3 недели с момента заполнения формы.

Поскольку каталог едва ли не самый распространенный вид сайтов в Сети, то существуют специальные сервисы и даже отдельные программы, которые регистрируют ваш ресурс сразу в нескольких (иногда до 1000 и более) каталогах. Правда, гарантии правильности "прохождения" регистрации (т. е. занесения ссылки в каталог) при таком подходе - минимальны. Качественные сервисы такого рода обычно платны, но есть и бесплатные или условно-бесплатные, предоставляющие возможность пробной регистрации в ограниченном количестве каталогов (обычно около 10). Список популярных ресурсов этого типа вы найдете в конце лекции.

Я считаю оптимальным методом регистрации нового ресурса - размещение ссылки вручную (то есть без использования автоматических регистрирующих сервисов) в самых известных каталогах с тем, чтобы потом добавлять ссылки в более мелкие по мере роста и расширения ресурса, например, случайно на такой каталог попав. Если вы периодически осматриваете сеть, то должны регулярно натыкаться на новые каталоги и коллекции ссылок, при наличии времени в них можно зарегистрироваться, но не стоит делать этого специально при запуске нового проекта.

Где же стоит зарегистрировать новый, только что запущенный в работу ресурс? Ниже я перечисляю наиболее значимые в Рунете на данный момент каталоги.

Каталог @Rus (бывший "Ау")

Один из самых известных каталогов в Рунете. Поравнявшись с ведущими каталогами, за плечами которых много лет индексации и добавления новых ресурсов, @Rus проводит очень серьезную маркетинговую политику, чтобы стать первым. Недавнее объединение с поисковой машиной "Апорт" фирмы "Агама" делает его одним из самых крупных сайтов в Рунете. Осенью 1999 г. представители обоих сайтов ездили на Нью-йоркскую выставку интернет-проектов, где у них был собственный стенд. В каталоге также есть и англоязычная часть, причем, если вы затрудняетесь в написании английского варианта регистрационной информации, то за вас это сделает автоматический переводчик на базе системы "Промт" (для небольших текстов он выдает вполне читаемые результаты). Предложенные в каталог ресурсы проверяются живыми людьми, поэтому регистрации придется ждать неделю-другую. Если ваш ресурс покажется модераторам каталога интересным большому количеству людей, то у вас есть шанс попасть в "находки" или даже в "тропы", что даст очень мощный приток посещаемости.

Форма для регистрации в каталоге находится по адресу: www.atrus.ru

Каталог Лист.ру

Пожалуй, ведущий каталог, достаточно еще молодой, чтобы, как и @Rus проводить крайне агрессивную маркетинговую политику. В каталоге постоянно открываются новые сервисы полезные для веб-мастеров, поэтому, вполне вероятно, что посетить его вам нужно не только для регистрации: потратив немного времени и внимательно изучив каталог, вы найдете для себя много полезного. Из всех остальных каталогов (не считая "Омен" и "Рамблер") List.ru отдает больше всех трафика, но при условии регистрации сразу и в каталоге и в рейтинге. Сам каталог постоянно модерируется гидами, поэтому имеет смысл указывать для регистрации только реально соответствующие категории, кроме того, если ваш ресурс действительно интересен, то при некотором везении он может попасть в колонку, которую ведет гид вашей рубрики и в "листовку" - новостной ресурс при каталоге, что ведет к существенному увеличению трафика.

Для регистрации в каталоге нужно предварительно выбрать соответствующую категорию и регистрировать сайт непосредственно из нее. Предварительно прочтите инструкции.

Каталог "Созвездие Интернет"

Еще один монстр Рунета. Расположенный на суперсервере "Инфоарта", он привлекает к себе более ста тысяч человек ежедневно, однако большинство приходящих интересуются вовсе не каталогом, а погодой, программой телевидения, новостями и другими сервисами, предоставляемыми "Инфоартом", так что, скорее всего, это не самый популярный каталог Рунета, хотя, конечно, один из. При каталоге есть также и рейтинг, но ввиду отсутствия рубрицирования - это не столько средство навигации по Сети, сколько своего рода "гамбургский счет", впрочем, никто не мешает зарегистрироваться и там, и там. Кроме того, при каталоге есть несколько полезных для веб-мастеров сервисов, в том числе - лента новостей сайтов, безусловно, очень привлекательная при проведении маркетинговой кампании.

Форма для регистрации в каталоге находится по адресу: www.stars.ru

"Россия в Сети"

В каталоге присутствуют отдельно русская и английская части, причем ссылка размещается в обеих раздельно. То есть, если у вас есть англоязычная версия сайта, то придется регистрировать ресурс дважды. Ссылки в каталоге прописываются вручную (не проверяются, а именно вставляются на страницы каталога), а следовательно, проделывается это крайне медленно. Тем не менее, это известный и посещаемый каталог в Рунете, и постараться прописать в нем свой сайт нужно обязательно.

Форма для регистрации в каталоге находиться по адресу: www.ru

Через одну-две недели после регистрации проверьте наличие ссылки в каталоге (теоретически, должно прийти официальное подтверждение, но приходит оно не всегда). Сначала попробуйте проверить в заданной рубрике, и если там нет, то поиском по ключевым словам или названию ресурса. При отсутствии ссылки в каталоге зарегистрируйтесь еще раз, если не помогло, то напишите личное письмо администратору сервера, - иногда эта мера помогает. Хорошей новостью можно считать то, что в последнее время регистрация стала проходить гораздо быстрее и, практически, без отказов.

Каталог Up.ru

Очень активно развивается, обеспечивая приток посетителей за счет постоянного запуска новых проектов. Хороший, кстати, пример, растущего с низу горизонтального портала.

Форма для регистрации находиться по адресу: www.up.ru

Каталог Chat.ru

Новый каталог (организован в феврале-марте 2000 г.) при сервере, предоставляющим бесплатное место под домашние страницы (кстати, один из худших сервисов такого рода, однако снискавший немалую популярность, поскольку был одним из первых). Каталог не посягает на суперпопулярность и, судя по его расположению, позиционируется на ту же нишу, что и "Омен", то есть на персональные проекты и домашние страницы. Популярность каталога уже достаточно велика и, вероятно, снижаться не собирается.

Форма для регистрации в каталоге находится по адресу: catalog.chat.ru

Также рекомендую зарегистрироваться в следующих каталогах:

Каталог "Весь русский интернет"
Search.ru
Search.Centre.ru
Кирилл и Мефодий
Улитка
Иван Сусанин
Data.ru

Напоследок, хочу дать несколько советов, которые пригодятся, когда вы займетесь массовой регистрацией. В течение этого процесса вам потребуется заполнять много различных форм (по крайней мере одну в каждом каталоге), однако суммарная информация, вводимая вами в форму каталога, всегда одинакова. Поэтому откройте текстовый редактор и наберите в отдельном файле всю необходимую информацию. Вам потребуются:

  • - название ресурса;
  • - его адрес (URL);
  • - ваш e-mail;
  • - описание ресурса. Лучше заготовить несколько различных описаний: серьезное, полушутливое, смешное и, наконец, детское, тогда у вас будет возможность гибче подстраиваться под профиль каталога. Кроме того, некоторые каталоги принимают строго ограниченное по длине описание, поэтому нужно заготовить как минимум два разных по размеру, одно не более 200 знаков (включая пробелы), а второе - любой длины, которую вы сочтете необходимой. Если же вы чувствуете тягу к клавиатуре, то напишите три варианта описаний: одно не более 200 знаков, другое - не более 500 и третье достаточно большое, чтобы вместить в себя все, что вы хотите сказать о своем ресурсе;
  • - ключевые слова к ресурсу. Набор слов, который может быть введен как критерий поиска к вашей тематике. Ограничивайтесь не более чем тридцатью, но не менее, чем десятью словами. Сортируйте внутри списка слова по важности.

Кроме того, потребуется ваше имя и, в отдельных случаях, страна и город проживания, но их уже можно будет выбрать из списка вариантов, и намерено включать в текстовый файл не имеет смысла.

Сохраните полученный файл на диск и выложите ярлычок на десктоп или в лоток-tray, так чтобы его можно было легко достать. Можно также специально для вашего нового проекта создать папку в программном (открываемом кнопкой Start) меню, где кроме этого текстового файла вы потом положите другую необходимую информацию и ярлыки к рабочим программам, используемым при создании сайта.

Удобно иметь отдельный текстовый файл для каждой рекламируемый страницы, если у вас их несколько. Когда вам приходит в голову новое, возможно, - лучшее описание сайта, то положите его рядом со старым в тот же текстовый файл, но старое не стирайте, - оно еще может пригодиться. Удобно, когда файл с информацией о ресурсе находится в примитивном текстовом формате ANSI, так как редактировать его приходится редко, а notepad открывается значительно быстрее, чем любой мало-мальски продвинутый текстовый редактор.

Еще один важный момент - многие каталоги просят разместить кнопку на титульной странице ресурса, обещая за это большие или меньшие блага. Размещать эти кнопки имеет смысл - это идет на пользу и вам и каталогу, естественно, речь идет, в первую очередь, о крупных каталогах, таких как "Ау". Обязательно нужно поставить кнопку каталога, если ваш ресурс участвует в рейтинге (тогда кнопка является одновременно и счетчиком, как, например, у list.ru - в этом случае, вы получите свой, индивидуальный код кнопки), а остальные при наличии у вас свободного места. Кроме того, вы вольны всегда эти кнопки снять, если место понадобиться для чего-либо другого.

На сегодня хватит.

Удачи и до новых встреч!

Рекомендованная литература:

  • Регистрация сайта.
  • Каким должно быть описание сайта - SuM

Ссылки по теме:

  • Автоматический регистратор от "Ярмарки сайтов"
  • Система Tau от Артемия Лебедева


Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Лекция 4.

Лекция 4

Рейтинги

В прошлой лекции я рассказал о каталогах, о том, в каких из них нужно регистрироваться и как это лучше сделать. Полагаю, что вы последовали моим рекомендациям, и к вам уже потянулись посетители, появились первые заинтересованные письма, вы уже видите первые результаты своих трудов. Теперь необходимо укрепить ваши позиции и еще увеличить популярность вашего сайта, на очереди рейтинговые системы. В этой лекции вы узнаете, что такое рейтинги и их значение для создания трафика, вы узнаете, в каких рейтингах нужно участвовать, а в каких не стоит. Итак, приступим.

В отличие от каталогов, где ссылки на страницы свалены кучей или, может быть, отсортированы по алфавиту, в рейтинге страницы расположены по мере роста какого-либо признака, то есть - лучше-хуже. Чаще всего, конечно же, критерием оценки является посещаемость сайта, как наиболее объективная (или, скорее, - очевидная) оценка качества ресурса. Так устроены рейтинги "Рамблер", "Ранкер", "1000 stars", "List top 1000", "Мафия" и еще многие, многие другие. Однако есть и не прямые рейтинги, сортировка в них происходит не по посещаемости, а по каким-то иным, более сложно измеряемым критериям. Так, например, устроен рейтинг GoldenURL, где сайты располагаются в порядке убывания зрительских симпатий (на каждом сайте-участнике размещена форма для голосования). Есть также и другие рейтинги, которые могут отражать точку зрения одного отдельно взятого человека или некие параметры сайта, например, его техническую оснащенность. Тем не менее, механизм обсчета для таких рейтингов сложнее, а результаты менее достоверны, рейтинги требуют большего внимания и, что гораздо важнее, большей активности посетителей, поэтому рейтинги, в основе которых лежит не посещаемость, а что-либо другое, менее распространены в Интернете.

Рейтинг имеет колоссальное значение при продвижении нового ресурса, именно для нового, еще неустоявшегося сайта рейтинг является зримым и весомым показателем успеха его владельца, свидетельством упорного труда и умения. Сам рейтинг, если он правильно выбран, представляет собой далеко не последний источник трафика для сайта: чем выше ваша позиция в рейтинге, тем больше народу к вам придет с него, и, следовательно, тем выше становится ваша позиция. Для некоторых рейтингов отдача может составить очень солидную цифру. Так например сайт Библиотека Мастер имеет более ста человек в день непосредственно от рейтинга "Рамблер" (если находится в первой двадцатке), при этом он расположен не в самой посещаемой рубрике.

В рейтинге, по большому счету, нужно участвовать только в том случае, если вы твердо рассчитываете оказаться среди лидеров. На мой взгляд, участие ради участия не пойдет на пользу, - такая позиция вредит рейтингу (обилие ресурсов второго эшелона снижает его ценность), подрывает вашу волю к победе и, главное, - практически не приносит пользы. Если ваш сайт находится дальше второй страницы рейтинга, это почти также плохо, как если бы его вообще в этом рейтинге не было. Статистика говорит о том, что посещаемая (!) рубрика "Рамблера" начиная с 60 и, тем более, 80 места дает уже не более чем 0-2 человек в сутки, что не стоит даже и трудов. Таким образом, если вы не можете и, тем более, не надеетесь пробиться в рейтинге на первые места, то не тратьте на это времени.

Приступим к обзору основных существующих на сегодняшний момент рейтингов.

"Рамблер топ 100"

Самый популярный рейтинг в Рунете. Возможно, это также и самый посещаемый сайт в русскоязычной части Интернета. Этот рейтинг очень используется как внешний аудитор посещаемости сайта при расчете с рекламодателями или при обмене ссылками. Очень часто можно услышать реплику: "У меня 200 человек в день по Рамблеру". Такая система внешнего аудита возможна благодаря существованию открытой статистики, которая составляется автоматически, а также известной строгости рейтинга в обсчете сайтов. По крайней мере, ситуации, когда "Рамблер" приходится проверять, случаются не слишком часто, - рейтингу можно уверенно доверять.

Как вы, наверное, знаете, рейтинг имеет 50 рубрик, внутри каждой из них сайты сортируются по посещаемости и выкладываются страницами по 20 сайтов в каждой. Таким образом, на каждый момент времени 1000 сайтов Рунета занимают лидирующие позиции в рейтинге и получают от него реальный приток посетителей (обычно не менее 50 человек в день). По умолчанию, учет ведется по уникальным посетителям (уникальность в переделах одного дня), пересчет положения сайтов производится каждые тридцать минут.

В рейтинге нет описаний, поэтому важно, чтобы название, которое вы вписываете при регистрации было интересным и легко запоминающимся. Попытайтесь не использовать английских названий, так как у русскоязычной аудитории они вызывают неосознанное отторжение и воспринимаются значительно медленнее. Постарайтесь не использовать названия длиннее 20 символов, так как длина строки ограничена и перенос на следующую строку выглядит небрежно и разбивает визуальный образ. То же самое касается и заглавных букв в названии.

Тщательно выбирайте рубрику, так как, в случае ее несоответствия содержанию сайта, посетителей вы соберете, а постоянную аудиторию (то есть, заинтересованных в вашем сайте людей), - нет. Если вашей тематике можно поставить в соответствие несколько рубрик, то внимательно изучите каждую из них, посмотрите, в какой из них встречается больше сайтов вашей тематики, где расположены ссылки на ваших конкурентов, на каком месте будет ваш сайт в этой рубрике, какова средняя посещаемость сайтов на первой странице в этом разделе и пр. Позиционировать свой сайт лучше в ту рубрику, где находятся ваши основные конкуренты, так как именно там будут искать материалы по вашей тематике посетители. Если и в этом случае перед вами стоит неоднозначный выбор, то выбирайте ту рубрику, средняя посещаемость которой более соответствует вашему сайту.

Не регистрируйте в рейтинге "сырой" сайт, чтобы тупо набрать посетителей на счетчике. Многие запомнят ваш сайт именно в образе недоделанного, некачественного продукта, и вам будет сложно потом завлечь этих посетителей обратно, когда сайт будет полностью обустроен. То есть я еще раз призываю вас методично следовать моим инструкциям и не опережать события.

Чтобы участвовать в рейтинге, необходимо разместить на рекламируемой странице счетчик посещаемости. Есть несколько вариантов счетчика: синий квадрат 88х88 точек (постепенно исчезающий символ Рунета 98-99 года) с цифрами или без и стандартные кнопки 88х31 точки нескольких разных расцветок с логотипом "Рамблера". В последнем варианте сам счетчик размещается в произвольном месте страницы (лучше размещать ее в самом верху страницы, это несколько увеличивает результаты) невидимой картинкой размером в одну точку. Счетчик "Рамблера" может быть размещен только на одной странице и только в единственном числе.

Форма для регистрации в рейтинге находится здесь.

Рейтинг "1000 звезд"

Рейтинг при мега-портале Infoart имеет очень низкую отдачу, в отличие от "Рамблера", причина чего кроется в отсутствии на нем рубрикации ресурсов. В результате, реальный прирост посещаемости от рейтинга имеют только первые 40 сайтов, попадающие на первые две страницы в рейтинге. При этом средняя посещаемость в первой двадцатке составляет около 4000 посетителей в день. Однако в отличие от "Рамблера", счетчик этого рейтинга можно размещать не только на титульной странице, но и на всех остальных страницах регистрируемого сайта. Таким образом, этот рейтинг является полностраничным, в противоположность одностраничному "Рамблеру". В целом, я не вижу интереса участия в этом рейтинге, за исключением тех случаев, когда вы можете попасть в двадцатку лидеров или хотите регулярно наблюдать свою позицию в Рунете на уровне 200-400 места.

Форма для регистрации в рейтинге находится здесь

Рейтинг "Лист Топ 100"

Рейтинг существует при каталоге Лист.ру и пользуется большой популярностью, хотя тягаться с "Рамблером" ему пока не по силам. Мне лично не нравиться ни сам каталог, ни рейтинг, но он приносит немало посетителей ежедневно и глупо ими пренебрегать. Рейтинг рубрицирован на несколько десятков разделов, ссылки на сайты даются без описания, представлены данные по количеству посещений всего, количеству уникальных посещений, а также прибавлению или убыли в процентах. Счетчик рейтинга, кроме этого, предоставляет вам довольно широкую статистику посещаемости, в том числе и по ссылающимся страницам. Для использования всех возможностей вам придется поставить полный код счетчика, включающий Java-скрипт (около 1,5 kb, не считая размера картинки), но в этом случае я рекомендую вам запретить неавторизированный доступ к данным, так как статистика по реферрерам (referrers) это очень ценная информация для конкурентов. Однако данные счетчика не всегда точны, поэтому его, в отличие от "Рамблера", рискованно использовать в качестве внешнего аудитора. Регистрация в рейтинге возможна только после регистрации в самом каталоге Лист.ру.

Форма для регистрации в рейтинге находится здесь

Рейтинг SpyLog

Так же как и предыдущий организован на базе статистического счетчика, и точно так же завязан все в том же скандале с базой данных почтовых адресов пользователей сервиса. Однако у этого сервиса есть и серьезные отличия от предыдущего рейтинга. Должен признаться, что предоставляемая сервисом статистика впечатляет: многостраничная обработка результатов, все стандартные данные, данные о реферрерах, статистика программного и аппаратного обеспечения пользователей, статистика распределения по времени, маршруты по сайту и пр. В целом, уровень этого сервиса приближается к возможностям лог-анализаторов, и в затылок дышит такому известному сервису, как HitBox, но мне очень не понравилось, количество битых картинок и неправильно загружаемых кусков страниц. Создается впечатление, что и сам счетчик работает не лучше. За первые полгода своего существования рейтинг набрал значительное количество участников и вышел в десятку лидеров среди рейтингов Рунета. В апреле 2000 года рейтинг публикуется на крупных площадках, что только увеличивает отдачу от него. В целом, этот рейтинг можно рекомендовать третьим после Рамблер и Лист.ру. Последнее время владельцы SpyLog практикуют трансляцию рейтинга на крупные ресурсы, что позволяет разместить свой ресурс одновременно в большом количестве рейтингов.

Форма для регистрации в рейтинге находится здесь

Рейтинг Count.ru

Некоторое время назад этот рейтинг, построенный на основе довольно приличного счетчика посещаемости стал быстро набирать популярность, но на данный момент, основная ниша, на которую он может претендовать - это домашние странички и персональные проекты. К тому же некоторое время назад разгорелся скандал по поводу продажи (или кражи) базы почтовых адресов пользователей этого рейтинга. В целом, этот рейтинг всплесками отдает очень неплохую приток посетителей, поэтому выгоден для персональных проектов, с другой стороны, участие в нем вряд ли будет выгодно для корпоративных сайтов.

Форма для регистрации в рейтинге находится здесь

Рейтинг "Ранкер"

Рейтинг с большой историей. Дважды он умирал и восстанавливался энтузиастами, пока, наконец, не был "прикоммандирован" к поисковой системе "Апорт". На данный момент считается одним из самых популярных рейтингов Рунета, в частности, поисковая система "Апорт" учитывает его показания, когда формирует страницу результатов поиска. У рейтинга неудобный интерфейс, кроме того, он медленно грузится, что тоже удобств не прибавляет. Регистрироваться в этом рейтинге, тем не менее, стоит.

Форма для регистрации в рейтинге находится здесь

Другие рейтинги:
Мафия топ 100
One.ru
Несколько советов напоследок.

1. Постарайтесь размещать счетчик как можно выше на странице, чтобы он всегда успевал загрузиться. Особенно это касается счетчиков тех рейтингов, которые позволяют установку невидимой картинки; в этом случае, как я уже писал, ее можно разместить в самом верху страницы без ущерба внешнему виду страницы.

2. Не стоит держать на одной странице несколько явных счетчиков. Это более серьезная проблема, чем может показаться на первый взгляд. С одной стороны, чем в большем количестве рейтингов вы участвуете, тем больше посетителей вы получаете, а с другой стороны, все рейтинги ведут обсчет результатов по-разному. В результате уже через несколько дней после регистрации вы обнаружите, что все счетчики показывают разные цифры, что производит очень тяжелое впечатление беспорядка на нового посетителя. На счастье, практически все рейтинги сейчас стали предоставлять возможность размещения слепого счетчика (то есть без цифр). Я рекомендую вам выбрать самый эстетичный на ваш взгляд счетчик (мне, например, нравиться лист.ру), а остальные убрать за логотипы.

3. Регистрируясь в разных рейтингах подумайте о том, что стоит варьировать описание или название в зависимости от аудитории рейтинга. Например для рейтинга Мафия топ 100 бесполезно давать выдержанное, аналитическое название, а для Инфоарта - наоборот.

Рекомендованная литература:

  • Регистрация сайта
  • Рейтинги
  • Успешная регистрация в каталогах - статья Тимофея Бокарева

Ссылки по теме:

  • Автоматическая регистрация в поисковых машинах и каталогах Рунета
  • Список наиболее успешных каталогов на Рамблере
  • Список каталогов и рейтингов в каталоге Лист.ру


Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Лекция 5.

Лекция 5

Регистрация в поисковых машинах

Вероятно, сейчас главным средством для нахождения чего-либо в Интернете являются поисковые машины. Я думаю, вы со мной согласитесь, если я скажу, что самая распространенная схема работы по поиску информации в Интернете - это нахождение нескольких дюжин зацепок через поисковые машины и последующее разворачивание темы по смежным ссылкам. Таким образом, мы знаем, что через поисковые машины в день проходит несколько десятков миллионов человек, которые ищут интересующую их информацию, - возможно, ею является ваш сайт. Несколько российских поисковых машин обрабатывают в день более ста тысяч запросов и являются одними из самых посещаемых сайтов в Рунете.

Поисковой машине абсолютно все равно, сколько у вас уже есть посетителей и на каком месте в рейтинге вы стоите. Ей также, в сущности, все равно, начинающий вы веб-мастер или опытнейший профессионал, ей абсолютно не важен дизайн вашей страницы. Робот - основа поисковой машины - всего лишь оценивает текст вашей страницы и определяет его релевантность (соответствие) введенному запросу. Для некоторых сайтов трафик от поисковых машин может достигать сорока и более процентов, однако твердо рассчитывать на это, все же, не приходиться. Тем не менее, на мои страницы приходит ежедневно до 100 человек только с поисковых машин, что уже выше, чем посещаемость множества небольших сайтов Интернета. Причем, в отличие от каталогов и рейтинговых систем, при использовании поисковых машин люди попадают непосредственно на интересующий их материал, который далеко не всегда является головной страницей сайта.

Очевидно, что взаимодействие с поисковыми машинами является одним из самых эффективных способов увеличения посещаемости ресурса. Пренебрегать им ни в коем случае не следует, более того, обратите особое внимание на оптимизацию вашего сайта для поисковых машин. Не верьте тому, кто скажет вам, что с поисковых машин ничего нельзя получить - то, что человек потерпел неудачу, говорит только о его личной практике, но не о вашей и, тем более, не об общераспространенном явлении.

Как я уже сказал, решающее значение для робота играет релевантность сайта (или конкретной страницы) запросу пользователя. Следовательно, ваша задача - найти запросы соответствующие тематике сайта и оптимизировать страницы именно под эти запросы. Просто подумайте, как бы вы сами искали вашу страницу с помощью поисковой машины, потом спросите друзей и, особенно, коллег по работе о том же. Составьте список с ответами, отсортировав его по частоте выпадения каждого слова - верхушка этого списка и будет являться релевантными вашей теме запросами. Сохраните этот список - он вам еще пригодиться.

То, что у вас получилось, - это список вероятных запросов, но еще не список ключевых слов, хотя это и достаточно близкие вещи. Запросы, которые вы выписали, в отличие от ключевых слов вашего сайта могут содержать слова и выражения, не встречающиеся в основном тексте страницы. Воспользуемся для анализа результатов вашей работы списком ключевых слов, который вы составляли в одной из предыдущих лекций, надеюсь, что вы еще не удалили тот текстовый файл, в котором они у вас хранятся. Давайте поработаем над этим списком ключевых слов.

Первым делом, сравните оба списка (ключевых слов и вероятных запросов). Посмотрите, каких слов явно не хватает и добавьте их, при этом равняйтесь лучше на последний список - список вероятных запросов. Вычеркните также и лишние слова, чтобы не замусоривать ваши страницы и не вводить в заблуждение пользователей. Перепишите список заново и сократите повторяющиеся слова и выражения, если встречается много дублей одного и того же слова, то постарайтесь употребить его в разных падежах или формах и в связках с разными словами. Теперь опять достаньте первоначальный список вероятных запросов и сравните с ним получившийся результат, если что-либо вас не удовлетворяет (не вычеркнули ли вы лишнего), - переделайте все еще раз. Это очень важная операция - она послужит основой всем вашим последующим действиям по регистрации в поисковых машинах, а следовательно, провести ее надо со всем возможным тщанием.

Правильный и окончательный список уберите в ящик стола на день-два и дайте ему "отлежаться", после чего возьмите в руки и еще раз внимательно прочитайте. Вспомните, при составлении списка вероятных запросов он был отсортирован по важности и частоте запроса. То же самое нужно сделать и с новым списком: отсортировать слова по мере убывания их релевантности вашему сайту. Проверьте все еще раз и - считайте полдела сделано!

Теперь воспользуемся получившимся списком ключевых слов. Для того, чтобы поисковый робот мог найти и понять ваши ключевые слова нужно их оформить в специальную конструкцию. Называется эта конструкция мета-тегами и помещается в самый верх страницы между тегами <head> и </head>, а выглядит все это безобразие следующим образом:

<meta name="autor" content="Автор страницы">
<meta name ="KEYWORDS" content="ключевые слова через запятую">
<meta name ="DESCRIPTION" content="описание страницы">

Все современные HTML редакторы, независимо от того, работаете ли вы непосредственно с кодом или в визуальном редакторе, позволяют вставлять мета-теги в автоматическом режиме. Достаточно указать в соответствующем мастере (или диалоге) описание страницы вместе с ее ключевыми словами, и мета-теги будут добавлены.

Очень хорошо, если каждая страница вашего сайта кроме собственного названия будет иметь и собственные, наиболее ей подходящие, ключевые слова, и собственное, естественно, описание. Конечно, часть ключевых слов, общих для всего ресурса, должна присутствовать в мета-тегах на всех страницах сайта, но там могут находиться также и свои, уникальные для каждой страницы слова. Это и естественно, если учитывать, что каждой странице вашего сайта присуще свое, уникальное содержание, и именно его, может быть, и потребуется найти пользователю через поисковую машину, поэтому уникальные особенности каждой страницы никогда не вредно отразить в мета-тегах.

Очень важно, чтобы ключевые слова были не просто описанием вашей темы, но и соответствовали основному тексту страницы, повторялись в нем, в противном случае все ваши усилия пропали даром, потому что страница, которая содержит искомые ключевые слова только в мета-тегах, скорее всего, будет признана роботом нерелевантной (или слаборелевантной, что, в общем-то одно и то же). Поэтому позаботьтесь о том, чтобы включить в основной текст вашей страницы ключевые слова, причем, чем чаще они там будут употребляться, тем лучше.

Хорошо. Теперь ваши страницы снабжены мета-тегами с описаниями и ключевыми словами и готовы к регистрации в поисковых машинах, следовательно, этим мы сейчас и займемся. Что такое регистрация в поисковой машине? Суть в том, что поисковая машина состоит из двух частей: паука (crawler) и индекса, паук постоянно "обходит" интернет и все встреченные по дороге ресурсы просматривает и заносит специальным образом в индекс (то есть, индексирует). Таким образом, при запросе на сайте поисковой машины поиск происходит не по реальным сайтам, а по их отображениям в индексе. Теоретически, если у вас есть сайт, то когда-нибудь "паук" до него доберется, но когда это произойдет не знает никто, поэтому существует механизм подсказки, когда вы можете предложить пауку проиндексировать ваш сайт, сообщив ему адрес. Так вы становитесь в некоторую "очередь на индексацию" и можете надеяться, что через несколько дней ваш адрес уже будет в базе данных поисковой машины - индексе.

Поисковых машин в интернете много, сколько их есть на самом деле наверно, не знает никто, но также как и с каталогами, вас интересуют только самые известные из них, для вас самые выгодные и перспективные. Остальные же поисковые машины не в состоянии обеспечить приличного объема трафика для того, чтобы имело смысл там регистрироваться.

Сначала посмотрим на русскоязычные поисковые машины, хотя не только они понимают русский язык, но именно через них проходит основная масса запросов на нем, поэтому именно русские поисковые машины предпочтительны для русскоязычного сайта. Внимания заслуживают, на мой взгляд, только три машины: "Апорт", "Яндекс" и "Рамблер".

Поисковая система "Яндекс"

Это моя любимая поисковая машина. Она прекрасно понимает русский язык и в состоянии образовать и понять любую словоформу русского языка - это означает, что если сделаете запрос "думать", то машина выдаст вам результаты поиска также и по словам: "думал", "подумавши" и даже "разум". Вы можете ввести просто нужную вам фразу, например: "как сделать сайт" и машина вам выдаст осмысленные результаты. Когда мне нужно найти что-либо в Рунете, то я всегда пользуюсь именно этим порталом, и очень редко возникает необходимость уточнять результаты или дополнять их с помощью другого поисковика. С точки зрения веб-мастера этот робот удобен также тем, что регистрация нового ресурса происходит в течение одного-двух дней, а быстрый "паук" регулярно обходит практически все поле Рунета и регулярно вносит изменения в индекс.

Форма для регистрации располагается по адресу: http://www.yandex.ru/addurl.html

Поисковая машина "Апорт"

Очень своеобразная машина. С недавнего времени был полностью переделан внешний вид сайта и, по словам разработчиков, также и обновлена база данных робота. Несколько позже был запущен новый механизм поиска и индексации "Апорт 2000", обладающий большими и интересными возможностями, такими, например, как поиск сайтов, а не страниц, индекс цитируемости, учет доступности и пр. недавно появился механизм поиска картинок, как обещают, более совершенный, чем простой поиск по полю alt. Эта машина претендует (и, надо сказать, довольно успешно) на роль не просто поисковой машины, но русскоязычного портала в Интернете, пытаясь вытеснить из этой ниши "Рамблер", "Инфоарт" и "Яндекс". Любопытно, что, благодаря новому механизму поиска "Апорт 2000", а также тесной интеграции с рейтингом "Ранкер", каталогом "Ау" и журналом "eMedia", это может получиться. Я не нахожу эту машину удобной, тем более, что довольно часто в качестве результатов поиска мне выпадал сбой робота, что довольно таки неприятно. Ко всему, сервер очень неторопливо загружает головную страницу, как назло, именно тогда, когда нужно срочно что-либо найти, а найти нужно обычно именно срочно. Тем не менее, этот робот уверенно входит в лидирующую тройку поисковых машин Рунета и сдавать свои позиции видимо не собирается, поэтому я не вижу причин, почему бы не зарегистрировать свой сайт в этой поисковой машине.

Форма для регистрации располагается по адресу: http://www.aport.ru/WINP/addurl.htm

Поисковая машина "Рамблер"

"Рамблер" - это монстр Рунета. Колоссальная поисковая машина соединенная вместе с самым популярным рейтингом и гигантским развлекательным центром "Чертовы Куличики" - все это вместе без сомнения является самым популярным комплексом в Рунете, причем суммарная посещаемость настолько велика, что сравняться с ней практически нереально.

К сожалению, поисковая машина "Рамблер" игнорирует мета-теги, поэтому работать с ней сложно и неудобно. Наибольшее значение в определении релевантности страницы имеют выделенные конструкции (заголовки, подзаголовки, жирный текст и пр.), а также непосредственно сам текст страницы. Соответственно для того чтобы зарегистрироваться в этом поисковике необходимо заполнить длинную форму, и это еще полбеды, так нужно еще чтобы в ней не повторялись слова, все поля были заполнены и т.д., а чуть что не так - переделывай.

Лично мне эта машина неудобна - неудобный вывод результатов, неудобный механизм поиска, не очень качественный (по сравнению с "Яндексом") отбор, неудобная регистрация, но ею пользуются десятки тысяч человек в день, поэтому зарегистрироваться там необходимо.

Форма для регистрации располагается по адресу: http://www.rambler.ru/new/add_site.shtml

Недавно появилась также новая поисковая машина "Епрст", но обретет ли он достаточно большую популярность, чтобы сравниться с ведущими тремя - неизвестно.

Форма для регистрации располагается по адресу: http://www.eprst.ru/docs/register.asp

Теперь я хочу сказать пару слов о зарубежных поисковых машинах. Как вы наверное знаете, несколько лет назад AltaVista анонсировала многоязыковой поиск, и, на сегодняшний день, практически все ведущие поисковые роботы научились индексировать русскоязычные документы. Такие гиганты как Infoseek, AltaVista, NorthStar, HotBot, Go и пр. Пропускают через себя несколько миллионов пользователей в день каждый, то есть, на два порядка больше чем русскоязычные. Поэтому, несмотря на то, что большая часть пользователей этих машин русского языка не знает, регистрироваться в них все равно нужно, так как это приносит реальных посетителей. Более того, при удачном стечении обстоятельств, вы можете получить до нескольких тысяч человек в день от любой из этих машин, но, правда, и удача для этого должна быть исключительной.

Перед тем, как регистрироваться в англоязычной поисковой машине переведите описание и ключевые слова на английский, возможно, сдублируйте их в мета-тегах, в форме регистрации на сайте поисковой машины лучше вводить либо английский текст, либо вместе с русским вариантом перевод на английский. Кстати, английский вариант описания и ключевых слов я рекомендую сохранить в общий файл с регистрационной информацией.

Поисковая машине AltaVista

Самая, пожалуй, известная и самая старая из ныне существующих лидеров поисковых машин, хоть и не самая удобная. Способна искать на тридцати или около того языках и переводить с одного на другой "на лету" (не на все, правда). Очень быстро индексировала страницы, обычно в течение двух-трех дней, что считается очень неплохим результатом. В ноябре 99 года была полностью переделана так, чтобы приобрести более "портальный" вид. Одновременно был переделан и сам поисковый механизм машины, но при этом из индекса загадочным образом "пропало" до 30% зарегистрированных ресурсов. В результате, обиженные веб-мастера кинулись регистрироваться заново и пробиться к странице регистрации практически невозможно. Попытаться, однако, стоит.

Форма для регистрации располагается по адресу: www.altavista.com

Поисковая машина Infoseek.

Самая большая (по крайней мере, долго таковой являлась) и самая удобная на сегодняшний день поисковая машина. Совершенно беспощадно отсекает спаммеров, буквально пропуская все вновь регистрируемые страницы через "прокрустово ложе" антиспаммеровских требований. Так же как и AltaVista способна искать на многих языках, и даже по базам Mp3 файлов и картинкам (по полю alt). Очень хорошо ищет по запросам из целых фраз, точно определяет при этом релевантные документы. Очень быстро индексирует страницы. Считается на данный момент одной из самых удобных и "аккуратных" поисковых машин.

Форма для регистрации располагается по адресу: http://www.go.com/

Поисковая машина HotBot.

Очень странная поисковая машина - ныне "младший брат" Infoseek (недавно приобретена). Умеет искать на нескольких языках, в том числе и на русском, не ищет словоформы, медленно регистрирует. Эффективность этой машины непредсказуема, так как одинаковая, казалось бы, начальная информация для Infoseek и HotBot означает принципиально разные вещи. Положение лидера говорит о том, что регистрировать свой сайт в базе это машины, все же, нужно, тем более, что база HotBot используется порталом Infoseek и несколькими популярными каталогами.

Форма для регистрации располагается по адресу: hotbot.lycos.com

Поисковая машина GoTo.com

Это самая молодая поисковая машина в десятке лидеров. Буквально за полгода она превратилась из мало кому известного сервера в одну из самых мощных и популярных поисковых машин. Именно Go.com первой из лидеров устроила аукцион по продаже ключевых слов (то есть верхних строчек результатов поиска по определенным ключевым словам). Вы можете зарезервировать одно или несколько ключевых слов с тем, чтобы при запросе на них, ссылка на ваш сервер стояла в самом верху. Стоимость такой услуги составляет от 1 цента за клик (то есть - цента за посетителя), но в условиях аукциона большинство "хороших" слов уже стоят по 50 и более центов за клик. При покупке ключевых слов вы должны все-таки соблюдать релевантность этих слов вашему сайту, в противном случае, они не могут быть за вами закреплены.

Форма для платной регистрации располагается по адресу: http://www.goto.com/

Другие поисковые машины, на которые стоит обратить внимание:
Google
Lycos
MSN
AOL
Google
Northern Light

На сегодня -все.

До следующих встреч!

Рекомендованная литература:

  • "Стратегии позиционирования в поисковых машинах"
  • Что понимается под успешной индексацией в поисковых системах - статья Тимофея Бокарева

Ссылки по теме:

  • SearchEngineWath.com - Лучший англоязычный справочный сайт по поисковым машинам.
  • Список поисковых машин в индексе цитирования "Яндекса"


Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Лекция 6.

Лекция 6

Ссылки

Почти наверняка, вы видели на многих сайтах такие разделы как "ссылки" или "мои друзья", или "другие ресурсы". Открыв подобный раздел, вы найдете там список адресов сайтов с описаниями или без оных. Зачем нужны эти страницы, какую роль они играют? Причин для создания страницы ссылок несколько: от желания похвастаться до полного бессилия сочинить что-либо путное, чтобы наполнить сайт. Но нас сейчас интересуют только две из списка возможных причин, а именно: связывание содержания с ресурсами близких тематик и популяризация собственного сайта путем обмена ссылками. Рассмотрим пример.

Существует сайт, посвященный приготовлению и употреблению варенья. На нем представлена обширная информация о вареньеедстве и вареньеварстве, дано множество советов, рецептов, в том числе, и уникальных. На сайте также присутствует раздел ссылок, где можно найти адреса артелей по сбору ягод, и агентств по закупке готового варенья. Здесь также есть адреса сертификационных комиссий, ярмарок и конкурсов на лучшего вареньееда, - все это может быть полезно, как начинающему, так и опытному вареньееду или вареньевару. Таким образом, посетители сайта имеют доступ не только к материалам сервера, но и к специализированной информации по всей области приготовления и поедания варенья, что делает рассматриваемый нами сайт вдвойне привлекательным. Во-первых, он интересен, как самоценный источник информации, и, во-вторых, как полезный справочник-путеводитель по тематическим ресурсам.

Очевидно, что создание собственной коллекции ссылок придает вашему сайту дополнительную солидность, а следовательно, дополнительных посетителей. Грамотно составленная страница ссылок находится на втором или третьем месте по посещаемости среди всех страниц сайта. Однако не стоит думать, что обилие ссылок - это провокация для ухода пользователя с сайта, так как если человеку не нравиться ваш сайт, то он волен уйти - хотите вы того или нет, причем, возможностей у него для этого предостаточно и без ссылок. В то же время, уйдя по ссылке, человек может еще не раз вернуться к вам, например, нажав на кнопку "back" в браузере.

Как грамотно составить таблицу ссылок? Для этого посмотрите на свои закладки, - наверное, у вас скопилось достаточное количество ссылок на сайты по вашей тематике, которые вы регулярно посещаете, - это и есть основа вашей страницы ссылок. Выложите все эти ссылки на одну страницу, уберите все малозначительные и случайные, а также не относящиеся к тематике, возможно, стоит убрать и ссылки на сервера, которые могут составить вам серьезную конкуренцию. Оставшиеся ссылки обязательно надо разбить по разделам в соответствии с их узкой тематикой. В зависимости от получившегося объема материалов разделов может быть больше или меньше, но я рекомендую вам придерживаться следующих рамок: 10-20 ссылок в разделе и не более 80 ссылок на странице. Таким образом, если вы не умещаетесь в этот объем, то можно организовать несколько страниц, на каждой из которых будет представлено по одному тематическому разделу. Объединив все эти страницы в отдельную область сайта, сделайте ее оглавление, поставив гиперлинки непосредственно на страницы разделов.

К каждой ссылке напишите небольшое описание на 200-300 знаков, характеризующее не только сам ресурс, но - и это особенно важно - ваше отношение к нему. Учтите, что чем больше ссылок на странице, тем короче должны быть описания, чтобы общий объем текста вместе с тегами не превышал 15-17 kb. Иногда к каждой ссылке достаточно приписать просто пару слов, объясняющих, чему именно посвящен ресурс, поскольку пользователь, теоретически уже ориентируется в тематике (он же изучил ваш сайт) и способен самостоятельно справиться с определением своих библиографических потребностей. Постарайтесь немного выделить ссылку (не только цветом, но и размером шрифта), чтобы она не терялась на фоне описания, но не переусердствуйте, ссылка - не заголовок.

Теперь нужно упорядочить ссылки по какому-либо принципу, например, по степени важности или исходя из ваших личных пристрастий. Я ни в коем случае не рекомендую сортировать ссылки по алфавиту, так как это ведет к официальности и потере информативности. Для небольшого персонального или коммерческого сайта лучше всего, на мой взгляд, подойдет сортировка на основании ваших личных оценок рекомендуемых сайтов. Если же вы создаете ресурс для профессионалов (например, для спортсменов вареньеедов), то хорошим вариантом будет также сортировка по степени важности рекомендуемых ресурсов или по полноте раскрытия темы (что, в общем-то, одно и то же).

Положение рубрик тоже играет важную роль, подумайте, что главенствует на вашем ресурсе, какая тематика вас лично более интересует (например, вареньеедство или вареньеварство, согласитесь, - это, все же, разные вещи), и согласно именно этим рассуждениям разложите разделы так, чтобы они более соответствовали характеру представленной вами тематики. Если вы решили разнести рубрики по разным страницам, то не забудьте, что нужно рассортировать строчки в самом оглавлении так, как это описано выше. Теперь перед вами рубрицированная страница ссылок с описаниями, которую вы готовы представить своим посетителям.

Вернемся к нашему примеру про вареньеедов и вареньеваров (пусть для простоты этот сайт называется "Варенье в массы"). Можете ли вы с уверенностью сказать, что он единственный в своем роде и больше в Сети нет ни одного ресурса посвященного поеданию и/или приготовлению варенья? Я думаю, что нет. Конечно же, существуют и другие сайты подобного рода, - одни из них хуже, другие - лучше, но они, безусловно, есть, поэтому на странице ссылок сайта "Варенье в массы" можно найти адреса этих ресурсов. В то же время, на страницах ссылок этих сайтов уже стоит ссылка на "Варенье в массы", таким образом, рассматриваемый нами сайт уже распространил свое влияние на довольно приличную часть сети и все, кто интересуется тематикой, довольно быстро его найдут.

Как это делается? Конечно же, не само собой. В данном случае начинает работать устоявшийся механизм обмена ссылками. В соответствии с ним, вы находите сайт, на котором хотели бы видеть свою ссылку, договариваетесь с его издателями (или вебмастерами, если они "по совместительству" являются издателями) и ставите ссылку у себя на соответствующей странице. В ответ на сайте-партнере появляется ссылка на вас. Принцип, как видите, очень прост, вопрос только в том, как найти нужные вам ресурсы и договориться с их владельцами.

Достаньте последний вариант списка ключевых слов, который вы, следуя совету в одной из предыдущих лекций, сохранили в отдельном файле на диске. А теперь набирайте адрес ближайшей поисковой машины и задайте ей поиск по вашим ключевым словам, - в результате, вы получите список сайтов одной с вами тематики (кстати, проверьте заодно, на каком месте вы находитесь в индексе). Обойдите эти сайты и решите, какие из них представляют интерес для вас и ваших пользователей - именно их занесите в закладки, а также в отдельный текстовый файл. Чтобы не полагаться на свою память, лучше сразу составлять описание сайта, коротенькое, предназначенное, скорее, для вас, чтобы служить вам напоминанием и предотвратить путаницу в ссылках. В этот же файл припишите к каждому адресу и e-mail его создателя (он должен быть указан на сайте). Повторите эту процедуру с несколькими поисковыми машинами и суммируйте результаты. К этому добавьте еще те ресурсы, на которые вы уже поставили ссылки (то есть на те, которые уже были у вас в закладках).

Составьте типовое письмо:
Добрый день, /имя/.

Мне очень понравился ваш сайт, он содержит нужную и интересную, на мой взгляд, информацию о приготовлении и поедании варенья. Некоторое время назад я создал свой собственный сайт на эту же тему - "Варенье в массы" (URL вашего сайта обязательно) и приглашаю вас в гости, надеюсь, что вам будет интересно. Так же я поставил на вас ссылку и, может быть, вы сочтете возможным поставить ссылку и на мой ресурс.

С уважением, Я
URL моего сайта

Укажите тематику, адрес и название своего сайта. Обязательно указывайте имя человека, к которому вы обращаетесь (его обычно можно найти на сайте), но если вы не знаете имени, то пишите "уважаемый издатель сайта такого-то". Разошлите персонализированные письма по списку и ожидайте ответа, но не забудьте поставить ссылки, если вы написали, что они стоят. Старайтесь отправлять письма на личные адреса, а не на официальные "ящики" типа webmaster@что-то.ру или owner@что-то.там

Положительный или отрицательный ответ будет зависеть, конечно, от тона вашего письма, но в несравненно большей степени от внешнего вида сайта, уровня подачи материала, а также от количества посетителей (впрочем, последнее играет незначительную роль). В случае согласия вашего адресата ссылка на ваш сайт появиться еще в одном месте, добавив тем самым еще один небольшой ручеек посетителей. Что же делать в случае отказа?

Разберитесь, почему вам отказали - обычно отрицательный ответ содержит мотивацию (если вам вообще ответили), если же объяснения в письме нет, то напишите веб-мастеру с просьбой объяснить причины отказа, опишите в этом письме самые лучшие стороны своего сайта, его качественный уровень и выгоды сотрудничества с вами. Возможно, человек передумает, и не исключено, что вы получите несколько ценных указаний по поводу того, как улучшить свой сайт. В этом случае, вы можете предложить обменяться ссылками еще раз, несколько позже, когда вы учтете замечания о сайте. Поэтому я не рекомендую снимать ссылок отказавших вам сайтов, не говоря уж о том, что вы собираете коллекцию ссылок по теме, а не ссылок на тех, кто поставил ссылку на вас. Также вам могут отказать из-за того, что ваш сайт может составить конкуренцию. Если это так (т.е. если вы имеете основания подозревать, что это так), то возьмите этот сайт "на заметку" и внимательно наблюдайте за ним. Во-первых, это ценный опыт, а во-вторых, он еще может доставить вам немало хлопот.

Не стоит учитывать все приходящие замечания по сайту, - это, все же, ваш сайт, а не общедоступный кусок пластилина. Учитывая замечания, просматривайте внимательно письма и накапливайте "критическую массу": если десять человек обратили внимание на один и тот же недостаток, то пора принимать меры. Надо критически относиться к себе и своему творению, внимательно выслушивать все замечания и анализировать их. Если вы не очень уверены в результате своего творчества, то можно завести специальную конференцию или просто попросить посетителей оценить ваш сайт в личном письме.

Одной из возможных причин отказа может стать скудность вашей страницы ссылок, некачественность ресурсов, представленных на ней. Мало кто захочет увидеть ссылку на свой сайт на аляповатой странице "самые coolest сайты в Сети", именно поэтому я так подробно описал принципы создания страницы ссылок и работы с ней. Именно поэтому вы сначала создаете приличную страницу ссылок из своих закладок, а только потом приглашаете к сотрудничеству других веб-мастеров.

Обязательно проверяйте ссылки на вашу страницу, которые ставят веб-мастера. Если что-то не так (искажено описание, дан неверный адрес или название сайта), то не стесняйтесь списаться с веб-мастером и попросите его исправить ситуацию. Периодически проверяйте наличие ссылок и их соответствие текущему состоянию сайта, изменяйте его в соответствии с новыми данными.

При проведении этой маркетинговой операции (в английской литературе она так и называется "linkage company") вам придется писать и получать много писем, наверное, впервые с начала раскрутки сайта. Отнеситесь к этому серьезно, так как письма - это одно из важнейших средств взаимодействия с аудиторией. Заведите себе несколько правил по работе с корреспонденцией:

  • старайтесь читать ее в тот же день, когда она приходит, выделите на это полчаса утром и час вечером
  • на самые важные письма отвечайте сразу - в течения часа-двух
  • отвечайте на все письма, хотя бы и односложно
  • отвечайте на письма не позднее, чем в течение 3 дней.

Эти правила становятся особенно важными, если ваш сайт не только информационный, но и коммерческий. В этом случае, возможно, выгоднее будет нанять специального человека, задачей которого будет отвечать на письма, если вы в отпуске или просто загружены другими делами. Разработка жестких правил работы с корреспонденцией избавит вас от финансовых потерь вследствие медленного и негибкого сервиса.

Мы разобрали организацию и проведение кампании по обмену ссылками. Ссылки, которые вы поставите (и, соответственно на вас - тоже) в случае успешного проведения кампании, составят основу вашего будущего трафика. Несмотря на небольшой вклад каждой из них, вместе все эти ссылки - большая сила. Задача опытного веб-мастера - постоянное увеличения количества ссылок на сайт, а следовательно, постоянное наращивание своего присутствия в Сети.

До следующих встреч.


Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Лекция 7.

Лекция 7

Баннерные сети

Безусловно, словосочетание "онлайновая реклама" прежде всего ассоциируется с баннерами, хотя это далеко не единственный рекламный носитель в Интернете (но все еще главный: до 57% рекламы в Интернете приходится на баннеры). Следовательно, при разработке маркетингового плана стоит уделить баннерной рекламе самое пристальное внимание. Рассмотрим возможности баннерной рекламы, ее свойства и применение при продвижении онлайнового представительства

Баннер - это прямоугольный графический объект (обычно *.gif или *.jpg) на странице, связанный гиперссылкой с другим сайтом (в отличие от, например, навигационной кнопки, которая связана с другой страницей на сайте и не является рекламным носителем). Теоретически, баннер может быть любого формата, лишь бы он умещался на странице, но существует несколько стандартных размеров, которые более распространены и могут быть использованы при обмене. Самые распространенные форматы, это (размеры в пикселах): 468х60, 400х50, 120х60, 100х100, 88х31, последний также иногда называется кнопкой. Баннер может быть, как анимированным, так и статическим, кроме того, последнее время получили распространения баннеры изготовленные с применением flash технологий.

Существует два основных варианта баннерной рекламы - это обмен и покупка. Первое означает, что вы ставите на своем сайте чей-то баннер, а кто-то у себя ставит ваш (то есть это тот же самый обмен ссылками, который был рассмотрен в предыдущей лекции, но основным носителем является не текстовая, а графическая реклама). Второй вариант - кто-то ставит ваш баннер на своем сайте, а вы за это платите (то есть покупаете рекламное пространство). Обычно и то и другое осуществляется через посредничество специальных узлов - баннерных сетей, которые, соответственно, могут быть платными или бесплатными.

Что такое баннерная сеть? Баннерная сеть - это система, объединяющая несколько (или много, или даже очень много) ресурсов и перераспределяющая показы баннеров по всем участвующим в системе сайтам. То есть система берет на себя работу по самостоятельному размещению вашего баннера на множестве сайтов других участников, а также по осуществлению мониторинга, сбору и анализу статистики и контролю за соблюдением правил. Грубо говоря, вы показываете некий усредненный баннер системы (обычно это баннер какого-либо, случайно выбранного участника), за что на страницах других участвующих сайтах демонстрируется ваш баннер. При осуществлении баннерного обмена вы обязаны разместить у себя на сайте код баннера системы, с помощью которого осуществляется показ на вашем сайте баннера какого-либо участника. При покупке баннерной рекламы, система обеспечит показ ваших баннеров на сайтах участников и оплату участникам в соответствии с внесенным вами депозитом (без установки на ваших страницах кода системы). За эти услуги (и платные и бесплатные) баннерообменная сеть взимает комиссионные, которые составляют обычно от 5 до 50 процентов, соответственно, деньгами или "натурой" (то есть баннерами). В большинстве сетей за платные услуги комиссия не взимается.

Несмотря на жуткое описание, только что прочитанное вами, все довольно просто, особенно если вы работали с кадровыми или рекламными агентствами. Представьте себе. В некоем городе есть несколько десятков тысяч рекламных щитов, причем каждым из них владеет отдельная компания. Вам необходимо разместить свою рекламу, скажем на 150 щитах и у вас есть две альтернативы: либо вы идете и договариваетесь с каждой фирмой отдельно (то есть теряете очень много времени на переговоры и разъезды), либо вы идете в рекламное агентство и заказываете размещение рекламы на 150 щитах. Последнее обойдется немного дороже, но без беготни, нервотрепки и, главное, быстро. Точно также действуют и баннерные сети, но иногда с большей гибкостью, чем офлайновые структуры, так как оперируют более полной информацией о составе аудитории, характера ресурса etc.

Как я уже писал выше, у вас есть два варианта использования баннерной рекламы: платный и бесплатный (причем, возможно и их сочетание). При бесплатной баннерной рекламе, чаще называемой баннерным обменом, вы получаете объем рекламы от других участников пропорциональный тому объему, который вы предоставили на своем сайте (учитывается, обычно, количество показов), таким образом, чем больше посещаемость сайта, тем больше он рекламируется в сети баннерного обмена. Вы, наверное, обратили внимание, что я написал "пропорциональный объем рекламы", а не "равный", так как количество показов, которое вы реально получите, будет отличаться от показанного вами на размер комиссионных баннерообменной сети. А объем отчислений, в свою очередь, может варьироваться в зависимости от количества показанных вами баннеров, эффективности показа рекламы на вашем сайте, присвоенного вам класса, но также может быть и фиксированным по всей сети. Самой распространенной схемой в Интернете является прогрессирующая шкала от 50 до 15 % комиссии в зависимости от объема показываемых вами баннеров (то есть, чем больше вы показываете баннеров, тем меньше взимаемая с вас комиссия).

Поговорим немного об эффективности баннерного обмена. По существующей на данный момент статистике, показываемые на сайте баннеры дают отклик (CTR - click true ratio) от 0,2 до 3,5 процентов, причем средний CTR равен 0,7 %. Отклик - это отношение количества просмотров на количество нажатий, то есть при отклике 1 % на баннер щелкает 1 человек из 100 посмотревших на этот баннер. Что в этом случае вы получите от баннерного обмена? Посчитаем: при условии, что вы помещаете баннеры на всех страницах своего сайта, среднее количество просмотров - три страницы за сеанс (то есть посетители в среднем просматривают по три страницы за посещение - это вполне реальная цифра), а средний отклик - один процент. Тогда вы получите около трех процентов новых посетителей за счет участия в баннерном обмене. Конечно, это не великая цифра, но как "прибавка к пенсии" выглядит вполне прилично. Таким образом, баннерный обмен - это не тот метод, на который можно делать ставку при продвижении нового ресурса, но им также не следует и пренебрегать.

С другой стороны, при покупке баннерной рекламы вы не привязаны к существующему на вашем сайте трафику. Действительно, вы можете купить любое количество баннерных показов, если у вас достаточно для этого денег, причем, стоимость баннерной рекламы, особенно на вторичном рынке, очень невысока. Тогда, даже и при том невысоком отклике, который предоставляет баннерная реклама, стоимость всей кампании останется невысокой. Покупка баннерной рекламы может стать серьезным шагом в сторону увеличения популярности вашего проекта. При этом надо понимать, что речь идет о покупке сотен тысяч и даже миллионов баннерных показов.

Если вы решили провести для своего сайта широкомасштабную баннерную кампанию, то проще всего будет обратиться непосредственно к брокеру (то есть, к баннерной сети). Имея солидный опыт в проведении рекламных акций, брокер посоветует вам и сроки, и объем баннерной кампании, и площадки, на которых лучше рекламироваться. В среднем, можно говорить о покупке, по меньшей мере, 250-400 тысяч баннерных показов (речь идет о рекламной акции в пределах Рунета), которые необходимо приобрести для проведения начальной рекламной акции - это, как вы понимаете, довольно большой объем рекламы, который только что запущенный ресурс самостоятельно показать не сможет никакими силами. Несколько сотен тысяч баннерных показов прокрутятся в Сети примерно за неделю и обеспечат вам от 2 до 7 тысяч посетителей, часть из которых останется в числе постоянной аудитории вашего сайта.

В Рунете на данный момент четыре крупных баннерных оператора - это Реклама.ру, ИнтерРеклама, RB1 и Russian Link Exchange - все они позиционируются на разные рынки, хотя и пересекаются местами между собой. Так Реклама.ру (РРУ) и RB1 предъявляет самые жесткие требования, как к самому сайту-участнику, так и к крутящимся в ней баннерам, при этом они обладают самым быстрым механизмом ротации среди всех крупных сетей. В целом, системы рассчитаны на бизнес-сайты высокого уровня. Сеть Russian Link Exchange (RLE) имеет две категории: общую и золотую, первая рассчитана на персональные сайты, небольшие бизнес-сайты, некоммерческие проекты с небольшим трафиком и пр., а вторая - на крупные рекламные площадки и большие проекты, составляя тем самым конкуренцию Рекламе.ру. Сеть ИнтерРеклама (ИР) включает в себя, по большей части, домашние странички и небольшие некоммерческие сайты, пересекаясь здесь с общим разделом RLE. В сетке есть раздел для порносайтов, который, теоретически, не пересекается с общим, но иногда бывают "прорывы" нежелательной рекламы на страницы обычных участников (хотя, надо сказать, такого давно не было). В среднем, система содержит баннеры очень низкого уровня и качества изготовления, поэтому участие в ней может быть накладным для бизнес-проектов, так как в один прекрасный момент вы можете обнаружить на верхней границе своего сайта баннер с полуголой Наташей Королевой. Репутация этой сети подмочена основательно.

Каждая из этих баннерных сетей с удовольствием продаст вам практически любое количество баннерных показов из своих комиссионных, если вы надумаете организовать баннерную кампанию для своего сайта. В отличие от обмена, где они занимают разные ниши, в борьбе за платного клиента эти сети жестко конкурируют, поэтому цены на показы регулярно падают.

Для обмена же я рекомендую использовать систему RLE (общий раздел), даже не смотря на ее высокую комиссию, а при достижении вашим сайтом 500 показов в день переходить в раздел RLE-gold или менять эту систему на РРУ. С другой стороны, возможно, вы не захотите участвовать в баннерной рекламе вообще, что, в общем-то, является оправданным решением для коммерческих сайтов. А вот покупать рекламу, как уже говорилось, можно у любого из этих трех операторов с примерно одинаковым успехом.

Ориентация на англоязычную аудиторию подталкивает вас к поиску аналогичных услуг за пределами Рунета. Здесь ситуация несколько иная. Безусловно, есть и баннерные сети, и они продают излишки показов всем заинтересованным в этом потребителям, но прямую и очень жесткую конкуренцию им составляют непосредственно баннерные брокеры, которые занимаются только продажей баннерной рекламы на площадях, непосредственно выкупаемых ими у веб-мастеров. Баннерные брокеры используют собственные или покупные отлаженные механизмы ротации, мониторинга, обсчета партнерских программ и пр. Поскольку же речи здесь о бесплатном обмене не заходит, то сайты участников гораздо жестче контролируются, а следовательно, обычно значительно выгоднее в качестве рекламоносителей. Поэтому конкурировать сетям бесплатного обмена и смешанным сетям с баннерными брокерами, нацеленными исключительно на продажу-покупку рекламного пространства, крайне сложно. Таким образом, если у вас есть необходимость в массированной рекламной кампании за пределами Рунета, то лучше сразу обратиться к баннерному брокеру и купить необходимое вам число показов.

Самые известные представители этого племени: ValueClick Teknosurf, Click2Net, eAds и др.

Как я уже писал выше, сети оперируют несколькими распространенными форматами, и основной из них - это 468х60 точек, но, в принципе, если вы не меняетесь, а продаете рекламу, то вы вольны использовать баннеры любого формата, так, например, на сайте "Библиотека мастера" используются нестандартные баннеры 160х50. Баннеры большего формата имеют обычно более высокий CTR, поэтому при проведении широкомасштабной рекламной акции имеет смысл ориентироваться именно на большие баннеры. Очень распространенным форматом являются также кнопки (88х31) - они обладают самым маленьким откликом, но и, соответственно, практически не занимают места. Обычно этот формат используется для локального обмена между веб-мастерами. Существуют также и системы обмена кнопками, но они не пользуются большой популярностью (кроме того, большинство из них не в Рунете).

Некоторое время назад (летом 99 года) сразу две обменные сети в Рунете объявили о поддержке новых форматов баннеров: РРУ теперь поддерживает формат 100х100, а RLE - 120х60 и 100х100 точек, однако, хоть эти стандарты имеют большую популярность, они не обеспечивают большого отклика и могут быть, на мой взгляд, использоваться только как дополнительные в том случае, если у вас есть свободное место на странице, не слишком нагруженной графикой.

На сегодня - все.

До следующих встреч.

Рекомендованная литература:

  • А был ли мальчик, или цена и ценность "бесплатного" баннерного обмена.
  • Баннерная кампания
  • Выгорание рекламы
  • Баннерная реклама. Введение. - Цикл статей Тимофея Бокарева.

Ссылки по теме:

  • Раздел "Баннерные Сети" на ИнтерРекламе


Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Лекция 8.

Лекция 8

Конференция

Все, что вы представляете на своем сайте: тексты, картинки, цитаты, идеи etc., - все это есть отражение вашего собственного отношения к миру. Вполне естественно - это же ваш сайт и то, что вы на него выкладываете - ваши интересы, то, как вы видите представляемую тематику, то, что вы думаете о ней. В то же время, ваши посетители, - я надеюсь, вы это понимаете, - могут иметь другие взгляды, возможно, совершенно отличные от ваших.

Люди не любят, когда им навязывают чужое мнение даже в том случае, если оно частично или полностью совпадает с их собственным. Каждый или почти каждый человек желает высказаться, причем, по возможности, - публично. Это заложено в самой глубине психики человека, поэтому бороться с желанием высказаться бесполезно. Как издатель вы заинтересованы в том, чтобы потакать желаниям ваших посетителей, следовательно, вам необходимо найти способ удовлетворить стремление пользователей высказаться. Поскольку проблема эта достаточно распространена, то у нее уже есть стандартное решение - это конференция или, как ее часто называют - форум.

Конференция представляет собой сравнительно простой CGI-скрипт, поддерживающий постинг пользователем сообщений с автоматическим упорядоченным их размещением в теле HTML документа. Хороший скрипт может также поддерживать поиск по темам, несколько тем для обсуждений (то есть несколько разных форумов) на одном скрипте, регистрацию участников. Я предпочитаю на своем сайте "Библиотека Мастера" устанавливать очень простой форум Robboard, так как дополнительные сервисы (такие, как регистрация пользователей), на мой взгляд, лишь усложняют посетителям доступ к сообщениям, отбивая у них охоту общаться, а простота и надежность скрипта, зачастую, играют решающую роль при его выборе.

Конференцию можно взять в виде готового скрипта в любом публичном архиве, где они представлены в огромном количестве, но вам придется запастись терпением при выборе подходящего варианта. В тоже время, иногда бывает очень удобным не устанавливать скрипт самостоятельно, а арендовать его на стороннем сервере (то есть воспользоваться готовым сервисом). Это, право же, очень распространено, поэтому у вас не может возникнуть никаких трудностей при поиске такой услуги, исключая, может быть, лишь необходимость найти достаточно настраиваемый скрипт, чтобы можно было его гибко "подогнать" под дизайн вашего сайта. Оплата этой услуги производится, как правило, демонстрацией на форуме рекламных баннеров.

Не смотря на желание людей высказаться, вы будете разочарованы тем, как мало новых сообщений появляется на вашем только что образованном форуме. Люди, как известно, обладают стадным инстинктом, поэтому мало кто решится писать новые постинги на пустую конференцию. Напротив, конференция с большим количеством обсуждаемых вопросов, видимой многолюдностью будет вызывать живой интерес и желание тоже чего-нибудь сказать. Поэтому при запуске нового форума всегда возникает такая проблема, как первоначальное наполнение сообщениями для того, чтобы новый пользователь имел возможность вступить в уже существующее обсуждение.

Первичное наполнение можно сделать и самому, задавая вопросы и отвечая на них, представляясь под разными именами. Лучше, однако, попросить ваших знакомых, которым может быть интересна ваша тематика, чтобы они помогли начать конференцию. Тогда темы и их подача не будет выглядеть однообразными. Практика показывает, что 10-20 вопросов и ответов (ответы обязательны, просто вопросы вызывают ощущение запущенности) достаточно для дальнейшего развития конференции силами самих посетителей. Однако при невозможности привлечь знакомых к наполнению форума, я рекомендую вам ограничиться не более чем пятью вопросами и ответами, в противном случае, вы рискуете, что у вас возникнет не конференция, а еще одна контентная страница вашего сайта.

В конференции важно не только количество тем, но также и глубина их развития. Это вполне понятно: развитая тема создает видимость живого общения, ощущение значимости форума. Таким образом, на вопросы пользователей необходимо отвечать, причем, по возможности, быстро. Это приводит нас ко второй проблеме: форуму нужен постоянный модератор.

Модератор - это человек, который постоянно следит за развитием форума, вычищает хамские, нетематические, матерные и рекламные записи. Кроме того, в обязанности модератора входит развитие беседы, создание новых, занимательных топиков, направление беседы. Ну и, конечно, создание архивов конференции, отключение нежелательных пользователей (многие форумы позволяют отключать возможность постинга с определенных ip-адресов), работа с частной почтой и т.д.

Вообще модератор - это ключевая фигура любого форума и именно от него (его интересов, работоспособности, квалификации и расторопности) зависит как сама беседа, так и отклик, который она найдет у читателей. Может случиться так, что через пару месяцев на конференции будут обсуждаться совсем другие вопросы, нежели те, ради которых вы ее открывали. Поэтому к выбору модератора надо подходить очень внимательно.

Я намерено говорю о выборе модератора, подразумевая, что им будете не вы (издатель сайта), а какой-либо сторонний человек. Даже если вы сейчас располагаете достаточным временем для модерации конференций, то, что будет через пару месяцев?.. Вы этого, конечно, знать не можете. Поэтому гораздо практичнее найти специалиста со стороны, причем, возможно, наилучшим выходом будет предложить эту работу человеку, который входит в вашу постоянную аудиторию и часто заглядывает на форум.

Несмотря на то, что предпочтительный модератор для конференции - это сторонний человек, вы должны регулярно на нее заглядывать. Так, на конференции могут подниматься нелицеприятные для издателя вопросы, и по глубине развития темы, серьезности вопросов и ответов можно легко определить, является ли это просто трепотней, или за обсуждением кроется что-то действительно серьезное. Тогда нужно учесть пожелания посетителей и постараться их исправить. Возможно, на конференции всплывут также вопросы по теме, которые не вредно бы вам осветить в одной из очередных статей на сайте. Могут, кроме того, проскакивать интересные для вас идеи, дельные советы и предложения, поэтому посещение собственной конференции пойдет на пользу и вам, и вашим посетителям.

Постепенно вокруг конференции начнет образовываться некая постоянная "тусовка", которая обсуждает многие вопросы самостоятельно, может быть, даже встречается вживую, помогает новичкам, а, заодно, и вам. Эти люди - ваша опора, ядро вашей постоянной аудитории. Берегите их, так как доверие посетителей очень сложно завоевать.

В следующей лекции мы рассмотрим еще один ход в деле создания постоянной аудитории - подписные листы. До встречи.

Рекомендованная литература:

  • Конференция или как побудить людей общаться.

Ссылки по теме:

  • Конференции от студии Land
  • Конференции от List.ru


Библиотека разработчика - Подписные листы

Лекция 9

Подписные листы

Среди ваших посетитель есть много людей, приходящих к вам регулярно: некоторые чтобы найти что-нибудь новенькое, некоторые, чтобы обсудить накопившиеся вопросы в конференции или в чате, некоторые - просто от безделья. Но есть и другие люди - те, кому интересен ваш ресурс и разрабатываемая вами тематика, но у них нет времени часто к вам заглядывать с надеждой, что на сайте появилось что-либо новое. А есть и третья категория людей, которым интересна разрабатываемая вами тема, но не слишком интересен ваш ресурс.

И тем, и другим, и третьим придется по вкусу идея регулярной почтовой рассылки, издаваемой вами. Теперь, если у человека недостаточно времени для частого посещения вашего сайта, он сможет приходить только за действительно интересными для него новостями. Что же касается остальных, то им будет, по крайней мере, приятно своевременно узнавать о новостях вашего сайта. Таким образом, мы приходим к понятию почтовой рассылки, как маркетингового хода, направленного на создание и увеличение постоянной аудитории и поддержку постоянного интереса к вашему ресурсу.

Очевидно, что для выпуска почтовой рассылки вам нужна база адресов, по которым вы будете эту рассылку отправлять, то есть вам нужны подписчики. Теоретически, вы можете отправлять рассылку по купленной базе адресов, не спрашивая на то разрешения владельцев почтовых ящиков (как, например, это делают бесплатные рекламные газеты наподобие "Экстра-М"). Однако в этом случае ваши действия квалифицируются как СПАМ (рассылка невостребованной почты, подробнее о нем можно прочесть в статьях, рекомендованных в конце лекции), т. е. являются незаконными во многих странах и уж, по крайней мере, неприятно для конечных пользователей. Представьте, что в ваш почтовый ящик попадает не менее пятидесяти "мусорных" писем в день. Поэтому в этой лекции мы рассматриваем частный случай почтовой рассылки - подписной лист, где пользователи самостоятельно подписываются на получение нужной им информации.

Можно рассылать письма по листу и вручную, однако это становиться очень неудобным, как только количество подписчиков начинает подходить к сотне. Для автоматизации процесса существуют специальные сервисы, такие, например, как ListBot. Также, если вы умеете устанавливать CGI-скрипты, вы можете инсталлировать специальный скрипт для рассылки (информацию о скриптах и удаленных сервисах этого направления вы найдете в конце лекции). И удаленные сервисы, и скрипты на вашем сервере, и даже специальные программы, которые устанавливаются у вас на компьютере, - все они обладают примерно равными возможностями: автоматическая подписка и отписка, подтверждение подписки, выпуски в разных кодировках, отсеивание "битых" адресов и пр. Для того, чтобы ваши посетители могли подписаться на рассылку вы должны установить на своем сайте (я рекомендую устанавливать на всех страницах) небольшую формочку, такую, как, например, форма подписки на "Альманах Вебмастера":

Регулярная рассылка

Более сложный вариант, требующий больших энергозатрат со стороны издателя, - это регулярная рассылка, например, еженедельная. Чтобы такая рассылка была интересна читателям, в ней должны публиковаться не только собственно новости сайта, но и тематические новости, интересные материалы, заметки, советы и пр. Несомненно, публикуемая регулярная рассылка должна быть интересна сама по себе, а не только как приложение к сайту. Естественно, что в рассылке вы также публикуете и свои новости, привлекая тем самым посетителей на свой ресурс.

В последнем случае подписной лист в ваших руках превращается в мощный маркетинговый инструмент, а также в хороший источник прибылей. Реклама в почтовых рассылках на данный момент с полным правом считается наиболее эффективной (по параметру цена/отклик), поэтому вы можете с большой отдачей использовать рассылку для публикации платной рекламы. Однако для того, чтобы привлечь рекламодателей необходимо набрать несколько тысяч подписчиков, а до этого рассылка денег приносить, скорее всего, не будет.

Из опыта известно, что на приложение к сайту (рассылку) подписывается примерно от двух до пяти процентов посетителей, причем это количество возрастает до верхней границы при проведении рекламных кампаний (много новых посетителей) и падает в остальное время, потому что ваши посетители в этот период, по большей части, приходят к вам не в первый раз. Очевидно, если посещаемость вашего сайта составляет тысячу человек в день, то можно как-то надеятся на прирост подписчиков, но при меньшей посещаемости вероятность достижения вами трехзначного тиража остается весьма призрачной. Поэтому не вредно зарегистрировать свою рассылку в специальных каталогах рассылок, таких как, например, мой.

Несмотря на то, что реклама в рассылке имеет более высокую эффективность, чем баннерная и даже текстовая реклама на сайте, реклама самой рассылки - крайне непростое занятие. Если вы выпускаете рассылку, то, кроме регистрации в каталогах и рекламы на страницах собственного сайта, у вас остается очень немного возможностей. Одной из них является так называемая "информационная поддержка", когда вы договариваетесь с каким-либо посещаемым сайтом о размещении на нем формы для подписки на ваше издание, за что вы этот сайт регулярно рекламируете. Набор полудюжины информационных спонсоров способен обеспечить вашему изданию вполне счастливое будущее.

Пара слов о периодике

Есть несколько моментов, которые нужно решить для себя до того, как затевать регулярное издание. Этих моментов я хочу сейчас коснуться. В первую очередь, периодическое издание - не только сильный маркетинговый инструмент, но это также и достаточно мощный политический и/или идеологический инструмент, и относиться к ней нужно со всей подобающей серьезностью.

1. Сила периодики - в периодичности.

Издание, которое выходит регулярно читается подписчиками с большим вниманием и расценивается, как постоянный источник информации. Зная, что издание должно выйти завтра (так как оно всегда выходит в этот день недели), читатель будет невольно ожидать его появления в своем почтовом ящике, причем, это ожидание не столько заслуга качества и содержания издания, сколько его периодичности (регулярности). В данном случае - форма определяет содержание. А вот степень нетерпения уже определяется содержательностью и качеством издания, однако стоит заметить, что и простое ожидание уже подразумевает лояльность.

2. Периодические издания имеют позицию.

В своем издании вы поднимаете те или иные вопросы, освещаете те или иные проблемы. Рано или поздно, но в один прекрасный день вам придется занять свою четкую позицию в отношении освещаемой вами тематики. Конечно, бывают и исключения, например "Бинокль" (позиция которого практически ни в чем не выражается), но это новостная рассылка, а не тематическая, причем новости в ней публикуются самые разные, не привязанные ни к какой области нашей жизни, кроме собственно Интернета. Когда же вы займете какую-то определенную позицию, то вам придется ее отстаивать, что вовсе не является легким или очень приятным занятием.

3. Издание с позицией - это не только маркетинговая сила.

Коль скоро у вашего издания уже есть позиция - свое отношение к освещаемой тематике - то вокруг издания начинает формироваться группа единомышленников. Будучи сформированной, эта группа обладает вполне реальной и мобильной силой, серьезность которой пропорциональна количеству подписчиков и, соответственно, "весу" издания. Теперь вы можете отстаивать свои интересы, ущемленные права - у вас есть для этого возможности в лице ваших подписчиков, поскольку многие из них ваши единомышленники и ваши интересы совпадают с их интересами. Эту силу очень редко пускают в ход, но с ней всегда считаются.

Таким образом, видно, что выпуск периодического издания - это серьезный шаг и большая работа, которая предъявляет очень жесткие требования к издателю. Поэтому стоит еще раз задуматься и оценить свои силы, средства и возможности для работы с периодикой.

Несколько советов напоследок
  • Если вы начинаете активное продвижение издания непосредственно с первого выпуска, то внимательно отнеситесь к "пилотному" (то есть первому) номеру. Практика показывает, что колебания отписки-подписки при массированной рекламе после первого и, в меньшей степени, второго выпусков могут составлять до 50 процентов. Поэтому "пилотный" номер должен быть сделан идеально. Вообще же, я советую вам сделать несколько выпусков без "раскрутки", то есть для малого количества подписчиков, которые успели подписаться непосредственно с вашего сервера. Потом, когда вы "притретесь" к своей рассылке, то можно начинать агрессивную рекламу и набирать подписчиков.
  • Начиная регулярную рассылку, не выпускайте первый номер "с наскока", накопите материалы, чтобы у вас всегда был резерв на несколько номеров вперед. Я рекомендую оставлять материал, по крайней мере, на 7 номеров для ежедневника и на 2 номера для еженедельника. Тогда у вас не будет особенных проблем при временной нетрудоспособности (болезнь, командировка, сессия, отпуск, просто нехватка времени или усталость). Естественно, что этот запас нужно постоянно пополнять, заменяя потраченные материалы новыми, к новостным сайтам это, естественно, не относится.
  • Старайтесь всегда удерживать рассылку в одном и том же объеме. Большие скачки объема производят впечатление нерегулярности, несмотря на то, что рассылка приходит всегда в один и тот же день недели. Причем, если ваша рассылка включает много текстовых материалов, имеет смысл ограничить ее объем 5-7 kb для ежедневного издания и 10-30 kb для еженедельного или ежемесячного издания. Это именно тот объем, который средний читатель в состоянии регулярно внимательно прочитывать. То же самое касается и содержания вашего издания. Старайтесь, чтобы у вас было более или менее постоянное количество рубрик и эти рубрики не менялись бы каждый номер. При этом возможны "плавающие рубрики", то есть такие, что появляются не в каждой рассылке, а через определенные промежутки времени. Однако при этом должно быть несколько ключевых рубрик - тех, что составляют суть вашей рассылки.

До следующих встреч.

Ссылки по теме:

  • Ситикет - ведущий оператор рассылок в Рунете
  • MailList - оператор рассылок от Agava Software
  • Content.ru - оператор рассылок от каталога List.ru
  • Атлант - один из старейших операторов рассылок


Библиотека разработчика -Ясли-сад. Курс маркетинг для мылышей. Лекция 10.

Лекция 10

Брендинг

Подходя к этой лекции, завершающей первую часть курса, вы многому научились и, возможно, многое уже сделали для своего сайта. Вы подготовили сайт для проведения рекламной кампании, зарегистрировали его в каталогах, поисковых машинах и рейтингах, обзавелись перекрестными ссылками с коллегами веб-мастерами, и многое, многое другое. Сегодня, своеобразным заключительным аккордом, я расскажу о брендинге. Это, пожалуй, самая сложная тема в рамках первой части "Маркетинга для малышей" и, тем не менее, я считаю, что она должна быть освещена как можно раньше, и приступать к ее реализации нужно не когда-нибудь, а прямо сейчас, когда ваш сайт еще совсем молод. Поэтому запаситесь вниманием и приступим.

Брендинг, в буквальном своем смысле, - создание бренда.

Бренд - общее торговое имя или торговая марка компании или продукта, репутация и известность этого имени.

Есть известный анекдот на эту тему: "Если купить компанию Coca-Cola, а затем продать все ее составляющие (заводы, торговые точки, помещения, офисное оборудование, патенты и пр.) по отдельности, то сумма, на которую вы погорите, и будет стоимостью бренда Coca-Cola.

Бренд - это первое место в области. Бренд - это Имя, которое пишется с большой буквы и его маркетинговая сила очень высока. Например: "Мы говорим - партия, подразумеваем - Ленин", - здесь - Ленин это бренд всей коммунистической кампании. Вспомните недавнее время, когда все wintel-персоналки скопом назывались IBM-ки, хотя производителем их мог являться кто угодно. Никто не говорил про них PC, все говорили IBM или IBM-совместимые. И так было вплоть до 486-х машин, - к тому времени у IBM не было и четверти рынка персональных компьютеров, а сейчас Compaq опережает ее чуть ли не вдвое, но никто не говорит Compaq-совместимые. Здесь IBM - бренд, причем на приведенном примере видна вся инерция этого имени.

В чем сила бренда? Представим на минуту, что вы не разбираетесь в предмете, который вам необходимо освоить или приобрести. Например, вы хотите купить лазерный принтер, но ничего в них не понимаете и понимать не хотите (а почему бы, собственно, и нет?). Вы идете в магазин и с вероятностью около 85% покупаете принтер от HP, - это действительно очень хорошие принтеры: они надежны, универсальны и неприхотливы, именно их вам посоветует продавец-консультант в магазине и будет прав. С другой стороны, во многих конкретных случаях по сумме показателей (цена, скорость работы, стоимость обслуживания, характер работы, нагрузка и пр.) можно найти принтер, который будет лучше или, по крайней мере, не хуже, чем HP, но об этом выборе знает человек, который хорошо разбирается в проблеме. Почему же тогда многие люди выбирают HP? Потому что это бренд, который все знают, потому что это известная компания с многолетним стажем, а вот что такое Oki, Kyosera, Canon, Fujitsu и пр. обыватель не знает.

Таким образом, очевидно, что бренд работает в основном на новую, незнакомую с тематикой аудиторию, постоянно попадаясь ей на глаза в витринах магазинов и на страницах журналов. Бренд - это основная движущая сила по расширению вашего присутствия на рынке. Он обладает чудовищной инерцией: однократные неудачи легко списываются как временные трудности компании, в то время как у noname-компании каждая неудача способна привести, если не к банкротсву, то, по крайней мере, к серьезным убыткам (вспомните недавнии злоключения Iomega). Посмотрите: десятки компаний с мировым именем, часть продукции которых не только не лидирует в своей области, но является откровенно неудачной на фоне конкурентов, несмотря на это процветают.

Естественно, что инерция бренда работает в обе стороны - создать его не менее сложная задача, чем растранжирить. Я обратил внимание, что последнее время на страницах газет о трудоустростве все чаще стали мелькать объявление о поиске brend-менеджеров. Эти работники закладывают основу имени фирмы, ее золотой фонд доверия, и, конечно, зарплата у них соответствующая.

Вернемся к рассматриваемому нами понятию "бренд". Это не только торговая марка, которая у всех на слуху, но и торговая марка, которая известна своей надежностью и качеством. Возьмем, к примеру, такую марку, как "МММ" - эта компания, безусловно, имеет широчайшую известность, но ее имя не является брендом. Наверное, достаточно точное определение понятия "бренд" будет: "Известное, доброе имя компании или продукта", тогда силой бренда, то есть тем параметром, который определяют фактическую маркетинговую, а следовательно, и финансовую отдачу, будет та степень известности, которую этот бренд имеет. Возвращаясь к анекдоту в начале статьи: чем больше денег вы потеряете, распродав фирму по частям, тем сильнее был ее бренд.

Говоря о силе бренда, надо, само собой, упомянуть о его масштабах. Вернемся к компании IBM, о которой я уже упоминал в этой статье, - этот бренд знают, без сомнения, во всем мире. С другой стороны, компания DVM известна в Москве, возможно, не менее, чем IBM, но кто о ней знает за пределами города? Следовательно, DVM-group - это московский (или, может быть, российский) бренд, а IBM - мировой. Или вот другой пример: рядом с моим домом пять или шесть продуктовых магазинчиков, и все они продают полный ассортимент продуктов от бакалеи до вино-водочных товаров, но вкусный хлеб есть только в одном из них, и жители окрестных домов ходят за хлебом именно в этот магазин, хотя он немного дороже остальных. Таким образом, этот магазин (назовем его "Магазин на горке") стал брендом, но только в пределах одного микрорайона.

Как видно из приведенных примеров, бренд может быть как местного масштаба, так и мирового. Любопытно, что инерция бренда как маркетинговой силы при этом практически не растет в пределах его области распространения. Единственное, что дает прирост силе бренда - это рассуждение потребителей: "сколько народу верит этой торговой марке?", которое не применимо к "Магазину на горке", то есть бренду самого мелкого, сугубо местного масштаба. Все остальные параметры сходятся.

Создание же бренда для разного уровня торговых марок различается принципиально. Так, хорошая слава для булочной создается поставкой высококачественной продукции по цене на несколько процентов ниже, чем в соседних магазинах, - этот путь многократно проверен и не вызывает сомнений. В данную схему, использующуюся уже много лет можно внести только одно изменение - название. Звучное, запоминающееся название, имеющее привязку, может быть, к каким-то местным особенностям (все магазины в народе как-то, да называются: "стекляшка", "молочный", "хамский" и т.д.) облегчит задачу бренд-менеджмента.

Совсем другая задача стоит перед потенциальным брендом большого масштаба, - ему нужно, в первую очередь, стать широко известной компанией. Вспомните кампанию на телевидении торговой марки Лианозовского молочного комбината "Милая Мила". Непрекращающийся поток рекламы (неплохо сделанной, но сколько можно смотреть один и тот же ролик) превратил "Милую Милу" в притчу во языцех. Словом, "Милая Мила" была ужасной рекламой, от которой успели устать все, в том числе и те, кто включал телевизор всего раз в неделю. Сейчас же, по прошествии полугода, это самое раскупаемое молоко в Москве - оно не хуже других и не дороже, поэтому люди, попав под мощный пресс массированной рекламы, покупают именно его. Вот так был создан бренд: сначала мощная рекламная кампания "по площади", чтобы все потенциальные потребители узнали новую торговую марку, а затем поставки качественной продукции и снятие рекламы.

Таким образом, мы можем видеть, что на первом этапе создания бренда важно обеспечить ему известность (но не популярность). Причем сделать это можно практически любыми методами, даже и некорректными. Так, одним из наиболее эффективных способов стать общеизвестным является создание крупного скандала. Со временем неприятности забудутся, а известность останется. Следует помнить, что любой из способов создать себе известность недешев, и скандал, возможно, самый дорогой из них, хотя, на первый взгляд, может показаться иначе. Удельная стоимость маркетинговых акций при массовой рекламе всегда много выше точечной или нишевой рекламы.

К примеру, весной 99 года компания Volkswagen открыла русскоязычный сайт. Для его начальной раскрутки был потрачен 1 миллион баннерных показов во всех трех крупных баннерных сетях, при этом CTR составил всего 1,3 процента, что было неизбежно при таком массовом сбросе баннерных показов (миллион показов был потрачен за неделю, при общем объеме рынка не более 12 миллионов показов в день). То есть компания Volkswagen сознательно пошла на почти втрое большие расходы ради мгновенного увеличения популярности.

После того, как вы добились известности, приступайте ко второй стадии - созданию доброго имени. В этот момент вам особенно важно, чтобы ваша продукция оказалась не хуже (и, желательно, дешевле), чем у конкурентов. Здесь у вас широкий простор для деятельности: вы можете играть ценой, бонусами, призами, разного рода дешевыми трюками и пр. Обратите внимание, что на этой стадии (и даже немного раньше) вы должны обеспечить легкий и бесперебойный доступ к вашей продукции или сервису. В противном случае, ваша рекламная кампания может разлететься в пух и прах просто потому, что покупатель не сможет удовлетворить возбужденное рекламой любопытство. Кстати, это не такая уж редкая ошибка, как можно подумать. Я наблюдал довольно много кампаний испорченных тем, что был плохо рассчитан начальный спрос и продукции просто не хватило, а потом подоспели конкуренты (в частности, это одна из регулярных в прошлом проблем AMD).

С точки зрения интернет-проектов, проблема обеспечения постоянного доступа кажется не столь существенной, - серверу что будет, - работает себе и работает. Тем не менее, проблема существует: так, после смены дизайна сетевой магазин "Озон" предпринял активную маркетинговую кампанию, и сервер, на котором он размещен, просто не выдержал и рухнул от потока посетителей.

С точки зрения Интернет-проектов, одним из элементов бренда, безусловно, является доменное имя и его доступность в нескольких доменных зонах. Если вы планируете заводить английский вариант сайта, то зарегистрируйте для него домен в зоне com, для французской версии - в зоне fr и пр. В том же случае, если доменное имя вашего сайта является транслитерацией (например, pirogy.ru), то для англоязычной версии сайта стоит зарегистрировать соответствующее переводное имя (cookies.com).

И последний, третий этап - это постоянная поддержка вашего бренда. Периодическая реклама, расширение ассортимента продукции (в том случае, если бренд - это имя фирмы, а не торговая марка продукта), расширение области присутствия и пр. То есть вам нужно постоянно напоминать о себе, чтобы закрепить бренд в памяти потребителей.

В отличие от первой стадии создания бренда, здесь у вас появляются новые возможности ("что позволено Юпитеру, не позволены быку"). Вы можете спонсировать выставки, соревнования, устраивать конференции и участвовать в них. Также никогда не вредно установить шефство (или спонсорство, как это теперь называется) над какой-нибудь общественно-полезной некоммерческой организацией. Вы можете организовывать конкурсы, учреждать награды и пр.

Так, например, являясь фирмой по изготовлению варенья, вы можете устроить конкурс среди школ своего города на лучшего вареньевара или вареньееда (это как вам больше нравиться). Причем, обратите внимание, что реклама этого конкурса (и вместе с ним вашей фирмы) в центральной прессе обойдется значительно дешевле, чем соответствующий объем обычной рекламы вашего предприятия. Или вы можете выбрать какую-либо школу и, дав ей немного денег на развитие, организовать на ее базе лицей "Варенье", выпускники которого будут при желании зачисляться в пищевой институт по результатам выпускных экзаменов.

Возвращаясь к интернет-проектам, мы видим, что здесь действуют схожие законы и механизмы. Например, крупный, широко развернувшийся сайт, может помочь молодым проектам, организовывать бесплатные сервисы, конкурсы, участвовать в благотворительных акциях. Все эти действия нацелены, прежде всего, не на собственно рекламу сервера, а на поддержание бренда, его усиление и распространение.

Я неспроста на протяжении всей лекции рассказывал о невиртуальных фирмах, хотя цель курса - обучение интернет-маркетингу. На невиртуальных примерах брендинг выглядит более выпуклым, очевидным, все действия лежат ближе к поверхности, и внимательный наблюдатель легко может отследить работу того или иного предприятия по созданию и продвижению собственного имени. Кроме того, рынок интернет-брендинга в Рунете еще недостаточно развит, чтобы можно было бы на нем демонстрировать развернутые примеры. Поэтому внимательно наблюдайте за поведением невиртуальных брендов и немедленно берите на вооружение все те методы, которые ведут к укреплению вашего собственного бренда.

На этом заканчивается первая часть курса "Маркетинг для малышей". Ждите продолжения.

Чуть-чуть завершающих слов

Рекомендованная литература:

  • Концепция брендинга - статья Ольги Гусевой
  • Марка, откуда ты родом? - статья Маргариты Васильевой
  • "Знак обслуживания как условие успешного бизнеса". Часть 1, Часть 2 - статья Инны Полянской.
предыдущая лекция далее


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 1.

Лекция 1

Планирование

Что бы вы ни затевали, будь то домашняя страничка, развлекательный или коммерческий сервер, начинать надо с принципиального плана. Подумайте что и, главное, ради чего вы хотите запустить новый проект? Даже если ваша цель характеризуется фразой "чтобы было…", то она все равно определяет средства, которые вам потребуются, вернее, которые вы будете применять для ее достижения. Мне не раз приходилось давать консультации новичкам, которые хотели бы сделать свой сайт, но не знали с чего начать, и первое, что я у них спрашивал - это то, какие цели человек ставит перед собой; что именно и кому он хочет сказать или доказать. Парадоксально, но люди чаще всего не могут дать вразумительного ответа на этот, казалось бы, простой вопрос. Чаще всего можно услышать отговорки наподобие: "шеф сказал", или "хочется", или "это модно", однако конкретная цель остается за пределами разговора.

Но важность цели невозможно переоценить. Именно она определяет все (да-да, именно все) дальнейшие ваши шаги, начиная с выбора инструментов и исполнителей и заканчивая бюджетом и маркетинговыми методами, которые вы будет применять. Поэтому первым делом нужно сесть, положить перед собой белый лист бумаги и написать на нем вдумчивое и развернутое обоснование того, для чего вы хотите запускать новый проект, какие у вас есть цели и почему они актуальны (хотя бы и для вас одного). Кстати, если вы работаете в команде, то изложение плана на бумаге имеет колоссальное значение для полноценной работы вашей команды. Кто и как поймет то, что вы сумбурно или с недоговорками объясните на словах - неизвестно, а бумага - это четко изложенная инструкция.

Теперь, когда вы изложили на бумаге свои цели, подумайте, а стоит ли вообще воплощать их? Очень часто наши "великие" идеи будучи изложенными на бумаге превращаются в весьма жалкое зрелище (вообще бумага - строгий судья). Может быть, имеет смысл подождать, когда у вас появиться что-нибудь более интересное в плане идей, а не реализовывать заведомо обреченные проекты?

Но, допустим, вы все же пришли к выводу, что ваши цели хороши (иначе зачем бы вам читать дальше?), но рано еще спешить к компьютеру, надо решить еще кое-какие вопросы. В частности, необходимо определить набор средств, с помощью которых вы будете добиваться поставленной цели. Например, вы решили создать сайт о вашем новорожденном ребенке с целью, чтобы все ваши родственники (которых очень много), а также знакомые (которых еще больше) могли с нетерпением следить за взрослением ребенка в режиме онлайн (при этом их желание следить за ростом вашего малыша роли пока не играет). Что вам для этого необходимо? Конечно, в первую очередь, это фотографии - много, много фотографий, разбитых на группы по месяцам и годам: вот первая улыбка, первый раз ребенок сел, вот первый шаг и т.д. Во-вторых, это описание - дневник жизни вашего малыша от рождения и до текущего момента, ну и, в-третьих, вам нужно место, где вы могли бы оперативно отвечать на вопросы и принимать поздравления.

Или, например, вы художник и хотите устроить выставку-продажу своих произведений. В этом случае вам потребуются фотокопии ваших картин, желательно специально снятые для вашей галереи, книга для отзывов и предложений, а также некий специальный механизм для приема и оплаты заказов. Не исключено, что вы захотите поместить на сайте свои мысли по поводу некоторых картин: когда и как они были написаны, какое настроение владело вами, когда вы писали ту или иную картину и прочая и прочая.

Или, например, рассмотрим очень оригинальный и интересный сайт "Варенье в массы", посвященный приготовлению и поеданию варенья. Что же необходио разместить на нем? Конечно, это огромное количество рецептов варенья и советы ведущих кулинаров к ним, различные рекомендации по сбору, покупке, выбору и заготовлению ягод (или из чего еще варится варенье), условия их предварительной подготовки, и что делать, если ягоды оказались непригодными. Кроме того, уместными будут забавные истории, связанные с вареньем, фотографии супер-поедателей и отзывы о них, очерки о различных методах поедания варенья. И, наконец, доска приглашений на дегустации в специальные клубы (дисконт прилагается), а также чат для всех желающих приобщиться к теме в живом общении.

Вариантов может быть бесчисленное множество, и для каждого из них будет свой собственный список необходимых компонентов. Постарайтесь учесть и те составляющие вашего сайта, которые появятся позднее, в процессе его развития. Так, например, на сайте "Варенье в массы" со временем может быть организована прямая трансляция через Интернет чемпионата мира по поеданию варенья, следовательно, создателям сайта желательно предусмотреть и такой вариант развития событий, чтобы потом не пришлось в срочном порядке перекраивать весь макет.

Теперь у вас есть список необходимых компонентов, которые будут составлять основное информационное наполнение вашего сайта (content). Этот список охватывает все, что должно присутствовать на вашем сайте, следовательно, именно этот список вы будете держать в голове при дальнейшей работе над проектом (дублирование списка на бумаге никоим образом не отменяется).

Следующее, что вам предстоит сделать - это подготовить структуру сайта, которая в дальнейшем определит не только систему навигации, но и возможности по расширению. Что такое структура? Это логическое построение разделов, их совместное расположение и взаимосвязь на сайте. Вернемся к нашему замечательному примеру - сайту "Варенье в массы". Здесь у нас представлено несколько разных направлений:

  1. Рецепты приготовления варенья;
  2. Советы по приготовлению варенья;
  3. Забавные истории о варенье;
  4. Рекомендации по поеданию варенья;
  5. Советы по приготовлению варенья;
  6. Очерки о способах поедания варенья;
  7. Рекомендации по сбору ягод;
  8. Доска приглашений на дегустации;
  9. Чат.

Итак, у нас есть восемь видов информационного наполнения, которые необходимо сгруппировать по нескольким разделам. Казалось бы, вполне естественно сделать два раздела: приготовление и поедание варенья, но этого явно недостаточно. Куда, например, поместить забавные истории о варенье, а также доску приглашений на дегустации (безусловно, дегустации - это раздел "поедание", но они предназначены для определения лучшего рецепта, то есть - раздел "приготовление"). Возможно, впоследствии вы захотите организовать массивы информации, такие как: "История варенья" или "Лечебные свойства варенья", которые при разбиении сайта на два больших раздела помещать также некуда. Следовательно, нужно организовать, как минимум, четыре больших раздела:

  1. Приготовление варенья;
  2. Поедание варенья;
  3. О варенье;
  4. Живое общение;

На самом деле, можно организовать и линейную структуру, но у нас в наличии восемь массивов, тогда как объем воспринимаемой человеком информации, как доказано физиологами, 5-7 предметов единовременно. Таким образом, при задании линейного массива информации в данном случае вы будете вносить дезорганизующие элементы в сознание (а следовательно, в восприятие) пользователя. Поэтому, постоянно помня о возможностях расширения, мы организуем на сайте "Варенье в Массы" четыре больших раздела, в которые и оформляем все наши массивы информации. А вот, линейная структура подходит очень хорошо для небольших объемов тексто-графической информации.

Итак, теперь у нас есть структура сайта "Варенье в массы":

Примерная схема рассматриваемого сайта _Варенье в массы_. Т-титульная страница, Рх-титульные страницы разделов, Мх-массивы самостоятельных контентных страниц.

Обратите внимание, что М 1… 8 - это массивы контентных страниц, а титульная страница (Т) и титульные страницы разделов (Р 1… 4) - это одиночные страницы. Если сравнить нашу схему с привычной каждому печатной книгой, то Т - это титульный лист, Р1-Р4 - шмутцтитулы, а М1-М8 - это собственно сами сотни страниц с текстом. Однако если в массивах 1-8 слишком много текстовых страниц, то они могут потребовать дополнительной рубрикации, то есть дополнительных промежуточных страниц (например, массив рецептов может содержать несколько сотен страниц, и пользователь будет испытывать неудобства, если для поиска нужного ему придется перебирать все варианты). Применительно к рассматриваемому нами массиву рецептов это может выглядеть следующим образом:

Схема сайта _Варенье в Массы_ при наличии подразделов (обрезанная)
Где Пр 1 - титульная страница подраздела.

Получившаяся структура даст вам не только прозрачное понимание сайта для всех, кто над ним работает, но впоследствии и основу навигации (о ней будет рассказано в следующих лекциях). Фактически, вам осталось натянуть на получившийся каркас непосредственно сами механизмы навигации и система перемещения по сайту уже готова.

Все, что у вас получилось надо записать на бумаге и отложить в сторону для раздумий, а через пару дней вернуться к своим запискам и подумать: ничего ли вы не упустили? Возможно, имеет смысл оставлять на полях заметки о смысле тех или иных разделов, которые вы предусмотрели на сайте, потому что через пару недель, когда вы приступите к наполнению сайта информацией, рабочие названия ваших разделов могут потерять для вас смысл и вы запутаетесь. Вообще, надо сказать, что на память лучше не полагаться, поскольку дел очень много и все важные, а память - вещь ненадежная, поэтому все, что можно записать, лучше записать.

Ну, что же, поставьте закладку, а завтра мы с вами перейдем к следующей лекции.

Рекомендованная литература:

  • Что такое стильный вебсайт
  • Постановка задачи.Часть II. Часть III


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 2.

Лекция 2

Макет

Макет - это набор правил, по которым располагаются элементы страницы. Таким образом, макет - это основа верстки, - тот каркас, на который "натягиваются" элементы дизайна и информационное наполнение страницы.

Обратите внимание, например, на какой-либо известный периодический журнал (лучше бумажный, а еще лучше - бумажный научный), здесь вы увидите, что повторяющиеся элементы: расстояние между колонками текста, размер запечатываемой области полосы, отступы перед заголовками, размеры пролей и пр. - одинаковые по всему журналу. Собственно это и есть макет журнала, и точно то же самое вам предстоит сделать для своего сайта.

Зачем нужен макет? Как один из основополагающих элементов стиля, макет создает в документе единство, ощущение неделимого образного ряда. То есть макет упорядочивает документ, делает его, в общем случае, легкочитаемым и более удобным для восприятия. Вторая, не менее важная роль макета - это облегчение жизни верстальщика. Теперь ему не нужно задумываться над тем, как "раскидать" элементы на страницы, так как их положение жестко задано или определено макетной сеткой.

Прежде чем начать создание макета, необходимо определить, макет чего вы собираетесь делать, что сводиться к определению количества принципиально различных страниц на вашем будущем ресурсе. Например, "Парад уродцев" целиком создан на одном макете, несмотря на то, что первая страница внешне несколько отличается от всех остальных; в этом случае создание макета для сайта сводиться к планированию одной единственной страницы. Результатом такого планирования, является единый шаблон, по которому создаются все внутренние страницы.

Иногда возникает необходимость создания нескольких макетов для одного сайта, однако это может быть оправдано только в том случае, если нужно заметно разделить несколько разделов или при наличии различных типов материалов, долженствующих размещаться отдельно. Но даже и в этом случае важно понимать, что создавать две разные страницы, пользуясь одним макетом гораздо проще, чем создать стилистически похожие страницы на разных макетах. Для примера можно сравнить страницы статей и страницы в каталоге рассылок на сайте "Библиотека Мастера", которые сверстаны по одному макету.

Поскольку основным средством точного позиционирования элементов на HTML-странице являются таблицы, то задача макетирования во многом сводиться к рисованию (естественно на бумаге) сетки этой таблицы. Потом, когда вы уже научитесь пользоваться языком разметки станиц HTML, то в том или ином редакторе создадите рабочий вариант этой таблицы и наполните ее содержимым, а пока ваша задача только нарисовать ее на бумаге.

Очевидно, что для создания макета необходимо четко представлять себе количество и характер элементов на странице, а следовательно, вам необходимо заранее определить типы материалов и их объем. Ну, с типами все довольно просто, так как вы определили их еще при планировании сайта, а вот с объемами придется немного повозиться. Фактически у вас есть два варианта: либо вы подгоняете макет под объем материалов, либо вы подгоняете объем материалов под заранее созданный макет. На самом деле, прибегать к первому варианту приходиться крайне редко, например, при работе с авторскими или другими специфическими материалами, которые не подлежат редактированию. Во всех же остальных случаях, любой материал - картинка или текст может быть доработан в соответствии с требованиями макета.

Возьмем в качестве примера "Парад уродцев". Это классический вариант подгона материалов под макет: все картинки приведены к одинаковой ширине (для удобства, макет допускает три стандартные ширины) так, чтобы они укладывались в отведенное им место. Естественно, что макет учитывает основной характер материала (крупные графические объекты), поэтому я легко могу подгонять материалы в соответствии с установленными правилами. С другой стороны, зажатый со всех сторон макет "Библиотеки Мастера" не подходит для графической информации, которая будет стараться "выйти за рамки страницы" и создавался специально для текстовых и презентационных материалов (диаграммы графики), поэтому не возникает проблем при их редактировании под формат. Точно также и вы определяете характер предполагаемых материалов, делаете макет, а затем подгоняете объем информационных элементов под установленные вами же рамки.

Вернемся к собственно самому макетированию - вам предстоит создать таблицу, отвечающую нескольким требованиям. Во-первых, она должна содержать пространство для каждого возможного элемента на странице, то есть, создавая таблицу, вы должны предусмотреть место для каждого элемента, который вы захотите на данной странице поместить вне зависимости от того, будет он реально присутствовать на каждой странице, сверстанной по этому макету, или только на некоторых. Во-вторых, в создаваемой таблице должно быть минимальное количество ячеек, которое будет удовлетворять вышеозначенному требованию. Это позволит вам легче управлять таблицей (то есть упрощает процесс верстки), и, кроме того, вы несколько сокращаете объем кода, уменьшая тем самым нагрузку на сервер и время, необходимое для загрузки страницы. На самом деле, язык HTML не обладает, мягко говоря, широкими возможностями для макетирования, однако, вы можете жестко задавать ширину столбцов и объединять (как в EXCEL) любые рядом стоящие ячейки. В-третьих, таблица должна быть достаточно гибкой, чтобы в нее можно было поместить широкий диапазон непредусмотренных элементов. Вам предстоит создать свою таблицу, исходя из вышеозначенных предпосылок.

Особенности WWW и собственно языка HTML приводят к тому, что вид вашей страницы зависит от настроек конкретного компьютера пользователя. В связи с этим ваше творчество ограничено рядом стандартов 'de facto' - со многими из них вы познакомитесь по ходу курса. Что же касается макета, то здесь вы ограничены по большей части экранным разрешением (то есть количеством точек, которые способен отображать среднестатистический монитор). Вернее будет сказать так: если вы не хотите доставить пользователям неудобство (а горизонтальная прокрутка экрана - это одна из самых неприятных штук), то ограничивайтесь экранным разрешением. Доминирующее сейчас разрешение - 800х600 точек, более того, с постепенным переходом на 17-дюймовые мониторы среднее разрешение возрастает до 1024х768. Опираясь на эти цифры, вы можете смело рассчитывать на ширину 700 точек - это будет максимальная ширина вашей таблицы. Внимание полиграфистам: точка (pixel) к пункту не имеет никакого отношения! Это физическая точка - элемент люминофора.

Создание макета - это не только конструкторская задача, но и, в некотором роде, творческий процесс. В связи с этим, предложить здесь какую-либо жесткую схему работы достаточно сложно, если не сказать - невозможно. Тем из вас, мои читатели, кто работал с печатной продукцией и особенно с версткой периодических изданий будет проще разобраться с созданием макета. Вместо того, чтобы пытаться выстроить схемы построения макетов, попробую рассказать, как я делаю макет нового сайта, возможно, вам поможет моя методика. Также я рекомендую прочесть литературу по теме, список ее вы найдете в конце лекции.

Во-первых, я сажусь за стол и кладу перед собой стопку бумаги и несколько карандашей и ручек разного цвета - мне удобно рисовать разными цветами, хотя на первых стадиях проектирования это может быть несущественным. Так, основы своих макетов я обычно разрабатываю в метро или в перерывах между работой на любом мало-мальски подходящем клочке бумажки. Затем я выписываю на бумагу все элементы страницы, в том числе и те, которые будут присутствовать только с некоторой степенью вероятности - планирование их присутствия необходимо, чтобы макет был достаточно гибок и учитывал все возможности расширения. Если вы грамотно спланируете принципиальный макет, то вам не придется его часто менять из-за того, что необходимо внести какие-либо материалы, которые "не лезут" в старую сетку. В списке, который я составляю, обязательно присутствуют и рекламные баннеры, и кнопки, и элементы навигации - все до самых последних мелочей, что должно присутствовать на страницах нового сайта. Если элемент имеет фиксированные размеры, то я обязательно помечаю это у себя в списке.

После этого я решаю для себя сколько потоков информации будет размещено на каждой странице, например на внутренних станицах "Библиотеки Мастера" таких потоков два: основной текст в левом поле и навигационное меню справа. Число визуальных колонок-полей текста (но отнюдь не колонок таблицы-разметки) будет соответствовать числу информационных потоков (и наоборот). Далее я рисую от руки примерное расположение элементов на странице, обязательно включая элементы, которые имеют фиксированные размеры (обычно это баннеры и кнопки). На этом этапе все подобные элементы должны быть распределены по странице, то есть в этот момент я уже представляю, как будет выглядеть страница. Важной деталью будет определение ширины колонок для комфортного размещения в них необходимых материалов. Например, если вы располагаете большой массив текста (более 5 килобайт), то вряд ли вы захотите это делать в узкой колонке 100-150 точек, для такого текста подойдет поле шириной 350 и более точек. Все это необходимо учитывать на начальной стадии "раскидывания" макета.

Затем я расписываю на получившемся макете размеры элементов (пока только фиксированные) и смотрю что получилось. Общая ширина таблицы не должна превышать 750 точек, но лучше ее сдерживать в пределах 700-710 точек, чтобы гарантировано избежать горизонтального прокручивания экрана на старых мониторах. В реальности, чаще всего ваша таблица упирается в фиксированные размеры баннеров и кнопок: вам приходится либо отказываться от их использования (что, зачастую, означает отказ от одного из немногих источников прибыли), либо строить свой макет на их основе.

На всякий случай напомню, что самые распространенные на сегодняшний момент размеры баннеров - это 468х60, 120х60, 100х100, 400х50, а также кнопка 88х31. Следует иметь в виду также и формы для подписки на рассылку, которые могут иметь заранее заданную ширину (ее, правда, всегда можно поменять), поисковые окна и прочие служебные элементы. Таким образом, задача создания макета наполовину состоит из решения головоломки, как разместить все эти элементы на ограниченном поле страницы так, чтобы полученный результат выглядел гармонично и аккуратно.

Закончив с принципиальной схемой, я рисую макет на бумаге уже с помощью линейки и карандаша, приводя все к реальному масштабу и размечая размеры элементов (таблица 700 точек поместится на листе А4 в масштабе 2 мм на точку). Теперь мне точно известны размеры колонок, а следовательно и ширина размещения текстовых или графических элементов, поскольку часть из них образована от стандартных баннеров, а остальные получены по остаточному принципу. Расчертив колонки, я отображаю на макете характер материала в каждом информационном потоке, стандартные элементы, расположение навигации, колонтитульные элементы и пр.

Теперь по полученному макету нужно определить сетку таблицы, которая будет составлять основу HTML-страницы. Основная задача на этом этапе - создать такую таблицу, в которой можно разместить все указанные нами элементы, учитывая, что единственным средством, доступным нам в момент верстки страницы, будет возможность объединения любых рядом расположенных ячеек. Соответственно, нужно посмотреть на страницу и определить, есть ли в ней элементы, которые пересекают несколько рядом стоящих колонок. В этом случае, возникает необходимость введения в таблицу дополнительных колонок, относительно тех "поточных" колонок, которые уже получены на вашем макете (см. рисунок.). Если линии макета и линии сетки будущей страницы не совпадают (как это показано на рисунке), то я рисую линии таблицы поверх макета другим цветом.

Схема таблицы с налезающими элементами. Стрелками показаны потоки информации, а черными линиями - сетка таблицы

Итоговая таблица должна состоять из наиболее мелких регулярных элементов, которые вам предстоит включить на свою страницу. На самом деле, можно составить таблицу из сетки ячеек размером 1х1 см, а потом их соединять по мере надобности в конгломераты нужного размера, однако это крайне неудобно, во-первых, и очень не рационально, во-вторых, потому что объем полученного таким путем кода будет превышать все мыслимые пределы. Поэтому ваша задача составить не просто таблицу из минимальных элементов, а таблицу из элементов не больше и не меньше минимальных!

Собственно, это все. Таблица уже готова и теперь ее можно описать в виде HTML-кодов и "натягивать" на нее элементы дизайна, в результате чего, у вас получиться шаблон для последующих страниц сайта. После этого на шаблон "заливаются" уже сами материалы и получается сайт, но это уже тема для последующих лекций.

До встречи.

Рекомендованная литература:

  • Модульные сетки в вебдизайне


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 3.

Лекция 3

Материалы

Прежде чем выкладывать материалы на сайт, необходимо их для этого подготовить. Причем подготовка материалов, включает в себя не только их непосредственное создание, но и целый комплекс мер по их предварительной "обкатке". Именно об этом я буду рассказывать в нижеследующей лекции.

Общие принципы

Все материалы вашего сайта должны быть единообразны внутри каждой категории. Например, если у вас есть раздел со статьями (написанными вами или вашей фирмой), то постарайтесь, чтобы все представленные в нем статьи были примерно одного размера (не в точности, конечно, но с отклонениями не более чем на треть). То же самое касается и визуальных материалов: они выглядят значительно аккуратнее, если приведены к одному размеру (или, если это невозможно, то к одинаковой ширине или высоте). Кстати, это обусловлено и сеткой, которую мы изучали в предыдущей лекции, - для ее соблюдения вам так или иначе придется унифицировать графическую информацию.

Пожалуй, единообразие материалов - это наиболее важное к ним требование. Особенно это касается корпоративных и других сугубо официальных сайтов. То есть, унификация содержимого сайта придает ему солидность и строгость во внешнем виде. Сайт, на котором вся информация строго структурирована и выглядит специально для этого сайта написанной, воспринимается значительно серьезнее, нежели тот, материалы которого "надерганы" из разнородных источников. Важно, что однородность материалов не обязательно приводит к общей "скучной информативности" сайта, - это, скорее, вопрос языка, на котором материалы написаны. Не стоит думать, что "я сделаю все одинаковым, и будет скучно", потому что будет не скучно, а упорядоченно, а чтобы сделать действительно "интересный беспорядок", нужно сначала научиться делать "порядок". Важно также соблюдать однородность на текстах "второго порядка" (описания, служебные тексты, расценки на размещение рекламы и пр.), тем более, что логически эти тексты представляют собой единый раздел служебной информации, даже если он и не выделен обособленно.

Отдельный разговор об иллюстративном материале для официальных сайтов. Здесь я рекомендую определить один жесткий размер изображения (или два: вертикальный и горизонтальный), зависящий от модульной сетки, и привязать его к формату отпечатка (лучше стандартному). В этом случае у вас, во-первых, не будет проблем с выбором формата печати, сканирования, обработкой и пр. Вполне возможно, что для соблюдения стилистики вам придется обязать фотографа снимать предпочтительно вертикальные кадры или наоборот, но зато ваш сайт будет выглядеть более гармоничным и строгим. То есть, единый стиль для официального сайта - это тот фетиш, в жертву которому имеет смысл принести все остальное. В конце концов, не стоит зацикливаться на строгости корпоративного сайта и пытаться совместить его с контент-проектом. Надо просто разделить официальную информацию о корпорации и работающие проекты этой корпорации: посмотрите, например, на сайт "Лукойл" и "Мультимедиа" - вот пример подобного разделения.

Другой важный момент, который часто не принимается во внимание создателями небольших сайтов, особенно персональных - это комплектность материалов. То есть все те рубрики, которые вы запланировали для вашего сайта, должны к моменту их открытия содержать необходимое минимальное количество материалов. Не оставляйте ничего "на потом", так как мало найдется вещей, которые раздражают посетителя более нежели надписи "будет скоро" или "еще в работе", особенно, когда он их наблюдает в течение нескольких месяцев подряд. Если вы не можете в данную минуту (например, к моменту запуска сайта) собрать материалы в какую-либо рубрику, то лучше не открывайте и не анонсируйте ее - вы всегда сможете добавить собранную рубрику к вашему сайту. Если же присутствие рубрик в содержании сайта необходимо, то имеет смысл отложить открытие сайта до полного сбора материалов.

Как обычно, это требование особенно жестко предъявляется публикой к представительским материалам, то есть корпоративным, торговым, сервисным, правительственным и подобным сайтам. Для контент-проектов и развлекательных узлов не столь важен их официальный, и строгий вид, однако практика показывает, что появление таких разделов не приносит никакой выгоды - ни прямой, ни косвенной. Поэтому старайтесь избегать "under construction", если только у вас есть такая возможность. Единственным исключением из этого правила может быть предварительное анонсирование проекта или его части. Так, например, поступила Transmeta, представляя свой первый процессор Crusoe, однако обратите внимание, что, во-первых, реклама этого проекта проходила не только в Сети, но и в других медиа-носителях, а во-вторых, и это ключевой момент подобной технологии, на сайте стояла дата "откроется такого-то", а не "скоро будет". Точная дата подстегивает интерес, тогда как вторая фраза лишь вызывает досаду от того, что желаемую информацию вы так и не смогли получить.

Работа с текстами

Главное - пишите о том, о чем вы хотите написать. Каждый текст имеет свою собственную направленность (речь идет, конечно же, о хорошем тексте), рассчитанную на наиболее легкое восприятие целевой аудиторией, то есть теми людьми, для которых он непосредственно предназначен. Поэтому при написании текста вы должны четко представлять себе к кому вы обращаетесь, что вы хотите сказать, чтобы ваши читатели не были дезориентированы. Соответственно, когда вы "направляете" текст на какую-либо конкретную социальную группу, то вы делаете это с помощью стилистики и словарного запаса, используемого в тексте. Достаточно очевидно, что использование простонародных выражений не всегда подходит для сайта, который распространяет биржевые сводки и новости, а большое количество компьютерных терминов может смутить неквалифицированного пользователя, которых в Сети становиться все больше и больше, о чем многие забывают.

Отступление.

"Это стереотипы и условности", - скажете вы, и будете совершенно правы. Однако эти стереотипы и условности во многом определяют социальную структуру нашего с вами общества. Ничто не мешает сделать вам сайт о медицинском оборудовании в красно-черно-коричневых тонах, но для его раскрутки потребуется значительно больше средств и времени, нежели для работы с традиционными цветовыми гаммами. Разница в том, что в последнем случае вы продвигаете всего-навсего новый товар (услугу и др.), который составит конкуренцию уже имеющимся на рынке, а в первом - вы продвигаете новую идею! Как вы думаете что проще и дешевле?

Сравним для примера стиль произведений Федора Михайловича Достоевского и Льва Николаевича Толстого. Несомненно, те из вас, кто читал и того и другого автора, отметят, что Федор Михайлович читается значительно тяжелее, нежели Лев Николаевич, несмотря на "одновременность" их творчества. Простейший подсчет количества прочтенных за единицу времени страниц покажет нам, что произведения Льва Николаевича читаются значительно быстрее, и, как следствие, значительно лучше воспринимаются - ни чтению, ни восприятию в них не мешает излишне сложный и изощренный язык. Федор Михайлович писал модным языком (вообще его романы по многим показателям можно считать модными), внося в него современные словечки и обороты, которые потом пропали из обиходной речи. То же самое относится и к использованию деепричастных и причастных оборотов, и сложноподчиненных предложений, то есть к конструированию самих фраз текстовок. Таким образом, если произведения Федора Михайловича адаптировать для современного русского языка, то у них есть хорошие шансы стать очень популярными и затмить многие современные бестселлеры.

Задачей редактора в данном случае будет являться подбор оптимальной стилистики и направленности текста и постоянное следование ей. Текст должен быть относительно ровным (длина фразы, количество знаков препинания и т.д.), но не слишком однообразным, потому что, в этом случае его будет совершенно невозможно читать, так как после второго абзаца от скуки начнет сводить челюсти. Если вы смогли добиться примерно одинакового ритмического рисунка текста по всей его длине, то у пользователя не возникнет (пусть и подсознательно) ощущения, что его куда-то гонят или затягивают. Если у вас есть сомнения в стилистике собственных текстов, то всегда можно обратиться к специалисту, например в "Редколлегию". Следует сказать, что если у вас нет ни малейшего опыта в написании бизнес-текстов, тем паче - текстов вообще, то стоит серьезно задуматься о привлечении к работе профессионального журналиста или редактора. Конечно, вышесказанное актуально только для коммерческих проектов, где от качества написания текстовых материалов напрямую зависит прибыль. Услуги профессионала в этой области обойдутся вам в пределах 10 долларов за килобайт написанного текста (при желании, конечно, можно найти и дороже, но 10 долларов - это нормальная цена для не очень известного журналиста), услуги редактора обычно несколько дешевле, однако, к редактору вы уже приносите готовый текст, требующий некоторой доработки. Таким образом, при суммарных вложениях в сайт, по крайней мере, нескольких сотен долларов (стоимость средне-минимального коммерческого проекта в Сети сейчас около 600-800 $, куда входит дизайн-студия, работа программистов, хостинг на несколько месяцев, доменное имя и немного маркетинга), трата на стилистическое состояние основных материалов нескольких десятков долларов не кажется чрезмерным расходом.

Работая над стилистикой текста, не стоит забывать о грамматике. Люди очень чувствительны к ошибкам в тексте и легко их ловят, тем более, что чужой текст обычно читают значительно внимательнее чем свой собственный. Поэтому, кстати, лучше доверить проверку ваших текстов другому человеку, даже если вы вполне уверенны в своей компетентности в качестве корректора или редактора. Практика показывает, что одной проверки средствами word недостаточно (хотя это уже очень приличная чистка). Поэтому, если ваш сайт содержит много текстовых материалов, то установите дополнительно к word какой-либо мощный языковый корректор, например, Orfo, тогда полученный результат будет вполне удовлетворительным для неофициального ресурса. Если же вам нужен действительно грамотно написанный текст, то, как уже говорилось выше, обратитесь к специалистом, тем более, что таких служб в Сети сейчас появилось довольно много. Когда же в вашем распоряжении находится постоянный поток информации (например, ежедневные новости, сводки, курсы и пр.), то имеет смысл нанять в штат собственного корректора, назначив ему постоянную зарплату, - это будет и экономичнее, и, главное, удобнее в работе. То же самое касается и версий сайта на иностранных языках, хотя следует учитывать, что англоговорящие, например, менее требовательны к правильности языка, чем русскоговорящие.

Все вышесказанное преследует своей целью показать, что Интернет следует рассматривать, как и любой другой, более привычный нам информационный носитель, поэтому не надо напрасно экономить при построении официального сайта. Грубо говоря, вы же не станете доверять изготовление рекламы в центральной газете человеку, который в первый раз слышит слова: "верстка", "треппинг", "дизайн" и пр. Таким образом, виртуальное издательство может потребовать штат не меньший, нежели у традиционного.

Отдельно стоит поговорить о заголовках. Частой ошибкой издателей (не только web) являются неподходящие, неуместные заголовки. Не стоит обольщаться, что заголовок "Особенности управления и программирования комплексных ракетно-ядерных установок в условиях мирного времени на основе алгол-фортран нелинейного программирования" достаточно информативен и всем понятен. Подобное название хорошо подойдет для диссертации, статьи в научном журнале, но никак не годиться для материалов, основной целью которых является привлечение к вам клиентов. Заголовки, точно отражающие смысл последующего за ними текста достаточно скучны и непривлекательны, хотя и исчерпывающе информативны. Поэтому для бизнес-статей требуется найти совершенно иной подход к названиям.

Старайтесь использовать интересные, интригующие названия: напустите туману, используйте иносказания, вопросы, загадки и пр. Любое название, даже самое скучное, можно переделать так, чтобы оно зазвучало интригующе. Например: "Причинно-следственные связи в последовательности действий, предпринятых царем Петром Алексеевичем Романовым для женитьбы арапа, находящегося у него на службе". Узнаете? Конечно - "Как царь Петр арапа женил" - какое из приведенных названий кажется вам наиболее интересным? Обратите внимание, как хорошо продумано название для фильма: оно и простоватое, и немного со старорусским оттенком, и с вопросом (интригой), и с юмором, словом, оно не только точно передает ощущение от самого фильма, но и хорошо привлекает внимание потенциальных зрителей. А будь этот фильм снят сегодня, то его название, скорее всего, звучало бы как "Свадьба арапа" или "Петр и арап", что, согласитесь, опять же скучно. Так что не стоит впадать в крайности.

Работа с изображениями

Сейчас мы говорим только о тех картинках, которые составляют содержание вашего сайта, а не являются элементами его оформления (о них речь тоже пойдет, но всему свое время). Чаще всего, контентными изображениями являются семейные фотографии (походные, свадебные, институтские и пр.), иллюстрации продаваемой продукции, рисунки или картины (особенно, если сайт посвящен художнику), кадры из фильмов, скриншоты игрушек и… несть им числа. Иллюстрации - это и благо, и бич Интернета. Благо, потому что с их помощью вы можете лучше донести до посетителя нужную информацию, - визуальные образы практически всегда более наглядны и понятны, нежели описательные. Фактически, без картинок (а значит, и без WWW) Интернет бы не переживал сейчас такой бум, который мы можем наблюдать последние два-три года, когда объемы подключений растут в экспоненциальной прогрессии, а за новыми пользователями следует рост информационного наполнения, финансовых инвестиций; развитие элементарной базы, не говоря уже о таких супер-проектах, как, например, SETI@HOME - распределения вычислений для решения сверхсложных задач. В то же время, современные скорости работы телекоммуникационного оборудования, составляющего "железную" основу Интернета, не в состоянии предоставить веб-мастерам того комфорта при работе с изображениями, который есть у дизайнеров печатной продукции. В результате, вы, как веб-мастер, все время должны помнить об объеме получающегося изображения, чтобы вашим посетителям не пришлось полчаса ждать его загрузки (вы сами стали бы столько ждать?).

Существует два основных формата графических данных, используемых в веб-мастеринге - это GIF и JPEG, хотя они и не единственные, но на данный момент наиболее распространенные (информацию о других графических форматах вы найдете в литературе, список которой, как обычно, в конце лекции). Формат GIF используется для презентационной (деловой) графики: схем, диаграмм, графиков, а также для анимации, однако если в вашем распоряжении есть подлежащая выкладыванию на сайт цветная фотография, то лучше использовать JPEG.

Формат GIF

Изображение не может содержать более 256 цветов (именно поэтому он не пригоден для фотографий), файл может содержать несколько изображений и описание, отражающее последовательность их воспроизведения, то есть, может использоваться для записи анимации. Формат поддерживает прозрачный фон, что делает его чрезвычайно удобным, когда есть необходимость размещения какого-либо графического элемента на сложной текстуре. Анимированные GIF умеет делать PhotoShop версии 5.5, совмещенный с ImageReady (последняя программа может поставляться отдельно). Кроме того, существует огромное количество программ сторонних разработчиков, которые поддерживают как анимированные, так и статичные GIF, в том числе и специально приспособленные к работе с изображениями для Интернета. Одной из лучших программ можно считать Ulead GifAnimator версии 2 и выше (на момент написания лекции, кажется, вышла уже четвертая), а также Gif Construction Set версии не ниже 1.3. Все эти программы позволяют очень качественно "сжимать" полученные файлы, эффективно уменьшая их объем.

Формат JPEG

Содержит не менее 8 бит на канал, то есть может содержать только полноцветное (true) или серое (grayscale) изображение, а следовательно, плохо приспособлен для деловой графики. Важное отличие от GIF (как и от других графических форматов) - искажающее сжатие, которое позволяет вам получить изображение очень маленькое, но настолько же далекое от совершенства. Алгоритм сжатия основан на удалении части цветовой гаммы изображения, с учетом того, что в целом и сложном изображении человек не очень хорошо различает близкие цвета. За счет этого изображения могут быть сжаты в несколько сотен раз, однако, чем больше сжатие, тем больше полутонов удаляется и тем заметнее искажения в изображении. Формат JPEG поддерживается всеми современными графическими программами, включая и самые простые. При работе с картинками для web я рекомендую использовать сжатие от 4 до 6, в зависимости от исходных размеров изображения, и прогрессивное сканирование оригинала (изображение анализируется последовательно несколько раз - это умеют не все программы, но PhotoShop версии 4 и выше понимает без проблем). При работе с этим форматом обязательно сохраняйте исходное изображение в формате Tiff или собственном формате рабочей программы, создавая JPEG файл только в самом конце работы, поскольку сжатие происходит при каждом сохранении файла, следовательно, ошибка будет накапливаться и с каждым сохранением вы будете получать картинку все более и более низкого качества.

Об иллюстрациях вообще

Принято считать разрешение мониторов равным 72 dpi. Поэтому все изображения для web следует подготавливать именно с таким разрешением, несмотря на то, что в действительности на вашем мониторе разрешение будет совсем другим (72 dpi - разрешение старых 14' дисплеев). Также обязательно учитывайте, что в вашем распоряжении есть не более 600-700 точек по ширине экрана, - удерживайтесь в рамках, чтобы избежать горизонтальной прокрутки изображения.

Как уже говорилось выше, формат JPEG предназначен для очень сильного сжатия изображения, однако и формат GIF тоже можно сжимать, причем достаточно эффективно. Принцип сжатия основывается на унификации цветовых палитр (теоретически, каждый кадр внутри файла может иметь собственную цветовую палитру, что заметно увеличивает размеры файла) так, чтобы итоговая палитра была только одна для всех изображений и содержала не больше необходимого минимума цветов. Кроме того, осуществляется уничтожение ненужных служебных записей и сжатие каждого отдельного кадра, а наиболее сильные в этой области программы сравнивают последовательно показываемые кадры и записывают в последний из них только изменения первого, таким образом, получается полтора кадра вместо двух. В результате, грамотно сжатый GIF может занимать до четверти исходного файла. Если же, несмотря на все ухищрения, впихнуть файл в установленные (например, баннерной системой) рамки не удается, то придется выкидывать кадры, при этом снизиться плавность анимации, однако и размер кадра при этом прилично уменьшится.

Несколько слов о подготовке фона. Не нужно подготавливать подложку формата предполагаемой вами страницы, более того, это даже очень вредно, поскольку вы имеете очень много шансов, что большая доля вашей аудитории будет иметь другое разрешение экрана или, по меньшей мере, другой формат окна браузера. Подготовьте изображение форматом 100*100 точек и браузер сам повторит его по всему полю экрана пользовательского монитора. Конечно, в данном случае возникает проблема создания повторяющегося изображения, но существует довольно большое количество клипартов на эту тему, некоторые ссылки вы найдете в конце лекции. Также у вас есть большой простор для творчества в PhotoShop, где можно сделать все что угодно; очень удобным фильтром для создания повторяющихся тонов является Texturizer и Andromeda (последняя - отдельно устанавливаемый фильтр). Подогнать края также можно, немного растушевав 5-6 пикселов по обрезу картинки.

В зависимости от назначения изображения стоит придерживаться следующих эмпирических размеров:

  • Для большого баннера 468х60 - не более 15 kb - это требование большинства баннерных сетей
  • Для кнопок навигации - 1-2 kb, чтобы они не перегружали страницу.
  • Для основного изображения - не более 100 kb, причем, только в том случае, если изображение самое главное содержание конкретной страницы (например, репродукция картины).
  • Для фонового изображения - 5 kb, но лучше сделать фон не более 3 kb.

Все эти размеры, теоретически должны укладываться в общую величину 70-100 килобайт на страницу, хотя, надо сказать, что и эти цифры достаточно высоки для средних страниц, обычно, если вы не слишком увлекаетесь анимацией и Java, общий объем не будет получаться более 30-40 kb (если это не галерея картинок).

Рекомендованная литература:

  • Работа с заголовками
  • Язык, на котором вы пишете
  • В копирайтеры пойду, пусть меня...

Ссылки по теме:

  • Редколлегия - проверка ваших текстов на грамотность
  • Коллекция Анимашек Вебмана
  • Коллекция бесплатной графики
  • Оптимизатор графики
  • Другой оптимизатор графики


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 4.

Лекция 4

Дизайн

Вот мы и подошли с вами к "философскому камню" всех веб-дизайнеров. Фантастическое количество людей говорит о дизайне, как о каком-то фетише, поклоняясь ему, в том числе, и с принесением человеческих жертв. В то же время, ситуация складывается несколько иная, чем может показаться на первый взгляд. Дизайн - это профессия (чтобы быть точным - ремесло), которой обучают в нескольких вузах России, причем делают это хорошо. Например, можно получить образование дизайнера в "полиграфе" (конкурс 10 человек на место), МАрхИ (10-15 человек на место), Текстильной академии (5 человек на место) и нескольких других. При огромном конкурсе на поступление в эти учебные заведения, все они вместе выпускают каждый год не менее сотни квалифицированных специалистов, что почти удовлетворяет потребности существующего рынка труда. Если вы занимаетесь (или планируете) заниматься изготовлением сайтов на заказ, то, возможно, имеет смысл получить профильное образование, тем более, что образование - это всегда не только и не столько бумажка.

Однако вернемся к собственно дизайну вашего сайта. В нижеследующей лекции я постараюсь рассказать некоторые основные принципы и подходы к созданию внешнего облика вашего сайта, приведу примеры, как хорошие, так и плохие, на которых можно поучиться. И первый же совет, который я хочу вам дать: "обратитесь в дизайн-студию, если вы не уверены в своих силах". Конечно, это будет не бесплатно, но вы сэкономите собственное время и, скорее всего, получите более удачный вариант, чем вы сделали бы сами. Зато единовременная оплата услуг студии позволит вам в дальнейшем избежать потерь из-за некачественного внешнего вида сайта (особенно, если ваш сайт - торговый). На мой взгляд, обращение в дизайн студию - это оптимальный выход для издателя, не имеющего соответствующего опыта и знаний в дизайне. Список дизайн-студий (неполный, конечно) вы найдете в конце лекции.

Выбирая студию для размещения заказа, не бросайтесь ни в самую дешевую (потому что это "по карману"), ни в самую дорогую (несмотря на то, что это "круто"). Также не стоит обращаться и в первую попавшуюся студию, рекламу которой вы случайно углядели в модном журнале или на крупном портале, - скорее всего, вы не будете удовлетворены. Внимательно изучайте работы студии (благо, каждая уважающая себя студия обязательно указывает ссылки на свои предыдущие работы), смотрите, какая стилистика вам нравиться, какие цветовые сочетания вам кажутся наиболее приятными. Не стесняйтесь задавать вопросы и учтите, что хороший дизайнер редко делает что-либо просто так, а следовательно, он может объяснить смысл и значение любого элемента в своей работе. Только посмотрев работы студии и поняв, что они вам нравятся, определив, что студия сможет выполнить необходимую вам работу (ведь сайт - это не только дизайн, но и программно-аппаратная часть), и, кстати, определившись с тем, что же именно вы сами хотите, обращайтесь уже за прайс-листом студии.

Если вы собираетесь разрабатывать только внешний вид сайта, не затрагивая ни обработку контента, ни создание сложных баз данных, ни программирование CGI-скриптов, то вам не нужна дорогая фирма с солидной репутацией - сила таких студий (например, Infoart) в разработке программной части, которая вам, фактически, не нужна. Теоретически, вам достаточно одного хорошего дизайнера, который просто нарисует вам одну-две страницы, а вы потом самостоятельно напишите для нее коды, то есть - воплотите "в цифре". Хотя, конечно, лучше обратиться к дизайнеру, который специализируется именно на www, поскольку, он уже знает требования, которые предъявляет Интернет к издателю, и вам не придется потом потеть, верстая страницы по созданному неопытным дизайнером шаблону.

Когда вы будете обращаться к дизайнеру или в студию, то не забудьте принести макет, который вы сделали, с его помощью вам будет значительно проще объяснить, что именно вы хотите в конечном итоге увидеть. В свою очередь, дизайнеру будет легче сделать именно то, что вы от него ждете. Вообще общение с дизайнером (как и общение с заказчиком) - чрезвычайно сложная и трудоемкая задача, которая порой превращается в разговор слепого с глухим. Чтобы у вас возникало поменьше затруднений, примите как данность, что дизайнер разбирается в дизайне гораздо лучше, чем заказчик, и в состоянии выполнить работу в соответствии с вашими пожеланиями, тем более, что его предыдущие работы вам понравились. Поэтому не стоит спорить с дизайнером по мелочам, а лучше просто выдать ему принципиальные схемы и сетки, которые у вас уже есть на руках, и сообщить необходимые подробности (о предполагаемой аудитории, целях и задачах сайта) и приоритеты (что для вас самое главное). Многолетний опыт убеждает, что больше всего дизайнеров впечатляет фраза "сделайте красиво" вкупе с неограниченными рамками для творчества. То есть: работая с дизайнером, доверяйте ему!

Если же вы решили обойтись собственными силами, то придется изрядно поработать. Все же дизайн, хоть и ремесло, но работа-то творческая, поэтому алгоритма создания гарантированно красивой вещицы нет и быть не может. Тем не менее, есть несколько ключевых моментов, которые помогут вам в работе.

Начните с того, что разработайте цветовую гамму для вашего сайта. В работе обязательно учитывайте направленность вашего сайта, его задачи, контролируйте образ, который возникает у посетителя вашего ресурса, поскольку цветовая гамма имеет не только эстетическое, но и глубокое психическое влияние на человека. На эту тему я рекомендую прочесть вам серию статей Константина Львовича Лидина (список литературы есть, как обычно, в конце лекции) о цветоведении в скрин-дизайне. Крайне желательно иметь единую цветовую гамму по всему сайту, по крайней мере, если вы нарушаете это единство, то должны четко осознавать в каких целях вы привносите диссонанс на свой ресурс. Очевидно, что дизайн ресурса (аналогично единообразию макета и как следствие этого), должен быть выдержан в едином стиле для обеспечения комфорта пользователя и создания цельного впечатления от узла, как от неделимого источника информации (развлечений, покупок etc.), а не как набора отдельно взятых страниц. И одним из механизмов создания единого облика является цветовая гамма. Тогда, если вы захотите выделить какой-либо раздел, то вам будет достаточно ввести один дополнительный цвет или оттенок и ваш раздел, не нарушая общей цветовой гаммы ресурса (то есть, не выпадая из общей картины), будет иметь собственную индивидуальность.

Некоторое время назад мне довелось прочесть статью, где один "чудо-дизайнер" рассуждал: "я открываю PhotoShop и набрасываю туда много всякой всячины: смешные картинки, орнаменты.., а потом стараюсь из всего этого собрать страницу". Так вот, так делать не надо! Дизайн - это, прежде всего, стилистика, преследующая определенную цель по разрешению поставленной перед дизайнером задачи (увеличение продаж, привлечение клиентов, создание моды или модного течения, социальная реклама…), а о какой стилистике можно говорить при работе "методом набрасывания"? Это не дизайн, а "художества".

Лучше всего взять белый лист бумаги и попробовать нарисовать на нем то, что вам хотелось бы видеть, пусть то, что вы делаете, будет похоже на детские каракули, но, в конце концов, вы же рисуете для себя и показывать свою работу до ее завершения никому не собираетесь. Изложив свои мысли в виде образов на бумаге, вы получите нечто наглядное, что-то, что уже можно редактировать, обрабатывать, исследовать, в целом - то, с чем можно работать. Если вы затрудняетесь определить, что именно вы хотите (наиболее частая ситуация: "чего-то хочу, а чего не знаю" или "все это не то, а что нужно - не знаю"), то побродите по Сети. Начните с дизайн-студий: поройтесь в их портфолио, затем посмотрите на художественные, развлекательные, рекламные сайты и ищите идею, которую вы сможете использовать в своей работе. Не копируйте чужие наработки, но используйте идеи. Синтезируйте и объединяйте их между собой, сочиняйте что-то свое, отталкиваясь от чужих наработок. В общем, учитесь на чужих работах создавать свои.

Как я уже говорил, главное - это единый образ вашего ресурса, поэтому стоит обратить пристальное внимание на общность шрифтового и графического оформления. Используйте единый шрифтовой тег для всех заголовков ресурса, для близких по смыслу элементов и пр. Вообще, постарайтесь использовать побольше одинаковых элементов в облике своих страниц. Помимо увеличения узнаваемости, это также снизит общее время загрузки, поскольку уже загруженные один раз элементы будут забираться браузером из кеша на локальном диске компьютера пользователя. Такие, повторяющиеся элементы часто называют "фишками", поскольку, становясь узнаваемым атрибутом узла, они начинают "держать" всю картинку, как бы говоря "я стою здесь, следовательно, все это принадлежит к таком-то семейству". Фишкой может являться логотип или товарный знак, либо какая-то узнаваемая часть этого знака. Например, если центральным элементом в вашем логотипе является синий треугольник, то вы можете использовать его потом во всех страницах ресурса, начиная с элементов оформления меню (например, каждый пункт выделен синим треугольником), и заканчивая завершающей пулей в тексте (значок, ставящийся в начале или конце статьи, для остановки читателя, более свойственен для журналов).

Конечно, хорошо, если эта фишка будет хоть как-то визуально ассоциироваться с тематикой вашего сайта, но, к сожалению, этого не всегда можно добиться. Поэтому иногда делается наоборот: придумывается фишка, а потом с ней ассоциируется уже тематика, т. е. фишка искусственно привязывается к тематике. Если же в оформлении входной страницы сайта вы использовали фотографию, рисунок или коллаж, то впоследствии вы можете вырезать смысловую часть рисунка и использовать именно ее в качестве фишки по всем другим страницам.

Посмотрите, как работают признанные, известные дизайнеры: Дмитрий Кирсанов, Артемий Лебедев, студия Дизайн-Депо (журнал "КАК") и др. Никогда не вредно учиться у профессионалов. Обратите внимание на используемые ими в оформлении принципы композиции, цветовые решения, решения пространства. Внимательно изучайте работы и старайтесь понять принципы взаимодействия тех или иных элементов страницы, стержень композиции, а поняв, попробуйте использовать схемы решений в своих работах. Единственно, чего не надо делать, это клонировать чужой дизайн. Во-первых, это пойдет на пользу не вам, а тому, кто его придумал, поскольку ваш сайт не будет иметь собственного лица, а во-вторых, можно и нарваться: по меньшей мере, на "музей клонирования", а в худшем случае, от вас могут тем или иным способом потребовать закрытия сайта.

Очень важная область дизайна - типографика - шрифтовое решение композиции. К сожалению, в отличие от печатных изданий, современные веб-возможности ограничены двумя группами очень похожих и не очень красивых шрифтов: рублеными (Arial, Verdana etc.) и антиквами во главе с Times New Roman. Все остальные шрифты могут оказаться не установленными на компьютере пользователя, и их использование регулярно приводит к невозможности посетителем прочесть ваше послание, - вместо текста будут показаны жуткие закорючки. Если же вам необходимо написать текст каким-нибудь особенным шрифтом, то используйте gif изображение для всего текста (например, для заголовков) или для каждой буквы в отдельности, что гораздо экономичнее, но чрезвычайно трудоемко (так, например, сделан сайт журнала "КАК"). Тем не менее, как бы вы не ухищрялись, использование текста в виде картинок приведет к многократному (sic) увеличению объема страницы, что крайне нежелательно, учитывая современные средства связи и загрузку интернет-каналов. Поэтому стоит подумать о том, чтобы суметь выразить представляемые вами образы существующими средствами, не используя громоздкие картинки.

Таким образом, из всего арсенала шрифтовых решений, которое может быть использовано в печати, веб-дизайнеру остается только два с половиной шрифта и 7 размеров. Не густо, конечно. Есть надежда, что ситуация скоро сдвинется с мертвой точки. Во-первых, использование CSS (о ней вы прочтете в следующих лекциях) позволяет задавать размер шрифта в пунктах, а количество браузеров, поддерживающих CSS уже достаточно велико, чтобы можно было на них смело ориентироваться. Во-вторых, недавно появилась система динамически подгружаемых шрифтов, которые можно использовать, не опасаясь последствий, поскольку при нахождении указания на такой шрифт браузер автоматически сгружает его с указанного сервера и устанавливает (при условии работы на платформе windows). К сожалению, я пока не нашел ни одного руссифицированного шрифта такого рода. Создавая шрифтовое решение для сайта, обязательно выписывайте шрифты, которые вы используете и их размеры, чтобы потом не запутаться. Еще раз подчеркиваю: не стоит полагаться на свою память, ей и так предстоят нелегкие испытания.

В дизайне большое значение имеет Мода, что легко заметить по рекламным материалам, оформлению бытовых приборов и их упаковки, газетам, и, в меньшей степени, по журналам. Например, сегодня очень популярен так называемый soft design - плавные линии, отсутствие острых углов, по возможности, белый цвет или приглушенные, иногда пастельные тона. В печатных изданиях царствуют линеечки и треугольнички с кружочками - большое количество выделяющих, отчеркивающих и акцентирующих линеек и полукругов делают страницы похожими на графический рисунок или даже чертеж (компания "Терем" около двух лет назад логически завершила эту моду и оформила свою рекламу в виде старого чертежа прошлого века). Точно так же мода диктует свои условия и в веб-дизайне. Хорошим примером модного сайта является узел Samsung или, например новый дизайн баннерной сети RLE. Следовательно, мода не столько выделит вас из общей массы, но сделает вас внешне более современным, и, соответственно, динамичным. Мода очень активно продвигается на рынке, вдалбливаясь в мозги пользователей, поэтому быть немодным означает проигрывать в глазах посетителей тем вашим конкурентам, которые моде следуют. Срабатывает "эффект бивиса-батхеда: "это же крута, Баклан", причем, этот эффект работает не только на 15-летних подростков, но и на взрослых, вполне сформировавшихся личностей, нужно только грамотно его использовать (а как вы думаете, почему ВАЗ 110 так популярен? - не такая уж это хорошая машина). На самом деле, вопрос следования моды касается не столько дизайнера, сколько маркетолога, а также идеолога всего сайта целиком, но задуматься о нем, наверное, стоит до того, как вы начали что-то делать руками, чтобы потом не пришлось переделывать.

И, напоследок, один очень большой секрет всего дизайна: мой многолетний опыт работы и с печатными, и с онлайновыми рекламными материалами и дизайнерскими работами убеждает в том, что обычному пользователю, по большей части, совершенно наплевать "что у них там нарисовано". Подходя к дизайну с точки зрения "я бы такую картинку на стенку не повесил", человек проходит мимо самых лучших дизайнерских наработок, причем, к заказчикам это относится не меньше, чем к потребителям. Куда важнее пользователю - удобен ли ваш сайт для изучения, естественна ли его система навигации, а собственно дизайн - это не самая важная на свете вещь. Увы, но это так.

На сегодня - все. До завтра!

Рекомендованная литература:

  • Книжка "Как сделать красиво в Интернете"
  • Дизайн и композиция.
  • Что такое стильный сайт
  • Лидин К.Л., Меерович М.Г.:
    "Общие принципы композиции в скрин-дизайне"
    "Общие принципы цветоведения в скрин-дизайне". Часть 2. Часть 3
  • Статьи по дизайну на английском языке

Ссылки по теме:

  • 5K дизайна
  • "Руководство" Артемия Лебедева
  • Дизайн студии:
    компания "Инфо Дизайн"


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 5.

Лекция 5

Верстка

Теперь, когда у вас есть готовая концепция сайта, его принципиальный макет, дизайн и все материалы, пора приступить собственно к созданию сайта как такового. Настоящая лекция достаточно сложна для восприятия и, по всей видимости, к тому же и длинная, так что наберитесь терпения. Кроме того, это первая лекция, когда вам для освоения материала понадобиться компьютер, все действия до этого можно и нужно было совершать безо всякого компьютерного вмешательства (может быть, только за исключением дизайна).

Сначала следует разобраться в структуре сайта. Узел состоит из отдельных страниц, где каждая страница описывается одним персональным файлом-сборкой и некоторым количеством дополнительных файлов-включений (структура очень похожа на файл Quark). То есть, для каждой страницы у вас должен быть один общий файл (Htm, Html, Shtml, Dhtml, Xml и т.д.), который описывает структуру страницы, а к нему прилагаются картинки, возможно, программные модули, дополнительные модули, таблицы стилей и прочее, что может понадобиться на этой странице. Очень важно - на каждую страницу сайта должен быть создан свой, отдельный и единственный файл-сборка, - именно этот файл и будет выдаваться сервером в ответ на запрос от браузера, именно на него вы будете ставить ссылки в навигации по сайту.

Элементы на странице связаны тегами - операторами языка разметки страниц HTML. В отличие от других языков описания страниц (PostScript, PCL и пр.), HTML чрезвычайно прост, поэтому вы очень быстро и легко его освоите. В языке есть несколько сотен тегов, однако, в своей повседневной работе вы вряд ли будете использовать более 70-80 из них. Запоминать теги, конечно не обязательно, - в процессе работы вы, со временем, выучите их, однако знание тегов сделает вашу работу значительно комфортнее. Куда печальнее другое: язык HTML имеет несколько стандартных версий, из которых самые распространенные сейчас - это 3.0, 3.2 и 4.0. Следует учитывать, что чем старше версия языка, теги которого вы используете, тем старше версия брузера нужна для его корректного восприятия (номер версии браузера соответствует номеру версии понимаемого им HTML), конечно, пользователей IE 3 и NN 3 уже практически не осталось, но они, тем не менее, есть. В связи с этим, старайтесь соблюдать стандарт, установленный консорциумом WWW: HTML 4.0 или HTML 3.2, и у ваших посетителей, а значит, и у вас возникнет значительно меньше проблем.

Между собой отдельные страницы узла связаны гиперссылками, которые задаются специальными тегами. С помощью гиперссылок можно связать не только любые две страницы, но и вообще два произвольных объекта, так, чтобы при щелчке на первом, браузер переходил на второй. Именно таким образом организуется оглавление, если оно расположено на одной странице с текстом.

Сайт в Интернете практически всегда располагается на удаленном сервере, который может работать под одной из версий Unix или под NT, причем первый вариант встречается значительно чаще. То есть, если вы покупаете хостинг, о чем я расскажу несколько позже, или располагаетесь на бесплатном, не оговаривая ОС сервера, то, с вероятностью 99%, ваш сайт будет располагаться на сервере с ОС Unix. Если ваш сервер расположен на Unix-сервере, то следует быть очень внимательным с названиями файлов и ссылками на них, поскольку Unix различает прописные и заглавные буквы и воспринимает их, как разные, следовательно, ссылка на страницу Beretta.html, записанная как beretta.html, будет неработоспособной.

Существует два основных варианта создания HTML-страниц. Первый - это работа с техническими редакторами, такими как Home Site, Hot Dog, Ultra Pad и др. (при необходимости можно использовать любой текстовый редактор, но по ряду причин удобнее использовать специализированные) В таких редакторах вы самостоятельно пишете код, видя перед собой именно текстовую страничку с тегами. Конечно, редактор поможет вам в написании тегов, проверит за вами строгость кода, даст посмотреть, ваше творение в окне браузера, однако основная работа будет состоять именно из скрупулезного написания, проверки и подгонки тегов. Второй вариант - это WYSIWYG редакторы, с помощью которых вы создаете визуальную картинку вашей страницы, то есть, имеете дело непосредственно с блоками информации, которые произвольно располагаете на странице, как это делается, например, в Word или Page Maker. Самым известным в этой области редактором является, пожалуй, Front Page производства Microsoft, а самым лучшим (по отзывам многих дизайнеров) - Macromedia Dream Weaver. Последний значительно менее популярен в силу своей дороговизны: в сравнении с бесплатным Front Page (версии '98 и старше уже не бесплатны), Dream Weaver стоимостью более 200 долларов выглядит очень дорогой игрушкой.

Принципиальная разница между этими двумя методами только в подходе: вы либо "делаете" страницу, либо "программируете" ее. Соответственно, дизайнерские вещи, наверное, проще делать в WYSIWYG редакторах, тогда как скоростная верстка - это удел Home Site и подобных ему. Отсюда вытекают и особенности той или иной верстки: программирование всегда более точная, более структурированная работа, чем визуальное редактирование. Споры по поводу того, какой редактор лучше использовать, вспыхивают каждые насколько месяцев с новой силой, однако разницы между подходами, кроме вышесказанной нет, поэтому выбирайте тот редактор, который вам больше по вкусу. На мой взгляд, будущее за визуальными редакторами, как это произошло в допечатной подготовке (кто помнит сейчас первую Ventura, которая именно программировала странички?), и со временем редакторы типа Home Site будут вытеснены с рынка, как это произошло с DOS Ventura и др. С другой стороны, сам я работаю именно в Home Site, потому что в свое время мне это показалось более удобным.

Кроме двух вышеописанных способов для создания HTML-страницы можно использовать множество "посторонних" программ, которые умеют сохранять свои данные в этом формате. Из известных мне программ такой возможностью обладают: Page Maker 6-6.5, Corel 8-9, Office 97, Office 2000 (все программы). Пользоваться подобными возможностями следует с большой осторожностью, и, в любом случае, после программной генерации нужно вручную проверять получившийся код.

Какой бы способ вы ни избрали для дальнейшей работы (а может быть, и все сразу), я рекомендую вам обзавестись книжкой по языку HTML, а также книжкой по программе верстки, ежели таковая имеется (книжки можно посмотреть в разделе "Книжная полка"). Несмотря на наличие в Сети большого количества справочников и вспомогательных страниц, книгой почти всегда пользоваться значительно удобнее. В конце лекции вы найдете список рекомендованной литературы, я же в рамках этого курса не буду касаться непосредственно описания языка HTML, тем более, что руководств по нему более чем достаточно.

Итак, вы скачали и установили программу верстки (нет, нет, не торопитесь, дочитайте лекцию до конца), положили рядом с собой нарисованный макет и образец дизайна, книжку по языку и несколько листов бумаги (все это вам пригодиться); теперь вы готовы работать. Первым делом создайте отдельную папку для вашего проекта - в ней будет храниться весь ваш проект и только он. Внутри этого каталога вы будете строить структуру вашего будущего сайта: создайте отдельные директории для каждой тематики, отдельную директорию для картинок - их удобнее хранить все вместе (разбив отдельные категории картинок на разные поддиректории), отдельную директорию для вложений и дополнительных модулей. Грамотно составленная структура каталога значительно облегчит вам жизнь, когда (неожиданно быстро) ваш сайт вырастет на порядок. Перенесите сюда готовые картинки (всегда сохраняйте исходные варианты в отдельной папке), а файлы страниц создавайте непосредственно там, где они и должны быть. Потом вы весь каталог загрузите на сервер в Сети, поэтому будьте внимательны.

Внимание! Все названия файлов, каталогов могут писаться только латинскими буквами, без пробелов и знаков препинания. Вы можете использовать неограниченное количество букв и цифр, разделяя их знаками "-" и "_", а также точкой. Тем не менее, я не рекомендую использовать более 10-15 знаков в названии, потому что общий объем ссылки может превысить некий нелогичный предел, после которого часть браузеров начинает "глючить".

Файл титульной страницы должен называться index.html (или index.htm, shtml, dhtml и т.д.), т.к., именно файл с таким названием будет загружаться на компьютер пользователя при наборе в адресной строке адреса вашего сайта (вы же набираете, фактически, адрес директории, а не конкретный файл с путем). В очень редких случаях хостинг-провайдер может настраивать свой сервер на выдачу по умолчанию файла default.html, но это бывает так редко, что не стоит серьезного рассмотрения.

Некоторые трудности может вызывать гиперссылка, если файлы, между которыми нужно ее поставить, находятся в разных директориях. В этом случае нужно указать либо относительный путь по дереву каталогов к файлу, на который вы ссылаетесь или абсолютный путь (url). Первый вариант обычно предпочтительнее.

Например, вы хотите поставить ссылку между файлами
work/site/about/owner.shtml
и work/site/advertising/job.shtml
относительная ссылка будет ../advertising/job.shtml, то есть, мы сначала выходим из директории about, потом входим в директорию advertising, где лежит нужный нам файл. Если же путь получается очень длинный с большим количеством переходов, то, может быть, проще поставить абсолютную ссылку или ссылку от корня сайта (той директории, где лежит файл индекса), в последнем случае, перед первым каталогом ставиться прямой слеш:
/advertising/job.shtml (в данном случае предполагается, что каталог advertising является поддиректорией корневой директории сайта).

Прежде чем приступать непосредственно к верстке конкретных страниц, заготовьте шаблон в соответствии с вашим макетом и сохраните его отдельно. Теперь, вместо того, чтобы писать коды каждой страницы заново, вы можете просто открыть шаблон и, сохранив его новым файлом, внести изменения, и вот - страница готова. Большинство продвинутых редакторов (как текстовых, так и визуальных) позволяют сохранять шаблоны именно как шаблоны, то есть, при создании нового файла будет выбираться заданный шаблон, а не просто пустая страничка. Более того, вы можете сохранить и несколько шаблонов, используя их по мере необходимости. Хорошо продуманный и грамотно созданный шаблон позволит вам, впоследствии, создавать страницы буквально за несколько секунд.

Кроме собственно языка HTML существует еще большое количество дополнений, которые призваны облегчить жизнь веб-мастеру и немного навести порядок на сайте. Есть среди них полезные, есть и вредные, но есть два дополнения, которые нужно использовать обязательно, даже если сейчас вы не видите, как они могут вам пригодится. Эти два дополнения - SSI (Server Side Inclusions) и CSS (Cascade Stile Sheets), оба они довольно простые, хоть и обладают совсем недетскими возможностями.

С помощью SSI вы можете включать в свою страницу любые необходимые вам фрагменты (тексты, картинки, счетчики, результаты работы программы и пр.) непосредственно на сервере. Это дает вам возможность загружать в заданное место страницы повторяющиеся элементы по всему сайту из одного источника. Хороший пример - оглавление - оно обычно повторяется на всех страницах узла и всегда одинаковое. Поставив директиву SSI, вы сможете хранить оглавление в отдельном текстовом (или HTML) файле, который сервер будет вставлять на каждой странице в указанное вами место. Такой файл гораздо легче исправить, если возникает такая необходимость. Представьте, что у вас 200 файлов, в каждом надо исправить оглавление и положить на сервер, а тут - поменял текст в одном файле и положил на сервер за несколько секунд. Кроме того, при большом объеме сайта можно значительно выиграть в дисковом пространстве, которое вам потребуется, оно, конечно, сейчас почти ничего не стоит, но вам, например, потребуется меньше времени на "заливку" файлов на сервер.

Как это делается? Существует ряд базовых директив (исполняемых команд) SSI, которые вы специальным образом включаете в свои страницы, а при запросе страницы компьютером пользователя, сервер сканирует ее на наличие директив и, если находит, то подставляет вместо них требуемые значения. Для того, чтобы сервер сканировал документ необходимо ему дать на то указание. Некоторые сервера сканируют все документы без разбора, другие - только те файлы, которые имеют расширение SHTML, причем, последних - большинство. Что именно будет сканировать сервер, зависит от его настроек, поэтому если у вас есть доступ к серверному ПО, то вы можете сделать так, как пожелаете, но если вы планируете арендовать хостинг, то рассчитывайте, что сканироваться будут только SHTML файлы.

SSI - это очень мощный инструмент, который способен реально помочь вам в работе над проектом, поэтому нужно сразу ориентироваться на его использование. Следовательно, даже если вы не собираетесь использовать возможности SSI прямо сейчас, все равно имеет смысл дать всем страничным файлам расширение SHTML, а не HTML, чтобы потом не пришлось переправлять все ссылки. Файлы переобозвать, понятно, просто, но ссылки на них стоят на других страницах, а может быть, и на других серверах, - пойди найди их все и исправь. Поэтому лучше сразу использовать SSI, тем более, что это очень просто.

Директивы SSI вставляются в файл в виде служебного тега "комментарии"

<!--#Здесь должна быть команда с параметрами--> такой тег (только без знака диез #) не отображается на страницы и служит для помещения в коде служебных записей, например, чтобы вы лучше ориентировались в тексте или, если над проектом работает много людей. В случае, если ваша директива не может быть выполнена, она просто не отобразиться (если настройки сервера это позволяют).

Две самые распространенные директивы SSI, которые вы можете начать использовать прямо сейчас это exec и include. Первая из них запускает внешнюю программу (обычно CGI-скрипт), вставляя на страницу результаты работы этой программы, а вторая - подставляет данные из файла и тоже может вставлять результаты работы сторонней программы. Возьмем, например, все то же оглавление и посмотрим, как будет выглядеть оно на странице при подстановке с помощью директивы SSI. Пусть у нас есть таблица в виде оконной рамы, где сверху - шапка страницы, слева текстовый блок с основным содержанием, а справа - оглавление. В этом случае код страницы, спроектированный обычным образом, будет выглядеть следующим образом (обрезанно):

<table ...> (тег таблицы с параметрами - шириной, толщиной линий, фоном и пр.)
<tr><td> (открываем строку, потом ячейку)
Основной текст страницы
</td> (закрываем ячейку)
<td> (открываем ячейку)
Оглавление
</td> (закрываем ячейку)
</tr> (закрываем строку)
</Table> (закрываем таблицу)

Теперь, если оглавление у нас везде одинаковое, мы можем подставить его с помощью директивы SSI, а само оглавление поместим в файл ogl.txt, который будет вставляться в файл непосредственно перед его открытием на компьютере пользователя. В этом случае страница будет выглядеть следующим образом:

<table ...> (тег таблицы с параметрами - шириной, толщиной линий, фоном и пр.)
<tr><td> (открываем строку, потом ячейку)
Основной текст страницы
</td> (закрываем ячейку)
<td> (открываем ячейку)
<!--#include virtual = "ogl.txt"-->
</td> (закрываем ячейку)
</tr> (закрываем строку)
</Table> (закрываем таблицу)

И к этому будет прилагаться файл ogl.txt, хранящийся в той же директории, что и файл рассмотренной нами только что странички. Если же файл будет храниться в отдельной директории, то надо указывать относительный путь, как и при обычной гиперссылке - это мы уже разбирали выше. Посмотрим на получившийся результат: казалось бы ничего не изменилось, только поменялась одна строка, но теперь у нас оглавление в отдельном файле и, если нам придется добавить в него одну строку, то нужно будет поменять только один файл. Кроме того, сам файл стал короче, ведь оглавление - это не одна строка, а мы заменили все одной строкой, убрав нагромождения тегов в отдельный файл - с получившимся файлом будет гораздо легче работать.

Однако теперь мы можем несколько сократить получившийся код, так, чтобы в шаблоне у нас было еще меньше мусора. Для этого мы уберем все окружающие оглавление теги в тот же самый подгружаемый файл (мы можем подгружать все, что угодно, а браузер уже получит страницу для отображения полностью собранной, так что можно разрывать таблицы, открывающие и закрывающие теги и пр.). Вот, что у нас получиться:

<table ...> (тег таблицы с параметрами - шириной, толщиной линий, фоном и пр.)
<tr><td> (открываем строку, потом ячейку)
Основной текст страницы
<!--#include virtual = "ogl.txt"-->

Здорово, не правда ли?! А в файле ogl.txt у нас теперь храниться много всякой ерунды:

</td> (закрываем ячейку)
<td> (открываем ячейку)
Оглавление
</td> (закрываем ячейку)
</tr> (закрываем строку)
</Table> (закрываем таблицу)

Причем, обратите внимание, что и тег, закрывающий таблицу, тоже здесь. В итоге, у нас есть один файл шаблона, в который осталось только поместить основной текст и отформатировать его (расставить абзацы, выключки, ссылки и пр.), объем кода на странице сократился заметно. Такой файл будет сделан для каждой страницы, а также один файл ogl.txt, который содержит единое для всех оглавление и некоторое количество служебных тегов.

Второе важное дополнение - это каскадные таблицы стилей - CSS. Они позволяют определять и переопределять стили оформления текста, а также других элементов на странице. На самом деле, возможности CSS очень велики: используя эту систему вы можете задать оформление всего сайта, описав его параметры в одном единственном файле, а потом несколькими движениями мыши переделать все оформление, просто поставив другие параметры в файле-описании. Более того, существуют системы на основе CSS, позволяющие то же самое проделывать не только издателю, но и посетителям. Это немножко похоже на фокус. Если вы когда-нибудь игрались с Desktop Themes (штука такая в Control panel, меняющая оформление win) или загружали себе на компьютер шкурки (skins), то здесь нечто похожее: поменял один файл-описание на другой, и на тебе: совершенно другой сайт.

CSS оформляются в виде описаний: {название стиля = его значение} и точно также обрамляются знаками примечания, как и SSI инструкции, чтобы браузеры не сочли их отображаемыми данными. Описания могут, теоретически, находиться в любом месте страницы, но предпочтительно их размещать все вместе в заголовке станицы между тегами <head></head>. В отличие от SSI, CSS - это инструкции для браузера, а не для сервера, причем, далеко не все браузеры в состоянии грамотно отобразить их, а, следовательно, не стоит удивляться тому, что не все пользователи смогут увидеть все красоты вашего сайта. Самая распространенная схема использования CSS - это переопределение стандартного ряда стилей H1-H6 и одновременное создание нескольких дополнительных стилей с собственными названиями. В результате, вы используете при верстке страниц стандартные стили, которые при открывании страницы пользователем выглядят в соответствии с заданными вами директивами. Если же браузер пользователя не в состоянии грамотно интерпретировать CSS инструкции, то человек увидит просто стандартные стили. Таким образом, сайт пострадает не катастрофично и все равно будет вполне читаемым, конечно, если вы использовали стили по назначению: H1 - самый крупный заголовок, H2 - немного помельче и т.д.

При желании, если вы определяете большое количество стилей, вы можете снести все записи в отдельный файл (обычно default.css), который браузер будет автоматически забирать при заходе на сайт. Это, кстати, реально увеличивает скорость загрузки, при длительном нахождении на сайте, поскольку файл описания стилей загружается один раз и только в самом начале сессии, а вот подставляется оно во все страницы, следовательно, при указывании стилей в заголовке каждой страницы, вы каждый раз увеличиваете объем файла на лишний 1-2 килобайта. В случае, если вы используете отдельный файл стилей, он вызывается строкой в заголовке страницы <link rel="STYLESHEET" type="text/css" href="../css.css">, причем, если ваш файл стилей называется default.css, то IE 5 автоматически "выцепит" его и подставит ко всем вашим страницам на любую глубину от корня, где был найден файл стилей.

Ну вот, теперь вы можете менять стилистику всего файла, редактируя один текстовый файл. Кроме того, вы автоматически применяете один и тот же стиль оформления по всему сайту, пользуясь при этом привычными тегами. Использование CSS тем более желательно, что при оформлении заранее заданными тегами гораздо сложнее ошибиться и поставить кегль, например, на единицу меньше. Таким образом, используя CSS, вы можете не задумываться, какой именно тег здесь поставить, поскольку все шрифты и размеры у вас уже определены в таблице стилей и расписаны в макете!

Вышеупомянутые мною системы SSI и CSS крайне желательны к применению на сайте. Даже если они сейчас вам не нужны, то при разрастании узла вы, со временем, придете к положению, когда они понадобятся, и тогда придется переделывать несколько десятков или сотен страниц. Очень удобно, в частности, то, что эти системы позволяют вам не держать в голове все страницы, поскольку все их ключевые элементы определяются либо таблицей стилей, либо подгружаются по заданному шаблону.

Существуют и другие технологии, которые могут помочь веб-мастеру, а также разнообразят и украсят любой узел. О некоторых из них вы узнаете в следующих лекциях, а об остальных из книжек с "Книжной полки".

На сегодня достаточно.

Рекомендованная литература:

  • Книги по языкам программирования и HTML
  • Спецификации CSS в Вебклубе.
  • Каскадные таблицы стилей. Учебник
  • Заголовок HTML документа. Учебник по HTML

Ссылки по теме:

  • Сайт Allaire, где можно скачать HomeSite
  • Проверка каскадных таблиц стилей
  • Web Site Garage - Один из лучших онлайновых проверяльщиков HTML кода страниц
  • Проверяльщик неработающих ссылок
  • Тоже проверка неработающих ссылок
  • Программы, необходимые в вебдизайне
  • Спецификация SSI


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 6.

Лекция 6

Предпродажная подготовка

Да, несколько вольное название лекции, может вызвать у вас улыбку или недоумение, но оно довольно точно отражает суть того, о чем мы будем сегодня говорить, - об окончательной подготовке и проверке ресурса перед выпуском его "в люди".

Давайте оглянемся назад. У вас уже есть сайт, и не просто домашняя страничка, а цельный и единый образ ваших устремлений в Сети. У него есть концепция, макет, дизайн, готовы материалы, все или почти все продуманно до мелочей, и в следующей лекции вы уже сможете выбрать место для размещения, и ваш проект заживет своей собственной, возможно, отличной от ваших первоначальных задумок, жизнью. Однако перед тем как запустить проект для всеобщего обозрения, нужно внести несколько небольших корректировок: тут подкрасить, там подклеить, здесь зачистить, словом, как говориться в одном старом анекдоте "обработать напильником". Именно этим мы сейчас и займемся.

1. Заголовки страниц

Вот уж что имеет колоссальное значение, так это заголовок. Именно он отображается в заголовке окна браузера, а затем в закладках пользователей, его будут показывать поисковые машины в результатах поиска, на него в первую очередь обратят внимание обозреватели сетевых ресурсов. Поэтому что-что, а название страницы следует выбирать очень и очень внимательно.

Название страницы размещается в специальной конструкции между открывающим и закрывающим тегами заголовка:

<title>
Название на любом языке длиной не более 256 знаков.
</title>

Таким образом, очевидно, что на самой странице заголовок не отображается, если только вы его не прописали отдельно внутри тега . Несмотря на то, что у вас в распоряжении есть четверть килобайта, размахиваться больше чем на 60-80 знаков не стоит, поскольку основные "потребители" названия - заголовки браузеров и закладки не вмещают длинных строк обрезая их сверх возможной длины. Заголовок, который "уползает" за длину строки браузера, выглядит не самым лучшим образом.

Я рекомендую начинать название страницы со значимого слова: названия продукта, торговой марки, бренда, услуги или тематики, например, очень часто можно встретить названия следующего вида: "новости сервера такого-то". Это грубая ошибка. Если пользователь поставит закладку на такую страницу, то просматривая впоследствии закладки, он увидит только "новости сервера…", таким образом, ссылка теряет для него свою значимость и, в конце концов, рискует отправиться в корзину, а ведь закладки - одно из самых значимых маркетинговых достижений. Куда лучше будет назвать страницу "Варенье в массы. Новости сервера" - название куда более информативное и, кстати, динамичное, что немаловажно: когда человек читает названия страниц в результатах работы поисковых машин, то динамичное название привлечет его куда больше, нежели вялое. Суть в том, что динамичное название уже содержит призыв к действию, оно как бы влечет за собой человека.

Обратите внимание на то, чтобы в название внутренних страниц попадало и название самого сервера, чтобы ни у кого не возникало и тени сомнения в их принадлежности. Это становиться особенно важным, когда страниц много, а разброс тем велик, потому что с поисковых машин посетитель часто попадает на внутренние страницы сервера, минуя титульную, а следовательно, он не будет знать ни названия вашего узла, ни его адреса.

2. Мета теги

Вы можете посмотреть, как это выглядит на других сайтах, заглянув в исходники командой View=>Page Source. Мета-теги также часто упоминаются в руководствах по созданию HTML страниц и в материалах по маркетингу. Что же это такое?

Мета теги - это необязательные атрибуты страницы, размещенные в ее заголовке (между тегами Библиотека разработчика -), которые содержат описание страницы, ключевые слова к ней, некоторую информацию об авторе, управляющие команды для поисковых роботов и прочую служебную информацию, не предназначенную для всех посетителей.

Выглядят мета-теги следующим образом:

<meta name=autor content="Автор страницы">
<meta name=KEYWORDS content="ключевые слова для вашего сайта через запятую">
<meta name=DESCRIPTION content="описание страницы">

В каждый контейнер <META NAME=___ CONTENT="___"> вы помещаете соответствующие значения, индивидуальные для каждой страницы (то есть, каждая страница должна содержать свое собственное описание и свои собственные ключевые слова, которые ей наиболее соответствуют). Это довольно большая работа, но необходимая, и ее станет значительно больше, если отложить "на потом" (в этом я имел возможность лично убедиться). От этой работы, в частности, зависит, некоторым образом, количество посетителей на вашем сайте.

Описание титульной страницы особенно важно, поскольку оно должно отображать весь ваш сайт: все его особенности, направления работы, интересные места, - или, проще говоря, его уникальность и значимость. Написав хорошее описание титульной страницы, описание каждой отдельной страницы составить несколько проще - вам нужно взять общее описание и сузить его до темы указанной страницы. Удачным ходом можно считать включение в мета-теги внутренних страниц описания и ключевых слов, составленных вами для всего сайта так, чтобы в заголовке страницы получилось два комплекта: общий для всего ресурса и персонализированный для конкретной страницы.

Длина каждого поля content ограничена килобайтом (1024 знака, включая пробелы и знаки препинания), чего более чем достаточно для комфортного проживания небольшого стада слонов, поэтому не стесняйтесь написать большое, продуманное описание и тщательнее работайте над ключевыми словами. Однако следует помнить, что мета-теги включены в код страницы, так что увеличение их длины ведет к увеличению объема страницы, а следовательно, увеличивает время загрузки. Поэтому не следует увлекаться. Кстати, в целях экономии места можно (и это имеет известный смысл) помещать в мета-теги внутренних страниц сокращенную версию описания всего ресурса, таким способом вы экономите место и подчеркиваете собственное описание страницы.

3. Подписи и копирайты

Ваш сайт - это ваша интеллектуальная собственность, которая охраняется международными законами об авторском праве. Мы не будем обсуждать сейчас степень соблюдения этих законов в нашей стране (скажем только, что при желании они очень даже соблюдаются), важно, что законы эти существуют и они адекватно отражены в Российском законодательстве. Так что, если вы их не нарушаете, то они работают на вас. Механизм вступления в действие закона достаточно прост: под каждым материалом, который вы хотите защитить, ставится значок копирайта и фамилия человек, которому эти права принадлежат. Теперь ваши права защищены законом.

Конечно, никакой закон не помешает стащить ваши материалы любому, кто пожелает, но они служат предупреждением: "воровство может быть наказано!", также как и красный свет не является физическим барьером для автомобилистов, а лишь предупреждает об опасности столкновения или штрафа. Учтите также, что если дело дойдет до суда, то одним копирайтом дело все же не ограничится, вам придется доказывать свое авторство документально.

Исходя из всего вышесказанного, я рекомендую расставить внизу каждой страницы копирайты, чтобы пресечь хотя бы часть возможных прецедентов в зародыше. Если же ваши материалы представляют большую ценность (например, если это литературные произведения, а вы получаете каким-либо образом комиссионные от их распространения), то следует впоследствии проводить постоянный мониторинг Сети на предмет незаконных копий. Делается это довольно просто: задайте поисковой машине словосочетание характерное для вашего материала и не очень характерное для случайного текста, затем исключите из результатов поиска ссылки на ваш сайт и смело идите по остальным ссылкам ругаться. Если такого словосочетания нет или его очень трудно подобрать, то задайте где-либо на странице бессмысленное сочетание букв (это можно сделать в мета тегах, комментариях внутри текста, или видимым текстом, цвет которого совпадает с цветом фона), дальнейшая последовательность действий та же. С картинками дело обстоит несколько сложнее, тут нужно не забывать про поле alt, можно также называть изображения хитрым образом, обязательно нужно подписывать картинки: если вы поставите в углу видимую надпись, то уже она одна отпугнет большое количество желающих. Кроме того, не стоит забывать о цифровой подписи, читалка которой прилагается к PhotoShop, а модуль нанесения придется покупать (правда, он недорог - что-то около 30 долларов). Есть и другие средства охраны вашего контента, но они, все же, выходят за рамки настоящего курса.

Хорошим тоном с вашей стороны будет поставить рядом с копирайтом не только фамилию, но и ваш официальный e-mail (то есть, адрес для деловой переписки). Такое расположение адреса уже стало стандартом de facto, поэтому заинтересованные в контакте с вами посетители будут, прежде всего, искать адрес именно там. Не случиться беды, если вы продублируете свой адрес в разных местах страницы, однако на всякий случай, подгружайте его с помощью SSI директивы, особенно, если ваш адрес расположен на бесплатном почтовом сервере.

4. Комментарии

Стоит предположить, что ваш сайт будет разрастаться и наступит время, когда вы будете не единственным человеком, работающим над проектом. В то же время, не так-то просто разобраться в том, как именно верстальщик собрал страницу, особенно, если на ней применены сложные таблицы многократного вложения (то есть, таблицы в таблицах). Да и сами вы вряд ли сможете удержать в голове все детали и нюансы вашего собственного макета, когда объем страниц перевалит за пару сотен. Чтобы создать себе и своим партнерам более комфортные условия, добавьте в тело страницы комментарии, поясняющие значение того или иного участка кодов. Комментарии, как уже говорилось, оформляются тегом , в них удобно указывать также и области распределения материалов, например:
<!-- Начало основного текста -->
<!-- Конец основного текста -->

или описывать сложные структуры, такие как таблицы третьего-четвертого уровня вложения, наборные картинки из большого количества мелких деталей.

Кстати, удобно размечать комментариями страницу еще в процессе верстки, например, вам, в соответствии с макетом, нужно поставить в этом месте на странице баннер, а самого его еще нет, тогда вы ставите комментарий и верстаете дальше. Потом, когда ситуация с баннером прояснится, вы сможете контекстно (то есть, автоматически программными средствами) заменить по всем файлам сразу комментарий на код самой рекламы. Когда я составляю макет (уже готовый на бумаге), еще только состыковывая части между собой, то все неизвестные элементы и собственно контентные области заменяю комментариям, чтобы потом ничего не потерять.

5. Изображения

Важной частью "ошкуривания" вашего сайта является оптимизация картинок в теле страницы. Мало того, что картинки должны быть качественно сжаты, о чем я уже рассказывал в лекции о подготовке материалов, но нужно оптимизировать и тег , который подгружает картинки на страницу. Тег этот имеет несколько важных параметров, к сожалению, используемых реже, чем должно. Первый такой параметр - это спецификация высоты и ширины картинки - атрибуты weight и height. Когда вы верстаете страницу, то обязательно проверяйте наличие этих атрибутов у каждого (!) тега img (вот здесь сказывается преимущество текстового редактора - там это сразу заметно). Большинство современных редакторов расставляет эти теги автоматически при переносе картинок на рабочее поле. При наличии этих атрибутов браузер сразу оставляет необходимое поле для картинки и загружает страницу дальше, не дожидаясь окончания подгрузки картинки. Таким образом, посетитель сразу видит вашу страницу и может начинать изучать ее, не дожидаясь загрузки всех компонентов.

Атрибут alt содержит в себе описание или комментарий к картинке, который высвечивается при наведении на картинку мыши или, если картинка не загрузилась, - вместо нее. Он не является обязательным, но я, все же, рекомендую им пользоваться. Почему? Потому что не все могут позволить себе выделенную линию, а качество соединения обычной модемной связью, как вы знаете, оставляет желать лучшего. Поэтому многие пользователи отключают изображения для ускорения времени загрузки, а следовательно, для уменьшения расходов на подключение. Если вы не заполните теги alt, то посетитель просто ничего не увидит, возможно, если ваши картинки играют ключевую роль в навигации, даже не поймет, куда он попал, и что ему дальше делать. То есть, если ваша система навигации построена на картинках, то необходимо предусмотреть и альтернативную ей текстовую навигацию для бедных каналом пользователей.

Последние два атрибута - border и bordercolor. Эти атрибуты устанавливают толщину и цвет рамки вокруг изображения. Разные браузеры по умолчанию принимают разные значения этих атрибутов, поэтому я рекомендую везде проставить атрибут border и установить его значение равное 0, атрибут bordercolor при этом не нужен. Если вы хотите поставить рамку вокруг изображения, то учтите, что толщина рамки прибавляется к размерам картинки (то есть, рамка толщиной 1 точку увеличивает размеры картинки на 2 точки по высоте и ширине). Поэтому заранее закладывайте рамки в макет. Также я не советую использовать черные рамки вокруг фотографий - даже при минимальной толщине они выглядят очень траурно. Если вам нужно обозначить край фотографии, возьмите тонкую рамочку земляного цвета (серого, коричневого), - она не будет слишком яркой, чтобы не вызывать раздражение, но и слишком темной, чтобы не выглядеть траурной.

На сегодня - все. До следующих встреч.

Рекомендованная литература:

  • "Голова или головная боль?"
  • "С чем едят мета-теги"

Ссылки по теме:

  • Редколлегия - вычитка ваших текстов.
  • Проверка каскадных таблиц стилей
  • Web Site Garage - Один из лучших онлайновых проверяльщиков HTML кода страниц
  • Проверяльщик неработающих ссылок
  • Тоже проверка неработающих ссылок
  • Проверка сайта на доступность людей с нарушениями некоторых функций.


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 7.

Лекция 7

Выбор хостинга
и доменного имени

Теперь у вас есть более или менее готовый сайт, но он совершенно бесполезен до тех пор, пока его единственная копия лежит у вас на компьютере. Следовательно, необходимо разместить его в Сети, причем таким образом, чтобы он был доступен для просмотра посетителям. Для этого существуют хостинг-провайдеры, то есть кампании, предоставляющие услуги по размещению сайтов в Интернете. Они предоставят вам некоторый объем дискового пространства на сервере, непосредственно доступном из Сети по TCP/IP протоколу, а также некоторый пакет дополнительных сервисов. Теперь, если вы правильно скопируете файлы своего сайта на выделенную вам область диска сервера, то сайт станет доступным для посетителей.

На данный момент существует фантастическое количество предложений хостинга, способных удовлетворить любые потребности: от самых скромных до наиболее сложных. Вы можете более не подгонять свои потребности и задумки под возможности сервиса, как это было всего пару-тройку лет назад, а наоборот, выбирать хостинг по уже сложившемуся сайту так, чтобы он оптимально соответствовал текущим потребностям. И, как вы понимаете, именно поэтому я затрагиваю тему выбора хостинга только сейчас, когда ваш сайт уже готов. Кроме того, вы платите за услуги провайдера помесячно, поэтому, если вы купите хостинг перед началом строительства, то вам придется платить и за время простоя, когда сайт еще не открыт, а сервис уже активирован.

Существует два основных вида хостинга: платный и бесплатный. В первом случае вы оплачиваете помесячно фиксированную арендную плату за пакет услуг (плюс вам может выставляться счет за превышение лимита трафика, однако на первых порах об этом можно не беспокоиться). Во втором же случае вы получаете услуги хостинга бесплатно, но на страницах вашего сайта демонстрируется реклама хостинг-комании. Вариантов бесплатного хостинга сейчас не меньше, чем платного, более того, можно найти такие варианты, стоимость которых при покупке у платного хостинг-провайдера достигала бы 100 $ в месяц и более. Таким образом, выбор того или иного варианта основывается не на пакете предоставляемых услуг, а на задачах сайта и его бюджете - именно они будут определять целесообразность использования того или иного сервиса.

Так, например, не имеет смысла размещать домашнюю страницу или небольшой персональный проект на платном хостинге, поскольку, финансовой отдачи вы все равно, скорее всего, не получите, и созданием бренда вам тоже заниматься не нужно. С другой стороны, сайт коммерческой фирмы, на который жалко отдать 20-30 $ в месяц, выглядит, по меньшей мере, несолидно. Бесплатный хостинг, как показывает практика, обычно работает медленнее приличного платного, то есть ваши посетители будут вынуждены дольше ожидать окончания загрузки страницы, что не добавит им энтузиазма в изучении вашего ресурса. Кроме того, бесплатный хостинг неудобен, если над проектом работает много людей, поскольку обычно не позволяет получить несколько почтовых ящиков от одного домена, не имеет раздельного доступа к FTP и Telnet. Кроме того, на бесплатном хостинге сложно организовать автоматизированные системы - базы данных, самообновляющиеся каталоги и пр., хотя последнее время стали появляться бесплатные системы, в пакет которых входят и такие услуги (например, Агава). Кроме того, далеко не все бесплатные хостинг-провайдеры согласятся бесплатно же поддерживать ваше собственное доменное имя, если вдруг вы захотите его приобрести.

Поговорим подробнее, кстати, о доменном имени. Доменное имя - это (в общем случае) то сочетание букв и цифр, которое набирается в адресной строке браузера для доступа к сайту. Есть также возможность доступа к сайту по IP адресу (например, 212.42.142.11), однако запомнить десять произвольных цифр чрезвычайно сложно, поэтому была разработана система имен. Доменное имя бывает разных порядков, начиная с первого. Домены первого уровня закрепляются за конкретными странами: Россия - ru, Англия - uk и т.д., есть также несколько доменов первого уровня - mil, org, net, com, gov, edu, предназначенные для специфических организаций, таких, например, как правительство или министерство обороны США. Домены второго уровня (yandex.ru) образуются от доменов первого и могут быть проданы частным лицам соответствующими государственными структурами. Домены третьего уровня (http://antyad.virtualave.net) и более глубокие домены (обычно используются в образовательных и государственных учреждениях) обычно можно получить бесплатно в придачу к какому-либо сервису (например, к бесплатному хостингу) или в обмен на небольшой объем рекламы (на этом специализируется da.ru). Сайт может быть также расположен и в директории на каком-либо домене, тогда его имя выглядит следующим образом: www.halyava.ru/luchiaen - так выглядел адрес моего первого сайта на "халяве".

Собственное доменное имя второго уровня означает для ваших посетителей, что вы серьезно относитесь к вашему проекту и готовы вкладывать в него собственные деньги. Такое имя лучше запоминается, чем невразумительная мешанина букв и директорий на доменах третьего уровня, кроме того, сайт с собственным доменным именем второго порядка охотнее регистрируют в каталогах и рейтингах, он вызывает больше доверия у покупателей (если это магазин) и рекламодателей. Поэтому вам имеет смысл покупать доменное имя, если вы представляете любого вида коммерческий или официальный проект, а также, если ваш проект предназначен для широкой аудитории и способен ее собрать. Для всех остальных проектов достаточным будет завести домен третьего уровня или даже директорию на каком-либо сервере.

Если вы решили купить для своего сайта домен, то у вас появилась еще одна проблема - выбор этого доменного имени. Как вы понимаете, в Интернете существует несколько миллионов сайтов, имеющих собственное доменное имя, следовательно, все, или почти все, "хорошие" имена (простые, запоминающиеся слова, короткие сочетания букв, броские названия) уже заняты. Таким образом, придется немного попотеть, чтобы выбрать себе имя так, чтобы оно легко запоминалось, хорошо читалось и имело что-либо общее с представляемой вами тематикой или названием вашей фирмы. Домен второго уровня желательно выбирать в той зоне, с населением которой вы собираетесь работать. То есть, если вы ориентируетесь на англоязычную аудиторию, то лучше подбирать имя в зоне com, если на русскоязычную, то - в зоне ru и т.д. Естественно, что никто не обязывает вас поступать именно так, но регистрация в нужной зоне немного облегчит вам последующее продвижение и позиционирование сайта. Есть также несколько национальных зон небольших стран, которые представляют интерес из-за интересного сочетания букв: tv, co, to, hm, at и другие. Например, национальный домен Тувалу - tv был куплен "на корню" некоей хостинговой компанией, которая теперь просит за регистрацию с любой телекомпании по несколько тысяч долларов за домен (при их средней стоимости 30-50 долларов в год). Таким образом, если вы не найдете себе подходящего имени в национальной зоне, то поищите среди открытых зон типа to или hm.

Зарегистрировать домен вы можете на специально существующих для этого серверах при помощи кредитной карты (в зоне ru регистрация производится через Интернет, а оплата - в офисе Росниирос или банковским переводом). Есть специализированные узлы, предлагающие регистрацию имени в нескольких различных зонах (например, сервис Registr.com предлагает выбор более чем из 30 зон). Список регистраторов вы найдете в конце лекции.

Вернемся к выбору хостинга. Сначала, наверное, нужно определить ваши потребности. Во-первых, дисковое пространство: посмотрите объем директории, в которой находится ваш сайт на диске, умножьте на три и округлите в большую сторону - у вас получиться от 10 до 30 мегабайт (действительно, практика показывает, что 25 mb хватает для большинства новых проектов "за глаза"). Во-вторых, вам потребуется поддержка SSI и собственных CGI скриптов, ну и, конечно, ftp. В-третьих, определитесь: потребуется ли вам поддержка почтовых ящиков, доменного имени, баз данных и telnet-доступа. Перепишите все ваши требования на бумажку и отправляйтесь по сайтам хостинговых компаний сравнивать условия.

Большое значение при выборе хостинга играет скорость соединения сервера и стоимость трафика. Трафик - это объем пересылаемой с сервера (нисходящий трафик) или на сервер (восходящий трафик) информации. Провайдер может ограничивать восходящий или нисходящий трафик (а, бывает, что и тот и другой) или требовать от вас какой-либо доплаты при превышении заранее установленного лимита. Для сайтов, отдающих большой трафик (например, для архивов, или для собраний программ, также для картинных галерей и т.д.), это условие может быть очень и очень печальным, так как при превышении трафика цены становятся совсем недобрыми, так что порой можно больше выложить за незапланированный трафик, нежели стоит весь стандартный пакет. Трафик и ширина канала (то есть, качество соединения) - это палка о двух концах: либо у вас бесплатный трафик, но тогда, скорее всего, качество канала оставляет желать лучшего, либо у вас хороший канал, но тогда и большой трафик вылетит вам в копеечку.

Если вы выбрали для себя платный хостинг

Опыт показывает, что российские хостинг-провайдеры обычно несколько дороже зарубежных, но с ними легче иметь дело (на родном-то языке) и удобнее расплачиваться (особенно, если вы находитесь в Москве или Питере). Что же касается скорости связи, то лучшей скоростью в Рунете обладают Аха и Демос, но хостинг у последнего очень дорогой. Если же ваш сайт нацелен не на Рунет (или не только Рунет), то имеет смысл подумать об американском хостинге - в этой ситуации он будет более подходящим выбором. Некоторые наиболее, на мой взгляд, удачные хостеры перечислены в конце лекции.

Если вы выбрали бесплатный хостинг

Прежде чем выбрать бесплатный хостинг, подумайте еще раз, поскольку он почти всегда менее надежен, удобен и обладает меньшими возможностями, чем платный сервис. Вас никто не будет предупреждать об изменении условий хостинга, возможном переносе сервера или переустановке программного обеспечения, увольнении опытного администратора, и прочая, и прочая. Что же касается предложений, то у вас есть широкий выбор, в основном, среди зарубежных провайдеров, хотя есть и несколько очень хороших предложений от российских фирм. Из всего многообразия предложений бесплатного хостинга можно выделить несколько наиболее часто встречающихся вариантов.

  1. 1. Предложение для новичков. Характерные признаки: мало места, web-интерфейс для загрузки новых файлов, много рекламы, плохая связь, никаких скриптов, но много разнообразных сервисов, начиная с гостевых книг и заканчивая настраиваемыми чатами. Яркие примеры: Geosities.com, Chat.ru, Халява, Tripod.com, Народ Яндекса, Boom
  2. 2. Хостинг для некоммерческих проектов или коммерческих проектов мелких фирм. Характерные признаки: 10-30 mb места, мало рекламы, поддержка SSI, CGI, FTP и пр., иногда, наличие IMAP почты. Всегда есть возможность расширения, но уже за деньги. Цель подобного сервиса - предоставление качественного хостинга начинающим с тем, чтобы они по мере расширения переходили на платный вариант. Яркие примеры: Virtualave.net, WebJamp.com.
  3. 3. Исчерпывающее предложение для крупных некоммерческих проектов. Характерные признаки: много или неограниченное место, поддержка SSI, CGI, FTP, Unix Shell, при необходимости регистрация доменного имени, доступ к лог-файлам сервера, умеренное количество рекламы, возможности расширения отсутствуют или малы. Яркие примеры: BizLand.com, Holm.ru

После выбора и регистрации хостинга вы получите логин и пароль для доступа в выделенную вам область диска. Теперь вам нужно загрузить в нее файлы. Для этого вам понадобится ftp-клиент. Я рекомендую взять CuteFtp или FarManager, первый из них, по моему, удобнее, зато второй - бесплатен для жителей России. Инсталлировав ftp-клиент, откройте в нем директорию у себя на машине и соответствующую директорию на сервере хостинг провайдера и просто перепишите все файлы сайта на сервер (естественно должна быть активирована связь с Интернетом) в том порядке и с теми поддиректориями, которые вы сделали при разработке узла на своем компьютере. Обратите внимание, что все публичные файлы (html и shtml) складываются не в корневую директорию предоставленного вам пространства, а в специальную поддиректорию, которая обычно называется public_html или www. В любом случае, перед загрузкой файлов ознакомьтесь с документацией, которую всегда можно найти на сайте хостера.

Скажу немного о структуре вашего аккаунта (то есть, выделенной вам области диска сервера): там будет одна или несколько директорий. Одна из них - это www или public_html, - в ней хранятся все файлы, которые доступны с помощью браузера. Другая директория - CGI или cgi-bin может содержаться рядом с директорией www или внутри директории public_html - в ней храните CGI-программы и вспомогательный файлы к ним. Кроме того, могут быть директории содержащие лог-файлы, файлы обработки статистики, отдельные директории для баз данных, - все они недоступны пользователю прямым набором в строке браузера. Однако, на данном этапе вас интересуют только директория для html файлов и картинок, то есть www или public_html (как именно она будет называться - зависит от настроек сервера). Обратите внимание на наличие и единственность индекса (файл index - головная страница вашего сайта). Дело в том, что большинство хостинг-провайдеров выкладывают в вашу директорию какой-либо стандартный индекс-файл (например, "домашняя страница Васи" или "сайт находится в процессе создания" и т.д.), - этот файл вы должны либо заместить своим, если он имеет то же расширение, либо просто стереть, если расширения отличаются. Убедитесь, что старого индекса не осталось, и в директории лежит только один файл с названием index - тот, который вы сами написали.

В итоге всех ваших действий на сервере в вашем аккаунте должна получиться точно такая же структура каталогов и подкаталогов, что и на вашей локальной машине. Некоторое разнообразие будут вносить файлы контроля доступа и служебной информации (например ".httaccess") - они все обычно начинаются с точки.

Некоторые особенности работы с ftp
  1. 1. ftp-протокол подразумевает два варианта передачи данных между серверами - побитно и посимвольно. Естественно, что изображения, а также архивы и компилированные программы должны передаваться побитно, иначе на выходе вы будете иметь все шансы получить полную абракадабру. С другой стороны, тексты лучше передавать посимвольно (это и быстрее), то есть все ваши страницы, а также служебные файлы, SSI-включения и др. предпочтительно отправлять именно как тексты.
  2. 2. Если у вас хороший ftp-клиент, то он позволит вам "заливать" на сервер директории целиком вместе с файлами, что, несомненно, очень удобно. Однако задавая программе большой кусок работы, убедитесь, что порядок отправления файлов соответствует сортировке их на панели, так как, в противном случае, при обрыве связи вам придется долго искать, что же не скопировалось. Теоретически, вы можете закачать архивированный файл, а потом попросить администратора файла его распаковать. Возможность эта только теоретическая, потому что на бесплатном хостинге вам никто таких услуг оказывать не будет, а на платном стоит договориться об этом предварительно. Такая возможность актуальна для сайтов больших объемов, тогда вы можете просто приехать в офис хостинг-провайдера с носителем. Например, если ваш сайт содержит очень много изображений и "весит" несколько сотен мегабайт. Конечно, если вы привезете CD с сайтом, то вам его закачают без лишних разговоров (тем более, что и цена хостинга на несколько сотен мегабайт отнюдь не маленькая), что будет намного быстрее и экономичнее, чем через ftp.
  3. 3. CuteFtp версии 3.2 и ниже не умеет удалять директории, если в них есть другие поддиректории или какие-либо файлы. Поэтому старайтесь не создавать сложных структур в качестве эксперимента - вы устанете их удалять.
  4. 4. В тоже время, CuteFtp 3.0 поддерживает закладки, которые очень удобны, если вам нужно добраться до директории 3-4 вложения от корня. Пользуйтесь этими закладками (меню @@), тем более, что это очень просто. Учтите, что при открывании каждой директории ftp-клиенту необходимо отправить запрос на листинг, получить его, обработать, послать подтверждение и т.д., - в целом, очень неторопливое занятие.
  5. 5. Некоторые сервера, особенно бесплатные не "держат" команду NOOP (продление соединения). В этом случае, у вас есть всего 120 секунд на раздумья, - если за это время вы ничего не сделали, канал закрывается. Это, конечно, очень неудобно, особенно, если вы в последний момент вспоминаете, что "надо собрать еще файлы оттуда, затем отсюда и, напоследок, оттуда"…Состояние связи вы увидите по ответам сервера, которые ftp-клиент выводит в одном из своих окон:

    NOOP
    421 Time Out
    Следовательно, связь разорвана, вам придется "перелогиниваться".

    или

    NOOP
    NOOP successful
    Следовательно, ваш сервер нужную команду поддерживает и у вас есть очень большой запас времени.

  6. 6. Внимательно читайте договор с провайдером! Особенно, если он бесплатный. Например, многие из них ограничивают размеры файлов на сервере и при превышении установленного лимита (обычно 200-400 килобайт) файл просто удаляется роботом. Это делается для борьбы с пиратством, а также для уменьшения трафика, так что не удивляйтесь, если однажды утром часть ваших файлов не обнаружиться. Может быть ограничен объем почты, содержание сайта, трафик, объем базы данных, может быть ограничена деятельность скриптов, чтобы спасти процессор сервера, - в общем, этих мелочей - миллион, и знать их лучше до того, как вы начнете работать с провайдером.

На сегодня - все, до следующих встреч.

Рекомендованная литература:

  • Подборка статей по настройке DNS
  • Выбираем хостинг - интервью.

Ссылки по теме:

  • РосНииРос - здесь регистрируются домены в зоне Ru
  • Регистрация в других доменных зонах
  • Web Host Directory - поисковая машина по планам хостинга.
  • Бесплатный хостинг от Agava Software
    предыдущая лекция следующая лекция
    • ©STS


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 8.

Лекция 8

CGI-скрипты

Огромную помощь издателю в автоматизации многих процессов на сайте оказывают CGI-скрипты. С их помощью можно наладить автоматическое обновление страниц, архивирование старых записей, рассылку почтовых сообщений, каталогизацию записей, торговлю, учет и многое другое. Часть возможностей CGI автоматизирует и упрощает то, что можно делать и руками, например каталог ссылок или доска объявлений, но есть и уникальные применения CGI, которые крайне сложно или невозможно воплотить в "ручном" исполнении, например, чат, опросы, рейтинги и другие системы реального времени. CGI - это палочка-выручалочка любого крупного проекта.

Что же это за чудо такое - CGI? На самом деле, ничего особенного - это один из шлюзов (на данный момент, самый распространенный) между HTML и исполняемым модулем (программой). Программа может быть написана практически на любом языке, но самым популярным на данный момент является язык Perl, который не требует компиляции (вернее, компилируется "на лету") и наилучшим образом приспособлен для разбора строковых переменных. Результатом работы скрипта чаще всего является HTML-страница или ее часть, письмо (его отправка и содержание), или запись в базе данных, но, по большей части, именно HTML-код.

Как и другие программы, CGI-скрипты могут быть очень простыми, для написания которых не надо быть ассом программирования, а бывают и развернутые комплексы, над которыми трудится много человек, чтобы потом заработать на коммерческом распространении своей программы. Работающими скриптами пронизано все в Интернете. Гостевые книги, формы для отправки письма прямо с сайта, обсуждения, баннерные ротации - все это примеры как раз простых программ. Каталоги, поисковые системы, почтовые рассылки, доски объявлений - это примеры сложных скриптов, их уже не одолеть "с полпинка". Программы на языке Perl немного похожи на C++ (вобще эти языки имеют довольно много общего), поэтому если вы раньше программировали на C, то вам будет проще работать с Perl.

Программы на Perl платформонезависимы, что совершенно необходимо для Интернета, где можно встретить сервера оснащенные, по крайней мере, шестью вариантами Unix, не считая систем на базе NT и других малораспространенных серверных ОС. Платформонезависимость достигается за счет компилирования программ "на лету" инсталлированным в системе интерпретатором. В то же время, программы распространяются непосредственно в их исходном виде, то есть, текстовыми файлами. Безусловно, есть небольшие различия между интерпретаторами для Win и интерпретаторами для разных версий Unix, однако необходимость в использовании платформозависимых функций возникает редко, и запись в описании к программе, декларирующая ее принадлежность к той или иной платформе, скорее всего, говорит о том, что для этой платформы скрипт тестировался, и его работа признана удовлетворительной.

Вот тут мы подошли к самому главному: существует большое количество готовых скриптов, выставленных в Сети для свободного использовании при условии сохранения ссылки на авторство. Почему так делается - отдельный разговор, который не имеет значения в рамках данной лекции, для нас важно, что для интеграции скрипта на сайте вам достаточно уметь грамотно инсталлировать его на сервере. Выбирать нужный вам скрипт можно в одном из публичных архивов, где они уже заботливо собраны, рассортированы и снабжены описаниями. Список самых популярных CGI архивов вы найдете, как обычно, в конце лекции. Важно только четко представлять себе, что именно вы ищете, тогда у вас есть шанс найти нужный скрипт и значительно облегчить себе жизнь. Чтобы лучше ориентироваться в том, что вы можете найти и что вам даст тот или иной скрипт, я рекомендую вам прочесть несколько обзорных статей на эту тему, список которых я, опять же, поместил в конце лекции.

Как выбирать скрипт? Первым делом необходимо понять, какие функциональные возможности вам нужны от программы. Простейший способ выяснить это - поглядеть на подобные же программы, установленные на других серверах. Если вы вдруг найдете у кого-либо точно такой скрипт, какой бы вы хотели иметь у себя, то попробуйте списаться с веб-мастером и спросите у него, где он взял программу. Вполне возможно, что вы получите точный адрес создателя скрипта. Иногда можно просто найти в конце страницы ссылку на автора, поскольку по условию бесплатного использования скрипта, вы обязаны обратную ссылку оставлять. Изучая скрипты, установленные на других серверах, обращайте особое внимание на то, как работает та или иная отдельная функция, насколько удобно работать с ней, насколько быстро работает скрипт в целом. Посмотрев на возможные варианты и сравнив их между собой, обратитесь в архив, чтобы найти себе программу по вкусу. Обратите внимание, что для каждого представленного в архиве скрипта (вне зависимости от архива - они все одинаковые) есть работающий пример, чтобы вы могли оценить функциональность программы. Часто на тестовых примерах вы можете получить права на доступ как у администратора, чтобы попробовать функции и этой части программы, - это будет единственная попытка попробовать программу в качестве администратора до того момента, как вы инсталлируете ее у себя на сервере.

Однако прежде чем выбирать скрипт, нужно разобраться в его структуре. Любой perl-скрипт состоит из исполняемого модуля - отдельного файла, имеющего расширение pl или cgi. В действительности этих файлов в одном скрипте может быть не один десяток, как, например, в скрипте каталога Links2, но простые скрипты обычно имеют не более трех исполняемых файлов. Также в скрипте, который вы скачаете из публичного архива, будут шаблоны для генерации HTML-страниц (а может, и нет), файлы данных, которые программа использует в процессе работы, а также конфигурационные файлы. Из вышеперечисленного набора обязательным является только исполняемый модуль, а все остальное может и отсутствовать, однако такие скрипты не очень удобны в настройке. Удобнее всего (если вы не знаете perl и не сильны в программировании вообще) работать с теми скриптами, которые состоят из одного-двух исполняемых файлов, а для генерации страниц используют внешние HTML-шаблоны, которые вы сможете произвольно изменять. Такой скрипт легко и удобно настраивать, и проще подогнать к общему дизайну вашего сайта, а отсутствие большого количества исполняемых файлов (каждый ведь нужно настроить под ваш сервер) снижает вероятность ошибки.

К сожалению, вы редко можете оценить такие параметры работы скрипта, как скорость и надежность (устойчивость) при большой нагрузке сервера. Вы также не знаете, насколько сильно он нагружает центральный процессор сервера (это важный параметр, потому что если ваш скрипт чересчур ресурсоемкий, то администратор может "отрубить" его без предупреждения). Недостатки программ в этой области вы обнаружите только инсталлировав их на сервере. Поэтому настоятельно рекомендую читать отзывы о скриптах, которые оставляют в архивах другие веб-мастера, а при случае, и самому оставить такой отзыв, поскольку это единственный источник информации о пользовательских качествах скрипта.

Выбрав программу для инсталляции, приступайте к ее настройке. Первоначально нужно настроить базовые параметры, без которых программа просто не будет работать, - все они описаны в инструкции к скрипту. Обычно это:

  1. Путь к интерпретатору Perl. В подавляющем большинстве случаев это либо usr/bin/perl, либо usr/local/bin/perl - какой именно вы можете узнать либо в документации к хостингу, либо написав письмо администратору сервера. Во избежание недоразумений на некоторых серверах Perl кладется и туда и туда. Не забудьте также выяснить версию интерпретатора - если она ниже 5.02, то вам придется об этом постоянно помнить.
  2. Путь к каталогу, где находится исполняемый путь скрипта. Этот путь указывается от корневой директории сервера или от корневой директории виртуального сервера. Посмотреть его можно в статусной строке ftp-клиента, зайдя в директорию, куда вы намерены поместить скрипт.

    Кстати, куда надо загружать скрипт на сервере? В доступном вам Ftp пространстве должна присутствовать специальная директория cgi или cgi-bin (могут быть варианты Vcgi и Hcgi), - именно в нее и только в нее можно складывать свои скрипты. Разумеется, что вы можете организовать внутри этой директории дерево любой сложности, но только внутри этой директории. Делается так потому, что нормально настроенный сервер из других директорий вашу программу просто не сможет запустить, а кроме того, пространство cgi-директории хоть как-то защищено от несанкционированного доступа, то есть, сторонний человек без специальных навыков не сможет получить листинг директории или содержимое ее файлов. Если все ваши скрипты - это голосование и гостевая книга, то защищенность директории не имеет для вас значения, однако если вы хотите закрыть доступ к части своего сервера паролем, то роль защиты становится очевидной. Поэтому создайте для скрипта новую поддиректорию внутри cgi-папки и туда грузите все необходимые файлы.

  3. Путь к дополнительным файлам. Вспомогательные файлы могут храниться в любом месте сервера, им не обязательно находиться внутри cgi-директории. Более того, HTML-шаблоны просто обязательно размещать в доступной для посетителя части сервера. Следовательно, вам необходимо указать путь до вспомогательных файлов. Обычно программа требует относительный путь по серверу от директории, где храниться исполняемый файл, до директории со вспомогательными файлами. Может также потребоваться полный www адрес (http://www_и_т.д.) до скрипта или же до директории со вспомогательными файлами.
  4. Если скрипту в процессе работы необходимо отсылать письма администратору или пользователям то может потребоваться путь к программе sendmail. Если пути к этой программе не указано в описании к хостингу, то нужно написать администратору или в службу поддержки пользователей и спросить об этом.
Вышеуказанные параметры общие для всех скриптов, но есть еще целый ряд установок, таких например, как путь между двумя исполняемыми файлами, путь к картинкам, которые использует скрипт, формат пересылаемых записей. Все эти установки обязательно описываются в помощи к скрипту или непосредственно в самом скрипте и не представляют особенных сложностей.

Если ваш скрипт служебный: отправка почты, рассылка, счетчик или статистика, баннерная ротация и т.д., то на этом его настройка, в общем-то, и заканчивается, - осталось только подставить файлы данных и скрипт можно считать готовым к работе. Совсем другое дело, если ваш скрипт - публичный и генерирует HTML-страницы, например, доску объявлений, форум, поисковую систему и пр., тогда вам предстоит еще подогнать внешний вид создаваемых программой страниц под дизайн вашего сайта. Вот тут-то и всплывает удобство внешних шаблонов: их вы можете менять как угодно, работая с ними, как с обычными HTML-страницами, каковыми они, собственно, и являются. Вы можете использовать инструкции SSI, каскадные таблицы стилей, другие CGI скрипты (например, баннерную ротацию) и прочая, и прочая. Взаимодействие шаблонов с исполняемым файлом осуществляется посредством комментариев, специальным образом расставленных в теле страницы. Если же скрипт не оперирует внешними шаблонами, а создает страницы "на лету" в соответствии с заложенными в нем описаниями, то вам придется редактировать теги страницы непосредственно внутри скрипта. Очевидно, что в ходе такого редактирования, не имея навыков и опыта, легко совершить ошибку, обнаружить которую в теле программы с несколькими сотнями строчек кода будет непросто. Поэтому, несмотря на наличие в скрипте детального описания, что, где и как следует поменять, я рекомендую выбирать варианты, которые используют для генерации страниц внешние шаблоны.

Указав все необходимые параметры, переходите к инсталляции. Запустите ftp-клиент и установите соединение с сервером. В директории для cgi-скриптов создайте новую поддиректорию (учтите, что ее название вы уже должны были указать в самой программе во время настройки, когда писали путь) и загружайте туда исполняемые файлы в соответствии с инструкцией, которая прилагалась к скрипту. Все файлы, написанные на perl, можно загружать только в текстовом режиме (!), в противном случае скрипт не будет работать. Обратите на это особенное внимание, потому что загрузка скриптов в битовом режиме - есть самая распространенная ошибка при инсталляции. Загрузив все необходимые файлы (включая шаблоны и файлы данных, если требуется) в соответствующие директории, установите атрибуты файлов. Атрибуты меняются командой change file attributes (контекстное меню CuteFtp или меню программы Far Manager), в документации к скрипту будут указаны некие CHMOD - это и есть атрибуты файлов. Для исполняемых файлов нужно установить 755, для файлов данных - 777, для шаблонов страниц - 644. То же самое касается и директорий, в которых эти файлы находятся: для директории с исполняемым файлом - 755, для директории с данными и шаблонами - 777 или 644 - это число должно соответствовать атрибутам файлов, которые в директории находятся. Если в директории есть файлы с разными атрибутами, то вы выбираете большее число.

Теперь, когда ваш скрипт инсталлирован, займитесь проверкой его работоспособности. Если при запуске программы сервер выдаст вам ошибку 500, это означает, что где-то вы ошиблись при настройке скрипта, то есть ошибка возникла внутри исполняемого файла. Ошибка 404 означает, что программа не нашла один из исполняемых файлов, и вам следует проверить все пути, которыми оперирует скрипт. Ошибка 403, скорее всего, говорит о том, что вы неправильно выставили атрибуты для шаблонов или директории, где они находятся.

Самые распространенные ошибки работы программы:
  1. Неправильный путь к интерпретатору perl. Обязательно уточните его у администратора сервера или службы технической поддержки пользователей.
  2. Скрипт залит на сервер в побитовом режиме пересылке. Это самая распространенная ошибка при инсталляции скрипта. Если вы работаете с CuteFtp, то лучше сразу настроить его на то, что все файлы с расширениями cgi или pl должны пересылаться на сервер в текстовом режиме
  3. Указаны неправильные пути к файлам или директориям внутри исполняемого файла. Проверяя пути, обращайте внимание на заглавные буквы, поскольку ОС Unix различают прописные и строчные буквы в названиях файлов и директорий.
  4. При правке уничтожены или добавлены лишние кавычки. Все параметры в perl обрамляются одиночными кавычками, которые очень легко уничтожить при правке. Найти потом хвосты очень и очень непросто, поэтому будьте внимательны при редактировании исполняемого файла.
  5. В тегах присутствуют двойные кавычки. Эта ошибка обычно возникает, если скрипт формирует страницы без шаблонов, а внешний вид будущей страницы описывается непосредственно в скрипте. В HTML языке очень часто используются двойные кавычки (например, в тегах вызова картинок, в мета-тегах, в тегах таблиц и т.д.), а интерпретатор воспринимает их как конец оператора, от чего скрипт работает некорректно. Для исправления этой ошибки перед каждой двойной кавычкой ставиться обратный слеш. Это обязательно должно быть указано в скрипте или описании к нему.
  6. Скрипт некорректно вызван. Проверьте еще раз по инструкции с какими параметрами следует вызывать программу.
Многие скрипты вызываются с помощью SSI (например, баннерные ротации, голосования и пр.) никогда не тестируйте этот скрипт на реальной странице! Создайте тестовый файл с вызовом скрипта и проверяйте на нем работоспособность программы, и только после того, как вы убедитесь, что все в порядке, смело ставьте директиву на реальную страницу.

Некоторые скрипты могут некорректно воспринимать цифры в названии директории или файла, поэтому старайтесь не употреблять цифровые названия директорий, если в этом нет острой необходимости.

Вот, вроде, и все. До следующих встреч.

Рекомендованная литература:

  • Книги по языкам программирования и HTML
  • Введение в Perl - спецификации языка
  • Спецификации языка Perl. Все на одной странице
  • Обзор CGI скриптов, Часть II
  • Введение в Javascript Стефана Коха

Ссылки по теме:

  • Script Locker - Коллекция CGI - скриптов. Удобна для новичков - скриптов немного, и в них просто разобраться.
  • Cgi Resources - наиболее полный архив CGI-скриптов.
  • Download.ru - пожалуй, самая большая русскоязычная коллекция CGI-скриптов.
  • ВебКлуб - Все полезные скрипты здесь есть


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 9.

Лекция 9

Букет Интерактивности

 Интерактивность - способность человека активно влиять на содержимое, внешний вид и направленность просматриваемых им страниц сайта, возможность общаться с другими посетителями, свободно высказывая свое мнение и узнавая чужие.

Суть интерактивности в том, что сайт перестает быть статичным набором страниц и становиться живым, гибким организмом, плодом не только вашей работы, но и желаний вашей аудитории. Значение интерактивности сложно переоценить, поскольку она приближает Интернет к среде для обитания, отдаляя его от других масс-медиа, таких как телевидение, радио или пресса. Представьте себе: когда вы приходите в библиотеку, вы всегда можете спросить у библиотекаря любую интересующую вас информацию, он всегда посоветует вам интересную или полезную книжку. Понятно, что для телевидения этот принцип уже неприменим, слабое подобие - звонки в студию, не открывают тех интерактивных возможностей, которые существуют при живом человеческом общении, если же мы будем говорить о печатной продукции, то письма, которые идут неделями, никоим образом уже под интерактивность не подпадают. Более того, зайдя в библиотеку или магазин, вы можете задать вопрос не только библиотекарю (или, соответственно, продавцу), но и другим посетителям, то есть широта и скорость взаимодействия не идет ни в какое сравнение с любым неличностным общением.

В то же время, Интернет такие возможности предоставляет, и именно в этом суть интерактивности. Таким образом, интерактивность - это биение жизни на вашем сайте. Нужно ли оно для вашего проекта - решать, конечно, вам, но подумать над этим очень даже стоит. Давайте разберемся, когда интерактивные возможности Интернета действительно не нужны. На мой взгляд, единственная сфера, где можно обойтись статическими страницами - это электронные архивы, основной целью которых является ознакомление общественности (именно общественности, как безликой массы) с какими-либо документами: правовыми, информационными, публицистическими и др. И все. Во всех остальных случаях интерактивность должна играть существенную роль в структуре сайта, являясь одним из серьезнейших инструментов целедостижения.

Реально, интерактивность создается целым комплексом средств, часть из которых реализуется сложными программными механизмами, другие доступны даже новичкам. В этой лекции я буду рассматривать только самые простые методы создания интерактивного сайта, ввиду дороговизны и сложности реализации продвинутых механизмов. А одним из самых, наверное, распространенных методов реализации любой интерактивной задумки являются CGI-скрипты, о которых рассказывалось в прошлой лекции.

Интерактивность - это, в первую очередь, возможность высказаться, следовательно, такую возможность необходимо посетителю предоставить. Для этого существуют возвратные формы, адрес вашей электроной почты, ваш номер телефона (для коммерческого, торгового сайта телефон - необходимое условие), с помощью которых посетитель может высказать свое мнение о той или иной тематике на сайте, о его работе, о веб-мастере. С почтовым адресом и номером телефона все понятно, а возвратная форма - это тот же самый адрес электронной почты, которая позволяет написать письмо, не открывая почтовой программы и, более того, не имея собственного адреса электронной почты. Это очень удобно для тех, кто хочет написать анонимное письмо или для тех, кто держит адрес на бесплатном сервере, не имеющем POP3 соединения.

Если же посетитель желает высказаться публично, то для этого существует гостевая книга или форум, которые вы, без сомнения, регулярно встречаете в процессе своих путешествий по Интернету. Первые организуются сравнительно простыми CGI-скриптами, ссылки на архивы скриптов вы, не сомневаюсь, нашли в конце предыдущей лекции этого курса. Если вы не хотите возиться со скриптами, то существуют специальные сервисы, которые предоставят вам уже инсталлированные и настроенные скрипты в личное пользование за небольшой объем рекламы на страницах, создаваемых программой. В этом случае, вам достаточно будет просто поставить ссылку на скрипт, работающий на стороннем сервере. Небольшой список подобных сервисов вы найдете, как обычно, в конце лекции. Гостевые книги, по большей части, - это "книги для жалоб и предложений" на сервере, лично я их не люблю и ни на одном из своих сайтов не держу, предпочитая установить форум для общения и доску объявлений для рекламы и др. информации. Тем не менее, гостевые книги пользуются неизменной популярностью, поскольку обладают целым рядом очень удобных свойств. Во-первых, они чрезвычайно просты в установке и администрировании, во-вторых, записи посетителей не требуют ответа, что немаловажно, наконец, это просто сейчас модно.

В отличие от гостевых книг, форум - это сложная система обмена мнениями, требующая повышенного внимания своего создателя. Существуют программы форумов, которые поддерживают сразу несколько обсуждаемых тематик (то есть, фактически, несколько различных форумов), поиск по сообщениям, а также авторизацию пользователей. На мой взгляд, форум - это оптимальный механизм интерактивности для больших и средних информационных ресурсов, поскольку при небольшой нагрузке на издателя они позволяют создать посетителям настоящую среду для общения. Работа с форумом относиться более к маркетинговым акциям по созданию сообщества (community) вокруг сайта и описана в соответствующей лекции курса "Маркетинг для малышей". В рамках же этого курса нас более интересует техническая сторона вопроса.

Планируя использование форума на сайте с помощью собственного (то есть установленного на вашем, а не на стороннем сервере) скрипта, проверьте объем доступного вам дискового пространства. Теоретически, если вы выбирали хостинг в соответствии с моими рекомендациями, то вам должно хватить места на что угодно, включая слона, но проверка займет всего несколько секунд и не будет лишней. Скрипт для форума (так же как и для гостевой книги) не является ресурсоемкой программой - сам по себе он занимает всего несколько сотен (а то и десятков) килобайт, но при работе он создает файлы с текстами сообщений, которые будут занимать какое-то место. Если у вас не очень много посетителей, и на форуме появляется от силы пара десятков сообщений в неделю, то вам не стоит беспокоиться, однако при трафике в полсотни сообщений в день и более стоит подумать о том, где все эти сообщения будут храниться. Таким образом, для средних форумов требуется до 2-3 мегабайт свободного дискового пространства.

Следующий вариант интерактивного общения онлайн - это чат. Хорошее описание особенностей работы с чатом и его маркетинговое значение можно посмотреть в очень толковой статье на эту тему: "Что чат для трафика дает". С технической точки зрения, чат обычно организуется также с помощью CGI скрипта на собственном сервере или арендуется, как и предыдущие скрипты в специальных сервисах - их список вы также найдете в конце лекции. В отличие от форума, чат является куда более ресурсоемкой программой, поскольку объем сообщений в нем многократно выше. Стандартные рекомендации для чата включают 30-40 мегабайт дискового пространства и быстрый процессор на сервере, чтобы обрабатывать поток поступающих данных. Я также рекомендую обсудить с администратором вашего сервера возможность установки скрипта до того, как вы начнете его инсталлировать, потому что если ваш сервер не в состоянии потянуть чат, то вы убьете весь свой сайт, а также те сайты, которые расположены рядом с вами. С большой уверенностью можно говорить о том, что на бесплатном хостинге вы вряд ли сможете установить собственный чат, я лично не знаю ни одного бесплатного сервиса, который уверенно мог бы позволить такую нагрузку на центральный процессор сервера. С другой стороны, например, Zoom (один из крупнейших провайдеров бесплатного хостинга) предлагает чат, но только как сторонний сервис, то есть, сами вы его установить (а следовательно, и выбрать) не можете. В любом случае, прежде чем устраивать чат, нужно детально изучить проблемы его поддержки (а их немало), после чего уже решать - хотите ли вы с этим возиться.

Рассмотренные методы относятся к разряду "вовлекающих", и их основная задача - дать человеку пообщаться и выговориться. Совершенно по-другому работают механизмы персонализации. Зайдите на какой-либо крупный портал, например, Lycos, Infoseek или MSN - в каждом из них присутствует возможность настройки внешнего вида портала и предлагаемых им рубрик под ваши конкретные интересы. При этом портал сам будет "узнавать" приходящего пользователя и "подсовывать" ему именно его персонализированный вариант страницы. Персонализация используется не только порталами, но и крупными магазинами (например, магазином "Озон"), новостными сайтами, поисковыми машинами и пр. С помощью таких персонализированных страниц порталы удерживают пользователей: раз уж человек потратил время на создание страницы "под себя", то он будет этим пользоваться, поскольку не захочет тратить время на создание такой страницы на другом сайте. Персонализация, подгонка контента под конкретного пользователя - это большая и сложная тема, и если вам интересна дополнительная информация по этому поводу, то посмотрите некоторые ссылки в конце лекции.

Механизм создания персонализированного сайта достаточно сложен и дорог. В целом, нельзя сказать, что он подвластен начинающему веб-мастеру, поэтому я опишу основы его работы, не вдаваясь в подробности, просто, чтобы вы имели представление о теме. Сначала нужен механизм идентификации пользователя, для чего используется два CGI-скрипта: механизм "подсаживания" cookie (текстовый файл с информацией, который пересылается на машину пользователя, а в следующее посещение считывается, в результате чего сервер может определить компьютер, с которого его уже посещали) и скрипт для доступа пользователя на сайт по паролю. Следует сказать, что cookie, которыми пугают маленьких детей (хакеры!.. кредитные карты!.. утеря личной информации!..) - незаменимый инструмент веб-мастера. С помощью этих небольших текстовых собщений можно сделать жизнь посетителей намного приятнее. Поэтому не стоит пугаться страшного слова "cookie" - это всего лишь инструмент, который можно использовать очень по-разному. Эти два скрипта обеспечивают достаточно точное узнавание и идентификацию пользователей. Затем создается база данных (обычно она пишется на SQL), и в эту базу данных заносятся элементы, из которых будут собираться страницы, а также настройки зарегистрированных пользователей. После этого необходим скрипт для взаимодействия издателя базы данных, то есть скрипт для "закачки" новых данных со стороны издателя (back end). Вслед за ним нужен еще один скрипт для взаимодействия базы данных и пользователей, то есть, этот механизм должен обеспечивать запись новых данных в базе (например, если пользователь создает или изменяет свои настройки), считывание и передачу пользователю данных из базы, словом, скрипт должен формировать и передавать запросы между базой и пользователем. После этого нужно еще создать к последнему скрипту интерфейс, чтобы пользователь мог непосредственно в браузере и, желательно, визуально отобрать необходимые ему компоненты. Теперь все это необходимо инсталлировать на сервере и проверить работоспособность (та еще головная боль) и, voila!, пользователь может работать и настраиваться так, как ему заблагорассудится.

Как видите, даже поверхностное описание этого механизма не кажется очень простым, когда же дело доходит до реализации, то тут впору вешаться потихоньку. Реализация такого проекта - задача для солидного штата программистов, поэтому разработки подобных систем стоят тысячи долларов, да еще и не каждая студия возьмется за такой заказ. Существуют готовые компоненты, которые можно найти в уже упомянутых общедоступных архивах. Из таких компонентов можно при желании собрать работающую систему, но для этого желательно обладать приличной квалификацией или небольшим штатом хотя бы из двух программистов.

Возвращаясь к простейшим проявления интерактивности, должен упомянуть еще об одном моменте, который часто упускают из виду - о гиперссылках. Мгновенный доступ к любому связанному документу (несмотря на низкое качество соединения, время ожидания страницы, все же, заметно меньше времени ожидания заказанной в "Ленинке" книги) - это одна из основ Сети, зародыш ее интерактивных возможностей. Зачем я напоминаю об этом? Затем, что не нужно гиперссылками пренебрегать. Сайт не должен быть соединен в единое целое только лишь оглавлением. Не забывайте связывать между собой ключевые понятия внутри текстовых страниц с соответствующими описаниями на вашем или других сайтах, организуйте перекрестные ссылки на смежные материалы по страницам своего сайта, чтобы пользователю было легче в нем ориентироваться. Правда, не следует и усердствовать, поскольку сайт, каждое слово которого представляет ссылку на связанные материалы, читать совершенно невозможно.

И, напоследок, хочу напомнить, что интерактивность подразумевает обратную свяь между посетителями, самим сайтом и издателем. Следовательно, эту связь необходимо постоянно поддерживать, так как сама она не будет развиваться. И в этой поддержке вы (или специально нанятый вашей фирмой человек) должны быть самым активным участником, в частности, потому, что это в ваших же интересах.

До следующих встреч.

Рекомендованная литература:

  • Конференции или как побудить людей общаться Джо Трайси
  • Интерактивность! Что? И как?


Библиотека разработчика -Ясли-сад. Курс Складываем кубики. Лекция 10.

Лекция 10

Все только начинается

Когда вы заканчиваете собственно создание сайта, то кажется, будто гора упала с плеч: заканчивается беготня, нервотрепка, лихорадочная деятельность и можно немного отдохнуть… не тут-то было! Ваша работа только начинается! Действительно, сайт нуждается в постоянной поддержке, развитии, его нужно продвигать, работать с аудиторией, подготавливать новые материалы и многое, многое другое. Конечно, сайт может оставаться статичной, необновляемой страницей более похожей на визитную карточку, чем на полноценный виртуальный ресурс. И, надо сказать, что подобных сайтов в сети немало, но скажите мне, кто придет на такой сайт во второй раз? Таким образом, если вы предпочитаете видеть свой сайт динамичным и развивающимся, то есть если вы хотите, чтобы ваш сайт был кому-либо интересен и полезен, то придется над ним постоянно работать.

Работа по поддержке сайта одновременно безобразно скучна и, в то же время, чрезвычайно интересна (впрочем, в любой работе можно найти обе эти составляющие). Можно поседеть от монотонной работы по выкладыванию новых материалов, особенно если они всегда однотипны, как и последовательность действий, которую надо совершить. По хорошему, надо, конечно, завести общую базу данных с двумя веб-интерфейсами, тогда обновление будет происходить заметно проще и быстрее. Очень не хочется (мне, по крайней мере, а я от природы очень ленивый человек) проводить рутинные маркетинговые акции, договариваться с хостинг-провайдером, и прочая, и прочая - этот процесс, на самом деле, тоже можно автоматизировать, особенно ту его часть, которая касается каталогов, поисковых машин и пр. И в то же время, вы получаете подлинное удовольствие от общения с живыми людьми, формирования и поддержки аудитории, работы на форумах, планирования и проведения масштабных акций. Так, например, для меня было очень ценным опытом проведение "живой" (офлайновой) конференции. К сожалению, необходимо проводить и те, и другие мероприятия, поскольку они одинаково важны для нормального функционирования и развития ресурса. Поэтому целью лекции будет показать методы, которые могут облегчить вам монотонные, рутинные операции по поддержке сайта.

Большая часть рутинной работы приходится на обработку и выкладку материалов. В этой операции, если она, конечно, не автоматизирована с самого начала, очень легко ошибиться, особенно, когда объем регулярно публикуемых материалов велик, и вы используете для верстки разные шаблоны в зависимости от раздела ресурса. Именно на этом этапе происходит большинство сбоев в работе мелких и средних узлов: неправильные ссылки. Непроставленные заголовки, оборванные таблицы, забытые вложения или рисунки и т.д. Поэтому необходимо если не автоматизировать, то хотя бы упорядочить процедуру прохождения материалов от бумаги до сайта.

Первым делом, займитесь шаблонами. Определите сколько и каких шаблонов вам нужно, то есть сколько у вас есть разных видов страниц и какие из них будут реально обновляться чаще раза год. Например, на сайте "Библиотеке Мастера" таких страниц семь: страница статей, страница архива "Альманаха Веб-мастера", страница оглавления, индексная страница, страница форума, страница информации из каталога рассылок, титульная страница каталога рассылок, однако регулярно обновляется только статьи, архив и рассылки. Таким образом, мне необходимо три аккуратных, детально выверенных шаблона, чтобы полностью "закрыть" мои еженедельные обновления - в такие готовые шаблоны мне достаточно просто "залить" материалы, и расставить гиперссылки внутри текста. То есть следует подготовить то количество шаблонов, которое вам может пригодиться при обновлении сайта и шаблоны эти тщательно вычистить, доведя до состояния, когда в них необходимо залить только сам материал - все остальное уже готово. Я уже упоминал о желательности создания шаблонов в одной из первых лекций, и сейчас еще раз напоминаю об этом: использование шаблонов для верстки новых материалов многократно сократит время на ежедневную поддержку ресурса.

Вторым мощным средством для упорядочивания рутинной работы являются уже описанные мною SSI и CSS. Все что можно, все, что не изменяется от страницы к странице, все это нужно запихнуть в отдельные, общие для всех страниц файлы и подгружать только через SSI инструкции. Помните только, что каждая страница должна иметь собственные мета-теги и теги заголовков (подробнее об этом можно прочесть в курсе "Маркетинг для малышей", который, я надеюсь, вы прочтете следом за настоящим). Старайтесь, чтобы непосредственно в самом шаблоне остались только те элементы, которые подлежат модификации и SSI-инструкции, подгружающие недостающие неизменные для всех страниц участки кода. CSS используется несколько реже, чем SSI, и совершенно напрасно, поскольку возможности таблиц стилей практически неограничены, о чем я уже писал. Имеет смысл описывать в таблицах даже те участки текстов, к которым вы не применяете никакого специально форматирования, чтобы потом была возможность это форматирование поменять, не прибегая к супермерам, таким, например, как переверстка всего сайта. Поскольку я такую переверстку несколько раз делал, должен сказать вам - очень неприятная штука. К слову сказать, несмотря ни на какие ухищрения, стоит себя заранее подготовить к тому, что все придется переверстать. Такое может случиться, если вы, например, захотите сменить весь дизайн.

Самой трудоемкой частью верстки является простановка ссылок. Причем, ссылок не только внешних, но и внутренних, соединяющих в единое целое страницы вашего сайта (надо честно признаться, что автоматическая установка ссылок визуальными редакторами при нахождении URL - хорошее подспорье). Представим себе, что вы собрали еще одну страницу сайта. Теперь к ней нужно поставить ссылку в новостях (ну, это просто), затем ссылку в оглавлении раздела (где-то оно лежит, но вот где?), ссылку в системе навигации (это хорошо, если навигация в SSI, а если нет?) и, наконец, перекрестные ссылки на смежных материалах сайта (а вот тут - легче повеситься). Итого получается от 2 до 5 ссылок, которые нужно поставить на каждую вновь публикуемую страницу. Что будет, если вам, представим, нужно выложить не одну-две страницы, а десять-двадцать? (собственно для этого и пишутся сложные, разветвленные базы данных, которые отслеживают появление нового материала и все остальное делают сами, не вовлекая в этот процесс оператора, однако написание баз данных точно выходит за пределы данного курса)

Если автоматизировать этот процесс невозможно, то его надо упорядочить. Первым делом, заведите бумажку и напишите на ней "Инструкцию по подготовке страниц текущих материалов для сайта такого-то" (дословно). Чем официальнее и четче вы будете выражаться в этой инструкции, тем меньше вероятность ошибки, поскольку сухие документы оставляют меньше простора для разгильдяйства. Эта же инструкция пригодится и вашим коллегам, если вы работаете над сайтом не в одиночестве. Технические аспекты часто относятся к той части проблем, которые "легче решить самому, чем объяснять", с помощью инструкций же вы легко покажете своему собеседнику, что и как ему предстоит сделать. Я знаю, как раздражают порой многочисленные идиотские планы и инструкции, но без них вы будете ошибаться чаще, несмотря на то, что все это разрабатывалось вами лично. Имея инструкцию перед глазами, вам не придется ни о чем вспоминать и ничего придумывать заново, - вот оно все тут рядом. Поверьте моему опыту: если нет строгого плана, то очень велик соблазн сделать "какое-нибудь улучшение".

Кроме добавления на сайт новых материалов вам также предстоит осуществлять маркетинговую поддержку вашего ресурса. Это сложная, вовсе не однородная работа, требующая большого напряжения внимания веб-мастера и издателя. Этой задаче полностью посвящен второй курс - "Маркетинг для малышей", который поможет разобраться вам в сложном и запутанном мире онлайн-маркетинга. Немаловажное значение в ежедневной поддержке сайта является его своевременность. Речь идет не о востребованности вашей темы аудиторией (то насколько представляемая вами тематика вообще может быть интересна), а о том насколько ваш информация актуальна для потенциальной аудитории. Таким образом, фактором, определяющим популярность вашего ресурса, будет не только тематика, но также полнота раскрытия темы на текущий момент. В то время как вопрос выбора темы и метода ее раскрытия относится, скорее, к планированию сайта, все вопросы связанные с постоянным пополнением ресурса новыми тематическими материалами ложатся на поддержку ресурса. То есть вы постоянно должны быть в курсе событий и, более того, сообщать посетителям со страниц сайта свежие и интересные новости пока они еще свежие и интересные. Также вы должны быть готовы ответить на любой вопрос, заданный вам посетителями сервера, поэтому раскрытие тематики, особенно информационной, требует от издателя постоянного самосовершенствования в выбранной области. В то же время, постоянное обновление сайта, наполнение его не только интересной, но и своевременной информацией - одна из основ для его успеха. Яркий пример -это бум, который переживают сейчас новостные издания. За неполный 99 год было открыто не менее дюжины информационных каналов, и все они пользуются немалой популярностью.

Не забывайте поздравлять свою аудиторию с наступающими праздниками и соответствующим образом подготавливайте к ним свой ресурс. Поместив на титульной (входной) странице ресурса несколько подходящих случаю картинок, вы создадите атмосферу праздника, что, безусловно, будет приятно вашим гостям. Хорошо, если вы сможете подобрать (или нарисовать) уникальные картинки, выполненные в едином стиле с вашим сайтом. Я даже рекомендую заказать вам несколько картинок, которые вы просто будете подставлять на сайте в нужные дни, по количеству праздников в году (последних не так уж и много, поэтому стоимость такой работы не будет слишком большой). Однако в Интернете существует немало бесплатных библиотек картинок, где вы всегда сможете найти для сайта достойное украшение. Кстати, такие праздничные поздравления-сюрпризы - достаточно распространенная практика, поэтому я просто рекомендую вам походить по крупным сайтам и посмотреть, как это сделано у них.

Вообще необходимо постоянно и внимательно следить за конъюнктурой: какие изменения происходят сейчас в Сети, какие тенденции сходят на нет, а какие преобладают, какие возникают и увядают модные течения. Так, например, в течение последнего года-полутора Рунет практически очистился от фреймов (если не считать Рамблера, то крупных сайтов с фреймовой версткой практически не осталось), зато оброс бесплатными почтовыми ящиками, баннерными сетями и дизайн-студиями. Подобные изменения происходят чрезвычайно быстро, поскольку Интернет развивается немыслимыми темпами, так что за ним не успевают никакие прогнозы. Один американский маркетолог высказался, что каждый год бизнеса в Интернете можно считать за семь лет в офлайне. Вопрос, который неизбежно рано или поздно встанет перед вами, - следовать ли моде или идти своим путем. При выборе того или иного решения следует учитывать, что большинство людей все же стремятся следовать моде, а следовательно, если ваш сайт рассчитан на широкую аудиторию с неизвестным составом, то моде следовать стоит. В конечном счете, для популярных сайтов следование моде - это вопрос прибылей.

Меняется не только мода. Постоянно и очень быстро увеличиваются возможности дизайнера вместе с расширением функций, как языка HTML, так и прикладных программ, используемых для просмотра содержимого сайтов. В свете этих постоянных изменений вам придется более или менее регулярно переделывать свой сайт, чтобы он был более модным, более функциональным и удобным для использования в данный текущий момент. Таким образом, в само понятие "поддержки сайта" необходимо заложить некоторые ресурсы на регулярное (раз в год-два) обновление (или даже полную переделку) дизайна сайта, включая и системы навигации, его структуру, взаимодействие частей сайта между собой, и прочая, и прочая. А может произойти и так, что ваш узел вырастет за отведенные ему рамки, и вам придется переделывать весь макет, чтобы учесть новые изменения и дополнения, которые произошли с момента первой верстки.

Федор Вирин

предыдущая лекция


Библиотека разработчика -Ясли сад. Курсы.

Курсы по созданию и продвижению сайта

Складываем кубики

Учебник по созданию интрнет-ресурса. В курсе подробно рассмотрены все этапы создания сайта от планирования до поддержки после запуска проекта. В курсе уделено особенное внимание интеграции технологий в рамках избранного ресурса.

Маркетинг для малышей

Курс маркетинга для начинающих. В курсе разобраны общие принципы маркетинга и рекламы, а также их примнение на практике в Интернете. Курс рекомендован всем, кто только начинает заниматься продвижением своего сайта.