Как пользоваться справочником

Для удобства пользования справочником используется следующая система, позволяющая наглядно представить все возможности реестра.

Используемые сокращения

  • HKLM = HKEY_LOCAL_MACHINE
  • HKCU = HKEY_CURRENT_USER
  • HKCR = HKEY_CLASSES_ROOT

Разделы реестра обозначаются синим цветом

HKLM\System\CurrentControlSet\Control\Lsa

Все настройки даны для текущего пользователя (раздел HKEY_CURRENT_USER) . Если существует аналогичная запись в HKEY_LOCAL_MACHINE (для всей системы), то HKCU выделяется желтым цветом

Если установки вступают в силу без перезагрузки, то параметры реестра обозначаются зеленым цветом

RestrictAnonymous

Если установки вступают в силу после перезагрузки, то параметры реестра обозначаются красным цветом
RestrictAnonymous

Данная система вступает в силу с мая 2003 года. Все параметры, которые были включены в справочник раньше этой даты, будут исправляться постепенно при наличии у автора свободного времени


Вступление

Что такое реестр? Общая теория

Реестр - база данных операционной системы, содержащая конфигурационные сведения. Физически вся информация реестра разбита на несколько файлов. Реестры Windows 9х и NT частично различаются. В Windows 95/98 реестр содержится в двух файлах SYSTEM.DAT и USER.DAT, находящиеся в каталоге Windows. В Windows Me был добавлен еще один файл CLASSES.DAT. В Windows XP реестр хранится во многих файлах. Основная часть хранится в файлах sam, security, software, system, default (все файлы без расширения).

По замыслу Microsoft он должен был полностью заменить файлы ini, которые были оставлены только для совместимости со старыми программами, ориентированными на более ранние версии операционной системы.

Почему произошел переход от ini файлов к реестру? Дело в том, что на эти файлы накладывается ряд серьезных ограничений, и главное из них состоит в том, что предельный размер такого файла составляет 64Кб.

ПРЕДУПРЕЖДЕНИЕ: НИКОГДА не удаляйте или не меняйте информацию в реестре, если Вы не уверены что это именно то, что нужно. В противном случае некорректное изменение данных может привести к сбоям в работе Windows и, в лучшем случае, информацию придется восстанавливать из резервной копии.


Внешний вид кнопки Пуск

Внешний вид кнопки Пуск (Windows XP)

Удаление фиксированного списка программ

В Windows XP в контекстном меню исполяемых файлов появился пункт Закрепить в меню "Пуск", который добавляет программу в фиксированный список данного меню. Также там могут находится две программы интернета и электронной почты (Пуск-Панель управления-Панель задачи меню "Пуск"-вкладка Меню "Пуск"-кнопка Настроить-рамка Отображать в меню "Пуск")
Для удаление данного списка из меню откройте раздел

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoStartMenuPinnedList типа DWORD со значением, равным 1. Также будет удален и пункт Закрепить в меню "Пуск" из контекстного меню программ

Удаление списка часто используемых программ

Если вы хотите удалить список часто используемых программ кнопки Пуск (на рисунке слева - стиль XP), то откройте раздел

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoStartMenuMFUprogramsList типа DWORD со значением, равным 1.

Запрет на попадание приложения в список часто используемых программ

Можно не удалять список часто используемых программ (смотри совет выше), а запретить отдельным программам попадать в этот список. Для этого откройте раздел

HKEY_CLASSES_ROOT\Applications\Имя_Программы.exe
и создайте пустой строковый параметр NoStartPage.

Удаление имени пользователя

Если вы хотите удалить имя пользователя в кнопке Пуск (на рисунке используется имя alexandr - стиль XP), то откройте раздел

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoUserNameInStartMenu типа DWORD со значением, равным 1.

Удаление пункта Мой компьютер

Чтобы удалить пункт Мой компьютер и заблокировать соответствующий флажок в диалоговом окне настройки, добавьте параметр типа DWORD {20D04FE0-3AEA-1069-A2D8-08002B30309D} со значением, равным 1 в разделе

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum

Удаление пункта Сетевые соединения

Чтобы удалить пункт Сетевые соединения, добавьте параметр типа DWORD NoNetworkConnections со значением, равным 1 в разделе

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer

Удаление пункта Сетевое окружение

Чтобы удалить пункт Сетевое окружение, добавьте параметр типа DWORD NoStartMenuNetworkPlaces со значением, равным 1 в разделе

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer

Удаление пункта Выход из системы

Ключ StartmenuLogoff типа DWORD, равный 1, раздела

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
удаляет пункт Выход из системы

Удаление вышеприведенных параметров или установка в 0 возвращает прежнее поведение


Меню кнопки Пуск: Подпапки

Меню кнопки Пуск: Папки

Существует возможность скрывать папки и файлы из верхней части меню кнопки Пуск, которые были скопированы из других мест (Папки при этом не удаляются). Откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoStartMenuSubFolders со значением 1.


Программы

Если вы хотите скрыть приложения из выпадающего меню кнопки Пуск из папки "C:\Documents and Settings\All Users\Главное меню\Программы", то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoCommonGroups со значением 1.


Червы

Хотите стать шулером в карточной игре "Червы"?

Откройте раздел

HKU\S-1-5-21-790525478-113007714-1957994488-1003\Software\Microsoft\Windows\CurrentVersion\Applets\Hearts
и создайте строковый параметр ZB со значением 42, тогда после нажатия клавиш CTRL+SHIFT+ALT+F12 вы откроете карты противников!
Параметр S-1-5-21-... у вас может быть другим.


Избранное

Удаление пункта Избранное

Если вы хотите удалить пункт Избранное из меню кнопки Пуск, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoFavoritesMenu со значением 1.


Документы

Удаление пункта Документы

Если вы хотите удалить пункт Документы из меню кнопки Пуск, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoRecentDocsMenu типа DWORD со значением 1.

Управление количеством запоминаемых документов

Windows помнит список из 15 последних открытых документов, доступ к которому можно получить через Пуск-Документы. Если вы хотите изменить это значение по умолчанию, то то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр MaxRecentDocs типа DWORD со значением от 0x0 - 0xFFFFFFFF (0xF = 15 документам).

Автоматическое очищение списка недавно открытых документов

Чтобы очищать список недавно открытых документов каждый раз при выключении компьютера, добавьте ключ ClearRecentDocsOnExit типа DWORD со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer

Не запоминать открываемые документы

Если Вы хотите, чтобы открываемые Вами документы не запоминались в этом списке, надо добавить ключ NoRecentDocsHistory типа DWORD со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer

Мои рисунки

Чтобы удалить пункт Мои рисунки из пункта Документы, используйте ключ NoSMMyPictures типа DWORD со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer


Настройка

Скрытие пунктов подменю из меню Настройка

Если вы хотите скрыть пункты Панель управления, Принтеры, Удаленный доступ к сети и др. из меню Настройка, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoSetFolders со значением 1.

Установка этого ключа также удалит эти папки из окна "Мой компьютер".

Примечание: Если нужно скрыть только один пункт Панель управления, не трогая остальные пункты, то смотри NoControlPanel

Скрытие Панель задач и меню "Пуск" из меню Настройка

Если вы хотите скрыть пункт Панель задач и меню "Пуск" из меню Настройка, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoSetTaskbar со значением 1.


Принтеры

Запрет на установку новых принтеров в систему

Если вы хотите запретить установку новых принтеров (Пуск-Настройка-Принтеры-Установка принтера), то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
и создайте параметр типа DWORD NoAddPrinter со значением 1.

При попытке установить новый принтер будет выведено сооответствующее предупреждение


Панель задач и меню "Пуск"

Скрытие пункта "Отображать команду "Завершение сеанса"

Если вы хотите скрыть пункт Отображать команду "Завершение сеанса" из Параметры меню "Пуск" и панели задач (Пуск-Настройка-Панель задач и меню "Пуск"-Дополнительно), то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
и создайте параметр типа DWORD StartMenuLogoff со значением 1


Поиск

Классический вид

Чтобы использовать классический вид поиска файлов без анимированного персонажа, то присвойте строковому параметру Use Search Asst значение no в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState

Очистка истории раннее вводимых слов

Если вы часто пользуетесь поиском во встроенном поисковике, то Windows услужливо подставляет ранне вводимые слова в строку поиска для облегчения набора. Если вам необходимо очистить историю вводимых ключевых слов (заметаете следы?), то просто удалите подраздел ACMru в разделе

HKCU\Software\Microsoft\Search Assistant
Если необходимо очищать данный раздел постоянно, то можете поместить в автозагрузку команду
regedit /s Clear.reg, а в папке Windows создать файл Clear.reg с содержанием:
REGEDIT4 [-HKEY_CURRENT_USER\Software\
Microsoft\Search Assistant\ACMru]
После этого история поиска файлов будет очищаться автоматически при запуске системы.

Удаление пункта Поиск

Если вы хотите удалить пункт Поиск из меню кнопки Пуск, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoFind типа DWORD со значением, равным 1.

После перезагрузки пункт Поиск исчезнет из меню кнопки Пуск, а также исчезнет команда Найти... из контекстного меню кнопки Пуск при нажатии на нее правой кнопкой. Также не будет работать клавиша F3, используемая для поиска. Кроме того, в Проводнике не будет работать кнопка Поиск (хотя сама кнопка будет на месте)

Удаление параметра или установка в 0 возвращает пункт в меню

Удаление или изменение подпунктов в пункте Найти

В пункте Найти могут присутствовать различные подпункты. Например, у меня там затесались Файлы и папки..., В Интернете..., Людей..., For MP3 files..., For Files on Internet...
Все эти пункты прописаны в разделе

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FindExtensions\Static
Например, пункту Людей... соответствует подраздел WabFind\0. Измените значение по умолчанию "&Людей..." на "&Ламеров и хакеров..."
За пункт В Интернете отвечает раздел WebSearch\0
Файлы и папки - ShellSearch\0 и т.д.


Справка

Удаление пункта Справка

Если вы хотите удалить пункт Справка из меню кнопки Пуск, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoSMHelp со значением 1.


Выполнить

Удаление пункта Выполнить из меню кнопки Пуск

Если вы хотите удалить пункт Выполнить из меню кнопки Пуск, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoRun со значением 1

Флажок "Запустить в отдельной области памяти"

Ключ типа DWORD MemCheckBoxInRunDlg, равный 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
добавляет флажок "Запустить в отдельной области памяти" в диалоговое окно "Запуск программы", который позволяет выполнить 16-разрядные приложения в отдельных виртуальных DOS-машинах

Очистка списка недавно использованных команд

Команда Выполнить содержит список недавно использованных команд (MRU list)

Этот список содержится в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Explоrer\RunMRU
.

Параметр MRUList содержит строку, определяющую порядок, в котором остальные записи будут появляться в списке. Например, запись "bca" говорит о том, что первым элементом в списке Открыть будет команда с именем b, потом c, а следом a

Сами команды хранятся как строки с оканчивающимися символами \1 в параметрах a, b, c, d и т.д. Всего допускается 26 записей

Для очистки списка нужно заменить параметры MRUList и все команды пустой строкой (""), либо отредактируйте по своему вкусу


Все программы

Удаление команды Все программы

Если вы хотите удалить команду Все программы кнопки Пуск (в стиле XP), то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoStartMenuMorePrograms со значением, равным 1.

Восстановление системы

Чтобы удалить команду Восстановление системы из меню кнопки Пуск (Пуск-Все программы-Стандартные-Служебные), то откройте раздел

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\SystemRestore
и создайте параметр типа DWORD DisableSR со значением, равным 1


Завершение работы

Выключить компьютер можно двумя способами

  • Используя команду Завершение работы меню кнопки Пуск
  • Открывая окно Завершение работы программы нажатием кнопок Ctrl+Alt+Del и нажимая кнопку Завершить работу
Windows позволяет запретить выключение этими способами для текущего пользователя

Для этого откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD NoClose со значением 1.

Кнопка Завершить работу в окне Завершение работы программы станет недоступной сразу же после изменения в реестре. После перезагрузки пункт Завершение работы исчезнет из меню кнопки Пуск

Это относится только к стандартным средствам Windows. Специальные программы или утилиты по-прежнему могут выключать компьютер


Контекстное меню кнопки Пуск

Если вы хотите запретить контекстное меню кнопки Пуск, позволяющее удалять, переименовывать и т.д., а также возможность перемещения пунктов меню методом drag-n-drop, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoChangeStartMenu типа DWORD со значением 1.


Скроллинг

Когда меню Пуск-Программы переполняется ярлыками, то в Windows 98 появляется прокрутка и достаточно ею неудобно пользоваться. В новых версиях Windows такой проблемы нет. При переполнении оно само разворачивается, если не используется "Использовать сокращенные меню" в Панели задач. В Windows 98 тоже можно добиться такого же поведения, избавившись от скроллинга. Для этого используйте строковый параметр StartMenuScrollPrograms со значением No в разделе:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Соответсвенно, если в новых версиях Windows вас не устраивает такое поведение и вы предпочитаете прокрутку, то используйте значение Yes


Корзина

Всплывающая подсказка

Когда вы подводите курсор к значку Корзина на Рабочем столе, то появляется всплывающая подсказка. Например, в Windows Me содержится надпись следующего содержания: "Используется для временного хранения удаленных файлов, пока они не будут окончательно стерты". Для изменения этой надписи используйте строковый параметр InfoTip в разделе

HKCR\CLSID\{645FF040-5081-101B-9F08-00AA002F954E},
в которой укажите желаемую строку (например, "Здесь хранится мусор")

Новое имя для корзины

В отличие от многих других элементов на Рабочем столе, у Корзины нет команды Переименовать. А иногда так хочется! Ищем раздел

HKCU\SOFTWARE\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}
и меняем строковый параметр (По умолчанию). Например, пишем Свалка. Обновите Рабочий стол, чтобы изменение вступило в силу

В Windows 2000/XP немного проще. Там в разделе

HKCR\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}
есть строковый параметр LocalizedString, в котором и пишем новое имя для Корзины

Контекстное меню

Пункт Свойства

Если вы хотите убрать пункт Свойства из контекстного меню Корзины, то создайте параметр типа DWORD NoPropertiesRecycleBin со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Пункты Переименовать и Удалить (Windows 9x/ME/2000)

Но можно и включить пункты Переименовать и Удалить в контекстное меню, что позволит Вам переименовать и/или удалить Корзину, как будто это была обычная папка. Меняем значение двоичного параметра Attributes равным " 70 01 00 20 " в разделе

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder
и тогда Вы сможете переименовать или удалить Корзину, щелкая правой кнопкой мыши на ней. (По умолчанию используется 40 01 00 20). Для появление только одного пункта Переименовать используйте значение 50 01 00 20, для пункта Удалить значение - 60 01 00 20

Удаление значка с Рабочего стола

Чтобы удалить значок Корзины с Рабочего стола, необходимо зайти в раздел

HKLM\SOFTWARE\CurrentVersion\explorer\Desktop\NameSpace
и удалить подраздел {645FF040-5081-101B-9F08-00AA002F954E}

Добавить значок Корзины в Мой компьютер

Чтобы добавить значок Корзины в Мой компьютер, необходимо зайти в раздел

HKLM\SOFTWARE\CurrentVersion\explorer\MyComputer\NameSpace
и добавить подраздел {645FF040-5081-101B-9F08-00AA002F954E}


Сетевое окружение

Скрытие значка Мое сетевое окружение на Рабочем столе

Чтобы скрыть значок Мое сетевое окружение на Рабочем столе, присвойте параметру типа DWORD NoNetHood значение, равное 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Вся сеть

Чтобы скрыть значок "Вся сеть" из Мое сетевое окружение, присвойте параметру типа DWORD NoEntireNetwork значение, равное 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Network

Скрытие значка не налагает запрет для текущего пользователя на просмотр или подключение к компьютерам из его рабочей группы или домена. Пользователь может подключиться к удаленным компьютерам с указанием в формате UNC полного сетевого имени разделенного ресурса в диалоговых окнах: как в команде "Выполнить", так и в команде "Подключить сетевой диск".

Соседние компьютеры

Чтобы скрыть значок "Соседние компьютеры" в папке Мое сетевое окружение, присвойте параметру типа DWORD NoComputersNearMe значение, равное 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Эта системная политика нацелена на удаление из списка сетевых ресурсов в "Проводнике" и окне Мое сетевое окружение компьютеров, входящих в рабочую группу. Она не имеет влияния на компьютеры, входящие в домен пользователя. Когда эта политика активизирована, система удаляет "Соседние компьютеры" и значки, отображающие соседние компьютеры, из папки Мое сетевое окружение и из диалогового окна обзора для подключения сетевых дисков. Имеет эффект только на "Текущего Пользователя".

Когда политика активна, пользователям не запрещено подключаться к компьютерам в своей рабочей группе или домене другими способами. Подключение можно произвести, набрав полное сетевое имя разделенного ресурса в формате UNC, в диалоговых окнах команд "Выполнить" или "Подключить сетевой диск". Чтобы удалить компьютеры из списка сетевых ресурсов, необходимо использовать политику "Скрыть значок "Вся сеть" в папке Мое сетевое окружение (смотри выше).


Обои для Рабочего стола

За картинку, используемую в качестве обоев для Рабочего стола отвечает строковый параметр Wallpaper, который содержит путь bmp-файла в

HKCU\Control Panel\Desktop

Чтобы ваша картинка на Рабочем столе располагалась в строго заданном месте, а не в центре, нужно в разделе

HKCU/Control Panel/Desktop
создать строковые параметры с названиями WallpaperOriginX и WallpaperOriginY и установите их значения так, чтобы они соответствовали нужным вам координатам X и Y левого верхнего угла картинки в пикселях.


Группировка кнопок на панели задач

Если у вас в свойствах панели задач установлено Группировать сходные кнопки панели задач, то Windows начинает группировать кнопки, если их число достигает 3 (по умолчанию). Вы можете изменить это число, используя параметр типа DWORD TaskbarGroupSize с вашим значением в разделе

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced


Версия Windows на Рабочем столе

Существует возможность вывода номера версии и номер сборки Windows в нижнем правом углу Рабочего стола. Для этого создайте ключ типа DWORD PaintDesktopVersion со значением 1 в разделе

HKCU\Control Panel\Desktop


Скрытие всех элементов на Рабочем столе

Существует возможность скрытия всех элементов на Рабочем столе. Будут доступны только панель задач и меню кнопки Пуск. Для этого создайте ключ типа DWORD NoDesktop со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer


Мигание кнопки на панели задач

Время, отведенное на мигание

Когда программа требует ввода данных, она может либо выскочить на передний план, либо начать мигать кнопкой на панели задач. Вы можете установить время,в течении которого программа будет сигнализиоровать перед этим выходом. Для этого нужно в разделе

HKCU\Control Panel\Desktop
создать или изменить параметр ForegroundLockTimeout типа DWORD и установить его значение на время задержки до "перехвата" фокуса в миллисекундах: 0 — окно сразу выскакивает вперед, 200 000 — значение по умолчанию.

Количество миганий

Также вы можете установить число миганий кнопки. Для этого надо в этом же разделе создать или изменить DWORD-параметр ForegroundFlashCount и установить его значение на нужное число миганий для привлечения внимания пользователя. Значения устанавливаются в десятичной системе: 0 заставит кнопку мигать бесконечно, по умолчанию значение равно 3


Active Desktop

Запрет на Active Desktop

Active Desktop позволяет вставлять в оформление рабочего стола HTML-файлы, ссылки из Интернета, файлы с картинками и анимацией и т.п. в качестве обоев. Чтобы исключить эту особенность, которая отнимает ресурсы у компьютера, присвойте параметру типа DWORD NoActiveDesktop значение 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

При этом

  • удаляется пункт Active Desktop из контекстного меню, вызываемого правой кнопкой мыши на Рабочем столе
  • удаляется вкладка Web из апплета Экран в Панели управления
  • становится недоступным пункт Отображать веб-содержимое на рабочем столе на вкладке Общие апплета Свойства папки в Панели управления


Удалить Мой компьютер

Удаление значка Мой компьютер

Чтобы удалить значок Мой компьютер из Рабочего стола, откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum
и присвойте параметру типа DWORD {20D04FE0-3AEA-1069-A2D8-08002B30309D} значение 1.


Дисковые утилиты

Если выбрать пункт Свойства в контекстном меню при нажатии правой кнопкой мыши на диске в окне Мой компьютер и перейти на вкладку Сервис, то там присутствует возможность запуска некоторых дисковых утилит. Можно прописать туда свои программы вместо установленных по умолчанию. Откройте раздел
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer. В этом разделе уже могут находиться некоторые подразделы, отвечающие за дисковые утилиты. Если их нет, то создайте их сами и в значениях по умолчанию задайте путь к вашему приложению.
Для утилиты Очистка диска создать подраздел CleanupPath
По умолчанию используется
NT/2000/XP: "%SystemRoot%\system32\cleanmgr.exe /D %c"
W9x/WME: "C:\Windows\CleanMgr.exe"

Для утилиты Проверка диска - подраздел ChkDskPath
По умолчанию используется
NT/2000/XP: "%SystemRoot%\system32\chkdsk.exe %c:"
W9x/WME: "C:\Windows\chkdsk.exe"

Для утилиты Дефрагментация диска - подраздел DefragPath
По умолчанию используется
NT/2000/XP: "%systemroot%\system32\dfrg.msc %c:"
W9x/WME: "C:\Windows\Defrag.exe"

Чтобы вернуться к прежнему состоянию, нужно либо установить значения по умолчанию (приводятся выше), либо удалить эти подразделы


Общие документы

Общие документы (Windows XP)

Чтобы скрыть папку Общие документы из папки Мой компьютер, удалите ключ {59031a47-3f72-44a7-89c5-5595fe6b30ee} из раздела

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\My Computer\NameSpace\DelegateFolders


Управление

Чтобы скрыть пункт Управление из контекстного меню значка Мой компьютер, создайте параметр типа DWORD NoManageMyComputerVerb со значением 1 в разделе

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Примечание: Данный пункт запускает утилиту compmgmt.msc. Удаление пункта не удаляет саму программу

Можно пойти более радикальным путем - удалите раздел

HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage


Мои документы

Запрет на изменение пользователем местоположения папки Мои документы

Если вы не хотите,чтобы пользователь мог перемещать и переименовывать папку Мои документы в Проводнике и Мой компьютер, то создайте параметр типа DWORD DisablePersonalDirChange со значением 1 в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer (не путайте папку Мои документы с элементом ActiveX Мои документы). Теперь при попытке переименовать или переместить папку будет выводиться соответствующее сообщение

Подсказка

Когда вы подводите курсор к значку Мои документы на Рабочем столе, то появляется всплывающая подсказка. Для ее изменения используйте строковый параметр HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\InfoTip, в которой укажите желаемую строку (например, "Здесь хранятся секретные материалы")

Удаление значка Мои документы из Рабочего стола, Проводника и диалоговых окон открытия и открытия файлов

Чтобы удалить значок Мои документы из Рабочего стола, Проводника и диалоговых окон открытия и открытия файлов, добавьте параметр типа DWORD {450D8FBA-AD25-11D0-98A8-0800361B1103} со значением 1 в раздел
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum


Оболочка Windows

Оболочка Windows (Windows NT/2000/XP)

Надоел Проводник в качестве оболочки Windows? Можно поставить любую программу, которая может служить в качестве такой оболочки, например, progman.exe, входящий в стандартную поставку Windows. Для этого поменяйте значение параметра Shell на "progman.exe" (без кавычек) в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
Когда захочется вернуть все назад, поменяйте указанное значение на explorer.exe.


Системные папки

Системные и специальные папки

В Windows можно поменять место расположения системных и специальных папок (Принтеры, Рабочий стол, Избранное, SendTo и т.п.). Но просто так перенести их в другое место не удастся - при следующей загрузке они опять восстановятся на старом месте. Это связано с тем, что пути к этим папкам прописаны в реестре. Чтобы настроить расположение этих папок на вашем жестком диске, зайдите в раздел

HKCU\Software\ Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
или
HKCU\Software\ Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
и поменяйте путь для нужных вам папок. Затем их можно будет спокойно перенести по прописанному вами адресу

После перезагрузки изменения вступят в силу


Контекстное меню Проводника

Блокировка контекстного меню

Чтобы сделать недоступным контекстное меню Проводника при щелчке правой кнопкой мыши, найдите ветвь:

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
- и создайте параметр типа DWORD NoViewContextMenu со значением 1

Новые пункты "Копировать в папку" и "Переместить в папку" (Windows 2000/XP)

Зачастую, возможностей стандартного контекстного меню файлов не хватает для различных задач пользователей. В Windows 2000/XP можно добавить еще пару пунктов, которые заложены в самой операционной системе, но по умолчанию не включены.

В реестре Windows существует два раздела {C2FBB630-2971-11d1-A18C-00C04FD75D13} и {C2FBB631-2971-11d1-A18C-00C04FD75D13}, которые отвечают за копирование и перемещение файлов в Windows. Эти две возможности, Копировать в папку и Переместить в папку, можно включить в контекстное меню файлов.

Эти два пункта вызывают стандартное окно для копирования или перемещения файла, пользоваться которыми порой гораздо удобнее, чем открывать отдельное окно с нужным каталогом, а потом перетаскивать в него файлы.

Чтобы включить новые пункты в контекстное меню надо создать разделы и параметры в реестре:

для копирования: установить значение по умолчанию равным {C2FBB630-2971-11d1-A18C-00C04FD75D13} в разделе

HKCR\*\shellex\ContextMenuHandlers\Copyto

для перемещения: установить значение по умолчанию равным {C2FBB631-2971-11d1-A18C-00C04FD75D13} в разделе

HKCR\*\shellex\ContextMenuHandlers\Moveto

В этом случае пункты меню появятся у всех файлов и папок. Чтобы добавить их только в файлы с конкретным расширением, надо добавлять записи в раздел shellex этих файлов. Так, для текстовых файлов это будет выглядеть таким образом:

для копирования
[HKCR\txtfile\shellex\ContextMenuHandlers\Copyto]
@="{C2FBB630-2971-11d1-A18C-00C04FD75D13}"

для перемещения
[HKCR\txtfile\shellex\ContextMenuHandlers\Moveto]
@="{C2FBB631-2971-11d1-A18C-00C04FD75D13}"

Изначально раздела shellex там нет. Надо создать его и все подразделы самостоятельно.


Новый ярлык

В Проводнике или Мой компьютер через меню Файл-Создать-Ярлык вы можете получить доступ к дискам компьютера, даже если вы отключили контекстное меню Проводника. Чтобы не допустить появления мастера создания нового ярлыка, удалите или переименуйте раздел:

HKCR\.lnk\ShellNew

Возможность создания нового ярлыка сохранится, но доступ к дискам будет перекрыт


Панель инструментов

Настройка панели инструментов

Если щелкнуть правой кнопкой мыши на панели инструментов, то появлятся всплывающее меню, содержащее пункт Настройка, который позволяет настраивать панель инструментов. Чтобы скрыть этот пункт, найдите ветвь:

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
и создайте параметр NoToolbarCustomize типа DWORD со значением 1

Подобный пункт будет удален также из Internet Explorer

Замена фона в панели инструментов в Проводнике

Существует возможность установки своего фона для панели инструментов в Проводнике. Для этого в разделе реестра

HKCU\SOFTWARE\Microsoft\Internet Explorer\Toolbar
создайте строковый параметр BackBitmapShell, значением которого будет полное имя BMP-файла с нужной картинкой - она и замостится мозаикой на панелях окон.

Для замены фона не только в Проводнике, но и в Internet Explorer смотрите Замена фона в панели инструментов в Internet Explorer


Удаление пункта меню Файл из Проводника

Для удаления пункта меню Файл из Проводника используйте параметр NoFileMenu со значением DWORD равным 1 в разделе
HKEY_CURRENT_USER\SOFTFARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Также будет удален этот пункт из окна Мои документы, Internet Explorer и других мест, использующих оболочку Windows


Настроить вид папки

Для запрещения команды Настроить вид папки в меню Вид используйте параметр типа DWORD NoCustomizeWebView со значением 1 в разделе

HKCU\Software\Microsoft\Windows\ CurrentVersion\Policies\Explorer


Удаление кнопки Поиск из Проводника

Проводник Windows содержит кнопку Поиск, схожее с пунктом Найти в меню кнопки Пуск. Для удалениея данной кнопки используйте параметр NoShellSearchButton со значением DWORD равным 1 в разделе
HKEY_CURRENT_USER\SOFTFARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Также будет удалена эта кнопка из окна Мои документы, и других мест, использующих оболочку Windows


Установка классического вида

Установка классического вида в Проводнике (Windows 98 и выше)

Проводник Windows содержит пункты меню, как Переход и Избранное, которые отражают новые Web-возможности Windows. Если нет необходимости использовать новые возможности, то можно использовать классический стиль окон оболочки и проводника, добавив параметр ClassicShell со значением DWORD равным 0x00000001 в раздел

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer


Связанные документы

Связанные документы (Windows Me/2000/XP)

В последних версиях Windows появилось понятие сопоставленных файлов. Например, если вы собираетесь переместить или удалить html-документ, то будут также перемещены или удалены и сопоставленные с этим документом файлы, которые содержаться в папке ИмяДокумента.files. Если вы хотите отключить подобное поведение, то создайте параметр типа DWORD NoFileFolderConnection со значением 1 в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer.

Изменения вступят после перезагрузки


Удаление вкладки DFS

Удаление вкладки DFS (Windows 2000/XP)

Чтобы удалить вкладку DFS из проводника, что позволит предотвратить изменение свойств локальных сетевых ресурсов DFS пользователями, выполните следующее:
Перейдите в подраздел HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\PoliciesExplorer и создайте ключ типа DWORD NoDFSTab со значением равным 1


Проводник как два отдельных процесса

Как известно, Проводник выступает и в качестве оболочки Windows, и в качестве файл-менеджера. И хотя это повышает удобство, на использовании памяти это сказывается отнюдь не лучшим образом. При нормальных условиях Проводник отнимает целых 8 Мбайт памяти Windows. Из-за проблем с выделением памяти Windows использует двойную квоту памяти для Проводника, считая ее используемой разными программами. Чтобы избавиться от этой проблемы, "интегрированной" в систему, надо запустить Проводник как два отдельных процесса вместо одного. Для этого нужно изменить значение параметра типа DWORD SeparateProcess в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced ("0" - один процесс, "1" - два процесса)
Примечание: Для Windows XP используется раздел HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Advanced


HotTrackingColor

Изменение цвета файла при подведении мыши

Если в Проводнике используется веб-вид (начиная с Windows Me, этот стиль стоит по умолчанию), то при подведении курсора мыши к значку и имени файла или папки изменяется цвет текста. По умолчанию этот цвет совпадает со цветом выделенного файла. Можно задать другой цвет, отличающийся от цвета выделенного файла. Создайте строковый параметр HotTrackingColor в разделе
HKEY_CURRENT_USER\Control Panel\Colors. Данный параметр должен содержать цвет в формате RRR GGG BBB, который является комбинацией трех цветов: красного, зеленого и голубого (например, 255 0 0).
Ниже приводится список некоторых цветов:
красный | 255 0 0
желтый | 255 255 0
зеленый | 0 255 0
голубой | 0 255 255
синий | 0 0 255
сиреневый | 255 0 255

После перезагрузки вы увидите, как изменяется цвет имени файла при наведении на него мыши.


Перезагрузка Windows

Перезагрузка Windows (NT/2000/XP)

Перезагрузка после краха (Windows XP)

Чтобы принудительно заставить Windows перегрузиться после краха в сисетме, измените значение параметра DWORD AutoReboot в разделе

HKEY_LOCAL_MASHINE\SYSTEM\CurrentControlSet\Control\CrashControl
с 0 на 1

Перезагрузка оболочки

По умолчанию при ошибках оболочки (Explorer) в Windows перезагружается вся операционнная система. Однако, существует возможность перезагружать только саму оболочку, тем самым не теряя данных, обрабатываемых другими приложениями. Для этого в разделе

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
надо изменить параметр типа DWORD AutoRestartShell
  • 0 - перезагружается операционная система
  • 1 - перезагружается только оболочка


Панель управления

Используем классический стиль Windows (Windows XP)

Чтобы использовать Панель управления без визуальных стилей Windows XP, используйте параметр типа DWORD ForceClassicControlPanel со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Запрет за запуск Панели управления и ее апплетов (Windows 2000/Me/XP)

Чтобы запретить запуск Control.exe, а также апплетов Панели управления, используйте параметр типа DWORD NoControlPanel со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Также будут удалены пункт Панель управления из меню кнопки Пуск и папка из Проводника. При попытке запустить апплет будет выводиться соответствующее предупреждение.

Для отмены запрета вышеприведенных примеров используйте значение 0 или просто удалите ключ.


Панель управления: Скрытие и показ значков апплетов

Панель управления: Скрытие и показ значков апплетов (Windows NT/XP)

Данные настройки позволяют скрыть отдельные значки апплетов Панели управления, либо наоборот, показать только разрешенные значки. Начнем с первого варианта. Он состоит из двух частей.

Если вы хотите скрыть отдельные значки в папке Панели управления, то создайте параметр типа DWORD DisallowCpl со значением 1 в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer. Затем в этом же разделе нужно создать подраздел с таким же названием DisallowCpl. В созданном подразделе вы перечисляете апплеты, которые нужно скрыть при помощи строковых параметров следующего формата:
Номер REG_SZ Applet.cpl, т.е. сначала создаете строковый параметр, начиная с 1 и присваиваете ему имя апплета:
1 main.cpl
2 mmsys.cpl
и так далее

Существует другой вариант. Вы запрещаете показ всех значков апплетов, кроме некоторых. Настройка схожа с вышеприведенным примером. В этом же разделе создается параметр RestrictCpl со значением 1 и создается подраздел RestrictCpl, в котором вы перечисляете апплеты, которые разрешаете показывать в папке Панели управления.

Примечание: Данные настройки просто скрывают значки, но сами файлы присутствуют на компьютере и их можно запускать любым доступным способом.


Администрирование

Администрирование (Windows XP)

Чтобы удалить апплет Панели управления Администрирование, откройте раздел

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
и найдите там подраздел {D20EA4E1-3957-11d2-A40B-0C5020524153} и переименуйте данный подраздел, поставив минус перед ним (-{D20EA4E1-3957-11d2-A40B-0C5020524153})


Дата и время

Часовой пояс

В апплете Панели управления Дата и время вы видите, что у вас часовой пояс Москвы, Санкт-Петербурга и Волгограда (или что-то в этом роде). Хотите, чтобы Windows знала о существовании вашей деревни Гадюкино? В разделе реестра

HKLM\SOFTWARE\MICROSOFT\Windows\CurrentVersion\TimeZones
находим подраздел Russian, где и меняем параметр Display, введя название своей деревни. Щелкните на часиках в правом углу и вы увидите в часовом поясе свою малую родину. Своей подружке скажите, что Билл Гейтс специально по вашей просьбе внес на карту название вашей деревни! :-)

Московское время (Windows XP)

В апплете Панели управления Дата и время на вкладке Дата и время вы можете видеть строку Московское время (зима) (или что-то в этом роде). Можно поменять эту строчку. В разделе реестра

HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation
меняем строковые параметры DaylightName и StandardName на свои, например, Время собирать камни


Принтеры

Сокрытие некоторых вкладок в диалоге "Свойства: принтер"

Если вы хотите скрыть некоторые вкладки в диалоге "Свойства: принтер", то откройте раздел
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте параметр NoPrinterTabs типа DWORD со значением, равным 1.

Запрет на удаление установленных в системе принтеров

Чтобы запретить пользователю удалять установленные в системе принтеры, используйте ключ NoDeletePrinter в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer

После перезагрузки изменения вступят в силу

Удаление параметра или установка в 0 возвращает прежнее поведение

Смотри также
Запрет на установку новых принтеров в систему


Установка и удаление программ

Установка и удаление программ (Windows NT/2000/XP)

Скрытие апплета Установка и удаление программ

Чтобы пользователь не мог воспользоваться апплетом Панели управления Установка и удаление программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoAddRemovePrograms типа DWORD и установите его равным 1

Теперь, если пользователь выберет пункт Установка и удаление программ в Панели управления, то будет показано сообщение об ошибке

Изменение или удаление программ

Чтобы скрыть вкладку Изменение или удаление программ в апплете Установка и удаление программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoRemovePage типа DWORD и установите его равным 1

Установка программ

Чтобы скрыть вкладку Установка программ в апплете Установка и удаление программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoAddPage типа DWORD и установите его равным 1

Установка компонентов Windows

Чтобы скрыть вкладку Установка компонентов Windows, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoWindowsSetupPage типа DWORD и установите его равным 1

Выбор программ по умолчанию

Вкладка Выбор программ по умолчанию появилась в Windows XP SP1 и Windows 2000 SP3 и позволяет пользователям настраивать программы по умолчанию. Чтобы скрыть эту вкладку в Установка и удаление программ, откройте или создайте при необходимости раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
и создайте параметр типа DWORD NoChooseProgramsPage со значением, равным 1

CD или дискета

Чтобы скрыть раздел Установка программы с CD-ROM или дискеты и кнопку CD или дискета на вкладке Установка программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoAddFromCDorFloppy типа DWORD и установите его равным 1

Windows Update

Чтобы скрыть раздел Установка программы от Майкрософт и кнопку Windows Update на вкладке Установка программ, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoAddFromInternet типа DWORD и установите его равным 1

Сведения о поддержке

Некоторые программы, представленные в списке Изменение или удаление программ могут содержать ссылку Чтобы получить сведения о поддержке, щелкните здесь. Чтобы скрыть данную ссылку, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall
ключ NoSupportInfo типа DWORD и установите его равным 1

Список установленных программ

Иногда в списке установленных программ Изменение или удаление программ может содержаться мусор (неправильно удаленные программы). Некоторых очень раздражают эти записи программ, которых давно уже нет на компьютере. Чтобы очистить этот список, найдите раздел

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
, который содержит подразделы, отвечающие за каждый отдельный продукт. Просто удалите ненужные подразделы

Информация о продукте

Можно настроить внешний вид записи в разделе Установленные программы и диалогового окна Поддержка, которое появляется при щелчке на ссылке Чтобы получить сведения о поддержке, щелкните здесь.
Для включения нужного режима используйте строковые значения в разделе

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\<имя программы>
  • DisplayIcon - иконка, соответствующая приложению в диалоге "Установка и удаление программ"
  • DisplayName - Описание приложения
  • ModifyPath - Путь инсталлятора (утилиты) для изменения установочных параметров программы. Еcли этот ключ установлен, то Кнопка "Заменить/Удалить" распадается на две - "Заменить" (Выполняется ModifyPath) и "Удалить" (выполняется UninstallString)
  • UninstallString - путь деинсталлятора
Ключи для диалогового окна Поддержка

Если вы создадите параметр Publisher, то в описании удаляемой программы появляется ссылка Чтобы получить сведения о поддержке, щелкните здесь, которая открывает диалоговое окно Поддержка. Для настройки внешнего вида этого окна используйте следующие строковые значения

  • Publisher - Издатель продукта
  • Readme - Путь к файлу Readme для данного продукта
  • Comments - Коментарии к продукту
  • Contact - Контактное лицо (e-mail и т.п.)
  • DisplayVersion - Номер версии
  • ProductID - Код продукта
  • RegCompany - Зарегистрированная компания
  • RegOwner - Зарегестрированный владелец
  • URLInfoAbout - Домашняя страничка производителя (параметр Publisher становится ссылкой)
  • URLUpdateInfo - URL обновления продукта
  • HelpLink - URL сведений о поддержке


Свойства обозревателя

Вкладки окна Свойства обозревателя

При выборе пункта меню Свойства обозревателя (Сервис-Свойства обозревателя или Пуск-Настройка-Панель управления-Свойства обозревателя) появляется диалоговое окно, содержащее несколько вкладок. Следующие параметры позволяют настраивать эти вкладки. Все приведенные параметры (если особо не оговорено) являются типа DWORD и находятся в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

Общие

Для скрытия вкладки Общие, присвойте параметру GeneralTab значение 1

Цвета

Чтобы заблокировать рамку Цвета (Общие-кнопка Цвета), присвойте параметру Colors значение 1

Ссылки

Чтобы заблокировать рамку Ссылки (Общие-кнопка Цвета), присвойте параметру Links значение 1

Шрифты

Чтобы заблокировать доступ к изменению параметров кнопки Шрифты, присвойте параметру Fonts значение 1

Языки

Чтобы заблокировать доступ к изменению параметров кнопки Языки, присвойте параметру Languages значение 1

Оформлелние

Чтобы заблокировать доступ к изменению параметров кнопки Оформление, присвойте параметру Accessibility значение 1

Домашняя страница

Для блокировки кнопок С текущей, С исходной, С пустой в рамке Домашняя страница присвойте параметру HomePage значение 1

Временнные файлы интернета

На вкладке Общие можно отключить все кнопки, относящиеся к рамке Временнные файлы интернета (Удалить Cookie"..., Удалить файлы..., Параметры...). Для этого присвойте параметру Settings значение 1

Блокировка кнопки Переместить

Чтобы блокировать кнопку Переместить (рамка Временные файлы интернета-кнопка Параметры), присвойте параметру Cache значение 1

Журнал

Чтобы блокировать рамку Журнал, присвойте параметру History значение 1

Безопасность

Для скрытия вкладки Безопасность, присвойте параметру SecurityTab значение 1

Запрет на добавление сайтов

Чтобы запретить добавлять сайты для Безопасности, присвойте параметру SecAddSites значение 1

Уровень безопасности для этой зоны

Чтобы заблокировать кнопки в фрейме Уровень безопасности для этой зоны, присвойте параметру SecChangeSettings значение 1

Конфиденциальность

Для скрытия вкладки Конфиденциальность, присвойте параметру PrivacyTab значение 1

Параметры

Чтобы заблокировать доступ к изменению настроек в рамке Параметры, присвойте параметру Privacy Settings значение 1

Содержание

Для скрытия вкладки Содержание, присвойте параметру ContentTab значение 1

Ограничение доступа

Чтобы заблокировать доступ к кнопкам Ограничения доступа, присвойте параметру Ratings значение 1

Сертификаты и Издатели

Чтобы блокировать кнопки Сертификаты и Издатели на вкладке Содержание, присвойте параметру Certificates значение 1

Сертификаты

Чтобы заблокировать только одну кнопку Сертификаты, то присвойте параметру CertifSite или CertifPers значение 1

Издатели

Чтобы заблокировать только одну кнопку Издатели, то присвойте параметру CertifPub значение 1

Запрет сохранения паролей для "Автозаполнения"

Если вы выберите на вкладке Содержание кнопку Автозаполнение, то увидите окно Настройка автозаполнения. Можно отключить возможность автозаполнения для пунктов Имен пользователей и паролей в формах и Запрос на сохранение пароля, блокируя автоматическое заполнение имен пользователей и паролей в формах web-страниц и предотвращая появление диалоговых окон с запросом о сохранении нового введенного пароля. Если эта настройка будет задействована, то названные выше пункты становятся затемненными, показывая тем самым, что заблокированы не только эти функции, но и сама возможность их включения. Для этого присваиваем строковому параметру FormSuggest Passwords значение "no". Установка новой политики для "запрета сохранения паролей для автозаполнения" не приводит к очистке уже занесенной информации в журнале, хранящем имена и соответствующие им пароли.

Запрос на сохранение пароля

Можно отключить только один пункт Запрос на сохранение пароля (смотри выше). Для этого в разделе:

HKCU\Software\Microsoft\Internet Explorer\Main
изменяем строковый параметр FormSuggest Passwords на "no"

Профиль

Для блокировки кнопки Профиль, , присвойте параметру Profiles значение 1

Подключения

Для скрытия вкладки Подключения, присвойте параметру ConnectionsTab значение 1

Чтобы заблокировть доступ к изменению параметров Подключения, кроме кнопки Установить, присвойте параметру Connection Settings значение 1

Кнопка Установить

Для блокировки кнопки Установить, которая запускает мастер подключения к Интернету присвойте параметру Connwiz Admin Lock значение 1

Автоматическая настройка

Для блокировки автоматической настройки (Свойства обозревателя-Подключения-Настройка локальной сети (LAN)) , присвойте параметру AutoConfig значение 1

Прокси-сервер

Для блокировки прокси-сервера (Свойства обозревателя-Подключения-Настройка локальной сети (LAN)) , присвойте параметру Proxy значение 1

Программы

Для скрытия вкладки Программы, присвойте параметру ProgramsTab значение 1

Электронная почта, Группы новостей и Связь по Интернету

Чтобы отключить Электронная почта, Группы новостей и Связь по Интернету на вкладке Программы, присвойте параметру Messaging значение 1

Календарь и адресная книга

Чтобы отключить Календарь и Адресная кника на вкладке Программы, присвойте параметру CalendarContact значение 1

Используемые программы для служб интернета

Вы можете добавить свои программы в список приложений, автоматически испольуемых Windows для различных служб Интернета. Вы видите на данной вкладке шесть различных служб: Редактор HTML, Электронная почта, Группы новостей, Связь по Интернету, Календарь, Адресная книга. Для добавления своих программ в эти службы откройте раздел

HKLM\Software\Clients
и в соответствующем разделе создайте свой подраздел. Предположим, вы хотите добавить программу почтовую программу WinMail. Открываем раздел Mail и создаем там новый подраздел WinMail. В этом подразделе значению по умолчанию присваиваем имя нашей программы WinMail. Теперь наша программма будет присутствовать в списке почтовых программ.

Сброс веб-параметров

Чтобы отключить кнопку Сброс веб-параметров на вкладке Программы, присвойте параметру ResetWebSettings значение 1

Проверять, является ли Internet Explorer используемым по умолчанию обозревателем

Чтобы заблокировать доступ к изменению параметров Проверять, является ли Internet Explorer используемым по умолчанию обозревателем, присвойте параметру Check_If_Default значение 1

Дополнительно

Для скрытия вкладки Дополнительно, присвойте параметру AdvancedTab значение 1

Запрет на изменения на вкладке Дополнительно

Можно не скрывать вкладку Дополнительно, а просто запретить делать изменения. Присвойте параметру Advanced значение 1, и вы не сможете ставить или убирать галочки, а также станет недоступной кнопка Восстановить значения по умолчанию


Свойства папки

Удаление апплета Свойства папки

Если вы хотите удалить пункт Свойства папки из меню Проводника, а также апплет из Панели управления, то откройте раздел
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте параметр NoFolderOptions типа DWORD со значением, равным 1.

После перезагрузки пункт Свойства папки исчезнет из меню Проводника и из Панели управления

Удаление параметра или установка в 0 возвращает пункт в меню и в Панель управления

Примечание: В Windows 98 Свойства папки находились не на Панели управления, а в меню Настройка кнопки Пуск

Отображать веб-содержимое на рабочем столе

Чтобы сделать недоступным пункт Отображать веб-содержимое на рабочем столе на вкладке Общие используйте ключ NoActiveDesktop в этом же разделе (см. выше)

Типы файлов (Windows 2000/XP)

Чтобы заблокировать кнопки Создать, Удалить, Изменить на вкладке Типы файлов, тем самым лишить пользователя возможности менять типы файлов, нужно создать параметр NoFileAssociate типа DWORD со значением 1 в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Данная блокировка не мешает менять типы файлов непосредственно в реестре или другими программами


Панель задач и меню "Пуск"

Скрытие пункта "Отображать команду "Завершение сеанса" (Windows Me/2000/XP)

Если вы хотите скрыть пункт Отображать команду "Завершение сеанса" из Параметры меню "Пуск" и панели задач (Пуск-Настройка-Панель задач и меню "Пуск"-Дополнительно), то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
и создайте параметр StartMenuLogoff типа DWORD со значением, равным 1.

Классический вид кнопки Пуск (Windows XP)

Если вы хотите запретить возможность переключать внешний вид кнопки Пуск в стиль XP, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoSimpleStartMenu типа DWORD со значением, равным 1.

После перезагрузки на вкладке Меню "Пуск" (Панель управления-Панель задач и меню "Пуск") становится недоступным переключатель Меню "Пуск" (в стиле ХР) и работать теперь можно только с классическим видом меню Пуск

Элементы меню "Пуск" (Windows XP)

Чтобы удалить различные пункты из Элементы меню "Пуск" (Панель управления-Панель задач и меню "Пуск"-вкладка Меню "Пуск"-кнопка Настроить-вкладка Дополнительно-Элементы меню "Пуск"), то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр типа DWORD со значением, равным 1
  • NoSMMyPictures - удаляет пункт Мои рисунки
  • NoStartMenuMyMusic - удаляет пункт Моя музыка
  • NoSMMyDocs - удаляет пункт Мои документы
  • NoNetworkConnections - удаляет пункт Сетевое окружение
  • NoStartMenuNetworkPlaces - удаляет пункт Сетевые подключения
При этом удаляются соответствующие пункты из меню кнопки Пуск

Область уведомлений

Скрытие области уведомлений (Windows XP)

Порой в области уведомлений (рядом с часиками) накапливается слишком много значков. Конечно, есть возможность выборочного скрытия отдельных значков. Но есть более радикальный способ - скрытие самой области уведомления. Для этого откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoTrayItemsDisplay типа DWORD со значением, равным 1. После перезагрузки на вкладке Панель задач в Панель задач и меню "Пуск" рамка Область уведомлений будет недоступной

Настройка уведомлений (Windows XP)

Если окно Настройка уведомлений (Панель управления-Панель задач и меню "Пуск"-вкладка Панель задач-кнопка Настроить) стало чересчер забито значками ненужных программ, значит пришло время почистить список. Для этого открываем раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\TrayNotify
и удалить параметры IconStreams и PastIconsStream.
Затем откройте Диспетчер задач Windows (Task Manager), выберите вкладку Процессы, выделите Explorer.exe и нажмите кнопку Завершить процесс. Затем в меню Файл выберите Новая задача (Выполнить...) и напечатайте explorer. OK.


Пароли

Пароли (Windows 95/98/Me)

Запрет запуска апплета "Пароли"

Чтобы запретить запуск апплета Пароли в Панели управления, создайте в разделе

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
ключ NoSecCPL типа DWORD и установите его равным 1

При попытке запуска апплета "Пароли" выдается сообщение, что системный администратор заблокировал доступ к программе изменения паролей

Для отмены запрета используйте значение 0

Смена паролей

Скрытие вкладки Смена паролей

Чтобы скрыть вкладку Смена паролей в апплете Пароли, создайте в разделе

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
ключ NoPwdPage типа DWORD и установите его равным 1. Эта вкладка убирается из приложения "Пароли", и пароли Windows не могут быть изменены через это приложение "Панели управления".

Алфавитно-цифровой пароль Windows

При нажатии на кнопку Сменить пароль Windows выводится диалоговое окно для создания нового пароля. Если вы хотите, чтобы во вновь создаваемом пароле должны обязательно присутствовать как цифры, так и символы алфавита, то создайте параметр типа DWORD AlphanumPwds в разделе

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Network

Эта настройка работает при условии, что не задана минимальная длина пароля.Также найстройка игнорируется, если при создании пароля, в ответ на приглашение задать новый пароль, вы используете пустой пароль, нажимая клавишу "Enter". Это делается для того, чтобы диалоговое окно для ввода пароля больше не появлялось при загрузке Windows.

Минимальная длина пароля в Windows

Можно задать минимальную длину создаваемого пароля, т.е наименьшее допустимое количество символов для нового пароля. Создайте двоичный параметр MinPwdLen в разделе

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
и присвойте ему некоторое значение, например 05. Теперь, если вы введете слово из трех символов при смене пароля, будет выводится окно с предупреждением, что пароль должен состоять из 5 символов. Диапазон значений, которые может принимать данный параметр: от "0" до "99".

Скрытие вкладки Настройки пользовательских профилей

Чтобы скрыть вкладку Настройки пользовательских профилей в апплете Пароли, создайте в разделе

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
ключ NoProfilePage типа DWORD и установите его равным 1. Эта вкладка убирается из приложения "Пароли", и таким образом, запрещается использование приложения для изменения установок пользовательских профилей

Скрытие вкладки Удаленное управление

Чтобы скрыть вкладку Удаленное управление в апплете Пароли, создайте в разделе

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
ключ NoAdminPage типа DWORD и установите его равным 1


Сеть

Запрет запуска апплета "Сеть"

Чтобы запретить запуск апплета Сеть в Панели управления, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Network
ключ NoNetSetup типа DWORD и установите его равным 1

При попытке запуска апплета "Сеть" выдается сообщение, что системный администратор заблокировал "Сеть".

Конфигурация

Чтобы скрыть вкладку Конфигурация в апплете Сеть, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Network
ключ NoNetSetupConfigPage типа DWORD и установите его равным 1.

Идентификация

Чтобы скрыть вкладку Идентификация в апплете Сеть, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Network
ключ NoNetSetupIDPage типа DWORD и установите его равным 1.

Управление доступом

Чтобы скрыть вкладку Управление доступом в апплете Сеть, создайте в разделе

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Network
ключ NoNetSetupSecurityPage типа DWORD и установите его равным 1

Для отмены запрета вышеприведенных примеров используйте значение 0 или просто удалите ключ.


Система

Диспетчер устройств (Windows 2000/XP)

В Диспетчере устройств (Система-Оборудование-кнопка Диспетчер устройств) если выбрать какое-нибудь устройства и отобразить его свойства, то по умолчанию будет показано стандартное окно свойств. К данному окну можно добавить еще одну вкладку Сведения. Для этого надо создать строковый параметр DEVMGR_SHOW_DETAILS в разделе

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Устройства (Windows 95/98/Me)

Чтобы скрыть вкладку Устройства в апплете Система, создайте ключ NoDevMgrPage типа DWORD и установите его равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Профили оборудования (Windows 95/98/Me)

Чтобы скрыть вкладку Профили оборудования в апплете Система, создайте ключ NoConfigPage типа DWORD и установите его равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Скрытие кнопки "Файловая система" на вкладке Быстродействие (Windows 95/98/Me)

Чтобы скрыть кнопку Файловая система на вкладке Быстродействие в апплете Система, создайте ключ NoFileSysPage типа DWORD и установите его равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Скрытие кнопки "Виртуальная память" на вкладке Быстродействие (Windows 95/98/Me)

Чтобы скрыть кнопку Виртуальная память на вкладке Быстродействие в апплете Система, создайте ключ NoVirtMemPage типа DWORD и установите его равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Для отмены запрета вышеприведенных примеров используйте значение 0 или просто удалите ключ.


Экран

Запрет запуска апплета "Экран"

Чтобы запретить запуск апплета Экран в Панели управления, создайте ключ NoDispCPL типа DWORD и установите его равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

При попытке запуска апплета "Экрана" выдается сообщение, что системный администратор заблокировал "Экран". Для изменения настроек "Экрана" придется работать с реестром напрямую или через утилиты третьих производителей

Темы

Чтобы скрыть вкладку Темы используйте параметр типа DWORD NoThemesTab со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Фон или Рабочий стол (Windows XP)

Скрытие вкладки Фон

Чтобы скрыть вкладку Фон в апплете Экран, создайте ключ NoDispBackgroundPage типа DWORD и установите его равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
Эта вкладка убирается из приложения "Экран", и таким образом нельзя воспользоваться ею для изменения узоров или обоев для "Рабочего стола"

Запрет изменения обоев

А можно не убирать эту вкладку, а просто запретить изменять фоновый рисунок. Для этого создайте ключ NoChangingWallpaper типа DWORD и установите его равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
Окошко с установленными картинками будет заблокировано. Данный параметр работает в Windows 98/ME/2000/XP. В Windows 95 и NT данный способ будет применим при установленном вместе с "Активным Рабочим столом" Internet Explorer 4.0.

Другой способ запрета на изменение фонового рисунка (Windows Me/2000/XP) - Создайте строковый параметр Wallpaper и пропишите в нем полный путь к вашему графическому файлу в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
В дополнение в этом же разделе создайте строковый параметр WallpaperStyle, в котором можете указать способ вывода картинки на Рабочий стол:
  • 0 - По центру (По умолчанию)
  • 1 - Замостить
  • 2 - Растянуть

После установки этих значений список Фоновый рисунок и кнопка Обзор будут заблокированы

Только растровые обои

А можно запретить использовать в качестве обоев картинки разных форматов, кроме растровых картинок (bmp). Как и в предыдущем примере, данный параметр применим для Windows 98/ME/2000/XP. В Windows 95 и NT данный способ будет применим при установленном вместе с "Активным Рабочим столом" Internet Explorer 4.0. Чтобы включить данный запрет, используйте параметр типа DWORD NoHTMLWallPaper со значением 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Заставка

Скрытие вкладки Заставка

Чтобы скрыть вкладку Заставка в апплете Экран, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
ключ NoDispScrSavPage типа DWORD и установите его равным 1. Эта вкладка убирается из приложения "Экран", и таким образом выбор экранной заставки, настройка ее параметров, энергосберегающих свойств монитора и компьютера будут недоступны

Блокировка вкладки Заставка (Windows 2000/XP)

А можно не скрывать вкладку, а просто заблокировать ее, запрещая запуск экранных заставок и блокируя всю вкладку Заставка с настройками. Для данной блокировки присвойте параметру типа DWORD ScreenSaveActive значение "0" в разделе

HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop
.

Защита паролем экранной заставки (Windows 2000/XP)

Можно настроить политику поведения паролей для экранных заставок. Для этого существует ключ типа DWORD ScreenSaverIsSecure в разделе

HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop
. Существует три состояния:
  • Параметр ScreenSaverIsSecure отсутствует в реестре. Обычное поведение экранной заставки - пароли можно изменять, применять или отменять их использование через окно "защита паролем".
  • Параметр хранит значение "0". Использование паролей к заставкам недоступно.
  • Параметр хранит значение "1", пароли к экранным заставкам принудительно включены.

Описанная выше политика "Блокировка вкладки Заставка" имеет приоритет над этой политикой. Если политика "Блокировка вкладки Заставка" находится в активном состоянии, то система игнорирует состояние политики "Защита паролем экранной заставки".

Оформление

Скрытие вкладки Оформление

Чтобы скрыть вкладку Оформление в апплете Экран, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
ключ NoDispAppearancePage типа DWORD и установите его равным 1. Эта вкладка убирается из приложения "Экран", и таким образом невозможно использовать данную вкладку для изменения цветов или цветовых схем "Рабочего стола" или окон.

Окна и кнопки (Windows XP)

Для блокировки элементов Окна и кнопки на вкладке Оформление создайте параметр типа DWORD NoVisualStyleChoice в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Цветовая схема (Windows XP)

Для блокировки элементов Цветовая схема на вкладке Оформление создайте параметр типа DWORD NoColorChoice в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Размер шрифта (Windows XP)

Для блокировки элементов Размер шрифта на вкладке Оформление создайте параметр типа DWORD NoSizeChoice в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Скрытие вкладки Web

Чтобы скрыть вкладку Web в апплете Экран, используйте ключ NoActiveDesktop

Скрытие вкладки Настройка

Чтобы скрыть вкладку Настройка в апплете Экран, создайте в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
ключ NoDispSettingsPage типа DWORD и установите его равным 1. Эта вкладка убирается из приложения "Экран", и таким образом невозможно использовать данную вкладку для изменения настроек дисплея, видеоадаптера, корректирующей гаммы

Видеоэффекты для меню и подсказок (Windows ME) или Применять следующий переходный эффект для меню и подсказок (Windows XP)

Анимационные эффекты для окон, меню и списков созданы для разнообразия работы пользователя, но могут и раздражать или просто отвлекать от работы. К анимационным эффектам, к примеру, относятся затенение и развертывание меню с эффектами взрыва или соскальзывания. Пункт "Видеоэффекты для меню и подсказок" или "Применять следующий переходный эффект для меню и подсказок", отвечающее за включенное или выключенное состояние эффектов анимации, находится на странице Эффекты вкладки Оформление.

Для блокировки данной опции используйте параметр NoChangeAnimation типа DWORD равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
. В этом случае данный пункт становится затеменным, показывая пользователю, что сама возможность включения эффектов анимации не доступна.

Блокировка пункта Скрывать указатели вызова с клавиатуры до нажатия <ALT> (Windows 2000/XP)

Данная опция находится на вкладке Оформление при нажатии на кнопку Эффекты. Для блокировки опции "Скрывать указатели вызова с клавиатуры до нажатия <ALT>" используйте параметр NoChangeKeyboardNavigationIndicators типа DWORD равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
В этом случае данный пункт становится затеменным, показывая пользователю, что сама возможность включения эффектов не доступна.

Для отмены запрета вышеприведенных примеров используйте значение 0 или просто удалите ключ.


Экран приветствия

Экран приветствия (Windows XP)

Экран смены пользователя

Существует возможность замены экрана приветствия без модификации самого файла logonui.exe, в котором содержится внешний вид экрана. Для этого скачайте из интернета или создайте самостоятельно такой экран. Затем в разделе

HKLM/SOFTWARE/Microsoft/Windows NT/CurrentVersion/WinLogon
создайте строковый параметр UIHost, в котором и пропишите полный путь к вашему новому файлу

ClearType

Совет для пользователей ноутбуков или жидкокристаллических мониторов. Для дисплеев такого типа Microsoft разработала технологию ClearType, значительно улучшающую восприятие текста. Но эта опция в настройках экрана включается отдельно для каждого пользователя и не работает до тех пор, пока профиль пользователя не загружен (экран приветствия, например). Чтобы включить этот режим и для экрана приветствия, нужно открыть раздел:

HKU\.DEFAULT\Control Panel\Desktop
и установить значения 2 для параметров FontSmoothing и FontSmoothingType и значение 1 для параметра FontSmoothingOrientation


Регистрационный номер

Регистрационный номер (Windows 95/98/Me)

Если вы потеряли свой регистрационный номер от компакт-диска с Windows, то не сможете переустанавливать систему. Но реестр поможет нам!

Для этого найдите ветвь:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion
и найдите строковое значение ProductKey, который и содержит ваш регистрационный номер


Регистрационные данные

Если вы нажмете на кнопку О программе в Проводнике или в других программах, поставляемых с Windows, то увидите, кто обладает правом использования этой копии. Также эти данные можно увидеть в апплете Система Панели управления. Возможно, вам компьютер достался от вашего босса Пупкина, и вы страстно хотели бы изменить регистрационные данные. Для этого нужно изменить строковые параметры RegisteredOwner (Ваше имя) и RegisteredOrganization (название организации) в разделах:

Для Windows 95/98/Me:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion

Для Windows NT/2000/XP:

HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion


Путь установки Windows

Иногда приходится переустанавливать Windows с разных мест - с жесткого диска, с компакт-диска, с записывающего CD-RW. Но Windows запоминает путь инсталяционных файлов, что порой создает проблему. Чтобы "обмануть" Windows, используйте строковый параметр SourcePath в разделе
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup, указав ваш путь


Диспетчер задач Windows

Диспетчер задач Windows (Windows NT/2000/XP)

Чтобы запретить пользователю возможность запуска Диспетчера задач Windows, установите значение параметра типа DWORD DisableTaskMgr в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
равным 1


Синий Экран Смерти - Blue Screen of Death (BSOD)

Синий Экран Смерти (Windows XP)

Если вы хотите полюбоваться на культовый Синий Экран Смерти - Blue Screen of Death (BSOD) в любое время, то откройте раздел

HKLM\SYSTEM\CurrentControlSet\Servises\i8042prt\Parameters
и присвойте параметру типа DWORD CrashOnCtrlScroll значение 1

Удерживая правую клавишу Ctrl, нажмите два раза на клавишу Scroll Lock и вы увидите этот синий экран


Сообщение при загрузке

Можно настроить систему таким образом, чтобы при загрузке выводилось окно с вашим сообщением. Для этого откройте раздел HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon (для Windows 95/98/ME) или HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon (для Windows 2000/NT) и создайте строковый параметр LegalNoticeCaption и введите вашу строку, которая будет выводиться в заголовке вашего сообщения, а для текста самого сообщения используйте строковый параметр LegalNoticeText в том же разделе. Теперь перед входом в систему появится созданное вами сообщение.


Панель переключателя задач

Отключение панели переключателя задач

Чтобы отключить панель переключателя задач (который выводится по Alt+Tab), надо в разделе

HKEY_CURRENT_USER\Control Panel\Desktop
присвоить строковому параметру CoolSwitch значение 0 (чтобы включить - значение 1).

Изменение числа строк и колонок

Чтобы изменить число строк и колонок, показываемое на панели переключателя задач (который выводится по Alt+Tab), надо в разделе

HKEY_CURRENT_USER\Control Panel\Desktop
отредактировать значения строковых параметров CoolSwitchRows и CoolSwitchColumns соответственно.


Всплывающие подсказки

Описания папок и файлов на Рабочем столе и в Проводнике

Если подвести указатель какому-нибудь элементу рабочего стола или оболочки, то открывается небольшое окно, содержащее текст описания этого элемента. Чтобы запретить появление этих окон, нужно присвоить параметру типа DWORD ShowInfoTip значение 0 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Всплывающие подсказки на панели задач (Windows XP)

Windows XP показывает всплывающие подсказки для начинающих пользователей. Чтобы отключить подсказки, нужно присвоить параметру типа DWORD EnableBalloonTips значение 0 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced


Пароль после спящего режима

Пароль после ждущего режима (Windows XP)

Можно настроить систему таким образом, чтобы при включении компьютера после Ждущего режима появлялось диалоговое окно с приглашением ввести пароль. Для этого в разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System\Power создаем параметр типа DWORD PromptPasswordOnResume со значением 1.


Автозагрузка

Что скрывается в автозагрузке?

Существует несколько способов прописать программу в автозагрузку. Самый простой - скопировать программу или ярлык в папку Автозагрузка. Например, у меня прописан там AVP Монитор. Но существует другой способ - через реестр. Этим способом часто пользуются вредоносные программы (вирусы, трояны, шпионы)

Сперва откройте раздел

HKLM\Software\Microsoft\Windows\CurrentVersion.

Найдите там подразделы Run, RunOnce, RunOnceEx, RunServices, RunServicesOnce. В этих разделах есть строковые ключи (некоторые разделы пустые), отвечающие за запуск программ. Название ключа может быть произвольным, а в качестве значения у них указывается запускаемая программа, если надо - то с параметрами. Обратите внимание на разделы, в названии которых присутствует "Once". Это разделы, в которых прописываются программы, запуск которых надо произвести всего один раз. Например, при установке новых программ некоторые из них прописывают туда ключи, указывающие на какие-нибудь настроечные модули, которые запускаются сразу после перезагрузки компьютера. Такие ключи после своего запуска автоматически удаляются.

Внимательно проверьте, что за программы у вас запускаются. Сразу после установки Windows в разделе Run присутствуют ключи с названиями internat.exe, LoadPowerProfile, ScanRegistry, SystemTray, TaskMonitor. В разделе RunServices - ключ LoadPowerProfile. Другие разделы пустые. Остальные ключи, которые могут присутствовать у вас в реестре, были добавлены другими установленными программами. Подумайте, все ли они нужны вам при загрузке и лишнее просто удалите. Это позволит значительно ускорить загрузку Windows.

В разделе

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion
есть только два подраздела, отвечающие за автозагрузку: Run и Runonce. Изначально они пустые, так что все записи сделаны другими программами

Для операционных систем Windows 9x возможно загружать программу с помощью драйвера VxD. Полный список загружаемых драйверов находится в разделе

HKLM\System\CurrentControlSet\Services\VxD
. В Windows NT/2000 нет VxD драйверов, но в разделе
HKLM\System\CurrentControlSet\Control\SessionManager
в параметре BootExecute можно прописать программу, которая будет грузиться еще до загрузки графической оболочки и сервисов.

Запрет на автозагрузку (Windows 98/ME/2000/XP)

Существуют способы наложения запрета на автозагрузку программ через записи в реестре, указанные выше. Используются параметры типа DWORD. Все параметры должны храниться в разделе

HKLMSoftware\Microsoft\Windows\CurrentVersion\Policies\Explorer

Для запрета запуска программ, прописанных в подраздел Run раздела LOCAL MACHINE используется параметр DisableLocalMachineRun со значением 1. В этом случае система игнорирует содержимое списка Run, находящегося в LOCAL MACHINE.

Аналогично действует запрет списка Run Once для LOCAL MACHINE. За состояние этой политики отвечает параметр DisableLocalMachineRunOnce. Система игнорирует содержимое RunOnce в LOCAL MACHINE.

Для запрета списка Run раздела CURRENT USER используется параметр DisableCurrentUserRun.

Для запрета списка Run Once раздела CURRENT USER используется параметр DisableCurrentUserRunOnce


Контекстное панели задач

Контекстное меню панели задач

Если вы хотите запретить контекстное меню панели задач, то откройте раздел
HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer и создайте параметр NoTrayContextMenu типа DWORD со значением, равным 1.

После перезагрузки установки вступят в силу

Удаление параметра или установка в 0 возвращает прежнее поведение


Диалоговое окно открытия и сохранения файла

Windows Me/2000/XP имеет новое диалоговое окно "Открыть\Сохранить файл", которое можно изменить по Вашему желанию.

В левой части диалогового окна расположены пять системных папок, которые можно поменять местами или изменить на те, которыми вы часто пользуетесь. Создайте в ветви
HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\comdlg32
раздел "PlacesBar". В нем хранятся имена папок. Как я уже говорил, их пять. И у каждой свой параметр. У первой Place0, у второй Place1, а у пятой Place4. Системные папки имеют значение типа DWORD:
Название папки | Значение
Рабочий стол | 00000000
Мои документы | 00000005
Мои рисунки | 00000027
Мои видеозаписи | 0000000e
Мой компьютер | 00000011
Избранное | 00000006
Мое сетевое окружение | 00000012
Шрифты | 00000014
History | 00000022

Папки могут быть и обычные, где строковое значение параметра Place указывает путь к папке. Например:
Place1="C:\Windows\Systems"

Если вы не используете все пять параметров, а только часть из них, например Place0 и Place1, то в левой части диалогового окна будут отображаться столько же папок.

Старый вид диалогового окна

Чтобы вернуться к старому виду диалогового окна Windows 95/98, создайте строковый параметр NoPlacesBar со значением 1 (или любым другим) в

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\comdlg32

Убираем кнопку Назад

Чтобы убрать кнопку Назад из Общего диалогового окна, создайте параметр NoBackButton типа DWORD со значением 1 в

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\comdlg32

Убираем список файлов

Чтобы убрать выпадающее комбинированное окно со списком файлов (Имя файла), создайте параметр NoFileMru типа DWORD со значением 1 в

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\comdlg32

Смотри также
Диалоговое окно открытия и сохранения файла для Office


Добавление нового пункта в меню "Создать"

Пункт контекстного меню "Создать" появляется, если щелкнуть на Рабочем столе или в Проводнике на свободном месте открытой папки. Существует возможность добавления нового пункта в это меню. Например, если вы веб-дизайнер, то было бы удобно иметь пункт Документ HTML, который позволит вам сразу создать заготовку для вашей странички.

Разобъем работу на несколько этапов. Для начала найдем каталог ShellNew в папке Windows. Там хранятся заготовки для файлов, которые создаются с помощью контекстного меню. Например, если у вас установлен Microsoft Office, то вы увидите в этом каталоге файлы-заготовки для Word и Exce.

Следующий шаг - создайте в папке файл, например index.html. Внутри него напишите шаблон вашей странички. Например, так:

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1251">
<title>Мой заголовок</title>
</head>
<body>

</body>
</html>

Третий этап. Работаем с реестром. Итак, ищем раздел HKEY_CLASSES_ROOT\.html и создаем раздел ShellNew. В этом разделе создаем строковый параметр FileName в качестве значения которого надо указать имя созданного нами шаблона (index.html). После перезагрузки в контекстном меню появится новый пункт.

Существуют и другие способы. Можно не создавать шаблон файла. Он может быть и пустым, но тогда вместо параметра FileName надо создать пустой строковый параметр NullFile.


Контекстное меню папок и файлов, дисков

При установке многих программ контекстное меню файлов и папок постепенно заполняется лишними пунктами.

Чтобы оставить в меню только то, что действительно нужно, найдите ветвь:
HKCR\*\shellex\ContextMenuHandlers
- в ней в качестве подразделов выступают команды, отображаемые в меню любого файла. Просто удалите ненужные команды.

Команды, привязанные к конкретному типу файлов можно найти уже в ветвях, соответствующих такому типу. Например, для файла AVI это будет раздел

HKCR\avifile\shell

Соответственно, чтобы добавить новый пункт в контекстное меню, нужно прописать строку типа

HKEY_CLASSES_ROOT\*\shell
@="Путь_к_программе %1"

Например, чтобы прописать пункт "Открыть с помощью..." в контекстном меню, найдем ключ

HKCR\*\shell\openas\command
Измените значение "По умолчанию" на "C:\WINDOWS\rundll32.exe shell32.dll,OpenAs_RunDLL %1" (путь к файлу подредактируйте при необходимости).

За меню папок отвечают

HKCR\Directory\shell
и
HKCR\Folder\shell

За меню дисков отвечают

HKCR\Drive\shell

Например, для быстрой очистки диска создайте в указанном месте новый раздел типа Очистка диска, в котором создать раздел command, в параметре "По умолчанию", которого прописать:
C:\WINDOWS\cleanmgr.exe /d %1
Теперь нажав правой кнопкой мыши на каком-либо диске можно выбрать команду Очистка диска.


Исполняемые файлы и ярлыки

Если вдруг вы не можете запустить исполняемые файлы или ярлыки (например, в результате ваших экспериментов с реестром), то решить эту проблему сможет мой справочник :-)

Откройте раздел

HKCR\exefile\shell\open\command
и присвойте параметру по умолчанию значение "%1" %*


Ярлыки

Удаление стрелочки с ярлычка

При создании ярлыка для папки, файла, диска и т.д., то в нижнем левом углу значка для этого элемента будет изображена стрелочка. Чтобы удалить эти стрелочки с ярлычка и PIF-файлов, нужно удалить параметр IsShortcut из разделов
HKEY_CLASSES_ROOT\lnkfile и HKEY_CLASSES_ROOT\piffile

Изменения вступят в силу после перезагрузки

Ярлык для (Windows 98)

Чтобы предотвратить добавление слова Ярлык для для создаваемых вами ярлыков, то измените значение двоичного параметра link на hex:00,00,00,00 в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer


Удаление "ладошки" из расшаренных ресурсов

Для удаления "ладошки" из расшаренных ресурсов нужно удалить строковое значение По умолчанию из раздела

HKCR\Network\SharingHandler

Чтобы вернуться к прежнему состоянию, используйте msshrui.dll для Windows 9x/Me или ntshrui.dll для Windows NT/2000/XP


Перемещение HOST, LMHOST и других файлов из %SystemRoot%\System32\drivers\etc в другое место

Перемещение HOST, LMHOST и других файлов из %SystemRoot%\System32\drivers\etc в другое место (Windows XP)

Если вы хотите указанные файлы в другое место (например, по соображениям безопасности) из папки %SystemRoot%\System32\drivers\etc, то:

  1. Скопируйте файлы в новое место
  2. Зайдите в раздел
    HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. Измените значение параметра DataBasePath на новый путь к папке
  4. Перезагрузитесь и удалите файлы из %SystemRoot%\System32\drivers\etc


Увеличение скорости всплывания меню

Иногда при выборе меню появляется подменю.Существует возможность менять скорость появления этих подменю (в т.ч. меню кнопки Пуск), облегчая работу на компьютере. Для этого используйте строковый параметр MenuShowDelay в разделе HKEY_CURRENT_USER\Control Panel\Desktop.

По умолчанию он равен "400". Значение "0" соответствует наиболее быстрому реагированию на движение мыши. В Windows 95 значение параметра можно изменять в диапазоне от 1 до 10. В последующих версиях Windows данный параметр можно менять от "0" до "32767" и от "-32768" до "-2"

Сделанные изменения вступят в силу после перезагрузки


Диски

Скрытие значков дисков в окне Мой компьютер и Проводник

Если вы хотите скрыть значки дисков в окне Мой компьютер и Проводник, то откройте раздел

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer
и создайте параметр NoDrives типа DWORD с требуемым значением. Также будут скрыты эти значки и в стандартных окнах Открытия и Сохранения файлов. Тем не менее, пользователь по-прежнему имеет доступ к этим дискам (через команду Выполнить или печатая вручную адрес в адресной строке Проводника)

Данный параметр является набором битовых флагов. Каждый бит соответсвует одному из 26 возможных имен дисков. Каждому диску присваиваются значения (hex): A -1; B - 2; C - 4 и т.д. Чтобы скрыть нужные вам диски, нужно сложить эти биты. Сложность состоит в переводе двоичного значения в шестнадцатиричное. Здесь приводится небольшой список возможных значений
0x03FFFFFF | Скрывает все значки
0x3 | Скрывает только диски A и B
0x4 | Скрывает только диск C
0x8 | Скрывает только диск D
0x7 | Скрывает только диски A, B и C
0xF | Скрывает только диски A, B, C и D
0x0 | Видны все диски
Можно использовать и десятичную систему. Смотри совет ниже.

Запрет на доступ к содержимому выбранных дисков (Windows Me/2000/XP)

Можно не скрывать сами значки дисков, но запретить пользователю доступ к файлам заданных дисков через Проводник, Мой компьютер, Выполнить или команду Dir. Откройте реестр и создайте параметр NoViewOnDrive типа DWORD в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer,
содержащий битовую маску для дисков. Например, диск A имеет бит 1, диск С - 4, диск D - 8. Таким образом, чтобы скрыть диски A и D, нужно сложить их значения 1 (A) + 8 (D) и установить значение 9.
Список всех дисков:
A: 1, B: 2, C: 4, D: 8, E: 16, F: 32, G: 64, H: 128, I: 256, J: 512, K: 1024, L: 2048, M: 4096, N: 8192, O: 16384, P: 32768, Q: 65536, R: 131072, S: 262144, T: 524288, U: 1048576, V: 2097152, W: 4194304, X: 8388608, Y: 16777216, Z: 33554432, Все диски: 67108863

Вкладка Оборудование (Windows 2000/XP)

Чтобы удалить вкладку Оборудование при просмотре свойств локального диска, создайте параметр типа DWORD NoHardwareTab в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer


Отключения автозапуска компакт-дисков

Автозапуск CD-ROM

Отключение стандартного автозапуска компакт-дисков (Windows NT/2000/XP)

Чтобы отключить автозапуск компакт-диска, устанавливаем значение параметра типа DWORD AutoRun, равным 0 в разделе

HKLM\SYSTEM\CurrentControlSet\Services\CDRom

Отключение нового метода автозапуска компакт-дисков (Windows XP)

В Windows XP существует новый метод автозапуска стандартных компакт-дисков (имеются в виду только те компакты, на которых не предусмотрен специальный вызов автозапуска через autorun.inf). Можно отключить данный метод или настроить его под себя. Итак, открываем следующий раздел:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\CancelAutoplay\Files

В этом разделе находятся текстовые параметры, содержащие имена файлов, отыскав которые на вашем компакте встроенный AutoRun запускаться не станет и позволит запустить компакт через autorun.inf. Добавьте строковый параметр следующего содержания: *.* и наслаждайтесь полным спокойствием вашего CD-ROM


Запрещение запуска программ

Windows позволяет ограничить доступ к программам, кроме разрешенных в специальном списке.

Для ограничения запускаемых программ надо открыть раздел HKEY_CURRENT_USER\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\Explorer и создать там ключ RestrictRun типа DWORD со значением 0х00000001. Затем тут же надо создать подраздел с аналогичным именем RestrictRun и в нем перечислить список РАЗРЕШЕННЫХ к запуску программ для текущего пользователя. Записи в этом подразделе пронумеровываются, начиная с 1, и содержат строки с путями (необязательно) и именами приложений. Файлы должны быть с расширением. Например, Word.exe, Excel.exe ...

Не забудьте указать файл Regedit.exe, иначе Вы сами не сможете больше запустить редактор реестра! Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0


Запрещение запуска редактора реестра

Вы можете запретить запуск редактор реестра

Для этого в разделе

HKCU\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\System
нужно добавить ключ типа DWORD DisableRegistryTools со значением 1. Запуск редактора реестра будет запрещен, однако останется возможность вносит изменения с помощью программного обеспечения сторонних разработчиков и с помощью REG-файла


Планировщик задач

Планировщик задач (Windows Me)

В Windows Me, в отличие от Windows 98, не выводится значок планировщика задач в области уведомлений (рядом с часиками), даже если программа запущена. Если вы все-таки хотите видеть этот значок (а вы - консерватор!), то создайте параметр типа DWORD EnableTrayIcon со значением 1 в разделе
HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent

Изменения вступят после перезагрузки


Пароли и безопасность

Рассматриваемые настройки хранятся в ветви

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Network
Все ключи имеют тип DWORD, если это не обговорено отдельно; значение ключа равное 1 включает данную опцию, 0 выключает, если это не обговорено отдельно

Запрет на соединение удаленного доступа (Windows 95/98/Me)

Ключ NoDialIn запрещает соединение удаленного доступа

Отмена кэширования пароля

Данная настройка помогает избавиться от проблемы "утаскивания" и дальнейшего взлома ваших сетевых и интернет паролей. Эти пароли хранятся в файле с расширением PWL. Отключение кэша запрещает запись паролей в этот файл. Следовательно, его "выкрадывание" и дальнейший взлом не приносят никаких результатов. Единственное неудобство - это надобность вводить каждый раз при коннекте в окно DialUp - Password пароль вручную. Но это всё же лучше, чем "подарить" пароль и логин хакеру. Итак, используем параметр типа DisablePwdCaching со значением 1

Находим в каталоге Windows файл (или файлы) с расширением PWL. Удаляем их. Перезагружаемся. Файл паролей хоть и создаётся опять, но он пустой :-)

Звездочки в паролях

Параметр типа HideSharePwds со значением 1 определяет, показывать ли пароли к расшаренным ресурсам (имеющим общий доступ) открытым текстом или заменять их звездочками.

Запрет на доступ к файлам и принтерам

Для запрещения доступа к файлам служит ключ NoFileSharing, а для запрета управления доступом к файлам - ключ NoFileSharingControl.

Запрет доступа к принтерам устанавливается ключом NoPrintSharing. Ключ NoPrintSharingControl устанавливает запрет на управление доступом к принтерам.

Запрет перечисления рабочей группы

Для того чтобы запретить перечисление содержимого рабочей группы, надо установить значение ключа NoWorkgroupContents равным 1.

Даже при запрете пользователи могут подключаться к компьютерам в своей рабочей группе или домене. Для этого необходимо набрать полное сетевое имя разделенного ресурса в формате UNC, в диалоговых окнах команд "Выполнить" или "Подключить сетевой диск".

Смотри также
Пароли
Отмена кэширования пароля в IE


Командная строка

Изменение вида приглашения

Вы можете изменить вид приглашения для командной строки. Как правило используется формат типа C:\> (текущий диск и угловая скобка). Откройте раздел

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
и создайте параметр PROMPT типа REG_EXPAND_SZ, которому нужно присвоить одно из следующих значений:
  • $B - | (вертикальная черта)
  • $D - текущая дата
  • $G - > (знак больше)
  • $L - < (знак меньше)
  • $N - текущий диск
  • $P - текущий диск и путь
  • $Q - = (знак равно)
  • $T - текущее время
  • $V - версия Windows
  • $$ - $ (знак доллара)

Запрет на расширенный режим командного процессора CMD.EXE

Существует возможность запрета на расширенный режим командного процессора (cmd.exe). Например, в расширенном режиме существуют такие команды как del, erase, chdir, goto. Для запрета найдите или создайте параметр типа DWORD EnableExtensions в разделе

HKCU\Software\Microsoft\Command Processor
и присвойте ему значение 0. Для включения этого режима используйте значение 1

Отложенное расширение переменных среды

Отложенное расширение переменных среды по умолчанию не включено. Для включения используйте параметр типа DWORD DelayedExpansion, равный 1 в разделе

HKCU\Software\Microsoft\Command Processor

Запрет на режим командной строки и обработки bat-файлов

Существует возможность запрета на режим командной строки (cmd.exe) и обработки bat-файлов. Для этого найдите или создайте параметр типа DWORD DisableCMD в разделе

HKCU\Software\Policies\Microsoft\Windows\System

Данный параметр может принимать следующие значения
0 (или отсутствие записи в реестре | Система может использовать режим командной строки и обрабатывать bat-файлы
1 | Система не может использовать режим командной строки, но может обрабатывать bat-файлы
2 | Система не может использовать режим командной строки и обрабатывать bat-файлы

Автонабор команд

Для включения возможности автонабора команд по нажатию клавиши Tab, в разделе

HKCU\Software\Microsoft\Command Processor
установите значение параметра типа DWORD CompletionChar равным 9, что соответствует идентификатору клавиши Tab. Для клавиши Backspace используйте 8, для клавиш Ctrl-D - 4, для Ctrl-F - 6

Быстрый запуск командной строки из контекстного меню

Если вы часто пользуетесь командной строкой, то возможно вам будет гораздо поместить вызов этой команды в контекстное меню папки в Проводнике. Для этого добавьте в раздел

HKCR\Directory\Shell
новый подраздел Командная строка. Затем в созданном подразделе создайте новый подраздел Command и присвойте параметру по умолчанию данного подраздела значение cmd.exe /k "%1". Теперь, щелкнув правой кнопкой мыши на любой папке в Проводнике, вы можете выбрать пункт Командная строка, которая запустить командный процессор в этой папке.


Консоль управления Windows (MMC)

Запрет на запуск консоли управления в авторском режиме

Чтобы запретить пользователю возможность запуска Консоль управления Windows (MMC) в авторском режиме, установите значение параметра типа DWORD RestrictAuthorMode равным 1 в разделе

HKCU\Software\Policies\Microsoft\MMC
В этом случае будет выводиться сообщение о невозможности открыть консоль управления в авторском режиме

Запрет на запуск любой оснастки консоли управления

Чтобы запретить пользователю возможность запуска любой оснастки, установите значение параметра типа DWORD RestrictToPermittedSnapins равным 1 в разделе

HKCU\Software\Policies\Microsoft\MMC
В этом случае будет выводиться сообщение о невозможности открыть оснастку


Защита системных файлов

Как отключить защиту

В Windows Me и выше на смену утилите sfc.exe пришла автоматически отслеживающая замену файлов служба System File Protection, которая не только обнаружит попытку переписать важный файл, но и сама восстановит его исходный вариант. Защита системных файлов — это средство Windows, обеспечивающее сохранность файлов, необходимых для работы системы. Оно предотвращает замену этих файлов их старыми версиями и версиями, не утвержденными корпорацией Майкрософт.

Даже приложения, разработанные корпорацией Майкрософт, не могут заменять защищенные этой системой файлы на их старые версии. Приложения сторонних поставщиков могут заменять системные файлы, только если эти файлы поставляются с каталогом, подписанным корпорацией Майкрософт, содержащим более новый файл.

В некоторых случаях требуется отключать эту защиту. Не забывайте делать резервную копию всего, что изменяете

Итак, для Windows 2000 без Service Pack 2 (SP2), то в раздел реестра

HKLM\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon
добавьте DWORD-параметр (если его нет) SFCDisable со значением FFFFFF9D.

Для Windows 2000 с Service Pack 2 (SP2) - откройте файл %\systemroot%\system32\sfc.dll в любом шестнадцатеричном редакторе, перейдите на смещение 00006211 (6211 hex) и измените байты 8BC6 на 9090. Если исходные значения другие, то ничего не меняйте! Сохраните изменения. В реестре установите параметр SFCDisable равным FFFFFF9D.

Для Windows XP без SP1 - в файле %\systemroot%\system32\sfc_os.dll по адресу 0000E2B8 (E2B8 hex) измените байты 8BC6 на 9090. В реестре установите параметр SFCDisable равным FFFFFF9D

Для Windows XP с SP1 - в файле %\systemroot%\system32\sfc_os.dll по адресу 0000E3BB (E3BB hex) измените байты 8BC6 на 9090. В реестре установите параметр SFCDisable равным FFFFFF9D

Для параметра SFCDisable существуют следующие возможные значения:
0 - включить WFP/SFC
1 - отключить WFP/SFC до следующей перезагрузки ПК, во время которой будет выдано приглашение снова включить защиту файлов
2 - отключить WFP/SFC до следующей перезагрузки
4 - включить WFP/SFC, отключить выдачу всех всплывающих сообщений о работе этой службы
FFFFFF9D - полностью выключить WFP/SFC.

Уведомления о защите файлов

Если вы ее не отключали защиту файлов, и если хотите получать каждый раз уведомление о срабатывании системы глобальной защиты основных файлов, то установите такой параметр типа DWORD ShowPopups равным 1 в разделе:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\SystemFileProtection

А почитать протокол уже проделанной работы System File Protection можно в файле C:\Windows\System\Sfp\sfplog.txt. При этом "родные" файлы для замены она берет не с компакт-диска, а из папки C:\Windows\Options, в которую записывает и обновленные после посещения Windows Update библиотеки, так что файлы в ее базе всегда самые свежие и удалять эту папку не рекомендуется.


Режим проверки цифровой подписи

Режим проверки цифровой подписи (Windows Me)

Иногда требуется отключать режим проверки цифровой подписи в Windows Me, чтобы установить новый драйвер, который система отвергает. Добавьте раздел

HKLM\SOFTWARE\Microsoft\Driver Signing
параметр Policy Value со значением 0 - он разрешит установку любых драйверов. Если же хотите, чтобы перед установкой неподписанного драйвера выдавался запрос на его установку, то установите 1. Соответственно, при значении 2 будут блокироваться все попытки инсталляции несертифицированных драйверов.


Разрешение на использование файла "autorun.inf"

Разрешение на использование файла "autorun.inf" (Windows Me)

В Windows существует возможность изменения значка дисков и автозапуска программ при помощи файла "autorun.inf".

Но в Windows Me, если вы захотите таким образом изменить значки логических дисков, этот прием не сработает. Дело в том, что существует ключ, разрешающий использовать файлы "autorun.inf". Итак, найдите ветвь:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MountPoints\C. Теперь для разрешения считывать информацию из файла "autorun.inf" на диске "С:", нужно создать строковой параметр _HasNotif с пустой строкой (""). Если у Вас есть еще логические диски "D:, E:" и т.д., то создайте для них тот же параметр _HasNotif="" в:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\ Windows\CurrentVersion\Explorer\MountPoints\D и по аналогии - для всех оставшихся дисков.


Часики

Часы

Синхронизация системных часов (Windows XP)

Для изменения интервала синхронизации системных часов компьютера с time-сервером в разделе

HKLM\SYSTEM\ControlSet001\Services\W32Time\TimeProviders\NtpClient
выбираем параметр SpecialPollInterval и изменяем его значение: оно должно быть равно требуемому интервалу между синхронизациями системного времени, выраженному в секундах (например, 43200 - 12 часов)

Выбор time-серверов (Windows XP)

Windows XP умеет подстраивать системное время, сверяясь со специальными серверами в интернете. Можно изменить адреса используемых серверов.

Без использования реестра: Щелкните правой кнопкой мыши на значке часов в системной области панели задач, выберите команду "Adjust Date/Time" и на странице "Internet Time" установите нужный сервер.

При помощи реестра: Откройте раздел

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\Servers
и внесите свой собственный список серверов, использующихся для синхронизации времени.

Украшение часиков

Украшаем часы. Идем в раздел

HKCU\Control Panel\International
и создаем строковый параметр sTimeFormat. Присвойте этому параметру слово, не превышающее 8 символом (свою фамилию), и оно отобразится вместо часов. Если вы не готовы к такому радикальному изменению, то предлагаю более мягкий вариант. В указанный параметр пишите "HH:mm Рыжик". В этом случае будет показываться и время и имя вашего любимого кота. Кстати, вместо стандартного разделителся -двоеточия (:) можете использовать и другие символы, например звездочку(*) или вообще обойтись без разделителя. Заодно можете поменять и формат - сначала минуты, потом часы - mm*HH

Можно применить и другой интересный эффект. В этом же разделе создаем еще два строковых параметра - s1159 и s2359 и присваиваем им слова, напр. Еще не вечер и Утро вечера мудреней. А в уже знакомом параметре sTimeFormat пишем HH:mm:ss tt (по-прежнему можно использовать другой разделитель). Теперь в утренние часы рядом с часиками будет надпись Еще не вечер, а с 12 до 24 часов соответственно Утро вечера мудреней

Примечание: Данные изменения могут проявится и в других местах. Например, в Outlook Express при получении и отправке писем


Раскладка клавиатуры

Раскладка для окна Приветствие

Если при установки системы вы в качестве основного языка установили русский язык, а пароль обычно используете на английском языке, то при выводе окна Приветствие вам каждый раз придется переключаться с русского языка на английский, чтобы ввести пароль. Чтобы по умолчанию система выводила английскую раскладку в этом окне надо открыть раздел

HKU\.DEFAULT\Keyboard Layout\Preload.
. И там надо на первую позицию поместить желаемую раскладку - 00000409 (английская раскладка) или 00000419 (русская), т.е. просто поменяйте их местами.

Свой текст для названия раскладки

Рядом с часиками находится значок раскладки, позволяющий переключать языки при набивке текста (В России обычно используют два языка - Русский и английский). Чтобы изменить всплывающий текст при подведении мыши, идем в раздел

HKLM\System\CurrentControlSet\Сontrol\Nls\Locale.
Там нужно изменить значение соответствующего параметра. Параметр русского языка — 00000419, английского — 00000409 и т.п. Например, вместо слова Русский пишем Великий и могучий


Изменение порога выдачи предупреждения о недостатке свободного места на диске (Windows NT/2000/XP)

Если на вашем диске остается свободным менее 10% (по умолчанию) места, то система информирует об этом появлением иконки в области уведомления (рядом с часиками). На дисках маленькой емкости этот порог вполне оправдан, но для дисков большой емкости это не совсем удобно. Можно изменить порог в процентном соотношении. Находим параметр типа DWORD DiskSpaceThreshold, в котором указываете значение от 0 до 99 (т.е процент от объема диска) в разделе

HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

Недостаточно места на диске

Если Windows постоянно выводит сообщения о том, что на диске мало места (см. выше), то создайте параметр типа DWORD NoLowDiskSpaceChecks со значением, равным 1 в разделе

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer


Дефрагментация

Как уменьшить фрагментируемость больших файлов на диске?

Для того чтобы операционная система при записи файла на диск сначала нашла для него наиболее подходящее по размеру место и поместила его туда, как можно меньше дробя на части, необходимо добавить в реестр:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem параметр ContigFileAllocSize со значением типа dword равный 00000200, который и определяет максимальный размер нефрагментируемого блока данных на диске. При желании размер такого блока можно еще увеличить. Данная настройка может быть очень полезной при работе с мультимедиа (уменьшается нагрузка на диск и процессор при записи и воспроизведении видео или звуковых файлов).

Запрет запуска экранной заставки во время работы программы дефрагментации диска (Windows 95/98/Me)

Запуск экранной заставки во время работы программы дефрагментации диска может замедлить или прервать работу приложения дефрагментации. Для блокировки запуска экранной заставки во время работы дефрагментатора диска присвойте строковому параметру DisableScreenSaver значение "Yes" в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Defrag\Settings.

Чтобы отключить данную блокировку используйте значение "No" (Установлено по умолчанию)

Необходимо отметить, что эта настройка распространяется только на стандартную программу дефрагментации, поставляемой с Windows. На работу дефрагментаторов других производителей эта настройка не влияет

Boot defrag (Windows XP)

Суть boot defrag заключается в дефрагментации тех файлов, что нужны для старта операционной системы. Выключение этой функции позволит на некоторое время уменьшить время загрузки, но со временем она будет становиться все медленнее. Если хотите отключить данную функцию, то идем в раздел
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction и меняем там значение параметра Enable на N. Для включения используйте Y


Файл подкачки

Файл подкачки (Windows NT/2000/XP)

Очистка файла подкачки

Файл подкачки pagefile.sys находится в корне каждого или только системного диска. Там могут оставаться ваши пароли к различным ресурсам и прочая конфиденциальная информация

Для очистки данного файла после завершения работы установите параметр типа DWORD ClearPageFileAtShutdown равным 1 в разделе

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Способ использования файла подкачки

По умолчанию, все запущенные системные драйвера и пользовательские коды, которые не помещаются в памяти, сбрасываются в файл подкачки на диске. При большой памяти компьютера можно разрешить не сохранять данные на диске. Для этого используйте ключ типа DWORD DisablePagingExecutive со значением 1 в разделе

HKLM\ SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management


Проверка диска

Автоматическое исправление ошибок (Windows Me)

При неправильном выключении компьютера при последующей загрузке ОС запускается ScanDisk, но в нем установлен флажок "Автоматически исправлять ошибки", причем флажок этот затемнен, и снять его невозможно. В результате приходится вообще отключать эту проверку, иначе высок риск неверных изменений таблицы FAT - пользователь не может контролировать процесс исправления каждой ошибки!

Чтобы отключить автоисправления, найдите следующий ключ:
HKEY_USERS\.DEFAULT\SOFTWARE\Microsoft\ Windows\CurrentVersion\Applets\Check Drive
и установите следующий параметр:
AutoChk = 02 00 00 00

Для возврата автоматического режима ставьте
AutoChk = 00 00 00 00

Изменение времени ожидания (Windows NT/2000/XP)

При загрузке Windows после неправильного выключения запускается проверка дисков. При этом пишется что-то вроде "Через 10 секунд начну проверять...". Чтобы уменьшить время ожидания надо в разделе
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager создать или отредактировать параметр AutoChkTimeOut типа DWORD и присвоить ему значение в секундах. По умолчанию установлена пауза в 10 секунд. Если вы присвоите ему значение больше чем 259200 секунд (около 3 дней), то будет использоваться значение по умолчанию


Num Lock

Num Lock (Windows 2000/XP)

Некоторые сетуют, что при входе пользователя в систему переключатель клавиатуры Num Lock всегда выключен. Можно ли сделать, чтобы он всегда был включен?

Для этого найдите ветвь:
HKEY_CURRENT_USER\Сontrol Panel\Keyboard
и установите строковое значение InitialKeyboardIndicators равным "2"


Выбор программы

Когда вы щелкаете на файле с незарегистрированным в системе расширением, то появляется окно "Выбор программы" (или "Открыть с помощью..."), в котором вам предлагается выбрать из предложенного списка программу, способную обработать неизвестный тип файла. Но в данном окне всегда установлен флажок "Всегда использовать эту программу...", что порой приводит к нежелательным проблемам. Как правило, данный флажок лучше не использовать, чтобы не повредить реестр. Существует способ, чтобы этот флажок отсутствовал по умолчанию. Для этого нужно немного подправить запись в реестре. Откройте раздел:
HKEY_CLASSES_ROOT\Unknown\shell\openas\command и в установленном по умолчанию параметре запишите C:\WINDOWS\rundll32.exe shell32.dll,OpenAs_RunDLL %1 %2


Клавиша Windows

Отключение клавиши Windows

На некоторых современных клавиатурах присутствует клавиша Windows (как правило, логотип-флажок Майкрософт). Некоторым пользователям она мешает при быстрой печати или играх. Чтобы отключить ее, нужно создать новый двоичный параметр Scancode Map со значением 00 00 00 00 00 00 00 00 03 00 00 00 00 00 5B E0 00 00 5C E0 00 00 00 00 в разделе

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout

Запрещение горячих клавиш с клавишей Windows

Можно отключить использование комбинацию "горячих" клавиш с клавишей Windows. Для этого создаем параметр типа DWORD NoWinKeys со значением 1 в разделе

HKCU\Software\Microsoft\Windows\Current Version\Policies\Explorer

Однако после установки этого запрета, одиночное нажатие клавиши Windows, которое вызывает меню "Пуск", будет работать.


Создание псевдонима для программы

Существует скрытая возможность создания псевдонима для запускаемой программ. Например, вы выбрали команду Пуск-Выполнить и напечатали WINRAR, а запускается блокнот NOTEPAD

Для этого найдите ветвь:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths
- в ней в качестве подразделов выступают имена программ.

Войдите в один из разделов, например WINRAR.EXE из измените строковое значение по умолчанию на путь к другой программер, например C:\WINDOWS\NOTEPAD.EXE.

Теперь закройте реестр. Выберите Пуск-Выполнить и напечатайте winrar и у вас запустится блокнот


Размер реестра

Размер реестра (Windows NT/2000)

Размер реестра ограничивается параметром RegistrySizeLimit (тип REG_DWORD) в разделе реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.

Увеличить максимальное значение его объема можно и в окне "Virtual Memory" диалога System Properties > Advanced > Performance Options > Change


Обработка reg-файлов

Импорт значений из reg-файла без вывода диалогового окна

Когда вы в Проводнике щелкаете на reg-файл, то происходит импорт значений в реестр при помощи редактора реестра Regedit, при этом выводится запрос к пользователю на подтверждение этой операции, а после ее завершения - еще и сообщение, что данные были успешно внесены. Но данный редактор имеет ключ, позволяющий не выводить диалоговые окна. Если вы часто пользуетесь reg-файлами, то используя этот ключ, вы можете съэкономить себе время, не нажимая две кнопки. Для этого откройте раздел
HKEY_CLASSES_ROOT\regfile\shell\open\command и измените строковое значение по умолчанию на regedit.exe /s "%1"

Обработка reg-файлов как текстового документа

Если предыдущий совет кому-то покажется небезопасным (без вашего ведома будут меняться настройки!), то воспользуйтесь прямо противоположным способом. Пусть вместо импорта reg-файл будет открываться в Блокноте. Для этого используйте запись:
NOTEPAD.EXE "%1" (В случае необходимости измените путь к вашем текстовому редактору).


Значки для DLL

Оболочка Windows использует для файлов DLL определенный стандартный значок. Но порой эти dll-файлы сами содержат значки. Можно настроить систему таким образом, чтобы она выводила значок из этих файлов (Если файл значков не содержит, то будет выведен стандартный значок для неизвестного типа файлов). Идем в раздел
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\dllfile\DefaultIcon и меняем установленное строковое значение по умолчанию (например, "C:\WINDOWS\SYSTEM\shell32.dll,-154") на "%1"


Автоматическая выгрузка DLL

Автоматическая выгрузка DLL (Windows 2000/XP)

Оболочка Windows выгружает неиспользуемые DLL не сразу, а через некоторое время. Этот промежуток времени иногда может достигать больших интервалов (особенно при отладке программ). Для автоматической выгрузки всех DLL установите значение строкового параметра AlwaysUnloadDLL равным "1" в разделе

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer


Ускорение файловой системы

Ускорение файловой системы (Windows NT/2000/XP)

Можно ускорить действие файловой системы, (если позволяет оперативная память) увеличив параметр типа DWORD IoPageLockLimit в разделе
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management от заданных по умолчанию 512 КБ до 4 МБ и более.

Этот параметр представляет максимальное число байт, которые могут быть блокированы для операций I/O. Когда значение параметра равно 0, то система использует встроенный алгоритм определения необходимой памяти и использует объем 512 КБ. Установка максимального значения должна основываться на объеме памяти в Вашей системе.
Таблица рекомендуемых значений
RAM (MB) | IoPageLockLimit
32 | 4096000
64 | 8192000
128 | 16384000
256+ | 65536000

Установки вступят в силу после перезагрузки системы


Отключение дебаггера

Отключение дебаггера (Windows NT/2000/XP)

При возникновении каких-либо неполадок в работе приложений пользователю показывается окно с сообщением об ошибке и предложением закрыть приложение, при этом DrWatson (дебаггер по умолчанию) автоматически записывает информацию о сбое в log-файл. Для отключения этой службы вставляем в ключ реестра

HKLM\SOFTWARE\Microsoft\Windows NT\Current Version\AeDebug
строковый параметр Auto со значением 0. После этого DrWatson больше не будет загружаться автоматически, а будет выводится окно с сообщением об ошибке. По умолчанию установлено 1 (автоматическая загрузка дебаггера)


Зависшие программы

Зависшие программы (Windows NT/2000/XP)

Время, по истечении которого программу считать зависшей

Иногда программа зависает, т.е. не реагирует на обращение к ней. Приходится принудительно закрывать его (например, через Диспетчер задач (Ctr-Shift-Esc)):
Ключ HungAppTimeout в разделе HKEY_CURRENT_USER\Control Panel\Desktop определяет время, по прошествии которого не отвечающее приложение считается зависшим (по умолчанию 5000 миллисекунд). Измените данный строковый параметр на необходимое значение

Время ожидания перед завершением зависшего приложения

Ключ WaitToKillAppTimeout в разделе HKEY_CURRENT_USER\Control Panel\Desktop задает время ожидания перед завершением зависшего приложения (по умолчанию 2000 миллисекунд). Измените данный строковый параметр на необходимое значение

Автоматическое завершение зависших программ

Вы можете разрешить системе автоматически завершать зависшие процессы. Для этого используйте строковый параметр AutoEndTasks в разделе HKEY_CURRENT_USER\Control Panel\Desktop
Значение "1" разрешает системе автоматически завершать процессы
Значение "2" - процессы не завершаются автоматически. Система ожидает, когда процесс завершится, и если время завершения процесса превышает значение HungAppTimeout (см. выше), то появлятеся диалоговое окно Завершение работы, указывающее, что приложение зависло

Примечания

При установке слишком малых значений в указанных ключах могут возникнуть проблемы с автозавершением запущенных задач, так как приложение может длительное время не отвечать на запросы в случае достаточно большой загруженности процессора или работой с другими программами


Регистрация ошибок в Windows

Регистрация ошибок в Windows (Windows 98)

Windows 98 позволяет вести логи по ошибкам, произошедшим в операционной системе. По умолчанию эта возможность выключена. Чтобы включить ее, надо в разделе
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\Fault создать строковый параметр LogFile, в значении которого надо прописать полный путь и название лог-файла ошибок


Длинные и короткие имена файлов

Запрещение длинных имен файлов

Вы можете запретить длинные имена файлов в Windows, заставив тем самым генерировать имена в формате 8.3 (DOS-овский формат). Для этого в разделе
HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\FileSystem надо изменить параметр Win31FileSystem, присвоив ему значение 01 (по умолчанию стоит 00)

Сделанные изменения вступят в силу после перезагрузки

Способ преобразования длинных имен файлов в короткие

Как в Windows происходит преобразование длинных имен файлов в короткие? Обычно от имени остаются первые шесть символов, затем идет тильда (~) и после нее число. Т.е. вы видите только первые 6 символов имени (например, regist~1.txt). Это не очень удобно. Можно заставить Windows генерировать 8-символьные имена, когда не происходит дублирования (если первые 8 символов у двух файлов одинаковые, будет генерироваться 6-символьное имя). Для этого надо создать двоичный параметр NameNumericTail со значением 0 в разделе
HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\FileSystem. После перезагрузки изменения вступят в силу.


Формат MS-DOS для файлов и папок

Формат MS-DOS для файлов и папок (Windows NT/2000/XP)

По умолчанию Windows NT и выше создают в разделе NTFS специальную таблицу, содержащую все имена файлов и папок в формате MS-DOS по формуле 8.3 (8 символов имени файла и 3 символа для его расширения). Данная возможность в настоящее время не совсем актуальна и ее можно отключить для повышения производительности системы

Для этого установите параметр типа DWORD NtfsDisable8dot3NameCreation в разделе
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem равным 1

Установки вступят в силу после перезагрузки системы


Обновление метки последнего доступа к папке

Обновление метки последнего доступа к папке (Windows NT/2000/XP)

По умолчанию Windows NT и выше в системе NTFS обновляют метку последнего доступа к папке при их открытии. Данная возможность может тормозить вашу систему при слишком большом количестве папок. Если вас не интересует данная метка, то можете отключить данную возможность.

Для этого установите параметр типа DWORD NtfsDisableLastAccessUpdate в разделе
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem равным 1

Установки вступят в силу после перезагрузки системы


Быстрое завершение работы Windows

Быстрое завершение работы Windows (Windows NT/2000/XP)

Windows NT версии 3.1и 3.5 позволяла закрыть все процессы за 20 секунд. В Windows NT 3.51 и выше существует возможность определять величину интервала, в течение которого система должна завершить свою работу. Для этого необходимо исправить ключ системного реестра – строковый параметр WaitToKillServiceTimeout, где установлена временная задержка закрытия всех запущенных сервисов в миллисекундах.

Этот ключ расположен в разделе HKEY_LOCAL_MACHINE/SYSTEM/ CurrentControlSet/Control

По умолчанию значение параметра равно 20000, что эквивалентно 20 секундам.

Для уменьшения времени завершения, нужно уменьшить это значение, например до 1000, что эквивалентно 1 секунде. Однако, помните, что слишком значительное уменьшение значения этого ключа не позволит системе корректно завершить запущенные сервисы, что может сказаться на стабильности загрузки. Во время завершения работы, система уведомляет все сервисы и дает каждому сервису время на корректное закрытие. По истечении этого времени система уничтожает сервис. При этом некоторые параметры настройки сервиса могут быть не сохранены. Поэтому, если при уменьшении значения система становится нестабильной, рекомендуется попробовать увеличить это значение до тех пор, пока система не будет полностью стабильной.


Управление размером файла SHELLICONCACHE

Windows хранит некоторые значки, используемые оболочкой, в файле SHELLICONCACHE. При частом изменений параметров оболочки размер данного файла увеличивается, что приводит постепенно к тормозам при перерисовке значков из-за отсутствия места в кэше. Можно увеличть размер кэша этого файла, устанавливая строковый параметр Max Cached Icons в разделе
HKEY_LOCAL_MACHINE\Software\Microsoft\ Windows\CurrentVersion\Explorer
равным 5000 (5 Мбайт)

По умолчанию этот параметр не присутствует в реестре.

Рекомендуется иногда удалять файл SHELLICONCACHE, особенно, когда вы начинаете замечать, что значки становятся черными на Рабочем столе


Запрет на null-сессию

Запрет на null-сессию (Windows NT/2000/XP)

Для запрета null-сессии, которая позволяет другому пользователю, получить информацию о зашаренных (доступных для общего пользования) директориях и об имеющихся на компьютере локальных пользователях, установите параметр типа DWORD RestrictAnonymous в разделе
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa равным 1

Установки вступят в силу после перезагрузки системы


Windows Installer

Контроль над Windows Installer

Майкрософт разработала новый формат для установки программ - Windows Installer (msi-файлы). Существует возможность контроля над этим форматом. Создайте новый параметр DisableMSI типа DWORD в разделе

HKLM\Software\Policies\Microsoft\Windows\Installer
и присвойте ему следующие значения
  • 0 - по умолчанию
  • 1 - только адмистраторы системы могут запустить Windows Installer
  • 2 - запрет на запуск Windows Installer

Запрет на запуск msi-файлов со сменных носителей

Можно запретить запуск msi-файлов со сменных носителей (CD-ROM, флоппи-диск, DVD и т.д.) при помощи параметра типа DWORD DisableMedia в разделе

HKCU\Software\Policies\Microsoft\Windows\Installer


Windows Script Host

Windows Script Host (WSH)

Существуют несколько параметров, позволяющих настроить Windows Script Host. Данные параметры находятся в разделе:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Script Host\Settings

Строковый параметр Enabled равный "0" отключает работу скриптов WSH (значение "1" включает обратно)

Строковый параметр DisplayLogo равный "0" отключает показ версии WSH и копирайт компании Майкрософт при работе скрипта в окне сеанса MS-DOS


MS-DOS

Запрет командной строки MS-DOS

Существует возможность запрета Запрет командной строки MS-DOS. Для этого создайте параметр типа DWORD Disabled равный 1 в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WinOldApp.

При попытке запуска DOS-приложения или активизации "командной строки MS-DOS" через иконку, содержащую ссылку на командный интерпретатор (процессор) "COMMAND.COM", Windows выдает сообщение о запрете запуска администратором

Сделанные изменения вступают в силу немедленно

Запрет запуска в монопольном режиме MS-DOS-приложений

Существует возможность запрета перегрузки из Windows в монопольный режим MS-DOS ("Single Mode"). Данный запрет не влияет на использование командной строки MS-DOS в Windows или запуск приложений MS-DOS из оболочки Windows. Чтобы установить запрет, создайте параметр типа DWORD NoRealMode равный 1 в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WinOldApp.

Значение параметра "0", являющееся "значением по умолчанию", или его отсутствие снимает запрет монопольного режима MS-DOS. При активизации этой системной политики в Windows 95/98 из диалога "Завершение работы" ("Shut Down") убирается пункт меню "Перезагрузить компьютер в режиме MS-DOS" ("Restart in MS DOS mode"). Однако здесь же стоит отметить, что это не запрещает полностью запуск монопольного режима MS-DOS. В него можно зайти, нажав при первоначальной загрузке Windows клавишу F8 и выбрав далее один из пунктов, содержащих запуск в "командной строке".


Установка способа доступа к расшаренным ресурсам компьютера из сети

Установка способа доступа к расшаренным ресурсам компьютера из сети (Windows NT/2000/XP)

Раздел: HKLM\System\CurrentControlSet\Control\Lsa Параметр типа DWORD RestrictAnonymous

Если значение равно 1 - запрещает анонимным юзерам просматривать удаленно учетные записи и расшаренные ресурсы. 2 - отказывает любой неявный доступ к системе (в сетевом окружении компьютер не будет виден, однако, доступ к нему можно будет получить, обратившись к нему по его IP).


Запрет сохранения паролей в Dial-Up-соединениях

Запрет сохранения паролей в Dial-Up-соединениях (Windows NT 4/2000/XP)

"По умолчанию", в Dial-Up-соединениях введенный пароль сохраняется после успешного соединения, если задействована опция "Сохранять имя пользователя и пароль", расположенная на диалоговом окне для Dial-Up. Это достаточно удобно для многих пользователей, но если вы занимаетесь проблемой безопасности системы, то можете запретить сохранение этих паролей. В разделе
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters создайте параметр типа DWORD DisableSavePassword со значением 1, который запрещает сохранение паролей в Dial-Up-соединениях. В этом случае опция "Сохранять имя пользователя и пароль" становится недоступной, а сохраненные пароли пропадают.


Блокнот

Вы можете получить доступ к дополнительным свойствам шрифта, используемого в Блокноте. Используются параметры типа DWORD

Зачеркнутый стиль - параметр lfStrikeOut со значением 1 в разделе

HKCU\SOFTWARE\Microsoft\Notepad

Подчеркнутый стиль - lfUnderline со значением 1 в разделе

HKCU\SOFTWARE\Microsoft\Notepad


Настройка системы (msconfig.exe)

Порой окно программы Настройка системы (msconfig.exe) засоряется ненужными записями. Чтобы удалить записи, которые мозолят вам глаза, нужно прогуляться в раздел

HKLM\SOFTWARE\Microsoft\Shared Tools\MSConfig
и просмотреть все подразделы. Удалите ненужные параметры и окно программы будет выглядеть гораздо аккуратнее


Internet Explorer

Здесь приводятся настройки, которые доступны из меню Сервис-Свойства обозревателя-Дополнительно. Обычным пользователям рекомендуется менять значения именно через это окно. Данные примеры предназначены только для программистов. Все параметры вносятся в раздел

HKCU\Software\Microsoft\Internet Explorer\Main
Включить автоматическую подгонку размеров изображения | AutoImageResize ("yes"/"no")
Автоматически проверять обновления Internet Explorer | NoUpdateCheck (dword)
Включить личное меню избранного | FavIntelliMenus ("yes"/"no")
Воспроизводить звуки на веб-страницах | Play_Background_Sounds ("yes"/"no")
Использовать одно и то же окно для загрузки ярлыков | AllowWindowReuse (dword)


Меню Файл

Удаление пункта меню Файл из Internet Explorer

Для удаления пункта меню Файл из Internet Explorer используйте параметр NoFileMenu со значением DWORD равным 1 в разделе

HKCU\SOFTFARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Также будет удален этот пункт из окна Проводника, Мои документы и других мест, использующих оболочку Windows

Запрет на создание нового окна

При выборе Файл-Создать-Окно (или Ctrl-N) создается новое окно. Для запрета такой возможности используйте параметр типа DWORD NoFileNew со значением равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Запрет на расширенное меню для пункта Создать

При выборе Файл-Создать-Окно появляется расширенное меню, включающее в себя команды Сообщение, Объявление, Контакт, Вызов через Интернет.

Чтобы убрать это расширенное меню, используйте параметр типа DWORD NoExpandedNewMenu со значением равным 1 в разделе
HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Открыть (Internet Explorer 4 и выше)

Если вы хотите, чтобы пользователь не мог открыть страничку (через Файл-Открыть, Ctrl-O, или Ctrl-L), то создайте следующий параметр типа DWORD NoFileOpen со значением, равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Править в ...

Internet Explorer делает попытку определить программу, используемую вами для создания и редактирования html-документа. В пункте меню Файл у вас может присутствовать строка Править в Блокнот (или другой текстовый редактор). Чтобы убрать данную команду, присвойте строковому параметру CheckDocumentForProgID значение no в разделе

HKCU\Software\Microsoft\Internet Explorer\Main

Сохранить как

Для удаления пункта Сохранить как ... из меню Файл используйте параметр типа DWORD NoBrowserSaveAs со значением, равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Печать и Предварительный просмотр

Чтобы удалить пункты Печать и Предварительный просмотр, то присвойте параметру типа DWORD NoPrinting значение, равное 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Импорт и экспорт

Если вы хотите запретить пользователю воспользоваться пунктом Импорт и экспорт, то создайте параметр типа DWORD DisableImportExportFavorites со значением, равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer
В этом случае, при попытке нажать на кнопку Готово, будет выводится соотвествующее предупреждение.

Закрыть (Internet Explorer 4 и выше)

Если вы хотите, чтобы пользователь не мог закрыть страничку (через Файл-Закрыть, Alt-F4, системное меню или нажимая крестик в верхнем углу), то создайте параметр типа DWORD NoBrowserClose со значением, равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions


Вид

Меню Вид

Просмотр HTML-кода

Для блокировки пункта меню Просмотр HTML-кода используйте параметр типа DWORD NoViewSource со значением равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Выбор текстового редактора для просмотра HTML-кода

По умолчанию для просмотра HTML-кода используется стандартный Блокнот. Вы можете использовать ваш любимый текстовый редактор, используя в разделе

HKLM\SOFTWARE\Microsoft\Internet Explorer\View Source Editor\Editor Name
строковый параметр (По умолчанию), в который нужно прописать полный путь к exe-файлу текстового редактора

Во весь экран

При выборе Вид-Во весь экран (или F11) Internet Explorer переходит в так называемый режим киоска. Для запрета такой возможности используйте параметр типа DWORD NoTheaterMode со значением равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions


Избранное

Чтобы удалить пункт меню Избранное в Internet Explorer, создайте параметр типа DWORD NoFavorites со значением 1 в разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions. Кнопка Избранное также будет недоступна на панели инструментов


Сервис

Меню Сервис

Почта и новости

Для блокировки пункта Почта и новости используйте параметр типа DWORD RestGoMenu со значением, равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Windows Update

В меню Сервис присутствует строка Windows Update. Вы можете изменить данную строку на свою. Для этого создайте строковый параметр Windows Update Menu Text с вашим текстом в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer
. Если вы будете использовать пустую строку, то данный пункт будет отсутствовать вообще

Свойства обозревателя

Чтобы запретить доступ к свойствам Internet Explorer (Сервис-Свойства обозревателя), используйте параметр типа DWORD NoBrowserOptions со значением 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions
(Для отмены запрета используйте значение 0)

Безопасность

На вкладке Безопасность можно настраивать список сайтов, относящихся к различным зонам безопасности. В случае надобности, этот список можно легко экспортировать. Для этого всего лишь надо сделать экспорт в reg-файл ветвей реестра:

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains.
После переустановки Windows сделайте импорт этих файлов, и все настройки восстановятся.
Смотри также Совет по блокировке рекламы и нежелательных сайтов


Справка

Все настройки делаются в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer
при помощи DWORD-параметров

Блокировка пункта Справка

Для блокировки пункта Справка создайте параметр NoHelpMenu со значением, равным 1

Для пользователей Netscape

Для скрытия подпункта Для пользователей Netscape в меню Справка создайте параметр NoHelpItemNetscapeHelp со значением, равным 1

Отзывы и предложения

Для скрытия подпункта Отзывы и предложения в меню Справка создайте параметр NoHelpItemSendFeedback со значением, равным 1

Полезный совет

Для скрытия подпункта Полезный совет в меню Справка создайте параметр NoHelpItemTipOfTheDay со значением, равным 1


Контекстное меню в Internet Explorer

Лишние команды в контекстном меню

Если контекстное меню вашего браузера, выпадающего, если нажать правую кнопку мыши на ссылке, содержит слишком много лишних команд, то найдите раздел

HKCU\SOFTWARE\Microsoft\Internet Explorer\MenuExt.
Данный раздел содержит подразделы, которые вы можете удалять, изменять, редактировать

Запрет на контекстное меню

Чтобы запретить вызов контекстного меню правой кнопкой мыши, используйте параметр типа DWORD NoBrowserContextMenu со значением, равным 1в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

Открыть в новом окне

Для блокировки возможности открытия страницы в новом окне, когда вы нажимаете правой кнопкой на ссылке и выбераете пункт Открыть в новом окне используйте параметр типа DWORD NoOpeninNewWnd со значением, равным 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions


Поиск

Кнопка Поиск

Чтобы изменить адрес поисковика, который у вас установлен, при нажатии кнопки Поиск, вам следуем изменить строковый параметр Search Bar в разделе

HKLM\SOFTWARE\Microsoft\Internet Explorer\Main


NoSelectDownloadDir

Запрет на загрузку файлов

Чтобы запретить пользователю загружать файлы из интернета, создайте параметр типа DWORD NoSelectDownloadDir со значением 1 в разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions. При попытке нажать кнопку Сохранить в диалоговом окне загрузки файлов будет выводится соответствующее предупреждение


Сохранение странички

Сохранение странички (Internet Explorer 5 и выше)

По умолчанию Internet Explorer позволяет сохранять страничку полностью - с картинками, скриптами, файлами. Чтобы запретить такую возможность, создайте следующий параметр типа DWORD NoBrowserSaveWebComplete со значением, равным 1 в разделе:

HKCU\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions
Теперь можно будет сохранять страницу только как Веб-страница, только HTML или Текстовый файл


Доступ к сайтам

Чтобы убрать ограничение на доступ к сайтам в IE достаточно удалить все параметры из раздела

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ratings


Ошибки при загрузке страницы

По умолчанию IE при возникновении ошибок 4** показывает страницы с подробным описанием соответствующей ошибки и дальнейшими рекомендациями. Чтобы запретить показ таких страничек, нужно изменить значение строкового параметра Friendly http errors со значением no в разделе

HKCU\Software\Microsoft\Internet Explorer\Main

В этом случае будут выводится пустые странички


Время ожидания ответа сервера

Время ожидания ответа сервера (Internet Explorer 4.0 SP1 и выше)

При работе в интернете иногда приходится обращаться к весьма удаленным или очень медленным сайтам, в связи с чем у Internet Explorer не всегда хватает терпения дождаться ответа от сервера, и он выдает такие сообщения: "Microsoft Internet Explorer error 10060 connection timed out", "Internet Explorer cannot open the internet site. The operation timed out", "The page cannot be displayed. Cannot find server or DNS Error". В этой ситуации можно попробовать увеличить время ожидания ответа сервера, которое по умолчанию составляет пять минут, установив, например, для восьми минут в разделе:

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
параметр типа DWORD ReceiveTimeout, равным 00075300 (480000). Для того, чтобы установить другое время, надо количество секунд умножить на 1000, то есть для нашего примера с 8 минутами мы получаем: 60 х 8 х 1000 = 480 000.

Время сохранения соединения

После установки соединения можно настроить время сохранения соединения с сервером. Для этого в разделе:

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
установить параметр типа DWORD KeepAliveTimeout с новым значением в миллисекундах (по умолчанию 0x0001D4C0 (120000))


Замена логотипа в Internet Explorer

Логотип по сути своей представляет собой вертикальную последовательность кадров-картинок в формате BMP-256. Таких лент должно быть две. В одной кадры должны быть 26х26 точек, в другой 38х38. Длина ленты (а стало быть и количество кадров) может быть любой длины. Важно лишь следить, чтобы длина ленты в одном случае была кратной 26 точкам, в другом - 38. Разместите оба файла в легкодоступном месте. Например в C:\WINDOWS\SYSTEM. Для примера назовем эти файлы bg_logo.bmp и sm_logo.bmp. Создайте раздел (если не существует):

HKCU\Software\Microsoft\Internet Explorer\Toolbar
и установите два параметра: BrandBitmap и SmBrandBitmap.

BrandBitmap должен содержать путь к "большому" логотипу (в нашем случае C:\WINDOWS\SYSTEM\bg_logo.bmp).
SmBrandBitmap - путь к "маленькому" логотипу (C:\WINDOWS\SYSTEM\sm_logo.bmp).

В свое время я написал программку, которая заменяла стандартный логотип на один из логотипов, содержащихся в коллекции программы. Один логотип приводится для примера.

Скачать Animated IE Logo


Замена заголовка в Internet Explorer

Найдите или создайте строковый параметр Window Title в разделе:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\. Создайте новую строку или измените существующую запись на вашу. Удалив раздел Window Title, вы установите значение заголовка по умолчанию


Замена фона в панели инструментов в Internet Explorer

Существует возможность установки своего фона для панели инструментов в Internet Explorer. Для этого в разделе реестра HKEY_CURRENT_USER \SOFTWARE\ Microsoft\Internet Explorer\Toolbar создайте строковый параметр BackBitmap, значением которого будет полное имя BMP-файла с нужной картинкой - она и замостится мозаикой на панелях окон. Кстати, заодно замостится и панель инструментов Проводника.

Для замены фона только в Проводнике, не затрагивая Internet Explorer смотрите Замена фона в панели инструментов в Проводнике


Установка стартовой странички

Найдите или создайте следующий строковый параметр: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\Start Page. Создайте новую строку или измените существующую запись на вашу. Удалив раздел Start Page, вы установите значение по умолчанию

Теперь, при запуске браузера будет загружаться указанная страница


F3

Клавиша F3 (Поиск)

Можно заблокировать клавишу F3 в Internet Explorer, которая запускает поиск в интернете. Создайте параметр типа DWORD NoFindFiles со значением 1 в разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions.


Кнопки на панели инструментов в Internet Explorer

Если панель инструментов вашего браузера содержит слишком много лишних кнопок, то найдите раздел: HKEY_LOCAL_MACHINE\ Software\ Microsoft\Internet Explorer\ Extensions. Данный раздел содержит подразделы, которые вы можете удалять, изменять, редактировать

Лишние кнопки могут быть невидимы, но присутствовать на панели инструментов. Чтобы просмотреть все существующие кнопки, нажмите правой кнопкой на панели инструментов и выберите команду Настройка


Кнопки Вперед и Назад

Чтобы заблокировать кнопки Вперед и Назад в Internet Explorer, создайте параметр типа DWORD NoNavButtons со значением 1 в разделе

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions


Строчки для комбобокса Адрес

При нажатии на треугольник в комбобоксе Адрес вываливается список вводимых вами адресов.

Вы можете отредактировать этот список (добавить, удалить, изменить). Войдите в раздел: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs. Там присутствует список ваших адресов, начиная со строкового параметра url1. Добавляйте или удаляйте строки, но следите, чтобы параметры были упорядоченными. Иначе, если у вас будет url1, url2, url5, url6, то будут выводиться только первые два адреса

Примечание: Данный список будет появляться, если в комбобоксе находится веб-адрес. Если же там путь к файлу на локальном компьютере, то появится список, аналогичный списку Проводника


Панель инструментов изображений

Панель инструментов изображений (Internet Explorer 5.5 и выше)

Отключение Панели инструментов изображений

В Internet Explorer при наведении указателя мыши на рисунок, который требуется сохранить, в уголке рисунка появляется панель инструментов изображений.

Эта панель позволяет быстро осуществить разные операции: сохранить, печатать, послать по почте, открыть папку Мои рисунки

Для отключения данной панели инструментов изображений создайте ключ типа DWORD MyPics_Hoverbar в разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\PhotoSupport со значением 1

Для включения панели инструментов изображений удалите описанный параметр или присвойте ему значение 0

Существует еще альтернативный вариант. Создайте строковый параметр Enable_MyPics_Hoverbar в разделе:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\main и присвойте ему значение yes (включить) или no (выключить)

Размер картинки

Панель инструментов изображений появляется не для всех рисунков. Для использования панели инструментов размер рисунка должен быть не менее 130 x 130 пикселов. Если вы хотите изменить данное значение, то создайте параметр DWORD Image_Filter в разделе:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\main и присвойте ему нужное значение

Смещение Панели относительно изображения

По умолчанию Панель инструментов изображений появляется смещенной на 10 пикселов от верхнего и левого сторон изображения. Для изменения этой настройки создайте параметр DWORD Offset в разделе:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\main и присвойте ему нужное значение


Отмена кэширования пароля в IE

Отмена кэширования пароля (Internet Explorer 4 и выше)

По некоторым сведениям, эта настройка имеет ограниченное применение. Приведенная информация относится к Internet Explorer версии 4.01 с установленным 2-м пакетом обновлений, к 5 и 5.01 версиям Internet Explorer, работающему под Windows 95, 98, NT 4.0 и Internet Explorer 5.01 для Windows 98 Second Edition. Например, при проведении испытаний под Windows ME, Internet Explorer 5.5 проигнорировал эту настройку.

Чтобы отключить кэширование паролей, используйте параметр типа DWORD DisablePasswordCaching со значением 1 в разделе
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings. По умолчанию в Internet Explorer задействовано кэширование паролей.

Microsoft посвятила этой проблеме статью Q229940 в MSDN под названием "How to Disable Internet Explorer Password Caching".

Смотри также
Отмена кэширования пароля


Команда "Q" в адресной строке для получения статьи из Базы Знаний

Команда "Q" в адресной строке для получения статьи из Базы Знаний от Майкрософт

Данная настройка будет полезна разработчикам. Порой в различных публикациях встречаются ссылки на определенный идентификатор статьи Базы Знаний (Knowledge Base). Можно быстро получить доступ к этой статьи, напечатав Q nnnnnn, где nnnnnn - номер статьи.
Для этого откройте или создайте раздел
[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl\Q и измените строковое значение по умолчанию на @="http://support.microsoft.com/default.aspx?scid=kb;en-us;%s"

Теперь вы можете запустить Internet Explorer, напечатать Q nnnnnn или Q Qnnnnnn и браузер сразу покажет нужную статью


Размеры окна

Если вас не устраивают размеры или позиция открываемого окна браузера, то удалите следующие параметры:

  • WINDOW_PLACEMENT в HKCU\Software\Microsoft\Internet Explorer\Main
  • OldWorkAreas и OldWorkAreaRects в HKCU\Software\Microsoft\Internet Explorer\Desktop


Замена заголовка в Outlook Express

Для Outlook Express 4
Найдите или создайте следующий строковый параметр: HKEY_CURRENT_USER\Software\Microsoft\Outlook Express\WindowTitle. Создайте новую строку или измените существующую запись на вашу. Удалив раздел WindowTitle, вы установите значение заголовка по умолчанию

Для Outlook Express 5.0 и 6.0
Для Outlook Express 5.0 и 6.0 местоположение ключа изменилось на: HKEY_CURRENT_USER\Identities\{** Identity ID **}\Software\Microsoft\Outlook Express\5.0\WindowTitle, где {** Identity ID **} - ваш идентификатор


Удаление заставки в Outlook Express

Для Outlook Express 4
Найдите или создайте следующий параметр DWORD: HKEY_CURRENT_USER\Software\Microsoft\Outlook Express\NoSplash. Если установите значение параметра равным 1, то заставка появляться не будет. Для появления заставки во время загрузки Outlook Express установите значение параметра в 0

Для Outlook Express 5.0 и 6.0
Для Outlook Express 5.0 и 6.0 местоположение ключа изменилось на: HKEY_CURRENT_USER\Identities\{** Identity ID **}\Software\Microsoft\Outlook Express\5.0\NoSplash, где {** Identity ID **} - ваш идентификатор


Общая Адресная книга

Общая Адресная книга в Outlook Express

Если нужно, чтобы несколько пользователей одного компьютера пользовались общей адресной книгой в Outlook Express, то проделайте следующее:
Войдите в систему под именем первого пользователя, запустите редактор реестра и найдите ключ
HKEY CURRENT USER\Software\Microsoft\WAB\WAB4\Wab File Name, в котором найдите путь к wab-файлу.
Теперь войдите под именем другого пользователя, найдите тот же ключ и впишите тот же путь к wab-файлу. Повторите ту же процедуру для всех пользователей. Теперь адресная книга у всех будет одна.


Учетные записи в Outlook Express

Учетные записи

Чтобы скрыть команду "Учетные записи" в Outlook Express (Сервис-Учетные записи), нужно добавить в раздел

HKLM\Software\Microsoft\Outlook Express
ключ типа DWORD No modify accts со значением 1


Фильтры в Outlook Express

Фильтры

Где содержится информация для почтовых фильтров программы Outlook Express (список блокированных отправителей и правила для почты)? Когда накоплен список из нескольких сотен всяческих правил и адресатов, задаешься вопросом, как его сохранить при переустановке системы.

Настройки Outlook Express располагаются в разделе

HKCU\Identities\{набор цифр}\Software\Microsoft\OutlookExpress\5.0


Изменение заголовка в Windows Media Player

Для изменения заголовка в Windows Media Player откройте или создайте раздел HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer с строковым параметром TitleBar, содержащим ваш текст


Параметры

Сеть (Проигрыватель Windows Media 8.0 и выше)

Чтобы скрыть вкладку Сеть (Сервис-Параметры), нужно установить значение типа DWORD параметра HideNetworkTab равным 1 в разделе

HKCU\Software\Policies\Microsoft\WindowsMediaPlayer.

Автоматическое обновление (Проигрыватель Windows Media 7.0 и выше)

Проигрыватель Windows Media периодически устанавливает связь через интернет для проверки существования новой версии программы (Сервис-Параметры-вкладка Проигрыватель-рамка Автоматическое обновление). Можно отключить данную возможность в Проигрыватель Windows Media, установив значение типа DWORD параметра DisableAutoUpdate равным 1 в разделе

HKLM\SOFTWARE\Policies\Microsoft\WindowsMediaPlayer.
После установки данного значения рамка Автоматическое обновление будет заблокирована


Плавная прокрутка документа

Чтобы включить плавную прокрутки документа в Word97, нужно присвоить параметру LiveScrolling значение 1 в разделе

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\8.0\Word\Options

В следующих версиях Word этот параметр уже включен


Диалоговое окно открытия и сохранения файла для Office

Office 2000/XP имеет новое диалоговое окно "Открыть/Сохранить файл", аналогичное в Windows Me/2000/XP, которое можно изменить по Вашему желанию.

В левой части диалогового окна расположены пять папок. Но многих пользователей не устраивает этот список. Вы можете скрыть, поменять местами или изменить на те, которыми вы часто пользуетесь. Открываем раздел

HKCU\Software\Microsoft\Office\9.0\Common\OpenFind\Places\StandardPlaces
(для Office 2000, для Office XP используется раздел 10.0) Вложенные разделы и определяют стандартные ссылки (Журнал, Мои документы и пр.) диалогового окна открытия документов. Чтобы скрыть отображение ненужных элементов списка, создайте в соответствующем подразделе DWORD-параметр Show со значением "0" (не показывать).

Спрятав таким образом значки ненужных папок, можно приступать к созданию собственного списка папок. Для этого перейдите в раздел

HKCU\Software\Microsoft\Office\9.0\Common\OpenFind\Places\UserDefinedPlaces.
Создайте в нем новый раздел (его имя не имеет особого значения, но влияет на сортировку папок). В этом разделе создайте два строковых параметра - Nаmе и Path и присвойте им соответственно название и полный путь к папке. Если общее число отображаемых папок равно пяти, то проблем не будет. Если же нет, список может оказаться слишком мал или слишком велик для отображения с установленным по умолчанию размером значка. Чтобы избежать этого, создайте в разделе
HKCU\Software\Microsoft\Office\9.0\Common\OpenFind\Places
DWORD-параметр ItemSize и присвойте ему значение "0" для уменьшения высоты значков папок.

Смотри также
Диалоговое окно открытия и сохранения файла


Ошибки в Office

Ошибки в Office (Office XP)

При возникновении сбоя в Office XP утилита DW.exe пытается отправить отчет о нем в Microsoft. Если вы не хотите заниматься ловлей багов, то можете отключить эту функцию. Существует несколько различных параметров, находящихся в разделе
HKEY_CURRENT_USER\Software\Policies\ Microsoft\Office\10.0\Common

  • Параметр типа DWORD DWNeverUpload со значением 1 отключает отправку данных и не выводит соответствущее сообщение
  • Параметр типа DWORD DWNoExternalURL со значением 1 отключает соединение с сервером Майкрософт и не выводит соответствущее сообщение
  • Параметр типа DWORD DWNoFileCollection со значением 1 не высылает файлы, запрашиваемые сервером обработки ошибок
  • Параметр типа DWORD DWNoSecondLevelCollection со значением 1 не высылает файлы особого рода (записи в реестре, версия файлов, используемые программы), запрашиваемые сервером обработки ошибок

Отсутствие этих параметров (по умолчанию) или установка в 0 включает эти настройки обратно


Выбираем персонаж

Выбираем персонаж (Office XP)

Можно подключать собственных персонажей к приложениям Office. Для этого перейдите в раздел
HKEY_CURRENT_USER\Software\Microsoft\Office\Common\Assistant и создайте строковый параметр AsstFile, в котором пропишите полный путь к вашему acs-файлу персонажа

Этот способ удобен, если ваш персонаж находится не в стандартной папке персонажей, который сканируется Office для выбора нового персонажа. Например, таким образом вы можете подключить персонаж Magic Gooddy, который находится в своей папке


Visual Basic 6.0

В Visual Basic 6.0 в отличие от пятой версии окна Code и Object появляются в нормальном, не в раскрытом виде. И приходится при каждом запуске VB6 раскрывать эти окна. Можно заставить автоматически раскрывать эти окна при каждом запуске. Создайте в соответствующем разделе реестра

HKCU/Software/Microsoft/Visual Basic/6.0
строковый параметр MDIMaximized равный "1"

Источник - Русский_Проект: Visual Basic на русском


Регистрация dll- и ocx-файлов

Данная заметка будет полезна разработчикам. Если вам часто приходится работать с ocx-файлами (а также с dll-файлами), которые требуют регистрации в реестре с помощью REGSVR.EXE, то будет гораздо удобнее внести соответствующую запись в реестр, чем каждый раз использовать командную строку для каждого файла. Создайте раздел
HKEY_CLASSES_ROOT\ocxfile\Shell\Регистрация\command и присвойте строковому параметру по умолчанию значение regsvr32.exe \"%1\". Аналогично создайте дополнительную запись, снимающую регистрацию:
HKEY_CLASSES_ROOT\ocxfile\Shell\Конец регистрации\command
@="regsvr32.exe /u \"%1\""
Тоже самое нужно проделать и в разделе dllfile

Теперь при нажатии правой кнопкой мыши на файле, вы увидите команду Регистрация, которая выполнит за вас необходимую работу.


Photoshop и русский шрифт

Как заставить Photoshop 5 корректно работать с русскими шрифтами? Открываем раздел
HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\Nls\Codepage. Изменяем значение параметров 1250 и 1252 с cp_1250.nls на cp_1251.nls и cp_1252.nls на cp_1251.nls соответственно. Для Windows 2000/XP названия чуть поменялись - C_1251.NLS (без одной буковки)

Изменения вступят после перезагрузки


WinRAR

При работе в многопользовательской среде может потребоваться запретить доступ к меню и настройкам WinRAR, оставив в распоряжении пользователя лишь основной набор функций, доступных с панели инструментов. В этом случае вам нужно создать в системном реестре раздел:
HKEY_LOCAL_MACHINE\Software\WinRAR\Policy или HKEY_CURRENT_USER\Software\WinRAR\Policy.
Параметры в HKEY_LOCAL_MACHINE имеют более высокий приоритет, чем ключ в HKEY_CURRENT_USER. Этот раздел может содержать следующие ключи типа DWORD:
Menu - Если установлено в 0, отключает главное меню WinRAR.
Settings - Если установлено в 0, отключает диалог "Параметры", команды импорта/экспорта параметров и контекстное меню панели инструментов


Редактор RegEdit и структура реестра

Основным средством для просмотра и редактирования записей реестра служит специализированная утилита "Редактор реестра". Для ее запуска наберите в запуске программы (Пуск->Выполнить) команду regedit.

Откроется окно программы, в которой слева отображается дерево реестра, похожее по виду на отображение структуры диска в Проводнике, а справа выводятся ключи, содержащиеся в выбранном (активном) разделе. С помощью редактора Вы можете редактировать значения, импортировать или экспортировать реестр, осуществлять поиск.

Более подробно о реестре и о программе Редактор реестра читайте в справке к этой программе.


Восстановление реестра

При работе с реестром надо соблюдать осторожность. Удаление каких-либо важных данных случайно или по незнанию может привести к краху операционной системы. Тогда спасти положение может только восстановление последней работоспособной копии.

Если Вы собрались поэкспериментировать с реестром, предварительно сохраните на диске файлы SYSTEM.DAT и USER.DAT. Они находятся в каталоге, куда была установлена операционная система и имеют атрибуты "только для чтения" и "скрытый". В случае если реестр будет серьезно испорчен, Вы сможете переписать эти файлы в каталог Windows, установить нужные атрибуты и реестр будет как новенький. Только не вздумайте восстанавливать эти файлы, когда загружен Windows, иначе система накроется окончательно и спасет ее только полная переустановка! Для восстановления этих файлов надо предварительно перезагрузиться в DOS и уже там заменять испорченные файлы хорошими.

Но это не единственный вариант восстановления данных. Дело в том, что операционная система, при каждом удачном запуске сохраняет копию реестра в CAB-файле, который записывается в скрытый каталог SYSBCKUP каталога Windows. По умолчанию, хранятся последние пять копий. Это число может варьироваться от 0 до 99 и устанавливается значением ключа MaxBackupCopies в файле scanreg.ini в каталоге Windows. Правда не стоит устанавливать слишком большое значение, т.к. файлы занимают немало места (один файл имеет размер больше мегабайта).

Чтобы восстановить реестр с одной из этих резервных копий надо перезагрузиться в DOS и выполнить команду

SCANREG /RESTORE

Появится список доступных резервных копий реестра отсортированных по времени их создания. После выбора нужной копии данные будут благополучно восстановлены, и Вы получите реестр, отвечающий состоянию дел на момент его создания.

Но если Вы устанавливали какие-то программы или меняли настройки операционной системы в промежуток между последней резервной копией и сбоем в реестре, то все эти данные безвозвратно пропадут. Надо ли нам это? Однозначно нет! Чтобы в любое время создать резервную копию реестра воспользуйтесь командой

SCANREG /BACKUP

которая в случае нормально прошедшей проверки создаст резервную копию.

Еще один вариант резервирования и восстановления реестра состоит в экспортировании раздела или целой ветви, которую Вы планируете изменять. Это можно осуществить в Regedite для Windows в меню "Реестр". Выделите нужный раздел и щелкните по пункту "Экспорт файла реестра". После задания имени файла данные этого раздела будут в него экспортированы. Файл имеет расширение REG. Для его импортирования в реестр достаточно дважды щелкнуть на нем и данные будут перенесены. Правда этот способ восстановления информации имеет один существенный недостаток: все удаленные или измененные записи будут восстановлены, но вот добавленные записи удалены не будут. Поэтому данный способ больше подходит, если Вы проводите какие-то несущественные изменения, и чтобы откатить их не вводя старые данные заново, можно воспользоваться экспортом/импортом.

Вообще, работать с реестром надо крайне осторожно, но если Вы будете периодически резервировать его, то никаких проблем возникнуть не должно.


Структура reg-файлов

Знание реестра Windows будет не полным без умения написать reg-файл. Начнем с того, что это такое. Reg-файл - это файл, имеющий определенную структуру и содержащий информацию, которая может быть импортирована в реестр. Если была заблокирована работа с редактором реестра , то наиболее легким способом подредактировать реестр будет создание и импортирование reg-файла (конечно, можно выйти в DOS, в защищенный режим, воспользоваться другими программами, но это все гораздо сложнее, а главное дольше).

К reg-файлам предъявляются определенные требования по структуре. Начнем с того, что в первой строке файла обязательно должно быть введено (для Windows 9x)

REGEDIT4

или (для Windows 2000/XP)
Windows Registry Editor Version 5.00

Обратите внимание на то, что буквы должны быть большие. Кроме этого в первой строке ничего быть не должно. После этого текста ОБЯЗАТЕЛЬНО должна быть пустая строка. Затем, указывается раздел реестра, в котором надо прописать или изменить какие-то параметры. Название раздела должно быть заключено в квадратные скобки [...]. Ниже прописываются параметры, которые надо добавить, по одному параметру в строке. Если вам надо провести изменения в нескольких разделах, то вы должны оставлять одну пустую строку между последним параметром предыдущего раздела и названием следующего раздела. Может немного запутанно, но вот как это должно выглядеть:

REGEDIT4

[Razdel1]
"param1"="znachenie1"
"param2"="znachenei2"
"param3"="znachenie3"

[Razdel2]
"param_1"="znachenie_1"

Последняя строка в файле должна быть ПУСТОЙ. После того, как вы создали такой файл, просто запустите его как обычную программу, вам будет выдан запрос о необходимости провести изменения в реестре, и после положительного ответа информация из файла будет импортирована. О результатах импортирования Windows сообщит в появившемся после этого окне.

Примечание: Windows 2000/XP обладает обратной совместимостью и может обрабатывать файлы, созданные в Windows 9x. Но если вы экспортировали файл в Windows XP и перенесли его на Windows 9x, то вручную измените первую строчку на REGEDIT4

Теперь пару слов о параметрах, которые можно добавлять. Как вы, наверное, обратили внимание, в приведенном выше примере добавляются параметры с помощью строк типа "param1"="znachenie1". Т.е. таким образом добавляется СТРОКОВЫЙ параметр с именем "param1" и значением "znachenie1". Но ведь существуют еще и параметры двоичные и DWORD. Формат записи для их добавления несколько другой. Для параметров типа DWORD используется строка

"param"=dword:XXXXXXXX

Здесь "param" - имя параметра, dword - указывает на тип этого параметра (буквы должны быть обязательно маленькие!) и после двоеточия следует значение из восьми цифр в шестнадцатеричном (!) формате. Однако большинство параметров DWORD имеют значение либо 0, либо 1, значит, вы должны написать соответственно либо 00000000, либо 00000001 вместо значков ХХХХХХХХ. Пробелы в строке не допускаются.

Для добавления двоичного параметра формат записи несколько иной:

"param"=hex:XX,XX,XX,....

Теперь расшифрую эту строку. Ну, с названием параметра все ясно, после знака "=" идет hex, т.е. указывается, что это будет двоичный параметр, затем идут шестнадцатеричные числа, отделенные запятой. Например, если вам надо добавить двоичный параметр равный "be 00 00 00", то вы пишете строку

"param"=hex:be,00,00,00

В реестре существуют параметры "По умолчанию" ("Default"). Чтобы присвоить им какое-то значение через reg-файл, надо добавить такую строку:

@="znachenie"

Здесь значок @ показывает, что у нас присваивается значение параметра "По умолчанию". Обратите внимание на то, что он не заключается в кавычки.

Теперь я приведу пример простенького reg-файла, который прописывает в реестр сайт, устанавливающий домашнюю страничку в Internet Explorer'e:

REGEDIT4

[HKEY_CURRENT_USER\Software\ Microsoft\Internet Explorer\Main]
"Start Page" = "http://winchanger.narod.ru/"

Удаление параметров

С помощью reg-файлов можно не только устанавливать новые параметры, но и удалять их. Например, для удаления раздела из реестра надо перед его именем в квадратных скобках поставить символ "-". Вот как это выглядит:

[-HKEY_LOCAL_MACHINE\Software\ QuickSoft\QuickStart]

Благодаря этой записи, подраздел "QuickStart" из раздела "QuickSoft" будет удален со всем содержимым.

Для удаления отдельных параметров используйте следующий синтаксис:

REGEDIT4

[HKEY_CURRENT_USER\Software]
"xxx"=-

Параметры командной строки

Редактор реестра можно запускать с некоторыми ключами

  • /s (импортирует значения из reg-файла без вывода диалогового окна)
  • /e (экспортирует параметры в reg-файл. Пример: regedit /e myfile.reg HKEY_USERS\.DEFAULT


RegClean 4.1

RegClean 4.1a

RegClean - это утилита от Майкрософт для работы с реестром. Рекомендуется для содержания реестра в надлежащем порядке

Что делает RegClean?

RegClean анализирует ключи реестра, расположенные в разделе HKEY_CLASSES_ROOT и находит ключи, содержащие ошибочные значения. RegClean записывает эти значения в файл Undo*.reg, имеющий следующий формат - после Undo записывается имя компьютера, дата и время:
Undo SASHA 20020721 110917.Reg
Затем RegClean удаляет ошибочные записи из реестра

Что RegClean не делает?

RegClean не является универсальной программой для лечения и восстановления реестра и не способна находить и исправлять ошибки в других разделах

Где скачать?

Скачать программу можно по адресу http://winchanger.narod.ru/regclean.zip

Как пользоваться RegClean?

Запустите RegClean (regclean.exe). RegClean выводит окно с индикатором прогресса. В это время программа сканирует реестр. В зависимости от размера вашего реестра и мощности компьютера сканирование может занять от 30 секунд до 30 минут.

После окончания сканирования индикатор прогресса исчезнет и вам будет предложено два варианта для продолжения:

Закончить работу RegClean - если вы не хотите очистить реестр и сохранить найденные ошибки, то выбирайте кнопку Cancel

Зафиксировать ошибки - если вы хотите очистить реестр от ошибок и сохранить найденные ошибки, то жмите на кнопку Fix Errors. Через несколько секунд программа запишет найденные ошибки в файл, который находится в той же папке, где установлена ваша программа RegClean. После этого вы можете закрыть программу, нажав кнопку Exit.

Если в течение нескольких дней ваша система работает стабильно, вы можете удалить созданный файл. Если в вашем компьютере стали возникать ошибки, и вы думаете, что это произошло из-за удаленных записей реестра, то можете восстановить прежние параметры, щелкнув два раза на сохраненном файле Undo.reg


Registry Monitor

Registry Monitor (или regmon для краткости) - незаменимый помощник всех исследователей реестра. Программа была написана программистами Mark Russinovich и Bryce Cogswell. Официальный сайт программы http://www.sysinternals.com.

Что делает RegMon?

Эта программа позволяет отследить ВСЕ обращения к реестру. Неважно, что вы делаете: устанавливаете какой-то софт, работаете с программами или просто запускаете их, Windows постоянно обращается к реестру. И все эти обращения можно зафиксировать с помощью Regmon. По-моему нет необходимости говорить о том, насколько такая информация может быть полезной. Теперь, проведя любые изменения в настройках системы, вы сможете узнать, где именно в реестре они отражаются. А куда в реестре обращается при запуске ваша любимая программа? И не прописывает ли при установке свежескачанная утилитка какой-нибудь непонятный файл в автозагрузку ;)? А сколько раз бывало, что заканчивался срок работы триальной программы, и для дальнейшей работы она требовала регистрации... Посмотрите с помощью Regmon, куда она обращается при запуске, и вы без труда найдете в реестре параметр, где указана дата инсталляции. Ну, а дальше все в ваших руках...

Что RegMon не делает?

Возможности программы большие, но не безграничные. Программа только отслеживает обращения к реестру.

Где скачать?

Найти программу можно на сайте http://www.sysinternals.com

Как пользоваться RegMon?

Все обращения к реестру выводятся в основном окне программы в виде семи колонок. Я думаю, описывать их нет смысла, все и так понятно. Основные функции по работе с программой вынесены в виде кнопок на переднюю панель - нет ничего лишнего и все нужное под рукой. Пройдемся по всем этим кнопкам:
1. Save (Ctrl+S) - ну, тут все понятно - вы можете сохранить лог работы программы в отдельном файле, чтобы потом на досуге изучить его;
2. Capture (Ctrl+E) - временная приостановка/начало слежения за обращениями к реестру;
3. Autoscroll (Ctrl+A) - запрещение/разрешение слежения за последней записью. Если эта функция включена, то список обращений будет автоматически прокручиваться на экране таким образом, чтобы всегда была видна последняя строка;
4. Clear (Ctrl+X) - очистка списка (кто бы мог подумать?). Одно неприятно - если этот список достаточно большой, то он очень долго очищается, даже иногда виснет;
5. Time Format (Ctrl+T) - переключение между режимами отображения времени во втором столбце. Первый вариант - показывает системное время, в которое произошло обращение к реестру, второй вариант - время в секундах прошедшее с момента запуска regmon'a;
6. Filter/Highlight (Ctrl+L) - установка фильтров. Вы можете отслеживать обращения к реестру только конкретных программ, можете отключить слежение за определенными программами. Для установки фильтров надо указывать имя программы, при этом можно использовать маску. Так, например, фильтр "i*" будет применен и для icq, и для iexplore. Жаль нельзя использовать "?";
7. History Depth (Ctrl+H) - устанавливает количество отображаемых на экране строк. Если значение равно 0, то ограничения нет;
8. Find (Ctrl+F) - поиск в списке;
9. Regedit Jump (Ctrl+J) - при выборе строки в списке обращений и нажатии на эту кнопку, будет открыт раздел в реестре, куда было обращение.


RegShot

RegShot - маленькая утилита, позволяющая быстро сделать снимки рееста и сравнить их. Все изменения в реестре можно сохранить в файле. Удобно, если вы хотите знать, какие изменения в реестр вносит новая программа при инсталяции

Где скачать?

Скачать программу можно по адресу http://winchanger.narod.ru/regshot161d.zip

Как пользоваться RegShot?

Порядок работы с программой читайте в файле readme.txt


Благодарности

Признательность

Авторы Александр Климов и Игорь Чеботарев использовали самые разные источники при составлении справочника: интернет, книги, журнальные и газетные публикации

Отдельное спасибо хочется сказать следующим людям, помогавшим нам в работе над справочником

  • Евгений Соболев (SOFTODROM) - за дельные замечания
  • Korsar - за отдельные статьи


Замена фона в панели инструментов в Проводнике

Существует возможность установки своего фона для панели инструментов в Проводнике. Для этого в разделе реестра HKEY_CURRENT_USER \SOFTWARE\ Microsoft\Internet Explorer\Toolbar создайте строковый параметр BackBitmapShell, значением которого будет полное имя BMP-файла с нужной картинкой - она и замостится мозаикой на панелях окон.

Для замены фона не только в Проводнике, но и в Internet Explorer смотрите Замена фона в панели инструментов в Internet Explorer


Домашняя страница

Сайт Справочника по реестру

Последние версии справочника вы можете скачать по адресу
winchanger.narod.ru